On 27. 12. 20 11:28, Heinrich Schuchardt wrote:
> This sort of code does not make much sense:
>
> if (ondie_ecc_enabled) {
> if (ondie_ecc_enabled) {
>
> Remove the inner if.
>
> The problem was indicated by cppcheck.
>
> Signed-off-by: Heinrich Schuchardt
> ---
> drivers/mtd/n
On 03. 01. 21 18:07, Heinrich Schuchardt wrote:
> Building xilinx_zynq_virt_defconfig fails on origin/next as reported by
> GCC 10.2 (as provided by Debian Bullseye):
>
> CC board/xilinx/common/fru_ops.o
> board/xilinx/common/fru_ops.c: In function ‘fru_capture’:
> board/xilinx/common/fr
> From: Padmarao Begari [mailto:padmarao.beg...@microchip.com]
> Sent: Tuesday, December 22, 2020 9:12 PM
> To: u-boot@lists.denx.de; bmeng...@gmail.com; Rick Jian-Zhi Chen(陳建志);
> anup.pa...@wdc.com; lukas.a...@aisec.fraunhofer.de; joe.hershber...@ni.com;
> lu...@denx.de; atish.pa...@wdc.com
> C
On 27. 12. 20 21:34, Florian Klink wrote:
> This adds the dts and entry in CONFIG_OF_LIST for the Digilent Zynq PYNQ
> Board(s).
>
> They're Zynq 7000 - based boards, the Z1 is from Digilent, the Z2 from
> TUL.
This is just saying that dt name is wrong. Pynq is not any board name.
>
> They h
On 03/01/2021 23:43, Samuel Holland wrote:
Hi Jernej,
thanks for that patch, that's a nice solution to avoid those long #ifdef
chains!
> On 1/3/21 3:26 AM, Jernej Skrabec wrote:
>> It turns out that there are at least 2 other SoCs which have basically
>> the same memory map, similar clocks and o
Hi Simon,
On 12/19/20 6:40 PM, Simon Glass wrote:
We have two functions which do the same thing. Standardise on
dev_has_ofnode() since there is no such thing as an 'invalid' ofnode in
normal operation: it is either null or missing.
Also move the functions into one place.
Signed-off-by: Simon G
Hi Peng,
On Sun, Jan 3, 2021 at 11:33 PM Peng Fan wrote:
> No need to disable icache. Dcache needs to be off, since we not have MMU
> setup.
Is the requirement to disable D-Cache in SPL specific to i.MX8MN and i.MX8MP?
We do not pass CONFIG_SPL_SYS_ICACHE_OFF=y and
CONFIG_SPL_SYS_DCACHE_OFF=y
All Xilinx SoCs have repository location filled already but boards are
covered by different fragment which is missing this link.
The patch is extending description with adding proper link to the same
repository.
Reported-by: Heinrich Schuchardt
Signed-off-by: Michal Simek
---
board/xilinx/micr
On Sun, Jan 3, 2021 at 5:36 PM Nicolas Saenz Julienne
wrote:
>
> Hi Peter, thanks for taking the time to test this, I'll send a new hopefully
> definitive version soon.
>
> On Tue, 2020-12-29 at 10:58 +, Peter Robinson wrote:
> > Hi Nicolas,
> >
> > With the xhci patch snippet the pci/xhci cra
On 12/19/20 4:34 AM, Simon Glass wrote:
On Fri, 18 Dec 2020 at 04:46, Patrick Delaunay
wrote:
From: Patrick Delaunay
Add helper functions to access to gd->console_out and gd->console_in
I don't see those in this patch
These helper function are console_record_putc() / _puts() / _getc() /
Clock delay in RGMII is required for some boards.
Clock delay is read from phy-mode dts property. Delay is configured via
proper bits in PORT_REG_PHYS_CTRL register.
Cc: Chris Packham
Cc: Joe Hershberger
Cc: Anatolij Gustschin
Cc: Tim Harvey
Cc: Tom Rini
Signed-off-by: Pawel Dembicki
---
Ch
This patch add MV88E6171 id to driver data.
Tested on Checkpoint L-50 board.
Cc: Chris Packham
Cc: Joe Hershberger
Cc: Anatolij Gustschin
Cc: Tim Harvey
Signed-off-by: Pawel Dembicki
---
Changes in v2:
- resend only
drivers/net/phy/mv88e61xx.c | 14 ++
1 file changed, 14 insert
Hi Simon,
On 12/19/20 6:40 PM, Simon Glass wrote:
At present ofnode is present in the device even if it is never used. With
of-platdata this field is not used, so can be removed. In preparation for
this, change the access to go through inline functions.
Signed-off-by: Simon Glass
---
arch/
On Sat, Jan 02, 2021 at 05:42:23PM -0500, Tom Rini wrote:
> On Thu, Dec 31, 2020 at 05:25:14PM +0100, Heinrich Schuchardt wrote:
>
> > Dear Tom,
> >
> > please, merge into origin/next.
> >
> > @Takahiro, Ilias, Sughosh
> > *Thanks a lot for all your contributions this year.*
> >
> > The followi
Remove the unnecessary space before the 2 "done:" labels
in env_sf_save().
Signed-off-by: Patrick Delaunay
---
env/sf.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/env/sf.c b/env/sf.c
index 91ed2860ed..42d762714e 100644
--- a/env/sf.c
+++ b/env/sf.c
@@ -139,7 +139,7
On 04.01.21 14:27, Ilias Apalodimas wrote:
> On Sat, Jan 02, 2021 at 05:42:23PM -0500, Tom Rini wrote:
>> On Thu, Dec 31, 2020 at 05:25:14PM +0100, Heinrich Schuchardt wrote:
>>
>>> Dear Tom,
>>>
>>> please, merge into origin/next.
>>>
>>> @Takahiro, Ilias, Sughosh
>>> *Thanks a lot for all your co
Change 2 typo error in CONFIG_LIB_ELF description:
- Supoort => Support
- fir => for
Signed-off-by: Patrick Delaunay
---
lib/Kconfig | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/Kconfig b/lib/Kconfig
index 7673d2e4e0..cc89fb4d91 100644
--- a/lib/Kconfig
+++ b/lib/
This adds support for specifying FDT overlays in an extlinux/pxelinux
configuration file.
Without this, there is no simple way to apply overlays when the kernel
and fdt is loaded by the pxe command.
This change adds the 'fdtoverlays' keyword for a label, supporting multiple
overlay files to be ap
On Mon, Jan 04, 2021 at 03:30:47PM +0100, Heinrich Schuchardt wrote:
> On 04.01.21 14:27, Ilias Apalodimas wrote:
> > On Sat, Jan 02, 2021 at 05:42:23PM -0500, Tom Rini wrote:
> >> On Thu, Dec 31, 2020 at 05:25:14PM +0100, Heinrich Schuchardt wrote:
> >>
> >>> Dear Tom,
> >>>
> >>> please, merge in
On Mon, Jan 04, 2021 at 03:33:43PM +0100, Neil Armstrong wrote:
> This adds support for specifying FDT overlays in an extlinux/pxelinux
> configuration file.
>
> Without this, there is no simple way to apply overlays when the kernel
> and fdt is loaded by the pxe command.
>
> This change adds the
A previous series already update STMicroelectronics emails maintainers
but some files have been omitted (Makefile, .dts, .dtsi and .rst files).
Update Patrick and my email address with the one dedicated to upstream
activities.
Signed-off-by: Patrice Chotard
---
arch/arm/dts/stih410-b2260-u-boot
Dne ponedeljek, 04. januar 2021 ob 15:41:17 CET je Tom Rini napisal(a):
> On Mon, Jan 04, 2021 at 03:33:43PM +0100, Neil Armstrong wrote:
> > This adds support for specifying FDT overlays in an extlinux/pxelinux
> > configuration file.
> >
> > Without this, there is no simple way to apply overlays
On 12/31/20 5:48 PM, Sean Anderson wrote:
> This adds support for partitions of the form "dev.hwpart:part" and
> "dev#partname". This allows one to flash to eMMC boot partitions without
> having to use CONFIG_FASTBOOT_MMC_BOOT1_SUPPORT. It also allows one to
> flash to an entire device without
A generic compatibility string was added, but it doesn't match the
name used by Linux or the device tree bindings from any of the SoC's.
Fix it to read "renesas,rcar-gen3-rpc-if"
Fixes: 2f220c639a2a ("spi: renesas_rpc_spi: Add R-Car Gen3 and RZ/G2 fallback
compatibility string")
Signed-off-by: Ad
From: Marc Ferland
This patch converts the dart6ul ethernet support to DM_ETH and cleans
up the legacy ethernet code. The clean up, more specifically:
* moves the fec2 node and pin definition to the carrier board DTS
since the phy associated with it is on the carrier board and not on
the SoM
Dne ponedeljek, 04. januar 2021 ob 11:35:41 CET je André Przywara napisal(a):
> On 03/01/2021 23:43, Samuel Holland wrote:
>
> Hi Jernej,
>
> thanks for that patch, that's a nice solution to avoid those long #ifdef
> chains!
>
> > On 1/3/21 3:26 AM, Jernej Skrabec wrote:
> >> It turns out that t
Dne ponedeljek, 04. januar 2021 ob 03:33:12 CET je Samuel Holland napisal(a):
> On 1/3/21 3:26 AM, Jernej Skrabec wrote:
> > This port is needed for communication with PMIC. SPL uses it to set DRAM
> > voltage on H616 boards.
> >
> > Signed-off-by: Jernej Skrabec
> > ---
> >
> > arch/arm/includ
Dne ponedeljek, 04. januar 2021 ob 03:39:52 CET je Samuel Holland napisal(a):
> On 1/3/21 3:26 AM, Jernej Skrabec wrote:
> > Allwinner H616 supports many types of DRAM. Most notably it supports
> > LPDDR4. However, all commercially available boards at this time use
> > only DDR3, so this commit add
Similar to usbboot, add command line to boot from raw mmc partition
using common_diskboot(), which supports legacy or FIT images.
Usage:
mmcboot [loadAaddr] [dev:part]
Where [loadAddr] defaults to CONFIG_SYS_LOAD_ADDR, and [dev:part]
defaults to ${bootdevice}.
Also fixing config macro usage for
Dne ponedeljek, 04. januar 2021 ob 03:47:06 CET je Samuel Holland napisal(a):
> On 1/3/21 3:26 AM, Jernej Skrabec wrote:
> > H616 is very similar to H6 so most of the infrastructure can be reused.
> > However, two big differences are that it doesn't have functional SRAM A2
> > which is usually used
Hi,
On Mon, Dec 28, 2020 at 12:39:57PM +0100, Stefano Babic wrote:
> On 15.12.20 00:41, Sebastian Reichel wrote:
> > Support reusing board_fit_config_name_match() to automatically
> > select a sensible default configuration for booting fitImages
> > using 'bootm'.
> >
>
> For reasons I have not
Hi Sebastian,
On 04.01.21 20:27, Sebastian Reichel wrote:
Hi,
On Mon, Dec 28, 2020 at 12:39:57PM +0100, Stefano Babic wrote:
On 15.12.20 00:41, Sebastian Reichel wrote:
Support reusing board_fit_config_name_match() to automatically
select a sensible default configuration for booting fitImages
Replace most #ifdef checks for USE_HOSTCC and CONFIG_*
with normal if instructions.
Reviewed-by: Simon Glass
Signed-off-by: Sebastian Reichel
---
common/image-fit.c | 46 --
include/image.h| 4
2 files changed, 24 insertions(+), 26 deletions
This was part of a cleanup series for GE Bx50v3 board. Board
specific patches have already been merged to i.MX tree; this
needs to be applied to get the default configuration working
again.
Changes since PATCHv2:
* rebase against imx/next (so basically drop patches 1,4,5)
* drop OF_LIBFDT_OVERLA
Support reusing board_fit_config_name_match() to automatically
select a sensible default configuration for booting fitImages
using 'bootm'.
Reviewed-by: Simon Glass
Signed-off-by: Sebastian Reichel
---
common/image-fit.c | 19 +--
1 file changed, 13 insertions(+), 6 deletions(-)
On 1/4/21 7:40 PM, Ravik Hasija wrote:
Similar to usbboot, add command line to boot from raw mmc partition
using common_diskboot(), which supports legacy or FIT images.
Usage:
mmcboot [loadAaddr] [dev:part]
Where [loadAddr] defaults to CONFIG_SYS_LOAD_ADDR, and [dev:part]
defaults to ${bootdevi
From: Marc Ferland
The previous macro was off by one bit and so we were getting a ddr
size which was twice the real size. This commit refactors the macro so
it returns the right size in _bytes_ and modifies the printf call so the
size is still printed in MiB.
Signed-off-by: Marc Ferland
---
bo
Clock delay in RGMII is required for some boards.
Clock delay is read from phy-mode dts property. Delay is configured via
proper bits in PORT_REG_PHYS_CTRL register.
Cc: Chris Packham
Cc: Joe Hershberger
Cc: Anatolij Gustschin
Cc: Tim Harvey
Cc: Tom Rini
Signed-off-by: Pawel Dembicki
---
Ch
This patch add MV88E6171 id to driver data.
Tested on Checkpoint L-50 board.
Cc: Chris Packham
Cc: Joe Hershberger
Cc: Anatolij Gustschin
Cc: Tim Harvey
Signed-off-by: Pawel Dembicki
---
Changes in v3,v2:
- resend only
drivers/net/phy/mv88e61xx.c | 14 ++
1 file changed, 14 inse
Hi Dennis,
On 1/1/21 8:42 PM, dennis laplacian1 wrote:
> Hi Jaehoon.
> The only degradation is that the check will be for every block in the
> deleted range and not for the range.
> I can move the check to mmc_erase_t, but then if the device is not
> supporting secure erase the error message will
On 1/5/21 3:40 AM, Ravik Hasija wrote:
> Similar to usbboot, add command line to boot from raw mmc partition
> using common_diskboot(), which supports legacy or FIT images.
>
> Usage:
> mmcboot [loadAaddr] [dev:part]
>
> Where [loadAddr] defaults to CONFIG_SYS_LOAD_ADDR, and [dev:part]
> defaults
Hi Pragnesh
> > From: Pragnesh Patel [mailto:pragnesh.pa...@sifive.com]
> > Sent: Tuesday, December 22, 2020 2:23 PM
> > To: u-boot@lists.denx.de
> > Cc: atish.pa...@wdc.com; palmerdabb...@google.com; bmeng...@gmail.com;
> > paul.walms...@sifive.com; anup.pa...@wdc.com; sagar.ka...@sifive.com; Ri
On 1/4/21 8:37 PM, Rick Chen wrote:
Hi Pragnesh
From: Pragnesh Patel [mailto:pragnesh.pa...@sifive.com]
Sent: Tuesday, December 22, 2020 2:23 PM
To: u-boot@lists.denx.de
Cc: atish.pa...@wdc.com; palmerdabb...@google.com; bmeng...@gmail.com;
paul.walms...@sifive.com; anup.pa...@wdc.com; sagar.k
Hi Joe
> From: Padmarao Begari [mailto:padmarao.beg...@microchip.com]
> Sent: Tuesday, December 22, 2020 9:12 PM
> To: u-boot@lists.denx.de; bmeng...@gmail.com; Rick Jian-Zhi Chen(陳建志);
> anup.pa...@wdc.com; lukas.a...@aisec.fraunhofer.de; joe.hershber...@ni.com;
> lu...@denx.de; atish.pa...@wdc
On Wed, Dec 30, 2020 at 05:07:18PM +0200, Ilias Apalodimas wrote:
> Up to now we install EFI_LOAD_FILE2_PROTOCOL to load an initrd
> unconditionally. Although we correctly return various EFI exit codes
> depending on the file status (i.e EFI_NO_MEDIA, EFI_NOT_FOUND etc), the
> kernel loader, only f
On 1/4/21 12:39 PM, Jernej Škrabec wrote:
> Dne ponedeljek, 04. januar 2021 ob 03:39:52 CET je Samuel Holland napisal(a):
>> On 1/3/21 3:26 AM, Jernej Skrabec wrote:
>>> Allwinner H616 supports many types of DRAM. Most notably it supports
>>> LPDDR4. However, all commercially available boards at th
On 22/11/20 4:00 am, Pali Rohár wrote:
> It looks like that i2c bus lot of times timeout on some units. Prior
> migration to CONFIG_DM_I2C i2c speed was set to CONFIG_SYS_OMAP24_I2C_SPEED
> value which was 10. Lower speed fixes timeout problems, so change speed
> back to its previous value.
On 22/11/20 4:03 am, Pali Rohár wrote:
> Move twl4030_power_mmc_init() from board_mmc_power_init() to misc_init_r()
> and disable CONFIG_SYS_MALLOC_F. Otherwise U-Boot cannot initialize MMC.
> Also disable CONFIG_CMD_SLEEP and CONFIG_DM_DEVICE_REMOVE to free some
> space.
>
> Signed-off-by: Pal
On 01/12/20 12:40 am, Pali Rohár wrote:
> Those two commands now doing same thing, reading from ext2/3/4 filesystem.
> So remove useless duplicated call.
>
> Signed-off-by: Pali Rohár
Applied to u-boot-ti/for-next branch
Thanks and regards,
Lokesh
> ---
> include/configs/nokia_rx51.h | 17
On Tue, Jan 5, 2021 at 7:12 AM Sean Anderson wrote:
>
> On 1/4/21 8:37 PM, Rick Chen wrote:
> > Hi Pragnesh
> >
> >>> From: Pragnesh Patel [mailto:pragnesh.pa...@sifive.com]
> >>> Sent: Tuesday, December 22, 2020 2:23 PM
> >>> To: u-boot@lists.denx.de
> >>> Cc: atish.pa...@wdc.com; palmerdabb...@g
On Tue, 5 Jan 2021, 10:28 AM Pawel Dembicki,
wrote:
> Clock delay in RGMII is required for some boards.
>
> Clock delay is read from phy-mode dts property. Delay is configured via
> proper bits in PORT_REG_PHYS_CTRL register.
>
> Cc: Chris Packham
> Cc: Joe Hershberger
> Cc: Anatolij Gustschin
On Tue, 5 Jan 2021, 10:28 AM Pawel Dembicki,
wrote:
> This patch add MV88E6171 id to driver data.
>
> Tested on Checkpoint L-50 board.
>
> Cc: Chris Packham
> Cc: Joe Hershberger
> Cc: Anatolij Gustschin
> Cc: Tim Harvey
> Signed-off-by: Pawel Dembicki
>
Looks good to me.
Reviewed-by: Chri
52 matches
Mail list logo