Hi Simon,
Simon Glass wrote:
> I see that, although it is adding to the fpga header so presumably
> making it harder for someone to move this over.
Yes, I'm not happy with changing the header and even xilinx C file to add
functionality for altera. However, this is due to the fact that a core fil
> From: Heinrich Schuchardt
> Date: Sat, 25 Nov 2017 02:49:41 +0100
>
> Hello Emmanuel,
>
> yesterday you reported on the u-boot ICS channel that you saw an
> incorrect device path for the SD card on your BananaPi M2
> (/venHw(e61d73b9-a384-4acc-aeab-82e828f3628b)/Usb(0x6,0x0)/HD(Part0,MBRType
Hi Simon,
Le 24/11/2017 23:35, Simon Glass a écrit :
> Hi Neil,
>
> On 22 November 2017 at 06:25, Neil Armstrong wrote:
>> Introduce a generic common Ethernet Hardware init function
>> common to all Amlogic GX SoCs with support for the
>> Internal PHY enable for GXL SoCs.
>>
>> Signed-off-by: Ne
Le 24/11/2017 23:35, Simon Glass a écrit :
> Hi Neil,
>
> On 22 November 2017 at 06:25, Neil Armstrong wrote:
>> This adds platform code for the Libre Computer CC "Le Potato" board based on
>> a
>> Meson GXL (S905X) SoC with the Meson GXL configuration.
>>
>> This initial submission supports U
Hi Tom, Simon,
Le 22/11/2017 14:25, Neil Armstrong a écrit :
> This patchset aimed to add minimal support for the following Amlogic GXL SoC
> based board:
> - LibreTech-CC
> - Khadas VIM
>
> The initial support is composed of :
> - Minimal boot support with serial, MMC, Ethernet and SDCard
> - Up
Hi Simon,
Le 24/11/2017 23:35, Simon Glass a écrit :
> Hi Neil,
>
> On 20 November 2017 at 08:36, Neil Armstrong wrote:
>> As discussed at [1], the Amlogic Meson GX SoCs can embed a BL31 firmware
>> and a secondary BL32 firmware.
>> Since mid-2017, the reserved memory address of the BL31 firmwar
Am 01.08.2017 um 16:47 schrieb Dmitry Korunov:
> The Raspberry Pi Zero W extends the Pi Zero family and it's also
> based on a BCM2835 SoC. Like the Pi Zero, it has 512MB RAM,
> Mini HDMI and USB On-The-Go ports. Both Pi's hasn't got Ethernet,
> but Pi Zero W has built in wireless LAN 802.11 b/g/n.
Am 24.11.2017 um 14:01 schrieb Sean Nyekjaer:
> It's the first 8 bits of the bootrom error register that
> contains the boot error/fallback error code. Lets check that
"bits ... contain"
"Let's"
> and continue to boot from UART.
>
> Signed-off-by: Sean Nyekjaer
> ---
> arch/arm/mach-mvebu/inc
On 11/25/2017 09:54 AM, Mark Kettenis wrote:
>> From: Heinrich Schuchardt
>> Date: Sat, 25 Nov 2017 02:49:41 +0100
>>
>> Hello Emmanuel,
>>
>> yesterday you reported on the u-boot ICS channel that you saw an
>> incorrect device path for the SD card on your BananaPi M2
>> (/venHw(e61d73b9-a384-4a
Hi Neil,
Am 25.11.2017 um 10:54 schrieb Neil Armstrong:
> Le 24/11/2017 23:35, Simon Glass a écrit :
>> On 20 November 2017 at 08:36, Neil Armstrong wrote:
>>> diff --git a/arch/arm/include/asm/arch-meson/gxbb.h
>>> b/arch/arm/include/asm/arch-meson/gxbb.h
>>> index 74d5290..117f796 100644
>>> -
At present the compression tests do not use the unit test framework, nor
are they executed by the 'make tests' command. This series converts these
tests to use the unit test framework, adding a few other minor
improvements along the way.
The overlay tests do not currently run for me, and we lack i
The logic to either iterate through a list of tests or pick a named test
is common to at lest two test suits. Move this logic into a new function
and call it from the environment tests.
Signed-off-by: Simon Glass
---
include/test/suites.h | 16
test/cmd_ut.c | 25 ++
Adjust the code to use the common test-execution function.
Signed-off-by: Simon Glass
---
test/overlay/cmd_ut_overlay.c | 21 ++---
1 file changed, 2 insertions(+), 19 deletions(-)
diff --git a/test/overlay/cmd_ut_overlay.c b/test/overlay/cmd_ut_overlay.c
index c730a11f518..627
Adjust this test to use the unit test framework. Drop the two existing
commands for running the tests and replace them with a single
'ut compression' command, with sub-commands.
Signed-off-by: Simon Glass
---
include/test/compression.h | 17 +
include/test/suites.h | 1 +
test/cmd_u
At present the test setup is somewhat mixed with the test itself. But if
the test setup fails (which it should not) then the test is actually
invalid. Put all the test buffers and sizes in a struct and separate out
the core code into a function.
This will make it easier to move the code to use the
The u-boot.sym file is scanned to find unit test suites for execution. At
present it only finds those whose names start with 'dm' or 'env'. This
code is buried in the bowels of the test code so when adding a new suite
it is not easy to discover why it is ignored by the test framework.
There seems
There is an #ifdef and #endif with nothing in between. This patch simply
removes this dead/useless code.
Signed-off-by: Adam Ford
diff --git a/include/configs/mx6_common.h b/include/configs/mx6_common.h
index 4de9db6..5fb85a1 100644
--- a/include/configs/mx6_common.h
+++ b/include/configs/mx6_c
On Sat, Nov 25, 2017 at 5:39 PM, Adam Ford wrote:
> There is an #ifdef and #endif with nothing in between. This patch simply
> removes this dead/useless code.
>
> Signed-off-by: Adam Ford
Good catch:
Reviewed-by: Fabio Estevam
___
U-Boot mailing lis
There are a few targets (clearfog, turris_omnia) and features (signing
in mkimage) in the Debian build of u-boot that have been avoided due to
lack of clarity on Licensing issues regarding GPL and OpenSSL
compatibility issues.
A reasonable description of the issue GPL linking against OpenSSL issue
+Tom, Masahiro, Philipp
Hi,
On 22 November 2017 at 03:27, Wolfgang Denk wrote:
> Dear Kever Yang,
>
> In message you wrote:
>>
>> I can understand this feature, we always do dram_init_banks() first,
>> then we relocate to 'known' area, then will be no risk to access memory.
>> I believe there m
Hi,
On 13 November 2017 at 18:54, Simon Glass wrote:
> Binman construct images consisting of multiple binary files. These files
> sometimes need to know (at run timme) where their peers are located. For
> example, SPL may want to know where U-Boot is located in the image, so
> that it can jump to
Hi Neil,
On 25 November 2017 at 02:48, Neil Armstrong wrote:
> Hi Tom, Simon,
>
> Le 22/11/2017 14:25, Neil Armstrong a écrit :
>> This patchset aimed to add minimal support for the following Amlogic GXL SoC
>> based board:
>> - LibreTech-CC
>> - Khadas VIM
>>
>> The initial support is composed o
Hi Heinrich,
On 23 November 2017 at 14:29, Heinrich Schuchardt wrote:
> On 11/21/2017 03:16 PM, Wolfgang Denk wrote:
>> Dear Heinrich Schuchardt,
>>
>> In message you wrote:
>>>
>>> +u16 *str = efi_dp_str((struct efi_device_path *)dp);
>>> +
>>> +buf = string16(buf, e
Hi,
> On 25 Nov 2017, at 23:34, Simon Glass wrote:
>
> +Tom, Masahiro, Philipp
>
> Hi,
>
> On 22 November 2017 at 03:27, Wolfgang Denk wrote:
>> Dear Kever Yang,
>>
>> In message you wrote:
>>>
>>> I can understand this feature, we always do dram_init_banks() first,
>>> then we relocate to
Jagan,
I resolved this by introducing a new Kconfig that affects what functionality
is included in spl_fit.c; however, this leaves an uneasy feeling, as we now
start to have different logic in our SPL stage.
Is there a plan in place to move sun50i to a TPL->SPL->U-Boot model?
Thanks,
Philipp.
>
> The boot (and fallback/emergency boot) concept for the RK3399-Q7
> differs from Rockchip's reference platforms.
>
> On the RK3399-Q7, some of this functionality is present in the
> bootloader itself (and configurable); some is backed in hardware by
> the Qseven BIOS_DISABLE signal to invoke the
> The RK3399 clk driver still has a left-over use of extract_bits, which
> can be replaced by using bitfield_extract from include/bitfield.h.
> This rewrites the invocation to use the shared function.
>
> Signed-off-by: Philipp Tomsich
> ---
>
> drivers/clk/rockchip/clk_rk3399.c | 8 ++--
>
> The ROCKCHIP_BOOT_MODE_REG option defaults to a hex value, so 0 will
> show as 0x0. Consequently, the "is set to something other than 0" test
> in a Makefile needs to be an ifneq($(CONFIG_ROCKCHIP_BOOT_MODE_REG), 0x0).
>
> This commit fixes mach-rockchip/Makefile and also resulting link
> issue
> The RK3399 has a total of 9 I2C controllers. To support these, the
> enum in periph.h is extended and the mapping from the IRQ numbers to
> the peripheral-ids is extended to ensure that pinctrl requests are
> passed through to the function configuring the I2C pins.
>
> For I2C8, the pinctrl is
> Spam detection software, running on the system "lists.denx.de",
> has identified this incoming email as possible spam. The original
> message has been attached to this so you can view it or label
> similar future email. If you have any questions, see
> @@CONTACT_ADDRESS@@ for details.
>
> Cont
> Spam detection software, running on the system "lists.denx.de",
> has identified this incoming email as possible spam. The original
> message has been attached to this so you can view it or label
> similar future email. If you have any questions, see
> @@CONTACT_ADDRESS@@ for details.
>
> Cont
> Enable GMAC configs for evb-rk3328
>
> Signed-off-by: David Wu
> Acked-by: Philipp Tomsich
> ---
>
> Changes in v2:
> - New patch
>
> configs/evb-rk3328_defconfig | 5 +
> 1 file changed, 5 insertions(+)
>
Reviewed-by: Philipp Tomsich
___
U
> Spam detection software, running on the system "lists.denx.de",
> has identified this incoming email as possible spam. The original
> message has been attached to this so you can view it or label
> similar future email. If you have any questions, see
> @@CONTACT_ADDRESS@@ for details.
>
> Cont
> Spam detection software, running on the system "lists.denx.de",
> has identified this incoming email as possible spam. The original
> message has been attached to this so you can view it or label
> similar future email. If you have any questions, see
> @@CONTACT_ADDRESS@@ for details.
>
> Cont
> Spam detection software, running on the system "lists.denx.de",
> has identified this incoming email as possible spam. The original
> message has been attached to this so you can view it or label
> similar future email. If you have any questions, see
> @@CONTACT_ADDRESS@@ for details.
>
> Cont
> Spam detection software, running on the system "lists.denx.de",
> has identified this incoming email as possible spam. The original
> message has been attached to this so you can view it or label
> similar future email. If you have any questions, see
> @@CONTACT_ADDRESS@@ for details.
>
> Cont
> Spam detection software, running on the system "lists.denx.de",
> has identified this incoming email as possible spam. The original
> message has been attached to this so you can view it or label
> similar future email. If you have any questions, see
> @@CONTACT_ADDRESS@@ for details.
>
> Cont
On 25/11/17 23:35, Dr. Philipp Tomsich wrote:
> Jagan,
>
> I resolved this by introducing a new Kconfig that affects what functionality
> is included in spl_fit.c; however, this leaves an uneasy feeling, as we now
> start to have different logic in our SPL stage.
Thanks for taking care. Is that a
> On 26 Nov 2017, at 01:06, André Przywara wrote:
>
> On 25/11/17 23:35, Dr. Philipp Tomsich wrote:
>> Jagan,
>>
>> I resolved this by introducing a new Kconfig that affects what functionality
>> is included in spl_fit.c; however, this leaves an uneasy feeling, as we now
>> start to have differ
> Add rk3328-evb gmac support.
>
> Signed-off-by: David Wu
> Acked-by: Philipp Tomsich
> ---
>
> Changes in v2:
> - New patch
>
> arch/arm/dts/rk3328-evb.dts | 30 ++
> 1 file changed, 30 insertions(+)
>
Reviewed-by: Philipp Tomsich
_
On 26/11/17 00:15, Dr. Philipp Tomsich wrote:
>
>> On 26 Nov 2017, at 01:06, André Przywara wrote:
>>
>> On 25/11/17 23:35, Dr. Philipp Tomsich wrote:
>>> Jagan,
>>>
>>> I resolved this by introducing a new Kconfig that affects what functionality
>>> is included in spl_fit.c; however, this leaves
On 11/25/2017 11:34 PM, Simon Glass wrote:
Hi Heinrich,
On 23 November 2017 at 14:29, Heinrich Schuchardt wrote:
On 11/21/2017 03:16 PM, Wolfgang Denk wrote:
Dear Heinrich Schuchardt,
In message you wrote:
+u16 *str = efi_dp_str((struct efi_device_path *)dp);
+
+buf = s
CONFIG_ENV_IS_IN_NAND has been removed in commit 2be296538e2e (Convert
CONFIG_ENV_IS_IN_MMC/NAND/UBI and NOWHERE to Kconfig).
CONFIG_ENV_IS_IN_SPI_FLASH has bee removed in commit 91c868fe7cd
(Convert CONFIG_ENV_IS_IN_SPI_FLASH to Kconfig). The environemnt #ifdef
is now empty. Remove it.
Signed-off
43 matches
Mail list logo