Re: [U-Boot] [PATCH 4/4] common/lcd_console: introduce display/framebuffer rotation

2015-03-15 Thread Igor Grinberg
Hi Hannes, On 03/12/15 18:46, Hannes Petermaier wrote: > > On 2015-03-12 13:26, Igor Grinberg wrote: >> Hi Hannes, > Hi Igor, > thanks for response. >> #endif >> -/* Paint the logo and retrieve LCD base address */ >> -debug("[LCD] Drawing the logo...\n"); >> -#if defined(CONFIG_LCD_LOGO

Re: [U-Boot] Ask for help: Compulab CM-510 U-boot version: Load Kernel from SD-Card

2015-03-15 Thread Dmitry Lifshitz
Hi Gabriel, Sorry for the late reply. I see you made a progress with that issue. Thank you for sharing the results. Best regards, Dmitry On 03/05/2015 11:48 AM, Gabriel Dobato wrote: Hi Dmitry, Finally, I got the SD Card as a bootable kernel space. However I had to set the registers as belo

Re: [U-Boot] [PATCH] mmc: fsl_esdhc fix register offset

2015-03-15 Thread Marek Vasut
On Sunday, March 15, 2015 at 06:54:49 AM, Peng Fan wrote: > Hi, > > On 3/11/2015 9:00 PM, Fabio Estevam wrote: > > On Tue, Mar 10, 2015 at 4:35 AM, Peng Fan wrote: > >> Commit f022d36e8a4517b2a9d25ff2d75bd2459d0c68b1 introduces > >> error register offset. > >> > >> Change the "char reserved3[59]

Re: [U-Boot] [RFC PATCH] usb: dwc2: handle bcm2835 phys->virt address translations

2015-03-15 Thread Stephen Warren
On 03/13/2015 12:13 AM, Stephen Warren wrote: > BCM2835 bus addresses use the top 2 bits to determine whether peripherals > use or bypass the GPU L1 and L2 cache. BCM2835-ARM-Peripherals.pdf states > that: ... If you do end up applying this, the subject should say phys->bus not phys->virt. ___

Re: [U-Boot] [PATCH] mmc: fsl_esdhc fix register offset

2015-03-15 Thread Joakim Tjernlund
On Sun, 2015-03-15 at 13:54 +0800, Peng Fan wrote: > Hi, > > On 3/11/2015 9:00 PM, Fabio Estevam wrote: > > On Tue, Mar 10, 2015 at 4:35 AM, Peng Fan wrote: > > > Commit f022d36e8a4517b2a9d25ff2d75bd2459d0c68b1 introduces > > > error register offset. > > > > > > Change the "char reserved3[59]" t

Re: [U-Boot] [RFC PATCH] usb: dwc2: handle bcm2835 phys->virt address translations

2015-03-15 Thread Stephen Warren
On 03/13/2015 12:13 AM, Stephen Warren wrote: > BCM2835 bus addresses use the top 2 bits to determine whether peripherals > use or bypass the GPU L1 and L2 cache. BCM2835-ARM-Peripherals.pdf states > that: > > 0: L1 & L2 cached > 4: L2 cache coherent (non allocaing) > 8: L2 cached only > c: Direct

[U-Boot] [PATCH 3/4] sunxi: common VBUS detection logic in usbc

2015-03-15 Thread Paul Kocialkowski
VBUS detection could be needed not only by the musb code (to prevent host mode), but also by e.g. gadget drivers to start only when a cable is connected. In addition, this allows more flexibility in vbus detection, as it could easily be extended to other USBC indexes. Eventually, this would help m

[U-Boot] [PATCH 2/4] sunxi: Avoid any assumption between musb gadget and host but fallback to host

2015-03-15 Thread Paul Kocialkowski
musb might be used in gadget mode on sunxi, so we don't want to assume anything related to host mode, especially USB keyboard support. However, in case gadget mode is not explicitly used, fallback to host mode. Signed-off-by: Paul Kocialkowski --- board/sunxi/Kconfig| 2 +- include/c

[U-Boot] [PATCH 1/4] sunxi: musb: Return early on VBUS GPIO error instead of on a positive value

2015-03-15 Thread Paul Kocialkowski
This allows printing the error message when VBUS is detected, as it would with AXP VBUS detect. Signed-off-by: Paul Kocialkowski --- drivers/usb/musb-new/sunxi.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/usb/musb-new/sunxi.c b/drivers/usb/musb-new/sunxi.c index

[U-Boot] [PATCH 4/4] board: sunxi: USB download gadget cable detection

2015-03-15 Thread Paul Kocialkowski
Signed-off-by: Paul Kocialkowski --- board/sunxi/board.c | 7 +++ 1 file changed, 7 insertions(+) diff --git a/board/sunxi/board.c b/board/sunxi/board.c index e1891d1..becdc8b 100644 --- a/board/sunxi/board.c +++ b/board/sunxi/board.c @@ -241,6 +241,13 @@ static struct musb_hdrc_platform_dat

[U-Boot] [PATCH] fastboot: Proper download gadget unregister and clear when cable is missing

2015-03-15 Thread Paul Kocialkowski
Signed-off-by: Paul Kocialkowski --- common/cmd_fastboot.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/common/cmd_fastboot.c b/common/cmd_fastboot.c index 346ab80..7956a5b 100644 --- a/common/cmd_fastboot.c +++ b/common/cmd_fastboot.c @@ -23,6 +23,8 @@ static int do_fastboot(cmd_tbl_t *

[U-Boot] [PATCH 2/2] sunxi: Ainol AW1 support

2015-03-15 Thread Paul Kocialkowski
Signed-off-by: Paul Kocialkowski --- board/sunxi/MAINTAINERS | 5 + configs/Ainol_AW1_defconfig | 16 2 files changed, 21 insertions(+) create mode 100644 configs/Ainol_AW1_defconfig diff --git a/board/sunxi/MAINTAINERS b/board/sunxi/MAINTAINERS index ef3c937..e486458

[U-Boot] [PATCH 1/2] power: axp209: VBUS detect

2015-03-15 Thread Paul Kocialkowski
Signed-off-by: Paul Kocialkowski --- drivers/power/axp209.c | 13 + include/axp209.h | 3 +++ 2 files changed, 16 insertions(+) diff --git a/drivers/power/axp209.c b/drivers/power/axp209.c index 4565398..11fe9d7 100644 --- a/drivers/power/axp209.c +++ b/drivers/power/axp209.c

Re: [U-Boot] [PATCH] fastboot: Proper download gadget unregister and clear when cable is missing

2015-03-15 Thread Marek Vasut
On Sunday, March 15, 2015 at 06:28:35 PM, Paul Kocialkowski wrote: > Signed-off-by: Paul Kocialkowski > --- > common/cmd_fastboot.c | 2 ++ > 1 file changed, 2 insertions(+) +CC Lukasz and Steve. > diff --git a/common/cmd_fastboot.c b/common/cmd_fastboot.c > index 346ab80..7956a5b 100644 > ---

Re: [U-Boot] [PATCH 3/4] sunxi: common VBUS detection logic in usbc

2015-03-15 Thread Marek Vasut
On Sunday, March 15, 2015 at 06:27:46 PM, Paul Kocialkowski wrote: > VBUS detection could be needed not only by the musb code (to prevent host > mode), but also by e.g. gadget drivers to start only when a cable is > connected. > > In addition, this allows more flexibility in vbus detection, as it

Re: [U-Boot] [RFC PATCH] usb: dwc2: handle bcm2835 phys->virt address translations

2015-03-15 Thread Marek Vasut
On Sunday, March 15, 2015 at 05:51:26 PM, Stephen Warren wrote: > On 03/13/2015 12:13 AM, Stephen Warren wrote: > > BCM2835 bus addresses use the top 2 bits to determine whether peripherals > > use or bypass the GPU L1 and L2 cache. BCM2835-ARM-Peripherals.pdf states > > that: > > > > 0: L1 & L2 c

Re: [U-Boot] [RFC PATCH] usb: dwc2: handle bcm2835 phys->virt address translations

2015-03-15 Thread Marek Vasut
On Sunday, March 15, 2015 at 05:04:05 PM, Stephen Warren wrote: > On 03/13/2015 12:13 AM, Stephen Warren wrote: > > BCM2835 bus addresses use the top 2 bits to determine whether peripherals > > use or bypass the GPU L1 and L2 cache. BCM2835-ARM-Peripherals.pdf states > > that: ... > > If you do en

Re: [U-Boot] bootcount: Add dcache flush to bootcount_store()

2015-03-15 Thread Tom Rini
... Add a few more PowerPC people. On Fri, Mar 13, 2015 at 10:34:03AM -0400, Tom Rini wrote: > On Fri, Mar 13, 2015 at 09:48:56AM -0400, Tom Rini wrote: > > On Wed, Mar 11, 2015 at 09:51:38AM +0100, Stefan Roese wrote: > > > > > Without this dcache_flush the updated bootcounter may not be saved t

Re: [U-Boot] [PATCH 2/4] common/lcd_console: ask only one-time for bg/fg-color per call

2015-03-15 Thread Nikita Kiryanov
Hi Hannes, On 03/11/2015 02:57 PM, Hannes Petermaier wrote: From: Hannes Petermaier Don't call the lcd_getfgcolor and lcd_getbgcolor within the "draw-loop", this only wastes time. Signed-off-by: Hannes Petermaier Signed-off-by: Hannes Petermaier --- common/lcd_console.c |7 ++-

Re: [U-Boot] [PATCH 1/4] common/lcd_console: cleanup lcd_drawchars/lcd_putc_xy

2015-03-15 Thread Nikita Kiryanov
Hi Hannes, On 03/11/2015 02:57 PM, Hannes Petermaier wrote: From: Hannes Petermaier the capability of drawing some *str with count from lcd_drawchars is unnary. It is always called from lcd_putc_xy with one character of and count = 1. So we simply rename lcd_drawchars into lcd_putc_xy and rem

Re: [U-Boot] [PATCH 3/4] common/lcd_console: move single static variables into common (static) structure

2015-03-15 Thread Nikita Kiryanov
Hi Hannes, On 03/11/2015 02:57 PM, Hannes Petermaier wrote: From: Hannes Petermaier For coming implementation of lcd_console rotation, we will need some more variables for holding information about framebuffer size, rotation, ... For better readability we catch all them into a common structur

Re: [U-Boot] [PATCH 4/4] common/lcd_console: introduce display/framebuffer rotation

2015-03-15 Thread Nikita Kiryanov
Hi Hannes, I second Grinberg's suggestion of a separate file and 0 degree default (also as a fallback for invalid rotation value, see below). Some additional comments: On 03/11/2015 02:57 PM, Hannes Petermaier wrote: From: Hannes Petermaier Sometimes, for example if the display is mounted in

Re: [U-Boot] Pull request: u-boot-uniphier

2015-03-15 Thread Tom Rini
On Sun, Mar 15, 2015 at 01:46:12PM +0900, Masahiro Yamada wrote: > Hi Tom, > > > The following changes since commit b79dadf846e5e140e261bbfa4decd024357702d7: > > Merge branch 'master' of git://git.denx.de/u-boot-tegra (2015-03-10 > 19:09:18 -0400) > > are available in the git repository at:

Re: [U-Boot] [U-Boot, 1/1] am335x_evm_usbspl: Remove other SPL modes

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 12:40:36PM -0400, Tom Rini wrote: > The purpose of this build target is to do SPL over USB RNDIS. We remove > YMODEM, MMC and NAND (and re-set ENV to be built-in) as when those are needed > we can use the other build targets. This brings us well under size limit > again.

Re: [U-Boot] [U-Boot, V6, 01/11] ARM: Introduce erratum workaround for 798870

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:11:59PM -0500, Nishanth Menon wrote: > Add workaround for Cortex-A15 ARM erratum 798870 which says > "If back-to-back speculative cache line fills (fill A and fill B) are > issued from the L1 data cache of a CPU to the L2 cache, the second > request (fill B) is then canc

Re: [U-Boot] [U-Boot, V6, 02/11] ARM: Introduce erratum workaround for 454179

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:12:00PM -0500, Nishanth Menon wrote: > 454179: Stale prediction may inhibit target address misprediction on > next predicted taken branch > Impacts: Every Cortex-A8 processors with revision lower than r2p1 > Work around: Set IBE and disable branch size mispredict

Re: [U-Boot] [U-Boot, V6, 04/11] ARM: Introduce erratum workaround for 621766

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:12:02PM -0500, Nishanth Menon wrote: > 621766: Under a specific set of conditions, executing a sequence of > NEON or vfp load instructions can cause processor deadlock > Impacts: Every Cortex-A8 processors with revision lower than r2p1 > Work around: Set L1NEON to

Re: [U-Boot] [U-Boot, V6, 03/11] ARM: Introduce erratum workaround for 430973

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:12:01PM -0500, Nishanth Menon wrote: > 430973: Stale prediction on replaced inter working branch causes > Cortex-A8 to execute in the wrong ARM/Thumb state > Impacts: Every Cortex-A8 processors with revision lower than r2p1 > Work around: Set IBE to 1 > > Based on

Re: [U-Boot] [U-Boot, V6, 05/11] ARM: OMAP: Change set_pl310_ctrl_reg to be generic

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:12:03PM -0500, Nishanth Menon wrote: > set_pl310_ctrl_reg does use the Secure Monitor Call (SMC) to setup > PL310 control register, however, that is something that is generic > enough to be used for OMAP5 generation of processors as well. The only > difference being the

Re: [U-Boot] [U-Boot, V6, 06/11] ARM: OMAP3: Rename omap3.h to omap.h to be generic as all SoCs

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:12:04PM -0500, Nishanth Menon wrote: > This is in preperation of using generic cross OMAP code. > > Signed-off-by: Nishanth Menon > Reviewed-by: Tom Rini Applied to u-boot/master, thanks! -- Tom signature.asc Description: Digital signature ___

Re: [U-Boot] [U-Boot, V6, 08/11] ARM: DRA7 / OMAP5: Add workaround for ARM errata 798870

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:12:06PM -0500, Nishanth Menon wrote: > From: Praveen Rao > > This patch enables the workaround for ARM errata 798870 for OMAP5 / > DRA7 which says "If back-to-back speculative cache line fills (fill > A and fill B) are issued from the L1 data cache of a CPU to the > L2

Re: [U-Boot] [U-Boot, V6, 10/11] ARM: OMAP3: Enable workaround for ARM errata 454179, 430973, 621766

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:12:08PM -0500, Nishanth Menon wrote: > Enable the OMAP3 specific errata code for 454179, 430973, 621766 > and while at it, remove legacy non-revision checked errata logic. > > Signed-off-by: Nishanth Menon > Reviewed-by: Tom Rini Applied to u-boot/master, thanks! --

Re: [U-Boot] [U-Boot, V6, 07/11] ARM: OMAP3: Get rid of omap3_gp_romcode_call and replace with omap_smc1

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:12:05PM -0500, Nishanth Menon wrote: > omap_smc1 is now generic enough to remove duplicate > omap3_gp_romcode_call logic that omap3 introduced. > > As part of this change, move to using the generic lowlevel_init.S for > omap3 as well. > > Signed-off-by: Nishanth Menon

Re: [U-Boot] README: remove description about driver model configuration options (again)

2015-03-15 Thread Tom Rini
On Wed, Mar 11, 2015 at 05:34:25PM +0900, Masahiro Yamada wrote: > The Driver Model description in README was removed by commit > 65eb659e56fa (README: remove description about driver model > configuration options), and was revived by mistake by commit > b79dadf846e5 when resolving the conflict. >

Re: [U-Boot] [U-Boot, V6, 09/11] ARM: OMAP5 / DRA7: Setup L2 Aux Control Register with recommended configuration

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:12:07PM -0500, Nishanth Menon wrote: > Update to existing recommendation for L2ACTLR configuration to prevent > system instability and optimize performance. > > These apply to both OMAP5 and DRA7. > > Reported-by: Vivek Chengalvala > Signed-off-by: Nishanth Menon > R

Re: [U-Boot] [U-Boot, V6, 11/11] ARM: OMAP3: rx51: Enable workaround for ARM errata 454179, 430973, 621766

2015-03-15 Thread Tom Rini
On Mon, Mar 09, 2015 at 05:12:09PM -0500, Nishanth Menon wrote: > RX51 has a secure logic which uses different parameters compared to > traditional implementation. So, make the generic secure acr write > over-ride-able by board file and refactor rx51 code to use this. > > While at it, enable the

Re: [U-Boot] config_distro_bootcmd.h: add note on error handling

2015-03-15 Thread Tom Rini
On Tue, Mar 10, 2015 at 03:40:58PM -0600, Stephen Warren wrote: > From: Stephen Warren > > This should make it more clear why there appear to be C pre-processor > symbols in the file that contain mixed case. They're really error > messages. > > Suggested-by: Simon Glass > Signed-off-by: Stephe

Re: [U-Boot] MAKEALL: Don't try to print size when ./u-boot is deleted

2015-03-15 Thread Tom Rini
On Wed, Mar 11, 2015 at 06:47:33PM -0500, Joe Hershberger wrote: > In the case of BUILD_NBUILDS > 1, MAKEALL would try to print the size > immediately after the u-boot binary is deleted by the call to: > > make -s clean > > Move the size print to before the clean > > Signed-off-by: Joe Hershber

Re: [U-Boot] [U-Boot,1/1] beagle_x15: increase phy autoneg timeout

2015-03-15 Thread Tom Rini
On Tue, Mar 10, 2015 at 04:00:09PM +0530, Sekhar Nori wrote: > When Beagle X15 is connected to Gigabit switch, it takes > more time to finish auto-negotiation than on a 10/100 switch. > > The default 4 second limit times-out more often than not. This is > observed when testing with a D-Link DGS-1

Re: [U-Boot] kconfig: remove meaningless prefixes in defconfig files

2015-03-15 Thread Tom Rini
On Thu, Mar 12, 2015 at 01:24:39PM +0900, Masahiro Yamada wrote: > Since commit e02ee2548afe (kconfig: switch to single .config > configuration), the prefixes in defconfig files such as "+S:", > "+ST:", etc., are meaningless. > > This commit was generated by the following command: > > find con

Re: [U-Boot] [PATCH 3/4] sunxi: common VBUS detection logic in usbc

2015-03-15 Thread Paul Kocialkowski
Le dimanche 15 mars 2015 à 19:19 +0100, Marek Vasut a écrit : > On Sunday, March 15, 2015 at 06:27:46 PM, Paul Kocialkowski wrote: > > VBUS detection could be needed not only by the musb code (to prevent host > > mode), but also by e.g. gadget drivers to start only when a cable is > > connected. >

Re: [U-Boot] [PATCH 3/4] sunxi: common VBUS detection logic in usbc

2015-03-15 Thread Marek Vasut
On Sunday, March 15, 2015 at 10:54:05 PM, Paul Kocialkowski wrote: > Le dimanche 15 mars 2015 à 19:19 +0100, Marek Vasut a écrit : > > On Sunday, March 15, 2015 at 06:27:46 PM, Paul Kocialkowski wrote: > > > VBUS detection could be needed not only by the musb code (to prevent > > > host mode), but

[U-Boot] [PATCH 2/2] ls102xa: config: Add USB XHCI controller base address for LS102XA

2015-03-15 Thread Nikhil Badola
Define base address of usb xhci controller Signed-off-by: Nikhil Badola --- arch/arm/include/asm/arch-ls102xa/config.h | 1 + include/linux/usb/xhci-fsl.h | 5 + 2 files changed, 6 insertions(+) diff --git a/arch/arm/include/asm/arch-ls102xa/config.h b/arch/arm/include/asm/ar

[U-Boot] [PATCH 1/2] drivers: usb: fsl: Add support for two USB XHCI controllers

2015-03-15 Thread Nikhil Badola
Add support for two USB XHCI controllers for fsl platforms Signed-off-by: Nikhil Badola --- Depends on "fsl/usb: Add USB XHCI support" drivers/usb/host/xhci-fsl.c | 17 ++--- include/linux/usb/xhci-fsl.h | 5 - 2 files changed, 14 insertions(+), 8 deletions(-) diff --git a/dr

[U-Boot] [PATCH] ARM: UniPhier: remove unnecessary CONFIG_SYS_SOC

2015-03-15 Thread Masahiro Yamada
Since commit a86ac9540e20 (ARM: UniPhier: include instead of ), UniPhier platform does not need the symbolic link arch/arm/include/asm. This option is not necessary either. Signed-off-by: Masahiro Yamada --- arch/arm/mach-uniphier/Kconfig | 3 --- 1 file changed, 3 deletions(-) diff --git a/

Re: [U-Boot] [PATCH 3/4] common/lcd_console: move single static variables into common (static) structure

2015-03-15 Thread Hannes Petermaier
Nikita Kiryanov schrieb am 15.03.2015 19:57:08: > Hi Hannes, Hi Nikita, > > > -static void *lcd_console_address; > > +struct console_t { > > + short curr_col, curr_row; > > + short cols, rows; > > + void *lcd_address; > > Can this be void *base_address? I think that's a bit more descripti

Re: [U-Boot] bav335x support broken

2015-03-15 Thread Gilles
Hi Anish, Thanks for pointing that out. I ran menuconfig and that fixed the compilation issue however, now I'm getting this error when I try to run it: spl_load_image_fat_os: error reading image args, err - -1 I guess I'll fool around with menuconfig see if there is something that should be en