Altera Arria10 SOCFPGA Pin Configuration Bindings
This document describes device tree bindings required to perform configuration
of the pins for an Altera Arria10 SOCFPGA . The bindings are intended to
be compact and easy to be consumed only by a SPL running in a small on-chip
ram before external
No one is using LCD_MONOCHROME; remove related code.
Signed-off-by: Nikita Kiryanov
Cc: Wolfgang Denk
Cc: Anatolij Gustschin
Acked-by: Simon Glass
---
Changes in V2:
- No changes.
common/lcd.c | 30 ++
drivers/video/mpc8xx_lcd.c | 17
Rename console_(row|col) to console_curr_(row|col) to make their meaning clearer
and distinguish them from CONSOLE_(COLS|ROWS).
This is a preparatory step for extracting lcd console code into its own file.
Signed-off-by: Nikita Kiryanov
Cc: Simon Glass
Cc: Anatolij Gustschin
---
Changes in V2:
No one is using CONFIG_SYS_INVERT_COLORS; remove related code.
Signed-off-by: Nikita Kiryanov
Cc: Simon Glass
Cc: Anatolij Gustschin
Acked-by: Simon Glass
---
Changes in V2:
- No changes.
common/lcd.c | 8
drivers/video/mpc8xx_lcd.c | 4 +---
2 files changed, 1
No one is using CONFIG_EDT32F10; remove related code.
Signed-off-by: Nikita Kiryanov
Cc: Wolfgang Denk
Cc: Anatolij Gustschin
Acked-by: Simon Glass
---
Changes in V2:
- No changes.
drivers/video/mpc8xx_lcd.c | 28
include/configs/R360MPI.h | 1 -
2 file
Remove code duplication from lcd_drawchars().
Signed-off-by: Nikita Kiryanov
Cc: Anatolij Gustschin
Cc: Simon Glass
Acked-by: Simon Glass
---
Changes in V2:
- No changes.
common/lcd.c | 14 +-
1 file changed, 1 insertion(+), 13 deletions(-)
diff --git a/common/lcd.c b/co
Replace CONSOLE_(ROWS|COLS) macros with variables, and assign the
original macro values.
This is a preparatory step for extracting lcd console code into its own
file.
Signed-off-by: Nikita Kiryanov
Cc: Anatolij Gustschin
Cc: Simon Glass
---
Changes in V2:
- New patch.
common/lcd.c |
Introduce lcd_getbgcolor() and lcd_getfgcolor(), and use them where
applicable.
This is a preparatory step for extracting lcd console code into its own
file.
Signed-off-by: Nikita Kiryanov
c: Anatolij Gustschin
Cc: Simon Glass
---
Changes in V2:
- New patch.
common/lcd.c | 20 ++
Introduce set_console_row(), set_console_col(), and lcd_init_console().
Use these functions in lcd functions: lcd_init(), lcd_clear(), lcd_logo().
This is a preparatory step for extracting lcd console code into its own
file.
Signed-off-by: Nikita Kiryanov
Cc: Anatolij Gustschin
Cc: Simon Glass
CONSOLE_ROW_SECOND, CONSOLE_ROW_LAST, and
CONSOLE_SCROLL_SIZE are unused. Remove them.
Signed-off-by: Nikita Kiryanov
Cc: Anatolij Gustschin
Cc: Simon Glass
---
Changes in V2:
- New patch.
common/lcd_console.c | 4
1 file changed, 4 deletions(-)
diff --git a/common/lcd_console.c
COLOR_MASK macro doesn't do anything; Remove it to reduce visual
complexity.
This is a preparatory step for extracting lcd console code into its own
file.
Signed-off-by: Nikita Kiryanov
Cc: Anatolij Gustschin
Cc: Simon Glass
---
Changes in V2:
- New patch.
common/lcd.c | 14 ++---
lcd_logo() has the following return value:
#if defined(CONFIG_LCD_LOGO) && !defined(CONFIG_LCD_INFO_BELOW_LOGO)
return (void *)((ulong)lcd_base + BMP_LOGO_HEIGHT * lcd_line_length);
#else
return (void *)lcd_base;
#endif
This return value gets assigned to lcd_console_address.
lc
NOTE: I'm resending this cover letter with a shorter Cc list because the
original mail got held up. Sorry for the double post.
This series is a first step towards an end goal of merging all CONFIG_LCD
related functionality into CONFIG_VIDEO code. My plan is to start by refactoring
lcd.c into somet
common/lcd.c is a mix of code portions that do different but related
things. To improve modularity, the various code portions should be split
into their own modules. Separate lcd console code into its own file.
Signed-off-by: Nikita Kiryanov
Cc: Anatolij Gustschin
Cc: Wolfgang Denk
Cc: Simon Gl
This series is a first step towards an end goal of merging all CONFIG_LCD
related functionality into CONFIG_VIDEO code. My plan is to start by refactoring
lcd.c into something cleaner (less ifdefs) and more modular (split code into
multiple files), then possibly refactor CONFIG_VIDEO code if needed
common/lcd.c is a mix of code portions that do different but related
things. To improve modularity, the various code portions should be split
into their own modules. Separate lcd console code into its own file.
Signed-off-by: Nikita Kiryanov
Cc: Anatolij Gustschin
Cc: Wolfgang Denk
Cc: Lukasz M
On 27 November 2014 at 08:08, Sjoerd Simons
wrote:
> Unlike the Peach-Pit board, there is no parade edp to lvds bridge on the
> Pi. So drop it from device-tree
>
> Signed-off-by: Sjoerd Simons
> ---
> Changes since v1: Only modify the DTB
>
> arch/arm/dts/exynos5800-peach-pi.dts | 5 -
> 1
On 27 November 2014 at 08:08, Sjoerd Simons
wrote:
> Not all exynos 5420 based devices with an LCD also have a parade LVDS
> bridge. So make sure compilation doesn't break if CONFIG_LCD is enabled
> and CONFIG_VIDEO_PARADE is not.
>
> Signed-off-by: Sjoerd Simons
> ---
> Changes since V1: New pa
On 27 November 2014 at 08:34, Sjoerd Simons
wrote:
> The ChromeOS EC keyboard is used by various different chromebooks. Peach
> pi being the third board in the u-boot tree to use it (snow and peach
> pit the other two). Rather then embedding the same big DT node in the
> peach-pi DT again, copy th
On 30 November 2014 at 05:29, Nikita Kiryanov wrote:
> Rename console_(row|col) to console_curr_(row|col) to make their meaning
> clearer
> and distinguish them from CONSOLE_(COLS|ROWS).
>
> This is a preparatory step for extracting lcd console code into its own file.
>
> Signed-off-by: Nikita Ki
On 30 November 2014 at 05:29, Nikita Kiryanov wrote:
> Introduce set_console_row(), set_console_col(), and lcd_init_console().
> Use these functions in lcd functions: lcd_init(), lcd_clear(), lcd_logo().
>
> This is a preparatory step for extracting lcd console code into its own
> file.
>
> Signed
On 30 November 2014 at 05:29, Nikita Kiryanov wrote:
> COLOR_MASK macro doesn't do anything; Remove it to reduce visual
> complexity.
>
> This is a preparatory step for extracting lcd console code into its own
> file.
>
> Signed-off-by: Nikita Kiryanov
> Cc: Anatolij Gustschin
> Cc: Simon Glass
Hi Nikita,
On 30 November 2014 at 05:29, Nikita Kiryanov wrote:
> Introduce lcd_getbgcolor() and lcd_getfgcolor(), and use them where
> applicable.
>
> This is a preparatory step for extracting lcd console code into its own
> file.
>
> Signed-off-by: Nikita Kiryanov
> c: Anatolij Gustschin
> Cc
Hi Nikita,
On 30 November 2014 at 06:22, Nikita Kiryanov wrote:
> common/lcd.c is a mix of code portions that do different but related
> things. To improve modularity, the various code portions should be split
> into their own modules. Separate lcd console code into its own file.
>
> Signed-off-b
On 30 November 2014 at 05:29, Nikita Kiryanov wrote:
> CONSOLE_ROW_SECOND, CONSOLE_ROW_LAST, and
> CONSOLE_SCROLL_SIZE are unused. Remove them.
>
> Signed-off-by: Nikita Kiryanov
> Cc: Anatolij Gustschin
> Cc: Simon Glass
> ---
> Changes in V2:
> - New patch.
Acked-by: Simon Glass
Te
Hi Stefan,
On 21 November 2014 at 08:34, Stefan Agner wrote:
> Resynchronize memcpy/memset with kernel and build them explicitly
> in Thumb2 mode (unified syntax). Those assembler files can be
> built and linked in ARM mode too, however when calling them from
> Thumb2 built code, the stack got co
On 2014-11-30 20:33, Simon Glass wrote:
> Hi Stefan,
>
> On 21 November 2014 at 08:34, Stefan Agner wrote:
>> Resynchronize memcpy/memset with kernel and build them explicitly
>> in Thumb2 mode (unified syntax). Those assembler files can be
>> built and linked in ARM mode too, however when callin
Hi Martin,
On 27 November 2014 at 01:42, Martin Dorwig wrote:
> this is an atempt to make the export of functions typesafe.
> I replaced the jumptable void ** by a struct (jt_funcs) with function
> pointers.
> The EXPORT_FUNC macro now has 3 fixed parameters and one
> variadic parameter
> The fi
Dear Sjoerd Simons,
On 28/11/14 00:08, Sjoerd Simons wrote:
> Not all exynos 5420 based devices with an LCD also have a parade LVDS
> bridge. So make sure compilation doesn't break if CONFIG_LCD is enabled
> and CONFIG_VIDEO_PARADE is not.
>
> Signed-off-by: Sjoerd Simons
> ---
> Changes since
This addes macro for set and clear bit control for module control register.
This is used when user want to disable the function of the devices
corresponding to register.
Signed-off-by: Nobuhiro Iwamatsu
---
arch/arm/include/asm/arch-rmobile/rcar-mstp.h | 4
1 file changed, 4 insertions(+)
Before a kernel boots, GPIO, SYS-DMAC, QSPI and MSIOF clock
is halted.
Signed-off-by: Hisashi Nakamura
Signed-off-by: Nobuhiro Iwamatsu
---
board/renesas/lager/lager.c | 43 +--
1 file changed, 41 insertions(+), 2 deletions(-)
diff --git a/board/renesas/
Module control registers of R-Car ARM SoC (r8a7790, r8a7791, r8a7793 and
r8a7794) are same address. This moves these to header file of SoC.
Signed-off-by: Nobuhiro Iwamatsu
---
arch/arm/include/asm/arch-rmobile/rcar-base.h | 39 +++
board/renesas/alt/alt.c
Control macro of mstp is common in R-Car ARM SoC (r8a7790, r8a7791,
r8a7793 and r8a7794). This moves these to arch-rmobile/rcar-mstp.h
Signed-off-by: Nobuhiro Iwamatsu
---
arch/arm/include/asm/arch-rmobile/rcar-mstp.h | 22 ++
board/renesas/alt/alt.c | 1
Before a kernel boots, GPIO, SYS-DMAC, QSPI, MSIOF and IPMMU-GP
clock is halted.
Signed-off-by: Hisashi Nakamura
Signed-off-by: Nobuhiro Iwamatsu
---
board/renesas/alt/alt.c | 43 +--
1 file changed, 41 insertions(+), 2 deletions(-)
diff --git a/board/re
Before a kernel boots, GPIO, SYS-DMAC, QSPI, MSIOF and IPMMU-GP
clock is halted.
Signed-off-by: Hisashi Nakamura
Signed-off-by: Nobuhiro Iwamatsu
---
board/renesas/koelsch/koelsch.c | 43 +++--
1 file changed, 41 insertions(+), 2 deletions(-)
diff --git a/bo
Before a kernel boots, GPIO, SYS-DMAC, QSPI, MSIOF and IPMMU-GP
clock is halted.
Signed-off-by: Hisashi Nakamura
Signed-off-by: Nobuhiro Iwamatsu
---
board/renesas/gose/gose.c | 44 ++--
1 file changed, 42 insertions(+), 2 deletions(-)
diff --git a/board
this is an atempt to make the export of functions typesafe.
I replaced the jumptable void ** by a struct (jt_funcs) with function pointers.
The EXPORT_FUNC macro now has 3 fixed parameters and one
variadic parameter
The first is the name of the exported function,
the rest of the parameters are used
Dear Nobuhiro,
In message <1417417556-23946-4-git-send-email-nobuhiro.iwamatsu...@renesas.com>
you wrote:
> Before a kernel boots, GPIO, SYS-DMAC, QSPI and MSIOF clock
> is halted.
>
> Signed-off-by: Hisashi Nakamura
> Signed-off-by: Nobuhiro Iwamatsu
The data structures and the code are all
On 30.11.2014 05:00, Luka Perkov wrote:
Signed-off-by: Luka Perkov
CC: Prafulla Wadaskar
CC: Stefan Roese
Acked-by: Stefan Roese
Thanks,
Stefan
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
On 30.11.2014 05:02, Luka Perkov wrote:
Signed-off-by: Luka Perkov
CC: Prafulla Wadaskar
CC: Stefan Roese
Acked-by: Stefan Roese
Thanks,
Stefan
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
On 30.11.2014 05:01, Luka Perkov wrote:
Signed-off-by: Luka Perkov
CC: Prafulla Wadaskar
CC: Stefan Roese
Acked-by: Stefan Roese
Thanks,
Stefan
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
On 30.11.2014 05:02, Luka Perkov wrote:
Signed-off-by: Luka Perkov
CC: Prafulla Wadaskar
CC: Stefan Roese
Acked-by: Stefan Roese
Thanks,
Stefan
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
On 30.11.2014 05:01, Luka Perkov wrote:
Signed-off-by: Luka Perkov
CC: Prafulla Wadaskar
CC: Stefan Roese
Acked-by: Stefan Roese
Thanks,
Stefan
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
On 30.11.2014 05:01, Luka Perkov wrote:
Signed-off-by: Luka Perkov
CC: Prafulla Wadaskar
CC: Stefan Roese
Acked-by: Stefan Roese
Thanks,
Stefan
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
From: Shaohui Xie
Add following configs in header file:
CONFIG_SYS_GENERIC_BOARD
CONFIG_DISPLAY_BOARDINFO
Signed-off-by: Shaohui Xie
---
include/configs/P2041RDB.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/include/configs/P2041RDB.h b/include/configs/P2041RDB.h
index 16f7525..ef062
45 matches
Mail list logo