NOTE: I'm resending this cover letter with a shorter Cc list because the original mail got held up. Sorry for the double post.
This series is a first step towards an end goal of merging all CONFIG_LCD related functionality into CONFIG_VIDEO code. My plan is to start by refactoring lcd.c into something cleaner (less ifdefs) and more modular (split code into multiple files), then possibly refactor CONFIG_VIDEO code if needed, and then finally: move CONFIG_LCD related functionality over to CONFIG_VIDEO code, replacing as much CONFIG_LCD related code with CONFIG_VIDEO related code as possible. This specific step eliminates some unused code and refactors lcd console stuff into its own file. In V2 I broke the last patch of the original series ("lcd: refactor lcd console stuff into its own file") into multiple patches to make it clear what changes had to be done in order to refactor the lcd console code into its own file. These preparatory patches ("lcd: rename console_(row|col)" to "lcd: make lcd_drawchars() independant of lcd_base") are meant to illustrate exactly what changed and where in the transition from lcd.c to lcd_console.c, and are not necesserily code improvements when viewed out of context. Additional changes in V2: - Added documentation for the new functions. The whole series was rebased over current mainline, and compile tested for arm and powerpc. Cc: Anatolij Gustschin <ag...@denx.de> Cc: Wolfgang Denk <w...@denx.de> Cc: Simon Glass <s...@chromium.org> Nikita Kiryanov (12): lcd: remove CONFIG_SYS_INVERT_COLORS lcd: cleanup lcd_drawchars mpc8xx_lcd: get rid of CONFIG_EDT32F10 lcd: remove LCD_MONOCHROME lcd: rename console_(row|col) lcd: replace CONSOLE_(ROWS|COLS) with variables lcd: expand console api lcd: get rid of COLOR_MASK lcd: introduce getters for bg/fg color lcd: make lcd_drawchars() independant of lcd_base lcd: refactor lcd console stuff into its own file lcd_console: remove unused defines common/Makefile | 2 +- common/lcd.c | 308 +++++---------------------------------------- common/lcd_console.c | 208 ++++++++++++++++++++++++++++++ drivers/video/mpc8xx_lcd.c | 49 +------- drivers/video/pxa_lcd.c | 15 --- include/configs/R360MPI.h | 1 - include/lcd.h | 25 ++-- include/lcd_console.h | 85 +++++++++++++ 8 files changed, 340 insertions(+), 353 deletions(-) create mode 100644 common/lcd_console.c create mode 100644 include/lcd_console.h -- 1.9.1 _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot