Re: [U-Boot] [PATCH][v2] driver/ifc:Change accessor function to take care of endianness

2014-01-18 Thread Wolfgang Denk
Dear Prabhakar Kushwaha, In message <1390028310-30861-1-git-send-email-prabha...@freescale.com> you wrote: > IFC registers can be of type Little Endian or big Endian depending upon > Freescale SoC. Here SoC defines the register type of IFC IP. As is, you are only adding dead code, as there is no

Re: [U-Boot] [PULL] : Please pull u-boot-imx

2014-01-18 Thread Albert ARIBAUD
Hi Tom, On Fri, 17 Jan 2014 17:03:58 -0500, Tom Rini wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA1 > > On 01/17/2014 12:27 PM, Fabio Estevam wrote: > > Hi Tom, > > > > On Fri, Jan 17, 2014 at 7:26 AM, Stefano Babic > > wrote: > >> Hi Albert, > >> > >> Commit 022298278 (mx6: soc: D

Re: [U-Boot] Help with USB keyboards: EHCI timeout error

2014-01-18 Thread John Donnelly
Hi, Platform : FreeScale - p4080 - e500mc Our Banner: U-Boot 2013.01-00040-gfd65bf6-dirty (Jan 16 2014 - 17:25:34) CPU0: P4080E, Version: 2.0, (0x82080020) Core: E500MC, Version: 2.0, (0x80230020) Keyboard has additional USB ports (HUB) on it : Dell Model: Dell Multimedia Keyboard : M/N:

[U-Boot] [PATCH 2/6] sf: Optimize flash features code

2014-01-18 Thread Jagannadha Sutradharudu Teki
- Shrink spi_slave {} - Shrink spi_flash_params {} - Documentation for sf features Signed-off-by: Jagannadha Sutradharudu Teki Cc: Marek Vasut --- doc/SPI/README.sf-features| 122 ++ drivers/mtd/spi/sf.c | 4 +- drivers/mtd/spi/sf_internal.h | 1 - d

[U-Boot] [PATCH 3/6] sf: Renames on dual_flash stuff

2014-01-18 Thread Jagannadha Sutradharudu Teki
- Used small names for dual_flash macros - Updated doc/SPI/README.dual-flash Signed-off-by: Jagannadha Sutradharudu Teki Cc: Marek Vasut --- doc/SPI/README.dual-flash | 9 + doc/SPI/README.sf-features | 3 +++ drivers/mtd/spi/sf_ops.c | 10 +- drivers/mtd/spi/sf_probe.c | 1

[U-Boot] [PATCH 6/6] sf: Update bank configuration

2014-01-18 Thread Jagannadha Sutradharudu Teki
Updated bank configuration code to more readable. Signed-off-by: Jagannadha Sutradharudu Teki --- drivers/mtd/spi/sf_probe.c | 22 -- 1 file changed, 12 insertions(+), 10 deletions(-) diff --git a/drivers/mtd/spi/sf_probe.c b/drivers/mtd/spi/sf_probe.c index 8f92333..06f99da

[U-Boot] [PATCH 5/6] sf: Minor macro cleanups

2014-01-18 Thread Jagannadha Sutradharudu Teki
Renamed SPI_FLASH with SF in few places in sf code. Signed-off-by: Jagannadha Sutradharudu Teki --- drivers/mtd/spi/sf_internal.h | 20 ++-- drivers/mtd/spi/sf_ops.c | 23 +++ drivers/mtd/spi/sf_probe.c| 19 +-- 3 files changed, 30 ins

[U-Boot] [PATCH 1/6] sf: ops: Squash the malloc+memset combo

2014-01-18 Thread Jagannadha Sutradharudu Teki
Squash the malloc()+memset() combo in favor of calloc(). Signed-off-by: Jagannadha Sutradharudu Teki Cc: Marek Vasut --- drivers/mtd/spi/sf_ops.c | 7 +-- 1 file changed, 5 insertions(+), 2 deletions(-) diff --git a/drivers/mtd/spi/sf_ops.c b/drivers/mtd/spi/sf_ops.c index 1f1bb36..1fac63a

[U-Boot] [PATCH 4/6] sf: Update read/write command macros

2014-01-18 Thread Jagannadha Sutradharudu Teki
- Used readable names for read/write command macros - Added comments for the same Signed-off-by: Jagannadha Sutradharudu Teki Cc: Marek Vasut Cc: Simon Glass --- drivers/mtd/spi/ramtron.c | 10 -- drivers/mtd/spi/sandbox.c | 12 ++-- drivers/mtd/spi/sf_internal.h | 16 +

[U-Boot] [PATCH 0/6] sf: Optimize spi_flash features code

2014-01-18 Thread Jagannadha Sutradharudu Teki
Shrinked spi_slave and spi_flash code with respect to added flash features. Jagannadha Sutradharudu Teki (6): sf: ops: Squash the malloc+memset combo sf: Optimize flash features code sf: Renames on dual_flash stuff sf: Update read/write command macros sf: Minor macro cleanups sf: Updat

Re: [U-Boot] Pull request: u-boot-spi/master

2014-01-18 Thread Marek Vasut
On Thursday, January 16, 2014 at 08:44:55 PM, Jagan Teki wrote: > Hi Marek, [...] > >> > >> Let me explain the journey with (spi_flash)sf since last 8 months. [1] > >> - We have a individual class of vendor drivers and removed all vendor > >> specific stuff and added a common probe. > >> - Added B

Re: [U-Boot] [PATCH 2/3] sf: Shrink spi_slave {}

2014-01-18 Thread Marek Vasut
On Friday, January 17, 2014 at 07:29:54 PM, Gerhard Sittig wrote: > On Fri, Jan 17, 2014 at 22:42 +0530, Jagan Teki wrote: > > On Fri, Jan 17, 2014 at 10:01 PM, Marek Vasut wrote: > > > Anyway, I feel we're sinking deeper and deeper into this > > > sh*t, we should instead take a step back and re-t

Re: [U-Boot] [PATCH 2/3] sf: Shrink spi_slave {}

2014-01-18 Thread Marek Vasut
On Friday, January 17, 2014 at 06:12:49 PM, Jagan Teki wrote: > On Fri, Jan 17, 2014 at 10:01 PM, Marek Vasut wrote: > > On Friday, January 17, 2014 at 03:41:46 PM, Jagannadha Sutradharudu Teki wrote: > >> Combined spi flash stuff as minimum as possible. > > > > Squashing the names of the flags

Re: [U-Boot] [PATCH 1/6] sf: ops: Squash the malloc+memset combo

2014-01-18 Thread Marek Vasut
On Saturday, January 18, 2014 at 09:06:28 PM, Jagannadha Sutradharudu Teki wrote: > Squash the malloc()+memset() combo in favor of calloc(). > > Signed-off-by: Jagannadha Sutradharudu Teki > Cc: Marek Vasut > --- > drivers/mtd/spi/sf_ops.c | 7 +-- > 1 file changed, 5 insertions(+), 2 dele

Re: [U-Boot] [PATCH 3/6] sf: Renames on dual_flash stuff

2014-01-18 Thread Marek Vasut
On Saturday, January 18, 2014 at 09:06:30 PM, Jagannadha Sutradharudu Teki wrote: > - Used small names for dual_flash macros > - Updated doc/SPI/README.dual-flash > > Signed-off-by: Jagannadha Sutradharudu Teki > Cc: Marek Vasut I agree with the documentation, but disagree with the rename. Ple

Re: [U-Boot] [PATCH 4/6] sf: Update read/write command macros

2014-01-18 Thread Marek Vasut
On Saturday, January 18, 2014 at 09:06:31 PM, Jagannadha Sutradharudu Teki wrote: > - Used readable names for read/write command macros > - Added comments for the same > > Signed-off-by: Jagannadha Sutradharudu Teki > Cc: Marek Vasut > Cc: Simon Glass Does this patch have any impact other tha

Re: [U-Boot] [PATCH 2/6] sf: Optimize flash features code

2014-01-18 Thread Marek Vasut
On Saturday, January 18, 2014 at 09:06:29 PM, Jagannadha Sutradharudu Teki wrote: > - Shrink spi_slave {} > - Shrink spi_flash_params {} > - Documentation for sf features > > Signed-off-by: Jagannadha Sutradharudu Teki > Cc: Marek Vasut > --- > doc/SPI/README.sf-features| 122 +

Re: [U-Boot] [PATCH 4/6] sf: Update read/write command macros

2014-01-18 Thread Jagan Teki
On Sun, Jan 19, 2014 at 2:06 AM, Marek Vasut wrote: > On Saturday, January 18, 2014 at 09:06:31 PM, Jagannadha Sutradharudu Teki > wrote: >> - Used readable names for read/write command macros >> - Added comments for the same >> >> Signed-off-by: Jagannadha Sutradharudu Teki >> Cc: Marek Vasut >

Re: [U-Boot] [PATCH 3/6] sf: Renames on dual_flash stuff

2014-01-18 Thread Jagan Teki
On Sun, Jan 19, 2014 at 2:07 AM, Marek Vasut wrote: > On Saturday, January 18, 2014 at 09:06:30 PM, Jagannadha Sutradharudu Teki > wrote: >> - Used small names for dual_flash macros >> - Updated doc/SPI/README.dual-flash >> >> Signed-off-by: Jagannadha Sutradharudu Teki >> Cc: Marek Vasut > > I

Re: [U-Boot] [PATCH 2/6] sf: Optimize flash features code

2014-01-18 Thread Jagan Teki
On Sun, Jan 19, 2014 at 2:09 AM, Marek Vasut wrote: > On Saturday, January 18, 2014 at 09:06:29 PM, Jagannadha Sutradharudu Teki > wrote: >> - Shrink spi_slave {} >> - Shrink spi_flash_params {} >> - Documentation for sf features >> >> Signed-off-by: Jagannadha Sutradharudu Teki >> Cc: Marek Vasu