This patch adds support the generic watchdog timer for s5pc1xx and exynos4
Signed-off-by: Minkyu Kang
Signed-off-by: Kyungmin Park
Cc: HeungJun, Kim
---
arch/arm/cpu/armv7/s5p-common/Makefile |1 +
arch/arm/cpu/armv7/s5p-common/wdt.c | 59 ++
arch/a
Signed-off-by: Minkyu Kang
Signed-off-by: Kyungmin Park
Cc: HeungJun, Kim
---
board/samsung/trats/trats.c | 11 +--
1 files changed, 1 insertions(+), 10 deletions(-)
diff --git a/board/samsung/trats/trats.c b/board/samsung/trats/trats.c
index 2925cff..f795ff0 100644
--- a/board/samsu
On 18/01/2012 04:08, Jason Hui wrote:
>> -int board_mmc_getcd(u8 *cd, struct mmc *mmc)
>> +int board_mmc_getcd(struct mmc *mmc)
>> {
>>struct fsl_esdhc_cfg *cfg = (struct fsl_esdhc_cfg *)mmc->priv;
>> + int ret;
>>
>>if (cfg->esdhc_base == USDHC3_BASE_ADDR) {
>>
On 18/01/2012 02:44, Eric Nelson wrote:
> On 01/17/2012 06:27 PM, Marek Vasut wrote:
>>> On 01/17/2012 04:19 PM, Marek Vasut wrote:
> Signed-off-by: Eric Nelson
> +/* ECSPI registers */
> +struct cspi_regs {
> +u32 rxdata;
> +u32 txdata;
> +u32 ctrl;
> +u
Commit 314284b1567f1ce29c19060641e7f213146f7ab8 has
changed board_mmc_getcd() function prototype, while
mx6qarm2 has still the old one.
Signed-off-by: Stefano Babic
CC: Jason Liu
Acked-by: Dirk Behme
---
Changes since V1:
- update subject (Fabio Estevam)
Changes since V2:
- board_mmc_getcd() m
Existing OMAP I2C driver does not support address
length greater than one. Hence this patch is to
add support for 2 byte address read/write.
Signed-off-by: Philip, Avinash
Signed-off-by: Hebbar, Gururaja
Signed-off-by: Patil, Rachna
---
Changes for v2:
Fixed review comments from Heiko Schocher
1. Compliant with Philips I2C specification version 2.1
2. Supports upto 100Kbps in standard mode.
Signed-off-by: Chandan Nath
Signed-off-by: Patil, Rachna
---
Changes for v2:
No change
drivers/i2c/omap24xx_i2c.c | 20 +---
1 files changed, 13 insertions(+), 7 deletions(-)
d
Add i2c driver board hookup for AM335X EVM.
Signed-off-by: Chandan Nath
Signed-off-by: Patil, Rachna
---
Changes for v2:
Fixed review comments from Chandan
arch/arm/cpu/armv7/am33xx/clock.c |5 ++
arch/arm/include/asm/arch-am33xx/common_def.h |1 +
arch/arm/include/asm/arch
On Wed, Jan 18, 2012 at 5:41 PM, Stefano Babic wrote:
> Commit 314284b1567f1ce29c19060641e7f213146f7ab8 has
> changed board_mmc_getcd() function prototype, while
> mx6qarm2 has still the old one.
>
> Signed-off-by: Stefano Babic
> CC: Jason Liu
> Acked-by: Dirk Behme
Acked-by: Jason Liu
> --
Add bit definitions for register 32 and 33 of Freescale MC13783.
Signed-off-by: Helmut Raiger
---
V3: moved change from fsl_pmic.h to mc13783.h (mc13892 differs!)
V2: pmic_reg_(read|write) use constants from fsl_pmic.h now
include/mc13783.h | 80
board_mmc_init() initializes the pins of SDHC1 and
turns on V_MMC1 of the PMIC. Config adds support for EXT2
and FAT.
Signed-off-by: Helmut Raiger
---
V3: moved change from fsl_pmic.h to mc13783.h (mc13892 differs!)
V2: pmic_reg_(read|write) use constants from fsl_pmic.h now
board/hale/tt01/
This patch adds SPI support for the MX28EVK. Support for
an optionally installed SPI flash is also added. An example
configuration for redundant envrionment from SPI flash is also
added but disabled by default.
This patch has been tested on a MX28EVK Rev. D with an installed
SST25VF032B 32Mbit SPI
This patch enables USB host support on the MX28EVK board.
Signed-off-by: Matthias Fuchs
---
board/freescale/mx28evk/mx28evk.c |7 +++
include/configs/mx28evk.h | 12
2 files changed, 19 insertions(+), 0 deletions(-)
diff --git a/board/freescale/mx28evk/mx28evk.c
This patch adds support for the MX28 internal RTC
and enables u-boot's date command.
Signed-off-by: Matthias Fuchs
---
include/configs/mx28evk.h |8
1 files changed, 8 insertions(+), 0 deletions(-)
diff --git a/include/configs/mx28evk.h b/include/configs/mx28evk.h
index bea46e7..8a
Hi,
while playing around with the mx28evk and differnet bootmedia
I found it helpful to see the current bootmode without
running to the board and checking it's switches. Also
some other CPU (e.g. 440 PowerPCs) print some kind of bootstrap
configuration during startup.
The patch probably needs s
Hi,
while playing around with the mx28evk and differnet bootmedia
I found it helpful to see the current bootmode without
running to the board and checking it's switches. Also
some other CPU (e.g. 440 PowerPCs) print some kind of bootstrap
configuration during startup.
The patch probably needs s
On 17.01.2012 23:09, Eric Nelson wrote:
This patch set refactors mxc_spi as described in
http://lists.denx.de/pipermail/u-boot/2010-March/068791.html
and requested in
http://lists.denx.de/pipermail/u-boot/2012-January/116023.html
in order to add support for the MX6Q in general and the mx
On 18/01/2012 11:41, Helmut Raiger wrote:
> board_mmc_init() initializes the pins of SDHC1 and
> turns on V_MMC1 of the PMIC. Config adds support for EXT2
> and FAT.
>
> Signed-off-by: Helmut Raiger
> ---
Hi Helmut,
> +#ifdef CONFIG_CONSOLE_EXTRA_INFO
> +void video_get_info_str(int line_number,
> This patch adds SPI support for the MX28EVK. Support for
> an optionally installed SPI flash is also added. An example
> configuration for redundant envrionment from SPI flash is also
> added but disabled by default.
>
> This patch has been tested on a MX28EVK Rev. D with an installed
> SST25VF0
> On 18/01/2012 02:44, Eric Nelson wrote:
> > On 01/17/2012 06:27 PM, Marek Vasut wrote:
> >>> On 01/17/2012 04:19 PM, Marek Vasut wrote:
> > Signed-off-by: Eric Nelson
> > +/* ECSPI registers */
> > +struct cspi_regs {
> > +u32 rxdata;
> > +u32 txdata;
> > +u32
> This patch adds support for the MX28 internal RTC
> and enables u-boot's date command.
>
> Signed-off-by: Matthias Fuchs
> ---
> include/configs/mx28evk.h |8
> 1 files changed, 8 insertions(+), 0 deletions(-)
>
> diff --git a/include/configs/mx28evk.h b/include/configs/mx28evk.h
On 18/01/2012 17:08, Marek Vasut wrote:
> Ok guys, I see ... Stefano, you're ok with putting the reg structures into
> these
> header files?
The reg structures are already into these header files - the patch moves
only the bit meaning inside the imx-regs.h files. We can discuss if we
should mov
Since MACH_TYPE_ORIGEN is updated on mach-types,
remove the MACH_TYPE_ORIGEN on config file.
Signed-off-by: Minkyu Kang
Cc: Chander Kashyap
---
include/configs/origen.h |2 --
1 files changed, 0 insertions(+), 2 deletions(-)
diff --git a/include/configs/origen.h b/include/configs/origen.h
Hi ,
I am trying to run u-boot from flash and the u-boot gets hanged at
relocate_code function below is the log
U-Boot 2010.03 (May 04 2011 - 16:44:35)
Unicore software on multiprocessor system!!
To enable mutlticore build define CONFIG_MP
CPU: 8641D, Version: 3.0, (0x80900130)
Core: E600
Hi Govindraj,
On 01/17/12 08:10, Govindraj wrote:
>
> And just to clarify further there is no code duplication for ulpi read writes
> in ehci-omap.c done with this patch.
This is not just about code duplication,
this is also about using the ULPI framework instead of direct writes to the
ULPI PHY
The function get_sdr_cs_offset reads the CS_CFG register in the SDRC
to determine where CS1 is mapped to. make_cs1_contiguous() will set
CS1 to follow after CS0. The CS_CFG register has values in bits 9:8
and 3:0 but we had erroneously been testing 5:4 and 3:0 resulting in
incorrect offsets on pl
On 01/18/2012 05:07 PM, Marek Vasut wrote:
>> This patch adds SPI support for the MX28EVK. Support for
>> an optionally installed SPI flash is also added. An example
>> configuration for redundant envrionment from SPI flash is also
>> added but disabled by default.
>>
>> This patch has been tested
> On 01/18/2012 05:07 PM, Marek Vasut wrote:
> >> This patch adds SPI support for the MX28EVK. Support for
> >> an optionally installed SPI flash is also added. An example
> >> configuration for redundant envrionment from SPI flash is also
> >> added but disabled by default.
> >>
> >> This patch h
[+TI maintainers, tx25 board maintainer]
Hi Albert,
On Tue, Jan 17, 2012 at 11:28 PM, Albert ARIBAUD
wrote:
> Hi Simon,
>
> Le 26/12/2011 19:24, Simon Glass a écrit :
>
>> (I am resending this rebased so I can continue with this board-unification
>> work and allow people to review patches. There
On 01/18/2012 01:39 AM, Stefano Babic wrote:
On 18/01/2012 02:44, Eric Nelson wrote:
I'll defer to Stefano on this one, since I did this in response
to his request:
Yes, I admit I am guilty about this !
The layout of the CSPI registers is not exactly the same for all SOCs.
For example, the MX
On Tue, Jan 17, 2012 at 1:12 AM, Simon Glass wrote:
> From: Heiko Schocher
>
> This Patch introduce the new i2c_core file, which holds
> the I2C core functions, for the rework of the multibus/
> multiadapter support.
> Also adds changes in i2c.h for the new I2C multibus/multiadapter
> support. Th
On Wednesday 18 January 2012 15:11:56 Tabi Timur-B04825 wrote:
> On Tue, Jan 17, 2012 at 1:12 AM, Simon Glass wrote:
> > --- a/arch/arm/include/asm/global_data.h
> > +++ b/arch/arm/include/asm/global_data.h
> > @@ -87,6 +87,9 @@ typedef struct global_data {
> >unsigned long post_lo
Mike Frysinger wrote:
> that's only needed if you expect the pointer to stay valid across calls. i
> don't think it does for most (all?) drivers.
True, but it's hard to know sometimes when it's needed. I do it in my
code just to be sure.
Regardless, I still think the idea of a "current" i2c bu
Hi Tabi,
On Wed, Jan 18, 2012 at 12:11 PM, Tabi Timur-B04825
wrote:
> On Tue, Jan 17, 2012 at 1:12 AM, Simon Glass wrote:
>> From: Heiko Schocher
>>
>> This Patch introduce the new i2c_core file, which holds
>> the I2C core functions, for the rework of the multibus/
>> multiadapter support.
>>
Simon Glass wrote:
> I agree completely, it was one of the things I was going to ask for.
> We should add a new parameter to calls instead IMO.
I would be in favor of a patch that replaces all of the I2C calls. It
would be a massive patch, but it solve a lot of problems in one shot.
--
Timur Ta
On 01/11/2012 09:32 PM, Simon Glass wrote:
> This fixes five trivial issues in fdtdec.c:
> 1. fdtdec_get_is_enabled() doesn't really need a default value
> 2. The fdt must be word-aligned, since otherwise it will fail on ARM
> 3. The compat_names[] array is missing its first element. This is needed
On 01/11/2012 09:32 PM, Simon Glass wrote:
> Add a function to look up a property which is a phandle in a node, and
> another to read a fixed-length integer array from an fdt property.
> Also add a function to read boolean properties, although there is no
> actual boolean type in U-Boot.
>
> Signe
On 01/11/2012 09:32 PM, Simon Glass wrote:
> This adds some support into fdtdec for reading GPIO definitions from
> the fdt. We permit up to FDT_GPIO_MAX GPIOs in the system. Each GPIO
> is of the form:
>
> gpio-function-name = ;
That's not true in general.
The binding definition for the GPIO co
Hi Timur,
On Wed, Jan 18, 2012 at 1:39 PM, Timur Tabi wrote:
> Simon Glass wrote:
>> I agree completely, it was one of the things I was going to ask for.
>> We should add a new parameter to calls instead IMO.
>
> I would be in favor of a patch that replaces all of the I2C calls. It
> would be a
reg = <0x7000D000 0x200>;
> + interrupts = < 85 >;
> + };
This is slightly out-of-date now; in next-20120118, that node's
compatible flag is nvidia,tegra20-i2c-dvc. The HW register layout is
somewhat different for this I2C controller, and the differen
s is also somewhat out-of-date w.r.t. the latest in kernel tag
next-20120118. It's probably not too much of an issue, so this is
probably fine to apply as-is. U-Boot may benefit from the addition of
many status="disable" properties, and clock-frequency properties for the
I2C nodes.
On 01/11/2012 09:32 PM, Simon Glass wrote:
> Add a directory to hold device tree binding files, to permit easy review
> of this material in U-Boot patches.
>
> Signed-off-by: Simon Glass
> diff --git a/doc/device-tree-bindings/README b/doc/device-tree-bindings/README
> +The intent is not to com
Simon Glass wrote:
> I agree. Do you know of such a patch? :-)
No, but it wouldn't be heard to create -- mostly a global
search-and-replace. I wouldn't even attempt it without getting
pre-approved by Wolfgang first, though.
--
Timur Tabi
Linux kernel developer at Freescale
On 01/11/2012 09:32 PM, Simon Glass wrote:
> This adds a property to indicate a port which can switch between host and
> device
> mode.
>
> Signed-off-by: Simon Glass
> ---
>
> doc/device-tree-bindings/usb/tegra-usb.txt |4
> 1 files changed, 4 insertions(+), 0 deletions(-)
>
> diff
Albert,
Please pull u-boot-tegra/master into arm master. Thanks.
The following changes since commit 137703b811502dfea364650fb3e17f20b4c21333:
overo: add SPL support (2012-01-16 08:40:13 +0100)
are available in the git repository at:
git://git.denx.de/u-boot-tegra master
Simon Glass (9):
Document a binding for the Tegra20 CAR (Clock And Reset) Controller,
add it to tegra20.dtsi, and configure it for the board in tegra-
seaboard.dts.
Signed-off-by: Stephen Warren
---
All, Simon Glass is attempting to upstream Tegra USB support in U-Boot.
The driver is only instantiated from device
On 01/11/2012 09:33 PM, Simon Glass wrote:
> This adds clock references to the USB part of the device tree for U-Boot.
>
> The USB timing information may vary between boards sometimes, but for
> now we hard-code it in C. This is because all current T2x boards use
> the same values, we will deal wi
On 01/11/2012 09:33 PM, Simon Glass wrote:
> This adds basic USB support for port 0. The other port is not supported
> yet.
> diff --git a/board/nvidia/common/board.c b/board/nvidia/common/board.c
> +#ifdef CONFIG_USB_EHCI_TEGRA
> + /* For USB GPIO PD0. for now, since we have no pinmux in fdt
On 01/11/2012 09:33 PM, Simon Glass wrote:
> This adds basic support for the Tegra2 USB controller. Board files should
> call board_usb_init() to set things up.
> diff --git a/arch/arm/cpu/armv7/tegra2/usb.c b/arch/arm/cpu/armv7/tegra2/usb.c
> +/* Record which controller can switch from host to d
Hi,
On Wed, Jan 18, 2012 at 05:16:52PM -0700, Stephen Warren wrote:
> .../bindings/clock/nvidia,tegra20-car.txt | 156
>
> arch/arm/boot/dts/tegra-seaboard.dts | 18 +++
> arch/arm/boot/dts/tegra20.dtsi |7 +
> 3 files chang
On Wed, Jan 18, 2012 at 03:48:30PM -0700, Stephen Warren wrote:
> On 01/11/2012 09:32 PM, Simon Glass wrote:
> > This adds a property to indicate a port which can switch between host and
> > device
> > mode.
> >
> > Signed-off-by: Simon Glass
> > ---
> >
> > doc/device-tree-bindings/usb/tegra-
Dear Simon Glass,
In message
you wrote:
>
> > I was really hoping we could get rid of the concept of a "current" i2c
> > adapter, and just force all drivers to specify the I2C adapter they
> > want to use for a given I2C operation. =A0That's how Linux operates, and
> > it will prevent stuff lik
Hi Olof,
On Wed, Jan 18, 2012 at 9:35 PM, Olof Johansson wrote:
> On Wed, Jan 18, 2012 at 03:48:30PM -0700, Stephen Warren wrote:
>> On 01/11/2012 09:32 PM, Simon Glass wrote:
>> > This adds a property to indicate a port which can switch between host and
>> > device
>> > mode.
>> >
>> > Signed-o
Hello Wolfgang, Timur, Simon,
Wolfgang Denk wrote:
> Dear Simon Glass,
>
> In message
> you
> wrote:
>>> I was really hoping we could get rid of the concept of a "current" i2c
>>> adapter, and just force all drivers to specify the I2C adapter they
>>> want to use for a given I2C operation. =A0
Hi Heiko,
On Wed, Jan 18, 2012 at 10:35 PM, Heiko Schocher wrote:
> Hello Wolfgang, Timur, Simon,
>
> Wolfgang Denk wrote:
>> Dear Simon Glass,
>>
>> In message
>> you
>> wrote:
I was really hoping we could get rid of the concept of a "current" i2c
adapter, and just force all drivers
On Tue Jan 17, 2012 at 08:27:58AM -0700, Tom Rini wrote:
> On Mon, Jan 16, 2012 at 11:46 PM, Sughosh Ganu
> wrote:
> >> >> Hmm.. how did u-boot work on such boards? How can u-boot work with
> >> >> D-Cache
> >> >> enabled, if u-boot is not initializing it? (And I think, on davinci SoC
> >> >> w
Hi Olof,
On Wed, Jan 18, 2012 at 10:41 PM, Olof Johansson wrote:
> Hi,
>
> On Wed, Jan 18, 2012 at 9:55 PM, Simon Glass wrote:
>
>>> fsl-usb.txt uses "dr_mode" here, which might make sense to reuse given some
>>> of
>>> the shared IP in question for device mode:
>>>
>>> - dr_mode : indicates t
Hi,
On Wed, Jan 18, 2012 at 9:55 PM, Simon Glass wrote:
>> fsl-usb.txt uses "dr_mode" here, which might make sense to reuse given some
>> of
>> the shared IP in question for device mode:
>>
>> - dr_mode : indicates the working mode for "fsl-usb2-dr" compatible
>> controllers. Can be "host",
On Wed, Jan 18, 2012 at 10:59 PM, Simon Glass wrote:
> Hi Olof,
>
> On Wed, Jan 18, 2012 at 10:41 PM, Olof Johansson wrote:
>> Hi,
>>
>> On Wed, Jan 18, 2012 at 9:55 PM, Simon Glass wrote:
>>
fsl-usb.txt uses "dr_mode" here, which might make sense to reuse given
some of
the share
On 01/18/2012 01:37 PM, Stefano Babic wrote:
Hi Helmut,
+#ifdef CONFIG_CONSOLE_EXTRA_INFO
+void video_get_info_str(int line_number, char *info)
This has nothing with MCC. Please extend your commit message to explain
you are also adding this feature.
I simply mixed in a different branch, which
board_mmc_init() initializes the pins of SDHC1 and
turns on V_MMC1 of the PMIC. Config adds support for EXT2
and FAT.
Signed-off-by: Helmut Raiger
---
V4: removed unrelated video_get_info_str() stuff
V3: moved change from fsl_pmic.h to mc13783.h (mc13892 differs!)
V2: pmic_reg_(read|write) use
Hello Simon,
Simon Glass wrote:
> Hi Heiko,
>
> On Wed, Jan 18, 2012 at 10:35 PM, Heiko Schocher wrote:
>> Hello Wolfgang, Timur, Simon,
>>
>> Wolfgang Denk wrote:
>>> Dear Simon Glass,
>>>
>>> In message
>>> you
>>> wrote:
> I was really hoping we could get rid of the concept of a "curre
62 matches
Mail list logo