Hello Kim,
Kim Phillips wrote:
> On Wed, 25 Feb 2009 09:00:39 +0100
> Heiko Schocher wrote:
>
>>> so instead of naming it "i2c_bus_num_mux" it should be renamed
>>> "i2c_adapter_num"?, or does i2c_get_bus_num() still imply that it will
>> No, i2c_adapter_num should be 0 or 1 for Controller 0 or
Hello Timur,
Timur Tabi wrote:
> On Wed, Feb 25, 2009 at 2:00 AM, Heiko Schocher wrote:
>
>> We should rework this "i2c multibus" instead complete, so we can remove
>> all this instances from i2c_get_bus_num()/i2c_set_bus_num() in every
>> i2c driver ... such an attempt was in discussion, but un
On Wed, Feb 25, 2009 at 2:00 AM, Heiko Schocher wrote:
> We should rework this "i2c multibus" instead complete, so we can remove
> all this instances from i2c_get_bus_num()/i2c_set_bus_num() in every
> i2c driver ... such an attempt was in discussion, but unfortunately
> failed ... but I hope I c
On Wed, 25 Feb 2009 09:00:39 +0100
Heiko Schocher wrote:
> > so instead of naming it "i2c_bus_num_mux" it should be renamed
> > "i2c_adapter_num"?, or does i2c_get_bus_num() still imply that it will
>
> No, i2c_adapter_num should be 0 or 1 for Controller 0 or 1, I think,
> and i2c_bus_num_mux ca
Hello Kim,
Kim Phillips wrote:
> On Tue, 24 Feb 2009 08:53:33 +0100
> Heiko Schocher wrote:
>
>> Hello Kim,
>>
>> Kim Phillips wrote:
>>> On Thu, 19 Feb 2009 17:24:09 +0100
>>> Heiko Schocher wrote:
>> [...]
unsigned int i2c_get_bus_num(void)
{
+#if defined(CONFIG_I2C_MUX)
On Tue, 24 Feb 2009 08:53:33 +0100
Heiko Schocher wrote:
> Hello Kim,
>
> Kim Phillips wrote:
> > On Thu, 19 Feb 2009 17:24:09 +0100
> > Heiko Schocher wrote:
> [...]
> >> unsigned int i2c_get_bus_num(void)
> >> {
> >> +#if defined(CONFIG_I2C_MUX)
> >> + return i2c_bus_num_mux;
> >> +#else
>
Hello Timur,
Timur Tabi wrote:
> On Thu, Feb 19, 2009 at 10:24 AM, Heiko Schocher wrote:
>> Signed-off-by: Heiko Schocher
>> ---
>
> Could you add a description that says what I2C mux support is? That
> would make it easier to review this patch.
Ok, do this with the next version of this patch
Hello Kim,
Kim Phillips wrote:
> On Thu, 19 Feb 2009 17:24:09 +0100
> Heiko Schocher wrote:
[...]
>> unsigned int i2c_get_bus_num(void)
>> {
>> +#if defined(CONFIG_I2C_MUX)
>> +return i2c_bus_num_mux;
>> +#else
>> return i2c_bus_num;
>> +#endif
>> }
>
> I don't get this mux variant -
Hello Kim,
Kim Phillips wrote:
> On Thu, 19 Feb 2009 17:24:09 +0100
> Heiko Schocher wrote:
>
>> @@ -369,6 +370,23 @@ i2c_probe(uchar chip)
>>
>> int i2c_set_bus_num(unsigned int bus)
>> {
>> +#if defined(CONFIG_I2C_MUX)
>> +if (bus < CONFIG_SYS_MAX_I2C_BUS) {
>> +i2c_bus_num =
On Thu, Feb 19, 2009 at 10:24 AM, Heiko Schocher wrote:
> Signed-off-by: Heiko Schocher
> ---
Could you add a description that says what I2C mux support is? That
would make it easier to review this patch.
--
Timur Tabi
Linux kernel developer at Freescale
__
On Thu, 19 Feb 2009 17:24:09 +0100
Heiko Schocher wrote:
> Signed-off-by: Heiko Schocher
> ---
> drivers/i2c/fsl_i2c.c | 24 +++-
> 1 files changed, 23 insertions(+), 1 deletions(-)
>
> diff --git a/drivers/i2c/fsl_i2c.c b/drivers/i2c/fsl_i2c.c
> index ce646fd..5242884 10
On Thu, 19 Feb 2009 17:24:09 +0100
Heiko Schocher wrote:
> @@ -369,6 +370,23 @@ i2c_probe(uchar chip)
>
> int i2c_set_bus_num(unsigned int bus)
> {
> +#if defined(CONFIG_I2C_MUX)
> + if (bus < CONFIG_SYS_MAX_I2C_BUS) {
> + i2c_bus_num = bus;
> + } else {
[1]
> +
Signed-off-by: Heiko Schocher
---
drivers/i2c/fsl_i2c.c | 24 +++-
1 files changed, 23 insertions(+), 1 deletions(-)
diff --git a/drivers/i2c/fsl_i2c.c b/drivers/i2c/fsl_i2c.c
index ce646fd..5242884 100644
--- a/drivers/i2c/fsl_i2c.c
+++ b/drivers/i2c/fsl_i2c.c
@@ -42,6 +42
13 matches
Mail list logo