Dear Joe Hershberger,
> On Thu, Sep 13, 2012 at 11:45 PM, Marek Vasut wrote:
> > Dear Joe Hershberger,
> >
> >> Hi Marek,
> >>
> >> On Thu, Sep 13, 2012 at 4:28 AM, Marek Vasut wrote:
> >> > Dear Michal Simek,
> >> >
> >> >> + /*
> >> >> + * Following is the setup for Network Control
Dear Joe Hershberger,
> Hi Marek,
>
> On Thu, Sep 13, 2012 at 4:28 AM, Marek Vasut wrote:
> > Dear Michal Simek,
> >
> >> + /*
> >> + * Following is the setup for Network Control register.
> >> + * Bit 2: Set to enable Receive operation.
> >> + * Bit 3: Set to enable Transm
Hi Marek,
On Thu, Sep 13, 2012 at 4:28 AM, Marek Vasut wrote:
> Dear Michal Simek,
>> + /*
>> + * Following is the setup for Network Control register.
>> + * Bit 2: Set to enable Receive operation.
>> + * Bit 3: Set to enable Transmitt operation.
>> + * Bit 4: Set to en
Dear Michal Simek,
[...]
> >
> > Add const int mask for the above.
>
> or macro should be fine.
const int is better due to type checking .
[...]
Thanks!
Best regards,
Marek Vasut
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/ma
On 09/13/2012 11:28 AM, Marek Vasut wrote:
Dear Michal Simek,
[...]
+static inline int mdio_wait(struct eth_device *dev)
+{
+ struct zynq_gem_regs *regs = (struct zynq_gem_regs *)dev->iobase;
+ u32 timeout = 200;
+
+ /* Wait till MDIO interface is ready to accept a new transa
Dear Michal Simek,
[...]
> +static inline int mdio_wait(struct eth_device *dev)
> +{
> + struct zynq_gem_regs *regs = (struct zynq_gem_regs *)dev->iobase;
> + u32 timeout = 200;
> +
> + /* Wait till MDIO interface is ready to accept a new transaction. */
> + while (timeout && !(re
On 08/16/2012 08:30 AM, Michal Simek wrote:
Device driver for Zynq Gem IP.
Signed-off-by: Michal Simek
CC: Joe Hershberger
---
v2: Remove phylib protection
Rename driver file name xilinx_gem to zynq_gem
Rename XEMACPSS to ZYNQ_GEM
Rename gemac_priv to zynq_gem_priv
Rename
Device driver for Zynq Gem IP.
Signed-off-by: Michal Simek
CC: Joe Hershberger
---
v2: Remove phylib protection
Rename driver file name xilinx_gem to zynq_gem
Rename XEMACPSS to ZYNQ_GEM
Rename gemac_priv to zynq_gem_priv
Rename gem_regs to zynq_gem_regs
Add zynq_ prefix to
8 matches
Mail list logo