On Fri, 21 Aug 2015 18:18:21 -0500
Joe Hershberger wrote:
> On Fri, Aug 21, 2015 at 6:11 PM, Lukasz Majewski
> wrote:
> > On Tue, 18 Aug 2015 19:31:03 -0500
> > Joe Hershberger wrote:
> >
> >> Hi Lukasz,
> >>
> >> On Tue, Aug 18, 2015 at 4:28 PM, Lukasz Majewski
> >> wrote:
> >> > On Tue, 18 A
Raspberry Pi by default loads the FDT to 0x0100 so set fdt_addr_r to
match and move scriptaddr to 0x0200 to avoid clobbering the FDT.
Signed-off-by: Jonathan Liu
---
include/configs/rpi-common.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/configs/rpi-c
On Saturday, August 22, 2015 at 07:09:21 PM, Simon Glass wrote:
> Hi Marek,
Hi Simon,
> On 22 August 2015 at 10:48, Marek Vasut wrote:
> > On Saturday, August 22, 2015 at 06:01:44 PM, Simon Glass wrote:
> >> Hi Marek,
> >
> > Hi!
> >
> >> On 22 August 2015 at 09:50, Marek Vasut wrote:
> >> >
Add driver model support to the TPM command and the TPM library. Both
support only a single TPM at present.
Signed-off-by: Simon Glass
---
Changes in v2:
- Correct error checking code in tpm_sendrecv_command()
- Use tpm_ prefix instead of tis_ for TPM functions
common/cmd_tpm.c | 26 ++
Add a TPM node to the various Chromebooks so that driver can be converted to
driver model.
Signed-off-by: Simon Glass
---
Changes in v2:
- Add tpm device tree node for panther also
arch/arm/dts/exynos5250-snow.dts | 9 +
arch/arm/dts/exynos5250-spring.dts| 8
arch/arm
Convert the sandbox TPM driver to use driver model. Add it to the device
tree so that it can be found on start-up.
Signed-off-by: Simon Glass
Acked-by: Christophe Ricard
---
Changes in v2:
- Implement the get_desc() method
- Include tpm.h header file instead of tis.h
arch/sandbox/dts/sandbox.
Add a few new functions which will be used by the test command in a future
patch.
Signed-off-by: Simon Glass
---
Changes in v2:
- Add new patch with functions to access flags and permissions
include/tpm.h | 49 +
lib/tpm.c | 51 ++
Convert the tpm_tis_i2c driver to use driver model and update boards which
use it.
Signed-off-by: Simon Glass
---
Changes in v2:
- Update driver for v2 TPM uclass which supports timeouts
configs/peach-pi_defconfig | 1 +
configs/peach-pit_defconfig | 1 +
configs/snow_defconfig | 1
These tests come from Chrome OS code. They are not particularly tidy but can
be useful for checking that the TPM is behaving correctly. Some knowledge of
TPM operation is required to use these.
Signed-off-by: Simon Glass
---
Changes in v2:
- Add new patch with a 'tpmtest' command
common/Kconfi
The TPM is listed in the device tree. Enable the driver and 'tpm' command
so that it can be used.
Signed-off-by: Simon Glass
Acked-by: Christophe Ricard
---
Changes in v2:
- Enable 'tpmtest' command for nyan
- Update cover letter to mention panther and the tpmtest command.
configs/nyan-big_de
Some definitions are in the C file and some are in the header file. Move
everything into the header file for consistency and to reduce clutter.
Signed-off-by: Simon Glass
---
Changes in v2: None
drivers/tpm/tpm_tis_i2c.c | 335 --
drivers/tpm/tpm_tis
Convert the tpm_tis_lpc driver to use driver model and update boards which
use it.
Signed-off-by: Simon Glass
---
Changes in v2:
- Update driver for the new uclass interface
configs/chromebook_link_defconfig | 2 +
configs/chromebox_panther_defconfig | 2 +
configs/coreboot-x86_defconfig
Rather then crashing when there is no data, print an error.
Acked-by: Christophe Ricard
Signed-off-by: Simon Glass
---
Changes in v2: None
common/cmd_tpm.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/common/cmd_tpm.c b/common/cmd_tpm.c
index 65e7371..e9c6618 100644
--- a/common/cmd_
Add a command to display basic information about a TPM such as the model and
open/close state. This can be useful for debugging.
Signed-off-by: Simon Glass
Acked-by: Christophe Ricard
---
Changes in v2:
- Use tpm_ prefix instead of tis_ for TPM functions
common/cmd_tpm.c | 26
I2C chips can support a register offset, with registers accessible by
sending this offset as the first part of any read or write transaction.
Most I2C chips have a single byte offset, thus the offset length is 1.
This provides access for up 256 registers.
However other offset lengths are supported
Use the same prefix on each function for consistency.
Signed-off-by: Simon Glass
Acked-by: Christophe Ricard
---
Changes in v2: None
drivers/tpm/tpm_tis_i2c.c | 113 --
1 file changed, 58 insertions(+), 55 deletions(-)
diff --git a/drivers/tpm/tpm_
When a 'tpm' command fails, we set the return code but give no indication
of failure. This can be confusing.
Add an error message when any tpm command fails.
Signed-off-by: Simon Glass
---
Changes in v2:
- Correct error-checking code in report_return_code()
common/cmd_tpm.c | 46 +
Add a new uclass for TPMs which uses almost the same TIS (TPM Interface
Specification) as is currently implemented. Since init() is handled by the
normal driver model probe() method, we don't need to implement that. Also
rename the transfer method to xfer() which is a less clumbsy name.
Once all d
Move all the init and uninit code into one place.
Signed-off-by: Simon Glass
---
Changes in v2: None
drivers/tpm/tpm_tis_i2c.c | 33 ++---
1 file changed, 10 insertions(+), 23 deletions(-)
diff --git a/drivers/tpm/tpm_tis_i2c.c b/drivers/tpm/tpm_tis_i2c.c
index 396
There are too many structures storing the same sort of information. Move the
fields from struct tpm into struct tpm_chip and remove the former struct.
Signed-off-by: Simon Glass
---
Changes in v2: None
drivers/tpm/tpm_tis_i2c.c | 24 +---
drivers/tpm/tpm_tis_i2c.h | 1 +
2
The function methods in struct tpm_vendor_specific just call local functions.
Change the code to use a direct call.
Signed-off-by: Simon Glass
---
Changes in v2: None
drivers/tpm/tpm_tis_i2c.c | 12
drivers/tpm/tpm_tis_i2c.h | 4
2 files changed, 4 insertions(+), 12 deletion
Use a _US suffix for microseconds and a _MS suffic for milliseconds. Move
all timeouts and delays into one place. Use mdelay() instead of udelay()
where appropriate.
Signed-off-by: Simon Glass
Acked-by: Christophe Ricard
---
Changes in v2: None
drivers/tpm/tpm_tis_i2c.c | 43 +
This command provides a few useful tests so enable it for common boards.
Signed-off-by: Simon Glass
---
Changes in v2: None
configs/chromebook_link_defconfig | 1 +
configs/chromebox_panther_defconfig | 1 +
configs/coreboot-x86_defconfig | 1 +
configs/peach-pi_defconfig | 1 +
The current Infineon I2C TPM driver is written in two parts, intended to
support use with other I2C devices. However we don't have any users and the
Atmel I2C TPM device does not use this file.
We should simplify this and remove the unused abstration. As a first step,
move the code into one file.
This function is misnamed since it only applies to a single driver. Merge
its fields into its parent.
Signed-off-by: Simon Glass
---
Changes in v2: None
drivers/tpm/tpm_tis_i2c.c | 79 ++-
drivers/tpm/tpm_tis_i2c.h | 16 +++---
2 files changed, 3
Convert all TPM options to Kconfig and tidy up.
Signed-off-by: Simon Glass
Acked-by: Christophe Ricard
---
Changes in v2: None
configs/chromebook_link_defconfig | 2 ++
configs/chromebox_panther_defconfig | 2 ++
configs/controlcenterd_36BIT_SDCARD_DEVELO
There are too many structures storing the same sort of information. Move the
fields from struct tpm_dev into struct tpm_chip and remove the former
struct.
Signed-off-by: Simon Glass
---
Changes in v2: None
drivers/tpm/tpm_tis_i2c.c | 52 +--
drivers/
Add an SPDX header to two drivers that don't have it.
Signed-off-by: Simon Glass
Acked-by: Christophe Ricard
---
Changes in v2: None
drivers/tpm/tpm_atmel_twi.c | 15 +++
drivers/tpm/tpm_tis_i2c.c | 18 +-
2 files changed, 4 insertions(+), 29 deletions(-)
diff -
Add new Kconfig options for TPMs in preparation for moving boards to use
Kconfig for TPM configuration.
Signed-off-by: Simon Glass
---
Changes in v2:
- Add a 'TPM' menu in Kconfig
common/Kconfig | 12 +++
drivers/tpm/Kconfig | 60 +++
This is not used anymore by any board so drop it.
Signed-off-by: Simon Glass
Acked-by: Christophe Ricard
---
Changes in v2: None
drivers/tpm/tpm.c | 108 ++
drivers/tpm/tpm_private.h | 4 +-
drivers/tpm/tpm_tis_i2c.c | 74 +---
The address of the I2C TPM is now defined in the device tree so there is no
need for the CONFIG options.
Remove them from the README and board config to avoid confusion.
Signed-off-by: Simon Glass
Acked-by: Christophe Ricard
---
Changes in v2: None
README | 6 --
This series adds driver model support for Trusted Platform Modules (TPMs).
These have a very simple interface and are configured via the device tree.
Two bus types are supported at present: I2C and LPC (Intel Low-Pin-Count).
Most drivers and users are converted over to driver model. The exception
This requires 'Series-cover_cc' at present which is incorrect. Fix it.
Signed-off-by: Simon Glass
---
tools/patman/series.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/patman/series.py b/tools/patman/series.py
index a17a7d1..3399f2c 100644
--- a/tools/patman/serie
These calls seem to be incorrect. The function expects an I/O address but
the existing callers pass the value at an I/O address. Fix it.
Signed-off-by: Simon Glass
---
Changes in v2: None
drivers/gpio/intel_ich6_gpio.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/dri
It should be possible to read an output GPIO. For now it is not clear
how to do this. Perhaps the driver should be adjusted to use memory-mapped
access throughout. For now, return an error to avoid confusion.
Not to apply.
Signed-off-by: Simon Glass
---
Changes in v2: None
drivers/gpio/intel_
This function can return an error. Correct the detection of this error so
that it works even with large 32-bit addresses.
The return value is set up for returning an I/O address but the function is
also used to return a memory-mapped address. Adjust the return code to make
this work.
Also add a b
This should be 0x250, not 0x258. Fix it.
Reported-by: Andrew Bradford
Signed-off-by: Simon Glass
---
Changes in v2: None
arch/x86/dts/minnowmax.dts | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/dts/minnowmax.dts b/arch/x86/dts/minnowmax.dts
index a8ecf0d..e917f0
Some controllers do not allow the output value to be read. Detect this and
report the error in that case.
Signed-off-by: Simon Glass
---
Changes in v2: None
common/cmd_gpio.c | 34 +++---
1 file changed, 27 insertions(+), 7 deletions(-)
diff --git a/common/cmd_gpio
These functions are defined by macros so do not show up with grep. Add
a comment to help.
Signed-off-by: Simon Glass
Reviewed-by: Bin Meng
---
Changes in v2:
- Fix 'micros' typo
include/pci.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/pci.h b/include/pci.h
index 488ff44..e24c
The ICH GPIO driver does not work correctly at present. This series tidies
things up and fixes a few bugs.
One issue remaining is that reading from output GPIOs does not work - it
always returns 0.
Changes in v2:
- Adjust pci_get_bus() to probe bus 0 so that the required bus is found
- Fix 'micro
At present, until a PCI bus is probed, it cannot be found by its sequence
number unless it has an alias. This is the same with any device.
However with PCI this is more annoying than usual, since bus 0 is always the
same device.
Add a function that tries a little harder to locate PCI bus 0. This
The datasheet suggests that the state of an output pin can be read. In fact
this does not seem to work, perhaps because we are also accessing the GPIO
state through I/O instead of just memory-mapped.
Not to apply.
Signed-off-by: Simon Glass
---
Changes in v2: None
drivers/gpio/intel_ich6_gpio
These GPIOs are accessible on the pin header. Add pinctrl settings for them
so that we they can be adjusted using the 'gpio' command.
Signed-off-by: Simon Glass
---
Changes in v2: None
arch/x86/dts/minnowmax.dts | 27 +++
1 file changed, 27 insertions(+)
diff --git a/a
Make CONFIG_SYS_NAND_U_BOOT_OFFS configurable through Kconfig, just like
SYS_NAND_BUSWIDTH_16BIT this is only enabled on some SoCs using depends,
to avoid double defining it for SoCs which have not yet moved to Kconfig
for this.
Having this in Kconfig is useful because this is something which may
We eventually want to add full nand support, since it makes no sense
to build SPL with nand support and u-boot without, or the other way
around, a single option will suffice.
Renaming the Kconfig option now makes things easier when we add full
nand support in the future.
The "obj-$(CONFIG_NAND_SU
We only ever use syndrome mode for the partitions which contain the SPL,
as that is required for the BROM to be able to read the SPL.
Instead of using some arbritray limit for deciding whether or not to
use syndrome, be smart and check if u-boot-dtb.bin is directly behind
the SPL, if it is not the
The inet97fv2 is a board found in the first generation of cheap allwinner
A10 based 7" tablets.
Note that this patch does not add a dts file as we already have one from
our dts syncs with the kernel.
Signed-off-by: Hans de Goede
---
board/sunxi/MAINTAINERS | 3 ++-
configs/inet97fv2_defcon
Modify the ubifs u-boot wrapper function prototypes for generic fs use,
and give them their own header file.
This is a preparation patch for adding ubifs support to the generic fs
code from fs/fs.c.
Signed-off-by: Hans de Goede
---
common/cmd_ubifs.c| 14 +++
fs/ubifs/ubifs.c |
From: Roy Spliet
Under the assumptions of having a UBI volume called boot, containing
a ubifs filesystem.
Signed-off-by: Hans de Goede
---
include/config_distro_bootcmd.h | 19 +++
1 file changed, 19 insertions(+)
diff --git a/include/config_distro_bootcmd.h b/include/config_d
Add generic fs support, so that commands like ls, load and test -e can be
used on ubifs.
Signed-off-by: Hans de Goede
---
disk/part.c | 23 +++
fs/fs.c | 16
include/fs.h | 1 +
3 files changed, 40 insertions(+)
diff --git a/disk/part.c b/disk/part.c
Hi,
On 22-08-15 00:01, Stephen Warren wrote:
On 08/21/2015 03:56 AM, Hans de Goede wrote:
Hi,
On 20-08-15 21:53, Stephen Warren wrote:
> On 20-08-15 18:04, Hans de Goede wrote:
ubifs does not go though the generic block layer because mtd devices
are special, so the "any" filesystem option
Implement the necessary functions for implementing generic fs support
for ubifs.
Signed-off-by: Hans de Goede
---
fs/ubifs/ubifs.c | 62 +++
include/ubifs_uboot.h | 4
2 files changed, 66 insertions(+)
diff --git a/fs/ubifs/ubifs.c b/fs
Hi Stephen & Scott,
As requested by Stephen here is a new version of my patch-set to add
mtd with ubi on top with ubifs on top support to distro_bootcmd, this
time using the generic filesystem related commands / code.
Scott, can you review the first three patches, and perhaps these should
also be
Hi Marek,
On 22 August 2015 at 10:48, Marek Vasut wrote:
> On Saturday, August 22, 2015 at 06:01:44 PM, Simon Glass wrote:
>> Hi Marek,
>
> Hi!
>
>> On 22 August 2015 at 09:50, Marek Vasut wrote:
>> > On Saturday, August 22, 2015 at 03:40:26 PM, Simon Glass wrote:
>> >
>> > Hi!
>> >
>> > [...]
>
On Saturday, August 22, 2015 at 06:01:44 PM, Simon Glass wrote:
> Hi Marek,
Hi!
> On 22 August 2015 at 09:50, Marek Vasut wrote:
> > On Saturday, August 22, 2015 at 03:40:26 PM, Simon Glass wrote:
> >
> > Hi!
> >
> > [...]
> >
> >> >> One way or another we'll figure this out sooner rather tha
Hi Marek,
On 22 August 2015 at 09:50, Marek Vasut wrote:
> On Saturday, August 22, 2015 at 03:40:26 PM, Simon Glass wrote:
>
> Hi!
>
> [...]
>
>> >> One way or another we'll figure this out sooner rather than later.
>> >
>> > I know :)
>>
>> Masahiro's series landed so I have applied this to u-bo
On Saturday, August 22, 2015 at 03:40:26 PM, Simon Glass wrote:
Hi!
[...]
> >> One way or another we'll figure this out sooner rather than later.
> >
> > I know :)
>
> Masahiro's series landed so I have applied this to u-boot-dm.
>
> Please check that it works as you expect.
I think we're ha
Hi Bernhard,
On 22-08-15 13:52, Bernhard Nortmann wrote:
Extend sunxi-common.h to include sunxi-boards.h - which in turn
can support multiple configurations/options/includes, based on
board-specific symbols (preprocessor definitions). These might
be supplied by the respective *_defconfig files.
On 10 August 2015 at 08:03, Marek Vasut wrote:
> On Monday, August 10, 2015 at 04:00:47 PM, Simon Glass wrote:
>> Hi Marek,
>
> Hi Simon,
>
>> On 10 August 2015 at 07:57, Marek Vasut wrote:
>> > On Monday, August 10, 2015 at 03:39:33 PM, Simon Glass wrote:
>> >> Hi Marek,
>> >
>> > Hi Simon,
>> >
I'm looking for ideas/comments on how to best integrate configuration
tweaks for specific sunxi boards into the U-Boot (build) ecosystem.
An example would be adding U-Boot support for GPIO-driven LEDs (and
the "led" command), which I'm demonstrating here for the Banana Pi.
My current line of thoug
Extend sunxi-common.h to include sunxi-boards.h - which in turn
can support multiple configurations/options/includes, based on
board-specific symbols (preprocessor definitions). These might
be supplied by the respective *_defconfig files.
Signed-off-by: Bernhard Nortmann
---
configs/Bananapi_de
Hi Simon,
On Sat, Aug 22, 2015 at 7:27 AM, Simon Glass wrote:
> Hi Bin,
>
> On 20 August 2015 at 07:40, Bin Meng wrote:
>> Per Intel FSP specification, we should call FSP notify API to
>> inform FSP that PCI enumeration has been done so that FSP will
>> do any necessary initialization as require
62 matches
Mail list logo