Hi Albert
> Could you send thoses two fixes as as a proper, standalone git patch
> rather than a reply to another patch, so that they can be properly
> attributed to you?
I received this message from mailing list robot:
"Message rejected. No base64 encoded MIME text parts allowed."
... I will try
From: Fabio Estevam
Since commit bce883707 (ARM: mxs: tools: Add mkimage support for MXS bootstream)
the following build error is seen when doing a MAKEALL build:
$ ./MAKEALL mx28evk
Configuring for mx28evk - Board: mx28evk, Options: ENV_IS_IN_MMC
mxsimage.c:18:25: fatal error: openssl/evp.h: No
From: Fabio Estevam
Performing tftp transfers on mx28 results in random timeouts.
Hector Palacios and Robert Hodaszi analyzed the root cause being related to the
alignment of the 'buff' buffer inside fec_recv().
GCC versions such as 4.4/4.5 are more likely to exhibit such problem.
Use ALLOC_C
On Sun, Sep 15, 2013 at 7:49 PM, Robert P. J. Day wrote:
> On Sun, 15 Sep 2013, Fabio Estevam wrote:
>
>> On Sun, Sep 15, 2013 at 7:10 PM, Robert P. J. Day
>> wrote:
>> >
>> > Fix various misspellings of things like "environment", "kernel",
>> > "default" and "volatile", and throw in a couple gr
In current gpio_set_value() implementation, it always sets the gpio control bit
no matter the value argument is 0 or 1. Thus the GPIOs never set to low.
This patch fixes this bug.
The address bus is used as a mask on read/write operations, so that independent
software drivers can set their GPIO bi
On Sun, Sep 15, 2013 at 1:50 PM, Fabio Estevam wrote:
> Hi Marek,
>
> On Sun, Sep 15, 2013 at 1:45 PM, Marek Vasut wrote:
>
>> Tom, are you OK with such a hack (invoking the in-tree mkimage) in the
>> documentation?
>
> This seems to be a common practice in the U-boot doc directory:
>
> doc/READM
On Sun, 15 Sep 2013, Fabio Estevam wrote:
> On Sun, Sep 15, 2013 at 7:10 PM, Robert P. J. Day
> wrote:
> >
> > Fix various misspellings of things like "environment", "kernel",
> > "default" and "volatile", and throw in a couple grammar fixes.
>
> Isn't there a typo in the subject itself ("typoes
On Sun, Sep 15, 2013 at 7:10 PM, Robert P. J. Day wrote:
>
> Fix various misspellings of things like "environment", "kernel",
> "default" and "volatile", and throw in a couple grammar fixes.
Isn't there a typo in the subject itself ("typoes") ?
___
U-Bo
Tidy up, reorder, and add newer info to the arch/ directory subsection
of the README file.
Signed-off-by: Robert P. J. Day
---
if anyone wants to adjust any of that differently, help yourself.
diff --git a/README b/README
index ccd47fa..be5336f 100644
--- a/README
+++ b/README
@@ -153,9 +15
Fix various misspellings of things like "environment", "kernel",
"default" and "volatile", and throw in a couple grammar fixes.
Signed-off-by: Robert P. J. Day
---
diff --git a/Makefile b/Makefile
index 1365db6..f55f8c0 100644
--- a/Makefile
+++ b/Makefile
@@ -45,13 +45,13 @@ endif
#
Hi Philippe,
On Sun, 15 Sep 2013 21:09:41 +0200, Philippe Reynes
wrote:
>
> Signed-off-by: Philippe Reynes
> ---
> README |3 +
> arch/arm/cpu/armv7/mx5/clock.c |2 +-
> arch/arm/cpu/armv7/mx6/clock.c |2 +-
> arch/arm/imx-common/Makefile |2 +-
> dri
Signed-off-by: Philippe Reynes
---
README |3 +
arch/arm/cpu/armv7/mx5/clock.c |2 +-
arch/arm/cpu/armv7/mx6/clock.c |2 +-
arch/arm/imx-common/Makefile |2 +-
drivers/i2c/Makefile |2 +-
drivers/i2c/mxc_i2c.c | 109 ++
Signed-off-by: Philippe Reynes
---
include/configs/apf27.h |5 ++---
include/configs/flea3.h |6 +++---
include/configs/imx31_phycore.h |6 +++---
include/configs/m53evk.h |6 +++---
include/configs/mx25pdk.h |6 +++---
include/configs/m
This serie is composed of two patches:
- one to port the i2c mxc driver to new subsystem
- one to update all configurations with i2c mxc driver
This serie was tested with success on armadeus apf27.
Philippe Reynes (2):
i2c: move to new subsystem
i2c: update config using mxc driver to new subs
Added W25* parts are which are avilable in spi_flash_probe_legacy.c.
Updated the sector_size attributes as per the flash parts.
Looks fine for with this sector_size for computing the size
of flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
Added GD25* parts are which are avilable in spi_flash_probe_legacy.c.
Updated the sector_size attributes as per the flash parts.
Looks fine for with this sector_size for computing the size
of flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
Compared to other spi flashes, ramtron has a different
probing and implementation on flash ops, hence moved
ramtron probe code into ramtron driver.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/Makefile
Added proper comment style on spi_flash structure to make
more readable.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
include/spi_flash.h | 63 +
1 file changed, 35 insertions(+)
Added SST25* parts are which are avilable in spi_flash_probe_legacy.c.
Updated the sector_size attributes as per the flash parts.
Looks fine for with this sector_size for computing the size
of flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
Few of the flashes(Atmel, Macronix and SST) require to
clear BP# bits in flash power ups.
So clear these BP# bits at probe time, so-that the flash
is ready for user operations.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers
Added AT45DB* parts are which are avilable in spi_flash_probe_legacy.c.
Updated the sector_size attributes as per the flash parts.
Looks fine for with this sector_size for computing the size
of flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
Included erase_size while printing probed flash details.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_probe.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/mtd/spi/spi_flas
Given proper spacing between flash table params.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_probe.c | 154 +++---
1 file changed, 77 insertions(+), 77 deletions(-)
diff
Hi Oliver,
On Sun, Sep 15, 2013 at 3:12 PM, Oliver Metz wrote:
> I can confirm that this patch fixes the issue for me on the mx28 board.
> Before the patch transmitting a linux kernel archive failed many times. With
> the patch applied the file was transfered successfully with the first try.
>
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_internal.h | 5 -
drivers/mtd/spi/spi_flash_ops.c | 2 +-
2 files changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/mtd/spi/spi_flash_inter
Add support for Macronix MX25L25635F SPI flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_probe.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/mtd/spi/spi_flash_probe.c
b/drivers/mtd/sp
Now the common probing is handled in spi_flash_probe.c
hence removed the unneeded flash drivers.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/Makefile | 8 -
drivers/mtd/spi/atmel.c | 544
Add support for Macronix MX25L51235F SPI flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_probe.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/mtd/spi/spi_flash_probe.c
b/drivers/mtd/sp
Divided the spi_flash framework into mutiple parts for
- spi_flash.c:
spi flash core file, interaction for spi/qspi driver to
spi_flash framework.
- spi_flash_ops.c
spi flash preffered operations, erase,write and read.
- spi_flash_probe.c
spi flash probing, easy to e
Added new spi_flash_probe support, currently added N25Q*
flash part attributes support.
Updated the sector_size attributes as per the flash parts.
Looks fine for with this sector_size for computing the size
of flash.
Defined CONFIG_SPI_FLASH_LEGACY for old probing style
which is available on spi_
Moved BAR config to spi_flash_validate_ids, so its
better to have all flash initalization at once.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_internal.h | 5 -
drivers/mtd/spi/spi_flash_probe.c
Added S25FL* parts are which are avilable in spi_flash_probe_legacy.c.
Updated the sector_size attributes as per the flash parts.
Looks fine for with this sector_size for computing the size
of flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
Use flash->page_size arg in print_size() instead of
flash->sector_size while printing detected flas part details.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_probe.c | 2 +-
1 file changed, 1 insertion(+
>From Micron, 512MB onwards, flash requires to poll flag status
instead of read status- hence added E_FSR flag on spectific
flash parts.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_probe.c | 14 +
Add support for Spansion S25FL256S_256K SPI flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_probe.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/mtd/spi/spi_flash_prob
SECT_4K, SECT_32K and SECT_64K opeartions are performed to
to specific flash by adding a SECT* flag on respective
spi_flash_params.flag param.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_ops.c | 8 +-
Added MX25L* parts are which are avilable in spi_flash_probe_legacy.c.
Updated the sector_size attributes as per the flash parts.
Looks fine for with this sector_size for computing the size
of flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
Add support for Spansion S25FL512S_256K SPI flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_probe.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/mtd/spi/spi_flash_probe.c
b/drivers/mtd
Added EN25Q* parts are which are avilable in spi_flash_probe_legacy.c.
Updated the sector_size attributes as per the flash parts.
Looks fine for with this sector_size for computing the size
of flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_internal.h | 3 --
drivers/mtd/spi/spi_flash_probe.c| 56 +++-
include/spi_flash.h | 3 --
3 files change
Add support for EON EN25Q64 SPI flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
- none
drivers/mtd/spi/spi_flash_probe.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/mtd/spi/spi_flash_probe.c
b/drivers/mtd/spi/spi_fla
Added M25P* parts are which are avilable in spi_flash_probe_legacy.c.
Updated the sector_size attributes as per the flash parts.
Looks fine for with this sector_size for computing the size of flash.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
- none
Changes for v2:
Hi All,
This is a v3 series for "sf: Add common probe support"
I am u-boot/spi custodian, I removed all flash drivers files(except ramtron,
handled in a separate driver) and implemented a common probe support.
Tested SST, STMICR, SPANSION, WINBOND from my side, REQUEST FOR ALL SPI CODE
FLASH_UE
Most of the SST flashes needs to write up using SST_WP, AAI
Word Program, so added a flag param on spi_flash_params table.
SST flashes, which supports SST_WP need to use a WP write
sst_write_wp instead of common flash write.
Signed-off-by: Jagannadha Sutradharudu Teki
---
Changes for v3:
Dear Fabio,
>Hi Robert and Hector,
>
>On Fri, Sep 13, 2013 at 2:46 PM, Wolfgang Denk <[hidden email]> wrote:
>
>> That's ALLOC_CACHE_ALIGN_BUFFER. Thanks.
>
>Could you please let us know wthether the change below fix the problem?
>
>Thanks,
>
>Fabio Estevam
>
>--- a/drivers/net/fec_mxc.c
Hi Tom,
Small pull request, planning to send next bunch of request for
next pull.
Thanks,
Jagan.
The following changes since commit 2b26201a2aef0b310b7c04702b0dba5dea493f77:
env_nand.c: support falling back to redundant env when writing (2013-08-22
17:49:47 -0500)
are available in the git r
Hi
On Sun, Sep 15, 2013 at 5:20 PM, Albert ARIBAUD
wrote:
> Hi Michael,
>
> On Sat, 14 Sep 2013 11:38:02 +0200, Michael Trimarchi
> wrote:
>
>> Hi Axel
>>
>> On Sat, Sep 14, 2013 at 11:34 AM, Axel Lin wrote:
>> > 2013/9/14 Albert ARIBAUD :
>> >> Hi Axel,
>> >>
>> >> On Fri, 06 Sep 2013 14:22:40
Hi Marek,
On Sun, Sep 15, 2013 at 1:45 PM, Marek Vasut wrote:
> Tom, are you OK with such a hack (invoking the in-tree mkimage) in the
> documentation?
This seems to be a common practice in the U-boot doc directory:
doc/README.imximage:./tools/mkimage -l
doc/README.imximage:./tools/mkimage -T
Dear Fabio Estevam,
> From: Fabio Estevam
>
> Fix the text to make clear that the 'mkimage' provided by U-boot should be
> used instead of the one provided by the host PC distribution.
>
> While at it, also fix the directory location of the configuration files.
>
> After these changes, it is p
Dear Fabio Estevam,
> Hi Marek,
>
> On Tue, Sep 10, 2013 at 6:33 PM, Marek Vasut wrote:
> > Dear Stefano Babic,
> >
> >> On 27/08/2013 23:32, Marek Vasut wrote:
> >> > Without this marker, Linux will complain that the NAND pages with
> >> > FCB are invalid.
> >> >
> >> > Signed-off-by: Marek V
Dear Mateusz Zalega,
> This commit unifies board-specific USB initialization implementations
> under one symbol (usb_board_init), declaration of which is available in
> usb.h.
>
> New API allows selective initialization of USB controllers whenever needed.
>
> Signed-off-by: Mateusz Zalega
> Sig
Hi Marek,
On Tue, Sep 10, 2013 at 6:33 PM, Marek Vasut wrote:
> Dear Stefano Babic,
>
>> On 27/08/2013 23:32, Marek Vasut wrote:
>> > Without this marker, Linux will complain that the NAND pages with
>> > FCB are invalid.
>> >
>> > Signed-off-by: Marek Vasut
>> > Cc: Fabio Estevam
>> > Cc: Stef
From: Fabio Estevam
Fix the text to make clear that the 'mkimage' provided by U-boot should be used
instead of the one provided by the host PC distribution.
While at it, also fix the directory location of the configuration files.
After these changes, it is possible succesfully generate a u-boot
Dear Fabio Estevam,
> Hi Marek,
>
> On Sun, Sep 15, 2013 at 11:03 AM, Marek Vasut wrote:
> > mxsimage is not enabled by default yet, I would like to postpone that for
> > next release. But (!) it would be nice if you did start testing it so
> > when enabled, it is working well.
>
> Ok, so the i
Hi Michael,
On Sat, 14 Sep 2013 11:38:02 +0200, Michael Trimarchi
wrote:
> Hi Axel
>
> On Sat, Sep 14, 2013 at 11:34 AM, Axel Lin wrote:
> > 2013/9/14 Albert ARIBAUD :
> >> Hi Axel,
> >>
> >> On Fri, 06 Sep 2013 14:22:40 +0800, Axel Lin
> >> wrote:
> >>
> >>> In current gpio_set_value() imple
Hi Marek,
On Sun, Sep 15, 2013 at 11:03 AM, Marek Vasut wrote:
> mxsimage is not enabled by default yet, I would like to postpone that for next
> release. But (!) it would be nice if you did start testing it so when enabled,
> it is working well.
Ok, so the issue was that I was using the mkimag
Dear Mateusz Zalega,
> On 09/06/13 13:40, Marek Vasut wrote:
> >>> Moreover, the 'int index' should likely be unsigned int and the
> >>> special value to init all controllers at once should probably then
> >>> be 0x
> >>
> >> Despite our greatest ambitions, I don't thi
Dear Afzal Mohammed,
> Hi,
>
> DFU spec mentions it as a method to upgrade firmware (software stored
> in writable non-volatile memory). It also says other potential uses of
> DFU is beyond scope of the spec.
>
> Here such a beyond the scope use is being attempted - directly pumping
> binary ima
Dear Huang Shijie,
> 于 2013年09月04日 23:46, Hector Palacios 写道:
> > Dear Marek,
> >
> > On 09/04/2013 04:38 PM, Marek Vasut wrote:
> >> Dear Huang Shijie,
> >>
> >>> On Wed, Sep 04, 2013 at 04:00:36PM +0200, Marek Vasut wrote:
> Dear Huang Shijie,
> How come hector was then able to write
Dear Hector Palacios,
> Dear Marek,
>
> On 09/04/2013 04:38 PM, Marek Vasut wrote:
> > Dear Huang Shijie,
> >
> >> On Wed, Sep 04, 2013 at 04:00:36PM +0200, Marek Vasut wrote:
> >>> Dear Huang Shijie,
> >>> How come hector was then able to write his JFFS2 partition ?
> >>
> >> If he uses the gp
Dear Fabio Estevam,
> On Sat, Sep 14, 2013 at 7:21 PM, Fabio Estevam wrote:
> > From: Fabio Estevam
> >
> > Building the mx28evk target on a host PC without the 'libssl-dev'
> > package, results in the following build error:
> >
> > mxsimage.c:18:25: fatal error: openssl/evp.h: No such file or
On Sun, 15 Sep 2013, Albert ARIBAUD wrote:
> Hi Wolfgang,
>
> On Sun, 15 Sep 2013 01:28:12 +0200, Wolfgang Denk wrote:
>
> > Dear "Robert P. J. Day",
> >
> > In message you wrote:
> > >
> > > given my pedantic nature, i've run across the occasional spelling
> > > mistake or grammar glitch and
Hi Wolfgang,
On Sun, 15 Sep 2013 01:28:12 +0200, Wolfgang Denk wrote:
> Dear "Robert P. J. Day",
>
> In message you wrote:
> >
> > given my pedantic nature, i've run across the occasional spelling
> > mistake or grammar glitch and want to know the best way to submit a
> > patch (or patches)
Hi Wolfgang,
On Sun, 15 Sep 2013 10:56:30 +0200, Wolfgang Denk wrote:
> Dear Albert,
>
> In message <1379224355-20157-1-git-send-email-albert.u.b...@aribaud.net> you
> wrote:
> > omap1510inn is orphan and has been for years now.
> > Reove it and, as it was the only arm925t target,
> > also rem
Dear Albert,
In message <1379224355-20157-1-git-send-email-albert.u.b...@aribaud.net> you
wrote:
> omap1510inn is orphan and has been for years now.
> Reove it and, as it was the only arm925t target,
> also remove arm925t support.
> Update doc/README.scrapyard accordingly.
>
> Signed-off-by: Alb
65 matches
Mail list logo