Hi,
I'm new to uboot mips port and first decided to try it with qemu.
I've encountered some problems with UART, but I guess that's more qemu
issue(lsr reg is not updated when the line is available).
Another issue I faced was code execution after the relocation is done. The
address of board_init_r
Add kerneldoc annotations into serial core.
Signed-off-by: Marek Vasut
Cc: Marek Vasut
Cc: Tom Rini
---
drivers/serial/serial.c | 157 +++
1 file changed, 157 insertions(+)
diff --git a/drivers/serial/serial.c b/drivers/serial/serial.c
index 57e3b7
Replace the in-place ad-hoc implementation of serial_puts() within
the drivers with default_serial_puts() call. This cuts down on the
code duplication quite a bit.
Signed-off-by: Marek Vasut
Cc: Marek Vasut
Cc: Tom Rini
---
arch/mips/cpu/mips32/au1x00/au1x00_serial.c |8 +---
arch/mips
Reorder the get_current() function to make it a bit more readable.
The code does not grow and there is minor change in the code logic,
where dev != NULL is now checked in any case.
Signed-off-by: Marek Vasut
Cc: Marek Vasut
Cc: Tom Rini
---
drivers/serial/serial.c | 21 -
This series does minor cleanup on the serial subsystem. The first patch
implements default_serial_puts() to put an end to endless duplication of
while (*s) { putc(*s++); } variations. The further three patches make use
of it and clean up the serial code slightly.
The remaining two patches annotate
U-Boot contains a lot of duplicit implementations of serial_puts()
call which just pipes single characters into the port in loop. Implement
function that does this behavior into common code, so others can make
easy use of it.
This function is called default_serial_puts() and it's sole purpose
is t
Add STDIO documentation template.
Signed-off-by: Marek Vasut
Cc: Marek Vasut
Cc: Tom Rini
---
doc/DocBook/Makefile |2 +-
doc/DocBook/stdio.tmpl | 46 ++
2 files changed, 47 insertions(+), 1 deletion(-)
create mode 100644 doc/DocBook/stdio.t
Reorder serial_assign() function to get rid of the extra level of
indentation. Also, adjust the return value to be -EINVAL instead of
positive one to be more consistent.
Signed-off-by: Marek Vasut
Cc: Marek Vasut
Cc: Tom Rini
---
drivers/serial/serial.c | 11 ++-
1 file changed, 6 in
Implement kerneldoc template for linker-generated arrays. This is
the first template in U-Boot that is used to generate kerneldoc
style documentation. This template is very basic.
Signed-off-by: Marek Vasut
---
doc/DocBook/Makefile |2 +-
doc/DocBook/linker_lists.tmpl | 46 ++
This patch converts the old method of creating a list of command
onto the new LG-arrays code. The old u_boot_cmd section is converted
to new u_boot_list_cmd subsection and LG-array macros used as needed.
Minor adjustments had to be made to the common code to work with the
LG-array macros, mostly t
This patch adds support for linker-generated array. These arrays
are a generalization of the U-Boot command declaration approach.
Basically, the idea is to generate an array, where elements of the
array are statically initialized at compile time and each element
is declared separatelly at differen
This patch adds essential components for generation of the contents of
the linker section that is used by the linker-generated array. All of
the contents is held in a separate file, u-boot.lst, which is generated
at runtime just before U-Boot is linked.
The purpose of this code is to especially ge
This is a second stab at the linker-generated array. Basically, this
concept is a generic abstraction of how u_boot_cmd works today. The
patch 2/4 contains a huge pile of documentation which should clarify
most of the questions.
I don't see size growth, I see size fluctiation in the order of tens
The default kernel-doc strips starting spaces from every single
line in the Example section. This makes the code look bad. Thus,
implement special handling for this section.
Signed-off-by: Marek Vasut
---
tools/kernel-doc/kernel-doc |3 +++
1 file changed, 3 insertions(+)
V3:
- Make use of
Add entry for kerneldoc into the git-mailrc pointing to the U-Boot ML
and myself.
Signed-off-by: Marek Vasut
---
doc/git-mailrc |1 +
1 file changed, 1 insertion(+)
V3:
- New patch
- Make use of patman tags in commit description
- Push the patches to testing:
http://git.denx.de/?p=
Import basic CSS stylesheet for the HTML documentation. The base for
the stylesheet is taken from:
http://ds9a.nl/docbook/minimal-page.html
I customized the CSS a bit further, for example to add curvy corners
to example section and change the tint of gray. The HTML documentation
does not
Dear Tom Rini,
> On Sun, Sep 30, 2012 at 02:21:31AM +0200, Marek Vasut wrote:
> > This patch series implants slightly modified kernel-doc documentation
> > generator from Linux kernel into U-Boot. First patch pulls in all the
> > necessary components with minor modifications made to them to work w
Dear Albert ARIBAUD,
> Hi Marek,
>
> Comments based on the assumption that we want to sync with the Linux
> tools.
>
> General comment/hypothetical question: would it not be simpler to patch
> the existing Linux tools in-place so that we can use them on the U-Boot
> tree?
>
> Detailed comments
From: Liu Ying
This patch checks self-clear sw_ipu_rst bit in
SCR register of SRC controller to be cleared
after setting it to high to reset IPUv3. This
makes sure that IPUv3 finishes sofware reset.
A timeout mechanism is added to stop polling
on the bit status in case the bit could not be
cleare
Hi Liu Ying,
On 10/06/2012 07:16 AM, Liu Ying wrote:
From: Liu Ying
This patch checks self-clear sw_ipu_rst bit in
SCR register of SRC controller to be cleared
after setting it to high to reset IPUv3. This
makes sure that IPUv3 finishes sofware reset.
A timeout mechanism is added to stop pollin
Hi Anatolij,
On Sat, 6 Oct 2012 11:31:03 +0200, Anatolij Gustschin
wrote:
> Fix:
> yaffs_guts.c: In function 'yaffs_check_chunk_erased':
> yaffs_guts.c:324:6: warning: variable 'result' set but not used
> [-Wunused-but-set-variable]
> yaffs_guts.c: In function 'yaffs_verify_chunk_written':
> ya
Hi Jimmy,
On Mon, 09 Apr 2012 16:52:56 -0700, jimmzhang
wrote:
> On Mon, 2012-04-02 at 16:18 -0700, Simon Glass wrote:
> > From: Jimmy Zhang
> >
> > Add support for setting up the memory controller parameters. Boards
> > can set up an appropriate table in the device tree.
> >
>
> Signed-off-
CONFIG_SYS_TFTP_LOADADDR is defined on severals boards,
but it's never used. So we can safely removed it.
Signed-off-by: Philippe Reynes
---
README|3 ---
include/configs/CRAYL1.h |1 -
include/configs/GEN860T.h |5 -
include/configs/TOP860.h |1 -
inclu
On Sat, Oct 6, 2012 at 9:59 AM, Fabio Estevam wrote:
> Hi Liu Ying,
>
> On Sat, Oct 6, 2012 at 7:32 AM, Liu Ying wrote:
>
>> @@ -397,6 +397,9 @@ void ipu_reset(void)
>> value = __raw_readl(reg);
>> value = value | SW_IPU_RST;
>> __raw_writel(value, reg);
>> +
>> + wh
Hi Liu Ying,
On Sat, Oct 6, 2012 at 7:32 AM, Liu Ying wrote:
> @@ -397,6 +397,9 @@ void ipu_reset(void)
> value = __raw_readl(reg);
> value = value | SW_IPU_RST;
> __raw_writel(value, reg);
> +
> + while (__raw_readl(reg) & SW_IPU_RST)
> + ;
Ok, but i
From: Liu Ying
This patch checks self-clear sw_ipu_rst bit in
SCR register of SRC controller to be cleared
after setting it to high to reset IPUv3. This
makes sure that IPUv3 finishes sofware reset.
Signed-off-by: Liu Ying
---
drivers/video/ipu_common.c |3 +++
1 files changed, 3 insertion
Hi,
On Sat, 6 Oct 2012 13:02:49 +0200, Albert ARIBAUD
wrote:
> Hi All,
>
> With Anatolij's fix in, ELDK4.2 still fails to build three boards:
> highbank, omap4_panda and omap4_sdp4430 (maintainers CCed).
>
> Build logs are weird for the two omap boards:
>
> Configuring for omap4_panda board..
Hi All,
With Anatolij's fix in, ELDK4.2 still fails to build three boards:
highbank, omap4_panda and omap4_sdp4430 (maintainers CCed).
Build logs are weird for the two omap boards:
Configuring for omap4_panda board...
arm-linux-gnueabi-size: './u-boot': No such file
make: *** [checkthumb] Erreur
Fix:
yaffs_guts.c: In function 'yaffs_check_chunk_erased':
yaffs_guts.c:324:6: warning: variable 'result' set but not used
[-Wunused-but-set-variable]
yaffs_guts.c: In function 'yaffs_verify_chunk_written':
yaffs_guts.c:352:6: warning: variable 'result' set but not used
[-Wunused-but-set-variable]
29 matches
Mail list logo