Reorder the get_current() function to make it a bit more readable.
The code does not grow and there is minor change in the code logic,
where dev != NULL is now checked in any case.

Signed-off-by: Marek Vasut <ma...@denx.de>
Cc: Marek Vasut <marek.va...@gmail.com>
Cc: Tom Rini <tr...@ti.com>
---
 drivers/serial/serial.c |   21 ++++++++++++---------
 1 file changed, 12 insertions(+), 9 deletions(-)

diff --git a/drivers/serial/serial.c b/drivers/serial/serial.c
index 1054494..57e3b75 100644
--- a/drivers/serial/serial.c
+++ b/drivers/serial/serial.c
@@ -225,20 +225,23 @@ static struct serial_device *get_current(void)
 {
        struct serial_device *dev;
 
-       if (!(gd->flags & GD_FLG_RELOC) || !serial_current) {
+       if (!(gd->flags & GD_FLG_RELOC))
                dev = default_serial_console();
+       else if (!serial_current)
+               dev = default_serial_console();
+       else
+               dev = serial_current;
 
-               /* We must have a console device */
-               if (!dev) {
+       /* We must have a console device */
+       if (!dev) {
 #ifdef CONFIG_SPL_BUILD
-                       puts("Cannot find console\n");
-                       hang();
+               puts("Cannot find console\n");
+               hang();
 #else
-                       panic("Cannot find console\n");
+               panic("Cannot find console\n");
 #endif
-               }
-       } else
-               dev = serial_current;
+       }
+
        return dev;
 }
 
-- 
1.7.10.4

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to