Hi Simon,
On Tue, Jan 24, 2012 at 1:05 AM, Simon Glass wrote:
> Hi Joe,
>
> On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger
> wrote:
>> Signed-off-by: Joe Hershberger
>> Cc: Joe Hershberger
>> Cc: Wolfgang Denk
>> ---
>> net/bootp.c | 26 ++
>> 1 files changed, 14
Hi Joe,
On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger wrote:
> Signed-off-by: Joe Hershberger
> Cc: Joe Hershberger
> Cc: Wolfgang Denk
> ---
> net/bootp.c | 26 ++
> 1 files changed, 14 insertions(+), 12 deletions(-)
>
Refactor why or to what purpose? Perhaps a
On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger wrote:
> Signed-off-by: Joe Hershberger
> Cc: Joe Hershberger
> Cc: Wolfgang Denk
Acked-by: Simon Glass
> ---
> net/arp.c | 13 -
> net/ping.c | 7 ---
> net/rarp.c | 6 --
> 3 files changed, 16 insertions(+), 10
Hi Joe,
On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger wrote:
> ICMP (ping) was reimplementing IP header code... it now shares code.
>
> Signed-off-by: Joe Hershberger
> Cc: Joe Hershberger
> Cc: Wolfgang Denk
> ---
> include/net.h | 4 +++-
> net/bootp.c | 6 +++---
> net/net.c
Hi Simon,
On Tue, Jan 24, 2012 at 12:09 AM, Simon Glass wrote:
> Hi Joe,
>
> On Fri, Jan 20, 2012 at 12:15 PM, Joe Hershberger
> wrote:
>> Hi Simon,
>>
>> On Fri, Jan 20, 2012 at 10:22 AM, Simon Glass wrote:
>>> Hi Joe,
>>>
>>> On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger
>>> wrote:
Hi Joe,
On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger wrote:
> Rename parameter len to payload_len in NetSendUDPPacket: this name
> more explicitly claims that it does not include the header size
> Rename CDPHandler to CDPReceive: this is not called as a handler,
> so don't name it that wa
Hi Joe,
On Fri, Jan 20, 2012 at 12:21 PM, Joe Hershberger
wrote:
> Hi Simon,
>
> On Fri, Jan 20, 2012 at 10:30 AM, Simon Glass wrote:
>> Hi Joe,
>>
>> On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger
>> wrote:
>>> Signed-off-by: Joe Hershberger
>>> Cc: Joe Hershberger
>>> Cc: Wolfgang Denk
Hi Joe,
On Fri, Jan 20, 2012 at 12:15 PM, Joe Hershberger
wrote:
> Hi Simon,
>
> On Fri, Jan 20, 2012 at 10:22 AM, Simon Glass wrote:
>> Hi Joe,
>>
>> On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger
>> wrote:
>>> The mv_eth driver should not redefine the net function definition
>>>
>>> Signed
On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger wrote:
> Signed-off-by: Joe Hershberger
> Cc: Joe Hershberger
> Cc: Wolfgang Denk
Acked-by: Simon Glass
> ---
> net/net.c | 25 +
> net/rarp.c | 38 +++---
> net/rarp.h | 1 +
>
Hi Joe,
On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger wrote:
> Signed-off-by: Joe Hershberger
> Cc: Joe Hershberger
> Cc: Wolfgang Denk
> ---
> include/configs/am3517_crane.h | 2 +-
> include/configs/am3517_evm.h | 2 +-
> include/configs/origen.h | 2 +-
Perhaps move the
On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger wrote:
> Signed-off-by: Joe Hershberger
Acked-by: Simon Glass
> Cc: Joe Hershberger
> Cc: Wolfgang Denk
> ---
> include/net.h | 3 +-
> net/Makefile | 1 +
> net/arp.c | 213
> +
Hi Joe,
On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger wrote:
> Signed-off-by: Joe Hershberger
> Cc: Joe Hershberger
> Cc: Wolfgang Denk
> ---
> arch/powerpc/cpu/mpc8xx/fec.c | 2 +-
> include/net.h | 9 +-
> net/Makefile | 1 +
> net/cdp.c
Hi Joe,
On Thu, Jan 19, 2012 at 4:53 PM, Joe Hershberger wrote:
> MAC-seeded rand() will be needed by link-local as well, so give it
> an interface
>
> Signed-off-by: Joe Hershberger
Acked-by: Simon Glass
> Cc: Joe Hershberger
> Cc: Wolfgang Denk
> ---
> net/Makefile | 1 +
> net/boot
On Monday 23 January 2012 19:44:15 Simon Glass wrote:
> Is this used by earlier patches (iwc it probably should go earlier) or
> is it new?
it is not (anymore). i meant to only send out the first five, but this doesn't
hurt. i'll probably leave it in my local branch until someone needs it.
> I
On Monday 23 January 2012 19:41:42 Simon Glass wrote:
> On Sun, Jan 22, 2012 at 10:30 PM, Mike Frysinger wrote:
> > --- /dev/null
> > +++ b/drivers/mtd/spi/sandbox.c
> >
> > +#include
> > +#include
> > +#include
> > +#include
> > +
> > +#include
> > +#include "spi_flash_internal.h"
> > +
> > +
On Monday 23 January 2012 19:31:23 Simon Glass wrote:
> On Sun, Jan 22, 2012 at 10:30 PM, Mike Frysinger wrote:
> > This adds a SPI framework for people to hook up simulated SPI clients.
>
> I don't know the SPI interface as well as use - might be useful to
> have a few comments and debug() things
Hi Mike,
On Sun, Jan 22, 2012 at 10:30 PM, Mike Frysinger wrote:
> Signed-off-by: Mike Frysinger
Acked-by: Simon Glass
> ---
> arch/sandbox/cpu/os.c | 13 +
> include/os.h | 1 +
> 2 files changed, 14 insertions(+), 0 deletions(-)
>
> diff --git a/arch/sandbox/cpu/o
Hi Mike,
On Sun, Jan 22, 2012 at 10:30 PM, Mike Frysinger wrote:
> This adds a SPI flash driver which simulates SPI flash clients.
> Currently supports the bare min that U-Boot requires: you can
> probe, read, erase, and write. Should be easy to extend to make
> it behave more exactly like a rea
Hi Mike,
On Sun, Jan 22, 2012 at 10:30 PM, Mike Frysinger wrote:
> This adds a SPI framework for people to hook up simulated SPI clients.
>
> Signed-off-by: Mike Frysinger
> ---
> arch/sandbox/include/asm/spi.h | 33 +++
> drivers/spi/Makefile | 1 +
> drivers/spi/sandbox_spi
On Wed, Jan 18, 2012 at 9:33 AM, Matthias Fuchs wrote:
> This patch adds SPI support for the MX28EVK. Support for
> an optionally installed SPI flash is also added. An example
> configuration for redundant envrionment from SPI flash is also
> added but disabled by default.
>
> This patch has been
Hi
The board that I am working on has multiple serial ports.
I am trying to use device trees to configure board resource of these
ports as well as the serial framework. So the driver doesnot know
apriori the number of uart ports on the board. But querries the device
tree for it.I am fa
On Monday 23 January 2012 07:23:09 Andreas Bießmann wrote:
> On 05.01.2012 16:59, Wolfgang Denk wrote:
> > Grant Erickson wrote:
> >> This patch allows the U-Boot user space companion utility, fw_setenv,
> >> to overwrite the 'ethaddr' key/value pair if the current value is set
> >> to a per-board-
Hi Matthias,
On 1/18/12, Matthias Fuchs wrote:
> Hi,
>
> while playing around with the mx28evk and differnet bootmedia
> I found it helpful to see the current bootmode without
> running to the board and checking it's switches. Also
> some other CPU (e.g. 440 PowerPCs) print some kind of bootstrap
On 1/18/12, Matthias Fuchs wrote:
> This patch adds support for the MX28 internal RTC
> and enables u-boot's date command.
>
> Signed-off-by: Matthias Fuchs
Tested-by: Fabio Estevam
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mai
> On 1/14/12, Matthias Fuchs wrote:
> > The generic spi flash driver (drivers/mtd/spi/spi_flash.c) uses the
> > spi low level driver's spi_xfer() function with len=0 to deassert the
> > SPI flash' chip select. But the i.MX28 spi driver rejects this call
> > due to len=0.
> >
> > This patch implem
On 1/14/12, Matthias Fuchs wrote:
> The generic spi flash driver (drivers/mtd/spi/spi_flash.c) uses the
> spi low level driver's spi_xfer() function with len=0 to deassert the
> SPI flash' chip select. But the i.MX28 spi driver rejects this call
> due to len=0.
>
> This patch implements an excepti
On 01/23/2012 10:51 AM, Fabio Estevam wrote:
> Patch 4 modifies the 'sf' command to allow a default chip-select
> to be specified by board headers as is done on efika et al. This allows
> a bare 'sf' probe command:
>U-Boot> sf probe
> instead of the more cumbersome usage when a GPI
On 1/23/2012 6:18 AM, Stephen Warren wrote:
Olof Johansson wrote at Saturday, January 21, 2012 12:32 AM:
On Thu, Jan 19, 2012 at 9:17 AM, Stephen Warren wrote:
Olof Johansson wrote at Wednesday, January 18, 2012 10:32 PM:
On Wed, Jan 18, 2012 at 05:16:52PM -0700, Stephen Warren wrote:
diff -
Hello!
(sorry for my english)
I need help!
Did you find solve with sd card for board with 9260/9g20?
I have board with at91sam9g20 and I have bug - gen_atmel_mci: CMDR 000d1052
(18) ARGR ec00 (SR: c0d7) XFER DTIP never unset, ignoring
u-boot 2011.12
All it works without mmc/sd.
My bug:
U-Bo
On 01/22/2012 10:41 AM, Simon Glass wrote:
> Hi Stephen,
>
> On Thu, Jan 19, 2012 at 12:51 PM, Stephen Warren wrote:
>> On 01/12/2012 12:00 PM, Simon Glass wrote:
>>> Add U-Boot's peripheral clock information to the Tegra20 device tree file.
>>
>>> diff --git a/arch/arm/dts/tegra20.dtsi b/arch/ar
On 01/21/2012 10:08 AM, Simon Glass wrote:
> Hi Stephen,
>
> On Wed, Jan 18, 2012 at 2:17 PM, Stephen Warren wrote:
>> On 01/11/2012 09:32 PM, Simon Glass wrote:
>>> This adds some support into fdtdec for reading GPIO definitions from
>>> the fdt. ...
...
>>> diff --git a/include/fdtdec.h b/inclu
On Fri, Jan 20, 2012 at 11:32:04PM -0800, Olof Johansson wrote:
> Hi,
>
> On Thu, Jan 19, 2012 at 9:17 AM, Stephen Warren wrote:
> > Olof Johansson wrote at Wednesday, January 18, 2012 10:32 PM:
> >> On Wed, Jan 18, 2012 at 05:16:52PM -0700, Stephen Warren wrote:
> >> > diff --git
> >> > a/Docum
Eric,
On 1/23/12, Eric Nelson wrote:
> Patch 4 modifies the 'sf' command to allow a default chip-select
> to be specified by board headers as is done on efika et al. This allows
> a bare 'sf' probe command:
> U-Boot> sf probe
> instead of the more cumbersome usage when a GPIO is tacked onto
> On 23/01/2012 16:52, Fabio Estevam wrote:
> > On 1/23/12, Marek Vasut wrote:
> >> Just put it amongst the other frequencies displayed by the clock
> >> command.
> >
> > What about this?
> >
> > --- a/arch/arm/cpu/arm926ejs/mx28/mx28.c
> > +++ b/arch/arm/cpu/arm926ejs/mx28/mx28.c
> > @@ -170,6
Signed-off-by: Eric Nelson
Acked-by: Dirk Behme
---
arch/arm/include/asm/arch-mx6/imx-regs.h | 44 ++
1 files changed, 44 insertions(+), 0 deletions(-)
diff --git a/arch/arm/include/asm/arch-mx6/imx-regs.h
b/arch/arm/include/asm/arch-mx6/imx-regs.h
index 7650cb9.
The default settings store the persistent environment on SD card
and not serial flash (SPI NOR).
To use SPI NOR to save the environment instead of SD card, edit
include/configs/mx6qsabrelite.h and
- undefine CONFIG_ENV_IS_IN_MMC
- define CONFIG_ENV_IS_IN_SPI_FLASH
The SPI driver can take as ch
Signed-off-by: Eric Nelson
Acked-by: Dirk Behme
---
include/configs/mx6qsabrelite.h |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/include/configs/mx6qsabrelite.h b/include/configs/mx6qsabrelite.h
index 8dd6e39..e34f108 100644
--- a/include/configs/mx6qsabrelite.h
+++
Signed-off-by: Eric Nelson
Acked-by: Dirk Behme
---
board/freescale/mx6qsabrelite/imximage.cfg|2 +-
board/freescale/mx6qsabrelite/mx6qsabrelite.c | 25 +
include/configs/mx6qsabrelite.h |9 +
3 files changed, 35 insertions(+), 1 delet
Signed-off-by: Eric Nelson
Acked-by: Dirk Behme
---
common/cmd_sf.c | 34 +++---
1 files changed, 23 insertions(+), 11 deletions(-)
diff --git a/common/cmd_sf.c b/common/cmd_sf.c
index 7225656..4b32171 100644
--- a/common/cmd_sf.c
+++ b/common/cmd_sf.c
@@ -70,20 +
This patch set refactors mxc_spi as described in
http://lists.denx.de/pipermail/u-boot/2010-March/068791.html
and requested in
http://lists.denx.de/pipermail/u-boot/2012-January/116023.html
in order to add support for the MX6Q in general and the mx6qsabrelite
specifically.
Patch 1 simpl
Move (E)CSPI register declarations into the imx-regs.h files for each supported
CPU
Introduce two new macros to control conditional setup
MXC_CSPI - Used for processors with the Configurable Serial Peripheral
Interface (MX3x)
MXC_ECSPI - For processors with Enhanced Configurable... (MX
Simon Glass wrote at Sunday, January 22, 2012 11:03 AM:
> On Wed, Jan 18, 2012 at 4:16 PM, Stephen Warren wrote:
> > Document a binding for the Tegra20 CAR (Clock And Reset) Controller,
> > add it to tegra20.dtsi, and configure it for the board in tegra-
> > seaboard.dts.
...
> > A comment on the
Olof Johansson wrote at Saturday, January 21, 2012 12:32 AM:
> On Thu, Jan 19, 2012 at 9:17 AM, Stephen Warren wrote:
> > Olof Johansson wrote at Wednesday, January 18, 2012 10:32 PM:
> >> On Wed, Jan 18, 2012 at 05:16:52PM -0700, Stephen Warren wrote:
> >> > diff --git
> >> > a/Documentation/dev
Hi Dirk,
On Jan 23, 2012 12:30 AM, "Dirk Behme" wrote:
>
> On 23.01.2012 08:31, Simon Glass wrote:
>>
>> Hi,
>>
>> On Thu, Jan 19, 2012 at 12:56 AM, Dirk Behme
wrote:
>>>
>>> From: Eric Miao
>>>
>>> Ignore the return value of eth_getenv_enetaddr_by_index(), and if it
>>> fails, fall back to use
On 23/01/2012 16:52, Fabio Estevam wrote:
> On 1/23/12, Marek Vasut wrote:
>
>> Just put it amongst the other frequencies displayed by the clock command.
>
> What about this?
>
> --- a/arch/arm/cpu/arm926ejs/mx28/mx28.c
> +++ b/arch/arm/cpu/arm926ejs/mx28/mx28.c
> @@ -170,6 +170,7 @@ int arch_c
Albert,
> -Original Message-
> From: Albert ARIBAUD [mailto:albert.u.b...@aribaud.net]
> Sent: Saturday, January 21, 2012 4:07 AM
> To: Tom Warren
> Cc: Wolfgang Denk; u-boot@lists.denx.de; Stephen Warren; Simon Glass
> Subject: Re: pull request: u-boot-tegra/master
>
> Hi Tom,
>
> Le 19
On 1/23/12, Marek Vasut wrote:
> Just put it amongst the other frequencies displayed by the clock command.
What about this?
--- a/arch/arm/cpu/arm926ejs/mx28/mx28.c
+++ b/arch/arm/cpu/arm926ejs/mx28/mx28.c
@@ -170,6 +170,7 @@ int arch_cpu_init(void)
int print_cpuinfo(void)
{
printf("F
Oh, found the Memory Management section, thanks! And it also explains that
stuff should be written after 0x 2000 because of the exception vector -
actually, I thinks this is a bit bigger here in my system, but now makes
sense why I was also getting crashes at the beginning of the memory!
Érico
Dear =?ISO-8859-1?Q?=C9rico_Porto?=,
Please stop top posting / full quoting.
In message
you wrote:
>
> Ok, this makes sense, but I think you mean:
No, I mean what I mean, not what you think I mean.
> memory start at 0x
>
> mtest {
> start address: right after (malloc area+global data
Ok, this makes sense, but I think you mean:
memory start at 0x
mtest {
start address: right after (malloc area+global data + stack)
end address: relocaddr
}
memory end at 0x0800
...
Érico V. Porto
On Mon, Jan 23, 2012 at 12:23 PM, Wolfgang Denk wrote:
> Dear =?ISO-8859-1?Q?=C9r
Dear Daniel Mack,
In message <4f1d60e8.4030...@lertes.de> you wrote:
>
> i recently stumbled upon a compile-error which appears after trying to
> compile via
>
> /./MAKEALL --arch arm --cpu pxa --vendor toradex/
>
> , it appears U-Boot uses software-FP whereas the native XScale-libs use
> hard
Dear =?ISO-8859-1?Q?=C9rico_Porto?=,
In message
you wrote:
>
> isn't U-boot's address given by the relocadrr variable? If it is so, it is
> already at the end of ram and I'm giving a smaller end address to the ram -
> I'm getting relocaddr 0x07fcd000 and using this minus 0x01000 as ending
> posi
Hello,
i recently stumbled upon a compile-error which appears after trying to
compile via
/./MAKEALL --arch arm --cpu pxa --vendor toradex/
, it appears U-Boot uses software-FP whereas the native XScale-libs use
hardware-FP, see for yourself please :
/[dmack@Blizzard ~/workspace/u-boot]$ .
Dear Wolfgang,
On 05.01.2012 16:59, Wolfgang Denk wrote:
> Dear Grant Erickson,
>
> In message <1324580395-27004-1-git-send-email-maratho...@gmail.com> you wrote:
>> This patch allows the U-Boot user space companion utility, fw_setenv,
>> to overwrite the 'ethaddr' key/value pair if the current v
isn't U-boot's address given by the relocadrr variable? If it is so, it is
already at the end of ram and I'm giving a smaller end address to the ram -
I'm getting relocaddr 0x07fcd000 and using this minus 0x01000 as ending
position...
Érico V. Porto
On Sat, Jan 21, 2012 at 2:21 PM, amruth vamade
Add i2c driver board hookup for AM335X EVM
Signed-off-by: Chandan Nath
Signed-off-by: Patil, Rachna
---
Changes for v3:
rebased, patches applied on top of master branch
arch/arm/cpu/armv7/am33xx/clock.c |5 ++
arch/arm/include/asm/arch-am33xx/common_def.h |1 +
arch/arm/inc
1. Compliant with Philips I2C specification version 2.1
2. Supports upto 100Kbps in standard mode
Signed-off-by: Chandan Nath
Signed-off-by: Patil, Rachna
---
Changes for v3:
rebased, patches applied on top of master branch
drivers/i2c/omap24xx_i2c.c | 20 +---
1 files change
Existing OMAP I2C driver does not support address
length greater than one. Hence this patch is to
add support for 2 byte address read/write.
Signed-off-by: Philip, Avinash
Signed-off-by: Hebbar, Gururaja
Signed-off-by: Patil, Rachna
---
Changes for v3:
rebased, patches applied on top of master
This patch adds support for MMC SPL booting.
Signed-off-by: Chander Kashyap
---
Changes for v2:
- None
Changes for v3:
- None
Changes for v4:
None
board/samsung/smdk5250/Makefile | 16
board/samsung/smdk5250/mmc_boot.c | 58
SMDK5250 board is based on Samsungs EXYNOS5250 SoC.
Signed-off-by: Chander Kashyap
---
Changes for v2:
- This patch is bifurcated into borad support and SoC support
- Fixed typo: s/EEYNOS/EXYNOS
- Squashed patch "SMDK5250: enable device tree support" in this.
Changes for v
Samsung's ARM Cortex-A15 based SoCs are known as Exynos5 series of
SoCs. This patch adds the support for Exynos5.
Signed-off-by: Chander Kashyap
---
Changes for v2:
- This patch was part of "EXYNOS: Add SMDK5250 board support"
- Now it is seprated as SoC support.
Changes for v3:
CONFIG_SYS_CLK_FREQ_C210 macro giving notion of S5PC2XX (Exynos4)
architecture. Replace CONFIG_SYS_CLK_FREQ_C210 with CONFIG_SYS_CLK_FREQ
to make it generic for exynos architecture.
Signed-off-by: Chander Kashyap
---
Changes for v2:
- None
Changes for v3:
- None
Changes for V4:
This patchset add support for Samsung's SMDK5250 board based on
EXYNOS5250 based SoC. It also adds support for MMC SPL booting.
The porting is done by Samsung engineers at HQ in System LSI Team.
I am contributing in upstreaming the code for the board.
Based upon discussions following patches are
On 23.01.2012 08:31, Simon Glass wrote:
Hi,
On Thu, Jan 19, 2012 at 12:56 AM, Dirk Behme wrote:
From: Eric Miao
Ignore the return value of eth_getenv_enetaddr_by_index(), and if it
fails, fall back to use dev->enetaddr, which could be filled up by
the ethernet device driver:
With the curren
Dear Simon Glass,
In message
you wrote:
>
> > $(DT_BIN): $(TOPDIR)/board/$(VENDOR)/dts/$(DEVICE_TREE).dts
> > - cat $< | $(CPP) -P $(DTS_CPPFLAGS) - >$@.tmp
> > - $(DTC) -R 4 -p 0x1000 -O dtb -o ${DT_BIN} $@.tmp
> > - rm $@.tmp
...
> The lines above are running the .dts file
65 matches
Mail list logo