On Fri, 28 May 2010 16:44:21 -0700
Ron Madrid wrote:
> Kim,
>
> This is defined this way:
>
> #define SICRL_USBDR 0x0C00
>
> However in order to actually set these pins to the USB_DR
> functionality the setting should be 0x0800. So it appears
> that these (#define SI
On Fri, May 28, 2010 at 4:45 PM, Becky Bruce wrote:
> void upmconfig (uint upm, uint *table, uint size)
> {
> volatile immap_t *immap = (immap_t *) CONFIG_SYS_IMMR;
> - volatile fsl_lbus_t *lbus = &immap->lbus;
> + volatile fsl_lbc_t *lbc = &immap->im_lbc;
Since you're using
Kim,
This is defined this way:
#define SICRL_USBDR 0x0C00
However in order to actually set these pins to the USB_DR
functionality the setting should be 0x0800. So it appears
that these (#define SICRL_*) are all masks. Each field seems
to be two bits and therefore 4
> Ian Abbott wrote:
>> On 28/05/2010 05:08, Thomas Chou wrote:
>>> Follow the discussion of Charles Manning and Mike Frysinger.
>>> Using gc_sections helps reduce image size.
>> Hi Thomas,
>>
>> Will that stop it working with the gcc3-based nios2 nommu toolchain?
>> The version of 'ld' in that tool
Each platform had its own version of the upmconfig, despite the
init process being identical. Now that we have a spot for common
lbc code, create a common upmconfig() there.
Signed-off-by: Becky Bruce
---
arch/powerpc/cpu/mpc83xx/cpu.c | 66
arch/power
This dumps out the contents of TLB1 on 85xx-based systems.
Signed-off-by: Becky Bruce
---
arch/powerpc/cpu/mpc85xx/tlb.c | 20
arch/powerpc/include/asm/mmu.h |1 +
2 files changed, 21 insertions(+), 0 deletions(-)
diff --git a/arch/powerpc/cpu/mpc85xx/tlb.c b/arch/pow
This somewhat random patch series got its start when I was asked to
create a reginfo command for 85xx by one of the internal teams here at
FSL to dump the BR/ORs, LAWs, and the TLBCAM entries. As I started doing
that, I began to notice that there was a lot of duplicated and inconsistent
code for m
The new command dumps the TLBCAM, the LAWs, and the BR/OR regs.
Add CONFIG_CMD_REGINFO to the config for all MPC85xx parts.
Signed-off-by: Becky Bruce
---
arch/powerpc/cpu/mpc85xx/cpu.c | 13 +
common/cmd_reginfo.c |5 +
include/configs/MPC8536DS.h|1 +
in
The current code redefines functions based on FSL_CORENET_ vs not -
create macros/inlines instead that hide the differences.
Signed-off-by: Becky Bruce
---
arch/powerpc/include/asm/fsl_law.h |1 +
drivers/misc/fsl_law.c | 125 ++--
2 files changed
Extract the operation to read a tlb into a function - we will need
this later to print out the tlbs, and there's no point in duplicating
the code. Create a TSIZE_TO_BYTES macro to deal with the conversion
from the MAS field to an actual size instead of duplicating this in code.
There are a few mis
Some parts that have an Enhanced Local Bus Controller weren't
setting CONFIG_FSL_ELBC. Fix this so we can use this define
properly going forward (currently it's only used if PHYS_64BIT is
set, which meant not all platforms needed to have it set correctly).
Signed-off-by: Becky Bruce
---
include
We were missing 8641HPCN_36BIT and MPC8536DS_36BIT.
Signed-off-by: Becky Bruce
---
MAKEALL |2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/MAKEALL b/MAKEALL
index 2527352..a82c93c 100755
--- a/MAKEALL
+++ b/MAKEALL
@@ -393,6 +393,7 @@ LIST_85xx=" \
MPC85
Add printing of LAWBARH/LAWBARL for FSL_CORENET platforms.
Signed-off-by: Becky Bruce
---
drivers/misc/fsl_law.c |6 ++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/drivers/misc/fsl_law.c b/drivers/misc/fsl_law.c
index 968..628bd59 100644
--- a/drivers/misc/fsl_law.
This avoids a build warning that you see if anyone in the
header chain has included io.h (which is coming shortly)
Signed-off-by: Becky Bruce
---
drivers/usb/host/ohci-hcd.c |2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/drivers/usb/host/ohci-hcd.c b/drivers/usb/host/o
Hi Andy,
Would you please review these patches?
05/03 [PATCH 1/3] lib: add crc7 from Linux
05/19 [PATCH 3/3 v8] mmc: add generic mmc spi driver
Best regards,
Thomas
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-bo
Ian Abbott wrote:
> On 28/05/2010 05:08, Thomas Chou wrote:
>> Follow the discussion of Charles Manning and Mike Frysinger.
>> Using gc_sections helps reduce image size.
> Hi Thomas,
>
> Will that stop it working with the gcc3-based nios2 nommu toolchain?
> The version of 'ld' in that toolchain do
Dear "Mangelschots, Jef",
In message
<226bc4afa29fc24789dfd00dff3084c250d3690...@safemail.safetran.railad.com> you
wrote:
>
> We are getting confused when reading the GPL and interpreting how it
> applies to our situation.
You may want to read "A Practical Guide to GPL Compliance", see
http://
Vipin,
On 5/28/2010 9:52 AM, Vipin Kumar wrote:
> Dear Wolfgang,
>
> This patch-set as been pending for a long time and it seems Tom is also away
> from mails. A few patches have already been Acked by respective device owners
>
> Please let me know how do I get this patch-set included in 2006.06 r
On May 28, 2010, at 3:18 PM, Timur Tabi wrote:
> Kumar Gala wrote:
>
>> My pref is to leave the tabs.
>
> The 'law' field would be misaligned. I would need to insert lots of tabs.
>
> unsigned long regs;
> pci_addr_t mem_bus;
> phys_size_t mem_phys;
> pci_si
Kumar Gala wrote:
> Will wait til there is code that uses fsl_pci_info.law until this is applied.
>
Can you push your ics307 patch to your repository?
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
On Friday 28 May 2010 13:50:57 Mangelschots, Jef wrote:
> We are getting confused when reading the GPL and interpreting how it
> applies to our situation.
then you should hire a lawyer to interpret it for you. legal advice cannot be
obtained from mailing lists such as this. the only thing you c
Kumar Gala wrote:
> My pref is to leave the tabs.
The 'law' field would be misaligned. I would need to insert lots of tabs.
unsigned long regs;
pci_addr_t mem_bus;
phys_size_t mem_phys;
pci_size_t mem_size;
pci_addr_t io_bus;
>
> struct fsl_pci_info {
> - unsigned long regs;
> - pci_addr_t mem_bus;
> - phys_size_t mem_phys;
> - pci_size_t mem_size;
> - pci_addr_t io_bus;
> - phys_size_t io_phys;
> - pci_size_t io_size;
> - int pci_num;
> + un
On May 28, 2010, at 3:05 PM, Timur Tabi wrote:
> Add the LAW target (enum law_trgt_if) to the fsl_pci_info structure, so that
> we can capture the LAW target for a given PCI or PCIE controller. Also update
> the SET_STD_PCI_INFO and SET_STD_PCIE_INFO macros to assign the
> LAW_TRGT_IF_PCI[E]_x m
Add the LAW target (enum law_trgt_if) to the fsl_pci_info structure, so that
we can capture the LAW target for a given PCI or PCIE controller. Also update
the SET_STD_PCI_INFO and SET_STD_PCIE_INFO macros to assign the
LAW_TRGT_IF_PCI[E]_x macro to the LAW target field of the structure.
This will
Dear Kristoffer Ericson,
In message <20100528183348.gb2...@boggieman> you wrote:
>
> I got an flashboard for my HP Jornada 700 which havent gone into
> production yet. Are there any rules on what might be accepted
> upstreams? Currently my board is one of 3 and its not 100% sure
> that any others
Dear Scott McNutt,
In message <4bffdcaf.7020...@psyent.com> you wrote:
> Dear Wolfgang,
>
> The following changes since commit 01f03bda5b22e5aeae5f02fd537da97a41485c73:
>Wolfgang Denk (1):
> Prepare v2010.06-rc1
>
> are available in the git repository at:
>
>git://git.denx.de/u
Greetings,
I got an flashboard for my HP Jornada 700 which havent gone into
production yet. Are there any rules on what might be accepted
upstreams? Currently my board is one of 3 and its not 100% sure
that any others will be made. So it might end up being the
only board done.
I also plan on addin
We are getting confused when reading the GPL and interpreting how it applies to
our situation.
We are adding features (not changing existing ones) to U-boot particular to our
in-house developed system which we sell as a product to our customers.
These changes involve adding a menu command for co
Dear TsiChung Liew,
In message <1275031378.23263.1.ca...@yvaine> you wrote:
> The following changes since commit
> c4976807cbbabd281f45466ac5e47e5639bcc9cb:
> Wolfgang Denk (1):
> Coding style cleanup, update CHANGELOG.
>
> are available in the git repository at:
>
> git://git.denx.d
Dear Remy Bohmer,
In message you
wrote:
> The following changes since commit 01f03bda5b22e5aeae5f02fd537da97a41485c73:
> Wolfgang Denk (1):
> Prepare v2010.06-rc1
>
> are available in the git repository at:
>
> git://git.denx.de/u-boot-usb.git master
>
> Sergei Shtylyov (1):
>
Dear Scott Wood,
In message <20100526230027.ga4...@schlenkerla.am.freescale.net> you wrote:
> The following changes since commit 01f03bda5b22e5aeae5f02fd537da97a41485c73:
> Wolfgang Denk (1):
> Prepare v2010.06-rc1
>
> are available in the git repository at:
>
> git://git.denx.de/u-b
Dear Vipin Kumar,
In message you
wrote:
>
> The u-boot source has been following a strict rule to use
> structures to define peripheral registers for some time now
>
> I was wondering if there really is an advantage over the macro
> definitions which is being used in Linux until today or this
hi,
The u-boot source has been following a strict rule to use
structures to define peripheral registers for some time now
I was wondering if there really is an advantage over the macro
definitions which is being used in Linux until today or this is just
a coding guideline to maintain consistency
Dear Wolfgang,
This patch-set as been pending for a long time and it seems Tom is also away
from mails. A few patches have already been Acked by respective device owners
Please let me know how do I get this patch-set included in 2006.06 release
Thanks in advance
Vipin
On Fri, May 14, 2010 at 8:
I would like to change the console from UART3 to UART2 on a Gumstix Overo
platform. Here is what I have done thus far, which doesn't work (as explained
below):
Made the following tweaks in include/configs/omap3_overo.h:
a. Changed the console definitions to be:
#define CONFI
Ping,
On Thu, May 13, 2010 at 11:41:13AM +0200, Dirk Behme wrote:
> On 11.05.2010 16:15, gda...@mvista.com wrote:
> >From: George G. Davis
> >
> >The ARM1136 cache_flush() function uses the "mcr p15, 0, rn, c7, c7, 0"
> >instruction which means "Invalidate Both Caches" when in fact the intent
> >i
Dear Wolfgang,
The following changes since commit 01f03bda5b22e5aeae5f02fd537da97a41485c73:
Wolfgang Denk (1):
Prepare v2010.06-rc1
are available in the git repository at:
git://git.denx.de/u-boot-nios.git next
Thomas Chou (8):
nios2: add gpio support
misc: add gpio
Wolfgang Denk wrote:
> Dear Thomas Chou,
>
> In message <4bff1e99.8020...@wytron.com.tw> you wrote:
>> Build and tested nios2 on boards.
>
> Thanks.
>
> Could you please send a formal "Tested-by:" ?
Dear Wolfgang,
I would suggest that we can remove the nios2-generic rule from the
Makefile alt
Kumar Gala wrote:
> * tweak SET_STD_PCIE_INFO to track LAW_TRGT_IF_PCIE_n
> * add something like the following to fsl_pci_init_port():
>
> struct law_entry law;
>
> law = find_law(pci_info->mem_phys);
> if (law.index == -1) {
> law.index = set_next_law(pci_i
Scott McNutt wrote:
> Wolfgang Denk wrote:
>> In message <4bff1e99.8020...@wytron.com.tw> you wrote:
>
>>> But old nios-32 arch is broken and will be removed soon. Shall I
>>> perform the removal based on current head or after these patches
>>> applied?
>>
>> I don't really care - the chages are
Hi all,
i am working on MPC8315 based board and i am able to port the
U-Boot with
(VERSION = 2009, PATCHLEVEL = 11, SUBLEVEL = 1). In my board one Temperature
sensor chip is connected and i am not able to access the chip from u-Boot. The
processor is getting initialized during p
Wolfgang Denk wrote:
> In message <4bff1e99.8020...@wytron.com.tw> you wrote:
>> But old nios-32 arch is broken and will be removed soon. Shall I perform
>> the removal based on current head or after these patches applied?
>
> I don't really care - the chages are simple enough.
>
> I see your p
On May 27, 2010, at 4:38 PM, Timur Tabi wrote:
> On Fri, May 21, 2010 at 4:17 AM, Kumar Gala wrote:
>
>>if (pcie_configured && !(devdisr & MPC85xx_DEVDISR_PCIE2)) {
>> + set_next_law(CONFIG_SYS_PCIE2_MEM_PHYS, LAW_SIZE_512M,
>> + LAW_TRGT_IF_P
This patch adds support for the Samsung Goni board (S5PC110 SoC)
Signed-off-by: Minkyu Kang
Signed-off-by: Kyungmin Park
---
MAINTAINERS|1 +
MAKEALL|1 +
Makefile |3 +
board/samsung/goni/Makefile
Dear Thomas Chou,
In message <4bff1e99.8020...@wytron.com.tw> you wrote:
>
> Build and tested nios2 on boards.
Thanks.
Could you please send a formal "Tested-by:" ?
> But old nios-32 arch is broken and will be removed soon. Shall I perform
> the removal based on current head or after these pat
Am Friday 28 May 2010 11:05:58 schrieben Sie:
> Hi Thorsten,
>
> 2010/5/28 Thorsten Mühlfelder :
> > So I've decided to compile a new U-Boot.
> >
> > My Toolchain is Codesourcery 2010q1 on a 32 bit Slackware Linux and I've
> > used U-Boot 2010.03 sources.
> > The board runs a 2.6.24-rt kernel with
On 28/05/2010 05:08, Thomas Chou wrote:
> Follow the discussion of Charles Manning and Mike Frysinger.
> Using gc_sections helps reduce image size.
>
> Configuring for nios2-generic board...
> Before,
>textdata bss dec hex filename
> 1239793724 22892 150595 24c43 /tmp
Am Friday 28 May 2010 10:45:39 schrieb Eric Bénard:
> Hi,
>
> Le 28/05/2010 10:29, Thorsten Mühlfelder a écrit :
> > 2. After endless compile sessions (I never compiled u-boot before) I'm
> > completely out of any idea what I can try now to get network in Linux
> > working. Any suggestions? :-)
>
>
Hi Thorsten,
2010/5/28 Thorsten Mühlfelder :
> So I've decided to compile a new U-Boot.
>
> My Toolchain is Codesourcery 2010q1 on a 32 bit Slackware Linux and I've used
> U-Boot 2010.03 sources.
> The board runs a 2.6.24-rt kernel with patch for Olimex support.
>
> As the Olimex board is heavily
Hi,
Le 28/05/2010 10:29, Thorsten Mühlfelder a écrit :
> 2. After endless compile sessions (I never compiled u-boot before) I'm
> completely out of any idea what I can try now to get network in Linux
> working. Any suggestions? :-)
>
are you sure the PHY is wired the same way as on the eval board
Hi,
I'm using an Olimex SAM9_L9260 based board here, which currently uses an
U-Boot 1.2 delivered by Olimex. Sadly this U-Boot version always marks it's
enviroment area as bad block on each write (probably it is patched by Olimex
to work with an old Atmel Sam-Ba version, that has the same error
The following changes since commit
c4976807cbbabd281f45466ac5e47e5639bcc9cb:
Wolfgang Denk (1):
Coding style cleanup, update CHANGELOG.
are available in the git repository at:
git://git.denx.de/u-boot-coldfire.git master
Wolfgang Denk (1):
Prepare v2010.06-rc1
Wolfgang Wegner
53 matches
Mail list logo