Dear Heiko Schocher,
In message <4ba85e53.90...@denx.de> you wrote:
>
> > I see function prototypes like:
> > static int
> > mod_i2c_mem(cmd_tbl_t *cmdtp, int incrflag, int flag, int argc, char
> > *argv[])
> >
> > and also
> > int do_i2c_probe (cmd_tbl_t *cmdtp, int flag, int argc, char *argv[
Hello Wolfgang,
Wolfgang Denk wrote:
> Dear Frans Meulenbroeks,
>
> In message you
> wrote:
>> In cmd_i2c the following snippet of code appears 6 times so it would
>> be a good candidate to factor out into a static helper function:
>
> Thanks for digging into this.
>
>> Now before I actually
Hello Frans,
Frans Meulenbroeks wrote:
> I've been peeking at optimizing a little bit more in i2c, and I bumped
> into a stylish question:
>
> I see function prototypes like:
> static int
> mod_i2c_mem(cmd_tbl_t *cmdtp, int incrflag, int flag, int argc, char *argv[])
>
> and also
> int do_i2c_pr
On 3/21/2010 10:20 PM, Wolfgang Denk wrote:
> Dear Vipin KUMAR,
>
> In message <4b908bc8.9030...@st.com> you wrote:
>>
>>> Why would that be needed? Do you really expect to see both types of
>>> interfaces on the same piece of hardware?
>>
>> Yes, that's precisely the case with Spear SoC. It has a
From: Wolfgang Denk
>
> Dear Vipin KUMAR,
>
> In message <4b908bc8.9030...@st.com> you wrote:
> >
> > > Why would that be needed? Do you really expect to see
> > > both types of interfaces on the same piece of hardware?
> >
> > Yes, that's precisely the case with Spear SoC. It has an FSMC
> >
This patch adds the driver of altera spi controller, which is also
used as epcs/spi flash controller.
With the spi_flash driver, they can replace the epcs driver at
cpu/nios2/epcs.c.
Signed-off-by: Thomas Chou
---
drivers/spi/Makefile |1 +
drivers/spi/altera_spi.c | 81 ++
This patch adds status polling method to offer an alternative to
data toggle method for amd flash chips.
This patch is needed for nios2 cfi flash interface, where the bus
controller performs 4 bytes read cycles for a single byte read
instruction. The data toggle method can not detect chip busy
sta
Hi Wolfgang,
I applied Ilya's ARM initramfs outside physical RAM patch and it
appears to work. It still displays the warning of disabling the
initrd due to the image being outside physical RAM (I can fix that :)
).
I took the cpio.gz I had and did the following mkimage to it:
mkimage -A arm -O
Dear Timur Tabi,
In message you
wrote:
>
> > Please make this "either version 2 of the License, or (at your
> > option) any later version'.
>
> I'd rather not, actually. I don't like the "at your option any later
> version" clause, and I intentionally don't include it in any new code.
> This
On Mon, Mar 22, 2010 at 5:46 PM, Wolfgang Denk wrote:
>> + * This file is licensed under the terms of the GNU General Public License
>> + * version 2. This program is licensed "as is" without any warranty of any
>> + * kind, whether express or implied.
>
> Please make this "either version 2 of t
Dear Kumar Gala,
In message <1269194951-17996-1-git-send-email-ga...@kernel.crashing.org> you
wrote:
> From: Dave Liu
>
> Read-to-read/Write-to-write turnaround for same chip select
> of DDR3 memory, BL/2+2 cycles is enough for them at BC4 and
> OTF case, BL/2 cycles is enough for fixed BL8.
>
Dear Timur Tabi,
In message <1269296309-23976-1-git-send-email-ti...@freescale.com> you wrote:
> The Freescale P2020DS board uses a new type of PIXIS FPGA, called the ngPIXIS.
> The ngPIXIS has one distinct new feature: the values of the on-board switches
> can be selectively overridden with shado
The Freescale P2020DS board uses a new type of PIXIS FPGA, called the ngPIXIS.
The ngPIXIS has one distinct new feature: the values of the on-board switches
can be selectively overridden with shadow registers. This feature is used to
boot from a different NOR flash bank, instead of having a regist
Dear Tom,
In message <4ba7e540.6000...@windriver.com> you wrote:
>
> These are the commits that Matthias highlighted as bug fixes that should
> go into the release.
>
> The following changes since commit daa989b47297c9f73426783599c286ef3a1f3f49:
>Asen Dimov (1):
> correct a syntax t
Provide extra environment Data. Remove default network
address and MAC address.
Signed-off-by: TsiChung Liew
---
include/configs/M5275EVB.h | 22 +-
1 files changed, 17 insertions(+), 5 deletions(-)
diff --git a/include/configs/M5275EVB.h b/include/configs/M5275EVB.h
index
Fix incorrect default environment for flash erase or protect
range. Change offset from 0 to 0xff80. Remove default
ethernet setup and MAC address.
Signed-off-by: TsiChung Liew
---
include/configs/M5253DEMO.h |9 ++---
1 files changed, 2 insertions(+), 7 deletions(-)
diff --git a/inc
On Monday 22 March 2010 17:39:04 Wolfgang Denk wrote:
> Mike Frysinger wrote:
> > perhaps, but it doesnt make projects compile any better, and i'd be
> > suspicious of how long it's actually going to take for that to become a
> > reality. gcc has behaved this way for years, and i dont see any sign
Daniel Gorsulowski wrote:
> CONFIG_CMD_AUTOSCRIPT support is deprecated and non-existing
> This clean up patch removes the references for esd boards
>
> Signed-off-by: Daniel Gorsulowski
Applied to arm/next
Thanks
Tom
___
U-Boot mailing list
U-Boot@lis
Wolfgang,
These are the commits that Matthias highlighted as bug fixes that should
go into the release.
Tom
The following changes since commit daa989b47297c9f73426783599c286ef3a1f3f49:
Asen Dimov (1):
correct a syntax typo in at91_matrix.h
are available in the git repository at:
Dear Mike Frysinger,
In message <201003221729.07522.vap...@gentoo.org> you wrote:
>
> perhaps, but it doesnt make projects compile any better, and i'd be
> suspicious
> of how long it's actually going to take for that to become a reality. gcc
> has
> behaved this way for years, and i dont see
Dear Frans Meulenbroeks,
In message you
wrote:
> In cmd_i2c the following snippet of code appears 6 times so it would
> be a good candidate to factor out into a static helper function:
Thanks for digging into this.
> Now before I actually start doing that a few questions.
> Should I factor out
On Monday 22 March 2010 07:18:52 Wolfgang Denk wrote:
> Mike Frysinger wrote:
> > > So if a C compiler auto-defines something as "arm", or "i386", or
> > > "microblaze", then it is NOT standard-conforming - bare with me if I
> > > simply call this broken.
> >
> > that may be, but if that is what t
In cmd_i2c the following snippet of code appears 6 times so it would
be a good candidate to factor out into a static helper function:
/*
* I2C chip address
*/
chip = simple_strtoul(argv[1], NULL, 16);
/*
* I2C data address within the chip. This
Hi,
I've been peeking at optimizing a little bit more in i2c, and I bumped
into a stylish question:
I see function prototypes like:
static int
mod_i2c_mem(cmd_tbl_t *cmdtp, int incrflag, int flag, int argc, char *argv[])
and also
int do_i2c_probe (cmd_tbl_t *cmdtp, int flag, int argc, char *argv
Dear Michael Zaidman,
In message <1269267894-15324-1-git-send-email-michael.zaid...@gmail.com> you
wrote:
> Serial loopback internal/external tests. Is based on my previous commit
> 078a9c4898e7802086b362baa44ad48b8ad1baed
This information is useless - no such commit ID is available in
mainline:
Dear Michael Zaidman,
In message <1269267840-15285-1-git-send-email-michael.zaid...@gmail.com> you
wrote:
> Added support for extra ns16550 chip extending total number of
> supported COMs up to 6. This targets the cases when due to the
> insufficient number of UART ports on the CPU chip designers
On Wed, Mar 17, 2010 at 5:39 PM, Timur Tabi wrote:
> Refactor and document the Freescale PIXIS code, used on most 85xx and 86xx
> boards. This makes the code easier to read and more flexible.
Kumar, please pick this up for the next merge window. Thanks.
--
Timur Tabi
Linux kernel developer at
Detlev Zundel wrote:
> Hi Michal,
>
>> Detlev Zundel wrote:
>>> Hi Horst,
>>>
in "lib_microblaze/board.c board_init()" the function
"env_relocate()" should be called before "getenv_IPaddr()"
otherwise there is no chance to save an ip-address in the
environment (like in lib_ppc
Hi Michal,
> Detlev Zundel wrote:
>> Hi Horst,
>>
>>> in "lib_microblaze/board.c board_init()" the function
>>> "env_relocate()" should be called before "getenv_IPaddr()"
>>> otherwise there is no chance to save an ip-address in the
>>> environment (like in lib_ppc/board.c).
>
> Horst: Give me st
Hi Scott,
> When an IP block can be shared among several different
> architectures, where should the _header_ files be located?
>
> Examples of such blocks would be OpenCores peripherals,
> Altera peripherals, etc.
>
> Some peripherals may not need to export any interfaces,
> so no header file is
Hi,
> I have tried to build u-boot for Beagle board with POST enabled but its
> throwing some compilation errors.
> What might be the reason? Am I missing some config options? Please help
> me.
>
> Error messages I got
>
> make[2]: Leaving directory
> `/home/anoop/beagleboard-default-u-boot
On Thu, Mar 18, 2010 at 5:23 PM, Michael Zaidman
wrote:
> On Thu, Mar 18, 2010 at 4:58 PM, Valentin Ecker
> wrote:
>> I see...I think we have a very similar setup, and I see how you init your
>> ports. Although I'm not sure if this is suitable for me, since editing the
>> ns16550-files to support
On 03/22/2010 07:05 PM, Stefan Roese wrote:
> I realise that this is copied from flash_status_check(). There has been a
> discussion and a not yet finished patch for this part. Please take a look at
> this thread:
>
> http://www.mail-archive.com/u-boot@lists.denx.de/msg19297.html
>
> And the last v
> -Original Message-
> From: Kumar Gala [mailto:ga...@kernel.crashing.org]
> Sent: Monday, March 22, 2010 2:12 AM
> To: u-boot@lists.denx.de
> Cc: Zang Roy-R61911
> Subject: [PATCH v2] fsl_esdhc: Only modify the field we are
> changing in WML
>
> From: Roy Zang
>
> When we set the r
2010/3/19 Scott Wood :
> On Thu, Mar 18, 2010 at 11:55:29AM +0500, Nikolay Petukhov wrote:
>> + /* move to ECC position if needed */
>> + if (eccpos[0] != 0) {
>> + /* This only works on large pages
>> + * because the ECC controller waits for
>> + * NAN
Serial loopback internal/external tests. Is based on my previous commit
078a9c4898e7802086b362baa44ad48b8ad1baed
Signed-off-by: Michael Zaidman
---
drivers/serial/serial.c | 87 +++
post/drivers/Makefile |2 +-
post/drivers/serial.c | 56 ++
Added support for extra ns16550 chip extending total number of
supported COMs up to 6. This targets the cases when due to the
insufficient number of UART ports on the CPU chip designers are
forced to put additional ns16550 chip on board.
Signed-off-by: Michael Zaidman
---
drivers/serial/serial.c
Detlev Zundel wrote:
> Hi Horst,
>
>> in "lib_microblaze/board.c board_init()" the function "env_relocate()"
>> should be called before "getenv_IPaddr()"
>> otherwise there is no chance to save an ip-address in the environment (like
>> in lib_ppc/board.c).
Horst: Give me step-by-step manual ho
Dear Mike Frysinger,
In message <201003220254.05158.vap...@gentoo.org> you wrote:
>
> > So if a C compiler auto-defines something as "arm", or "i386", or
> > "microblaze", then it is NOT standard-conforming - bare with me if I
> > simply call this broken.
>
> that may be, but if that is what the
Hi Thomas,
On Friday 19 March 2010 23:57:47 Thomas Chou wrote:
> This patch adds status polling method to offer an alternative to
> data toggle method for amd flash chips.
>
> This patch is needed for nios2 cfi flash interface, where the bus
> controller performs 4 bytes read cycles for a single
Tom wrote:
> Stefano Babic wrote:
>> The patch adds SPI devices to the mx51evk board. Two devices
>> are supported: Atmel SPI flash and MC13892 power
>> controller.
>
> Is Atmel SPI flash already supported?
> It does not look like anything atmel is setup here
No, not yes, only in a future patch s
Tom wrote:
>> +#define MXC_CSPIRXDATA0x00
>> +#define MXC_CSPITXDATA0x04
>> +#define MXC_CSPICTRL0x08
>> +#define MXC_CSPIPERIOD_32KHZ(1 << 15)
>> +
>
> Pulling these out and making them common may not be the best thing to do.
> Located here, it hides the
>
> #ifdef CO
Hi Tom,
Tom wrote:
> Stefano Babic wrote:
>> Added SPI driver for the Power Management Controller
>> used with i.MX51 Processor.
>>
>
> Errors in
> imx31_litekeit
> imx31_phycore_eet
> imx31_ads
> These must be fixed
...and I have to test with a MX31, too. I will find a board and test the
chang
Hi Wolfgang,
On Sunday 21 March 2010 17:34:50 Wolfgang Denk wrote:
> > The problem with AVR32 and the CFI flash driver has a few possible
> > solutions as noted by Haavard Skinnemoen in the email [1]. The only
> > thing I can do is to go with the first alternative and set the flash
> > address as
Wolfgang,
> Usually error messges mean what they say.
yes - of course. But I still couldn't see the difference between "-" and
"_" after looking at it three times.
>
> > What am I missing ?
>
> The directory /home/swa/u-boot.git/board/matrix-vision/mvsmr/ ?
ok - it's "matrix_vision" ... alre
45 matches
Mail list logo