On 19:59 Mon 06 Apr , Minkyu Kang wrote:
> CONFIG_S3C6400 is must defined at config header file
> That definition is unnecessary at this file
>
> Signed-off-by: Minkyu Kang
> ---
> include/s3c6400.h |4
> 1 files changed, 0 insertions(+), 4 deletions(-)
applied
Best Regards,
J.
___
Hello Peter,
Peter Tyser wrote:
> This patch series removes the "individual" I2C commands (and the
> CONFIG_I2C_CMD_TREE define) and migrates all boards to the newer
> "tree style" I2C commands.
>
> A small amount of cleanup was performed before and after removing
> the individual commands.
Than
On Thursday 16 April 2009, Jean-Christophe PLAGNIOL-VILLARD wrote:
> please move the Makefile to SOBJS-y COBJS-y
I'm not following. A quick scan of boards I've used shows
most of them using SOBJS, rather than SOBJS-y.
And how would you propose making a *negative* config option
(as in $SUBJECT) f
On Thursday 16 April 2009, Jean-Christophe PLAGNIOL-VILLARD wrote:
> On 15:44 Sun 12 Apr , David Brownell wrote:
> could you split it in more logical change please
I'll fragment it a bit more, ok. later.
> > @@ -129,10 +122,12 @@ void davinci_enable_uart0(void)
> > lpsc_on(DAVINCI_LPSC
Hello Wolfgang
Just a query
If its a problem of version than why u-boot for omap5912osk builds without
any error
U-boot version used -1.2.0
Steps are
#make clean;make omap5912osk_config;make
Compiler is :arm-none-linux-gnueabi- [same as I am using for my board]
Thanks & Regards
Bhavna Yad
> --- /dev/null
> +++ b/board/esd/meesc/meesc.c
> @@ -0,0 +1,300 @@
> +/*
> + * (C) Copyright 2007-2008
> + * Stelian Pop
> + * Lead Tech Design
> + *
> + * (C) Copyright 2009
> + * Daniel Gorsulowski
> + * esd electronic system design gmbh
> + *
> + * See file CREDITS for list of people who co
On 14:31 Tue 07 Apr , Daniel Gorsulowski wrote:
> This patch bases on patch of Ulf Samuelsson
> ([PATCH 1/1] ARM: Add command to control coloured led from the console,
> Wed Jan 7 21:09:55 CET 2009)
> It allows any board implementing the user LED API
> to control the LEDs from the console.
>
>
From: David Brownell
Make the U-Boot dm9000 driver read addresses from EEPROM just
like Linux does ... read six bytes, instead of reading twelve
bytes and then discarding every other one.
Using the right Ethernet address is a big win.
Signed-off-by: David Brownell
---
drivers/net/dm9000x.c |
On 15:44 Sun 12 Apr , David Brownell wrote:
> From: David Brownell
>
> Start updating DaVinci board support to reduce dependencies on
> dm644x chips and EVM-like boards ... beginning with "psc.c",
> which hosts a bunch of those dependencies:
>
> - Pinmux registers and their contents are SoC
On 15:49 Sun 12 Apr , David Brownell wrote:
> From: David Brownell
>
> Chips without the EMAC controller won't need the utilities
> it uses to read an Ethernet address from EEPROM; so don't
> include them needlessly.
>
> Use is_valid_ether() to validate the address from EEPROM.
> All-zero a
On 16:04 Sun 12 Apr , David Brownell wrote:
> On Sunday 12 April 2009, David Brownell wrote:
> > ... read six bytes, instead of reading twelve
> > bytes then discarding every one.
>
> Urgh, editing goof. Should read "discarding every other one".
please send a new version
Best Regards,
J
On 15:40 Sun 12 Apr , David Brownell wrote:
> From: David Brownell
>
> Minor cleanup to clock-related defines for DaVinci DM6446 boards:
>
> - CONFIG_SYS_CLK_FREQ is unused; remove it.
>
> - CONFIG_SYS_NS16550_CLK must be the same as CONFIG_SYS_HZ_CLOCK
>
> On DM6446 both of those periph
On 15:48 Mon 13 Apr , Nishanth Menon wrote:
> SMNAND_ENV_OFFSET is more specific to Samsung
> NAND, rename it to NAND_ENV_OFFSET
>
CONFIG_ENV_NAND_OFFSET or something simillar will be beter
Best Regards,
J.
___
U-Boot mailing list
U-Boot@lists.denx.
On 15:48 Mon 13 Apr , Nishanth Menon wrote:
> NAND CS is assumed to be CS0 while we could have
> choice b/w 0 to 7. This patch enables board files
> to handle varied CS on a need basis.
>
> Signed-off-by: Nishanth Menon
> ---
> cpu/arm_cortexa8/omap3/mem.c |8 +---
> include/asm-
On 15:48 Mon 13 Apr , Nishanth Menon wrote:
> NAND timing is defaulted to Micron NAND. To support
> varied boards, this is not scalable.
> This patch introduces compile time option to select
> the timing to select at the same time allows
> platforms to build with custom timing params
>
> Signe
On 08:52 Tue 14 Apr , David Brownell wrote:
> On Tuesday 14 April 2009, Wolfgang Denk wrote:
> > Please don't do it like this. Please use the same style like
> > everybody else.
>
> Having to guess .. you mean don't indent?
yes
please move the Makefile to SOBJS-y COBJS-y
Best Regards,
J.
___
On 20:15 Tue 14 Apr , Dirk Behme wrote:
> Remove remaining legacy NAND defines for Beagle, EVM, Overo and Pandora.
>
> Signed-off-by: Dirk Behme
> ---
>
> For Zoom1 it was already removed by
>
> http://lists.denx.de/pipermail/u-boot/2009-April/050150.html
> http://lists.denx.de/pipermail/u-
On 10:51 Thu 16 Apr , Shinya Kuribayashi wrote:
> sa1100.h is not used anywhere, then remove it.
>
> $ find . -name '*.h' -empty -print
> ./include/sa1100.h
> $ git grep 'sa1100.h' .
> $
>
> Signed-off-by: Shinya Kuribayashi
> ---
> include/sa1100.h |0
> 1 files changed, 0 insertions(
On Friday 17 April 2009, Richard Retanubun wrote:
> I've tried extracting the information at board_early_init_r (because I need
> to initialize MAC address later using this information also) and store the
> information using setenv("partnum" "extracted_board_id");
>
> However, the resulting printen
Marco Antônio Possamai wrote:
> Hello
>
> I've been working on building a 2.6.26 linux kernel to the mpc5200Lite
> PowerPc board. However, I am unable to boot the system using the
> generated image.
>
> I am using what seems to be the latest U-Boot for the job. Got it from
> www.denx.de/git/u-boo
From: David Brownell
Make the headers in the "mtdparts" command output line up
with their columns ... strike the extra TAB character.
Signed-off-by: David Brownell
--- a/common/cmd_mtdparts.c
+++ b/common/cmd_mtdparts.c
@@ -1314,7 +1314,7 @@ static void list_partitions(void)
pr
Hello
I've been working on building a 2.6.26 linux kernel to the mpc5200Lite
PowerPc board. However, I am unable to boot the system using the
generated image.
I am using what seems to be the latest U-Boot for the job. Got it from
www.denx.de/git/u-boot.git.
I'm using the device tree compiler dtc
Greetings,
Is there a framework in place for using U-Boot to boot Linux from an
SD Card on an at91sam9g20 processor?
I've been reading through the code and found at a minimum, I would
need to enable the mmc command and the atmel_mci library. Then the
mmc commands exist in the console but mmcinfo
On Thu, Apr 16, 2009 at 11:52 AM, Rabin Vincent wrote:
> Andy,
>
> On Sun, Apr 05, 2009 at 01:30:52PM +0530, Rabin Vincent wrote:
>> Remove some repeated words and superfluous newlines in the mmc command
>> help entries.
>>
>> Signed-off-by: Rabin Vincent
>
> Any comments on this set of patches?
On Sat, Mar 28, 2009 at 12:04 AM, Minkyu Kang wrote:
> This patch improves device command for selecting mmc device
>
> Signed-off-by: Minkyu Kang
Rather than porting features from the generic mmc framework into the
legacy system, I'd really prefer if the omap driver were ported to the
generic mm
On Apr 9, 2009, at 1:03 PM, Werner Nedel wrote:
>
> I'm trying to update my u-boot version (1.2) to the last one
> (2009.03). My
> board is very similar to MPC8548CDS. Everything was working fine
> till I
> tried to use the reset command. It hangs the processor in
> cpu_init_early_f,
> when
Scott Wood wrote:
> The above line just loads a constant into a register, so the source of
> the problem is likely elsewhere (possibly the code itself can't be fetched).
I don't remember exactly why, but I once had the same symptom that
Werner is reporting, and the cause was a misprogrammed LAWBA
Timur Tabi wrote:
> On Mon, Apr 13, 2009 at 2:38 PM, Werner Nedel wrote:
>> Actually, it hangs changing gd pointer, before set_tlb() call. In my older
>> u-boot version, it was made in cpu_init_f function.
>>
>>/* Pointer is writable since we allocated a register for it */
>>gd = (gd_t *)
On Mon, Apr 13, 2009 at 2:38 PM, Werner Nedel wrote:
> Actually, it hangs changing gd pointer, before set_tlb() call. In my older
> u-boot version, it was made in cpu_init_f function.
>
> /* Pointer is writable since we allocated a register for it */
> gd = (gd_t *) (CONFIG_SYS_INIT_RAM_ADDR
On Thu, Apr 16, 2009 at 2:41 PM, Peter Tyser wrote:
> This patch series removes the "individual" I2C commands (and the
> CONFIG_I2C_CMD_TREE define) and migrates all boards to the newer
> "tree style" I2C commands.
>
> A small amount of cleanup was performed before and after removing
> the individ
On Thu, Apr 16, 2009 at 5:01 PM, Richard Retanubun
wrote:
> I've tried extracting the information at board_early_init_r (because I need
> to initialize MAC address later using this information also)
> and store the information using setenv("partnum" "extracted_board_id");
>
> However, the result
Hi,
I am working on an MP8360E powerpc platform using uboot 2009.03.
our boards contain an i2c eeprom that identify the type of board it is.
sing this information I would like to have a universal u-boot binary that can
read the eeprom
and use the data to influence how the rest of the boot proce
Dear David Brownell,
In message <200904121538.07026.davi...@pacbell.net> you wrote:
> From: David Brownell
>
> Update the DaVinci DM6446 boards to use the new convention
> for CONFIG_SYS_NS16550_REG_SIZE ... the size hasn't changed
> from the original 4 bytes, but these chips are little-endian.
Dear Mike Frysinger,
In message <1239589760-19215-1-git-send-email-vap...@gentoo.org> you wrote:
> The first if statement checks for NULL ptrs, so there is no need to check
> it again in later else cases (such as .oob).
>
> Signed-off-by: Mike Frysinger
> CC: Scott Wood
> ---
> common/cmd_nand
Dear David Brownell,
In message <200904130803.39029.davi...@pacbell.net> you wrote:
> From: David Brownell
>
> Fix dependency goofage: it should certainly be possible to have the
> partition support without bringing in UBI commands.
>
> Signed-off-by: David Brownell
> ---
> drivers/mtd/Makef
Dear Stefan Roese,
In message <200904161625.03258...@denx.de> you wrote:
> Hi Wolfgang,
>
> I've updated my 4xx repository with the latest version of the "ppc4xx: Remove
> unused code for Sequoia NAND booting version" patch. So please pull the
> changes/fixes into mainline. Here again the lates
Dear Stefan Roese,
In message <200904151633.06420...@denx.de> you wrote:
>
> please pull some fixes for ppc4xx:
>
> The following changes since commit f75a729b5c1434d5a5bbf453b1b699bf1c3ffbce:
> Wolfgang Denk (1):
> Merge branch 'master' of git://git.denx.de/u-boot-blackfin
>
> are av
Dear Stefan Roese,
In message <200904141044.22603...@denx.de> you wrote:
> Hi Wolfgang,
>
> please pull a fix for ppc4xx:
>
> The following changes since commit f75a729b5c1434d5a5bbf453b1b699bf1c3ffbce:
> Wolfgang Denk (1):
> Merge branch 'master' of git://git.denx.de/u-boot-blackfin
>
Dear lafar...@rockwellcollins.com,
In message
you wrote:
>
> Can I get someone to point me in the right direction for researching out
> the Power On Self Test portion of U-Boot?
Did you read the documentation? If yes, then what are the questions
you did not find answered?
Best regards,
Wolf
Can I get someone to point me in the right direction for researching out
the Power On Self Test portion of U-Boot?
Thanks!
-Les
This message contains PRIVILEGED AND PROPRIETARY INFORMATION intended
solely for the use of the addressee(s) named above. Any disclosure,
distribution, copying or us
The individual i2c commands imd, imm, inm, imw, icrc32, iprobe, iloop,
and isdram are no longer available so all references to them have been
updated to the new form of "i2c ".
Signed-off-by: Peter Tyser
---
README| 15 ---
board/esd/tasreg/tasreg.c |4 ++--
When CONFIG_I2C_MUX was defined the output of 'help i2c' was not
correct, eg:
=> help i2c
i2c bus [muxtype:muxaddr:muxchannel] - add a new bus reached over muxes.
speed [speed] - show or set I2C bus speed
i2c dev [dev] - show or set current I2C bus
...
It has been changed to:
i2c speed [speed] -
Signed-off-by: Peter Tyser
---
common/cmd_i2c.c | 25 -
1 files changed, 4 insertions(+), 21 deletions(-)
diff --git a/common/cmd_i2c.c b/common/cmd_i2c.c
index 41f6e33..74a7735 100644
--- a/common/cmd_i2c.c
+++ b/common/cmd_i2c.c
@@ -130,9 +130,6 @@ DECLARE_GLOBAL_DATA
The following individual I2C commands have been removed: imd, imm, inm,
imw, icrc32, iprobe, iloop, isdram.
The functionality of the individual commands is still available via
the 'i2c' command.
This change only has an impact on those boards which did not have
CONFIG_I2C_CMD_TREE defined.
Signed
argc and argv should only be modified once instead of once for
every i2c sub-command
Signed-off-by: Peter Tyser
---
common/cmd_i2c.c | 52
1 files changed, 28 insertions(+), 24 deletions(-)
diff --git a/common/cmd_i2c.c b/common/cmd_i2c.c
i
New default, weak i2c_get_bus_speed() and i2c_set_bus_speed() functions
replace a number of architecture-specific implementations.
Also, providing default functions will allow all boards to enable
CONFIG_I2C_CMD_TREE. This was previously not possible since the
tree-form of the i2c command provide
Add "_test" to cm5200's function test command names to prevent
overlap with common, global function names. Originally, the
"do_i2c" function test command interfered with
common/cmd_i2c.c's "do_i2c" when CONFIG_I2C_CMD_TREE was defined.
The functions were also made static as they are not globally
This patch series removes the "individual" I2C commands (and the
CONFIG_I2C_CMD_TREE define) and migrates all boards to the newer
"tree style" I2C commands.
A small amount of cleanup was performed before and after removing
the individual commands.
Peter Tyser (7):
cm5200: Make function test com
Andy,
On Sun, Apr 05, 2009 at 01:30:52PM +0530, Rabin Vincent wrote:
> Remove some repeated words and superfluous newlines in the mmc command
> help entries.
>
> Signed-off-by: Rabin Vincent
Any comments on this set of patches?
Rabin
___
U-Boot maili
Hi Remco,
> While doing > git clone git://git.denx.de/u-boot.git, I get the following
> errors:
>> remote: Compressing objects: 100% (16533/16533), done.
>> remote: Total 90263 (delta 74103), reused 89209 (delta 73184)
>> Receiving objects: 100% (90263/90263), 29.61 MiB | 175 KiB/s, done.
>> Reso
Hi Wolfgang,
I've updated my 4xx repository with the latest version of the "ppc4xx: Remove
unused code for Sequoia NAND booting version" patch. So please pull the
changes/fixes into mainline. Here again the latest changelog:
The following changes since commit f75a729b5c1434d5a5bbf453b1b699bf1c3
Hi Wolfgang.
if I have any progress ,
I will send it to this list.
thanks
Xiangfu
Best Regards.
Wolfgang Denk wrote:
> Dear xiangfu_gmail,
>
> In message <49e5a2ed.2060...@gmail.com> you wrote:
>
>> there is a device name PI,
>> the CPU is Ingenic 4740 [1],
>> now we have the u-boot-1.1.6 pat
On Thursday 16 April 2009, Wolfgang Denk wrote:
> Overwriting the function definition in "cpu/ppc4xx/speed.c" with a
> #define like here is pretty ugly.
BTW: speed.c is not compiled in this NAND-booting version because of size
reasons (4k limit). Forgot to mention this in my previous mail.
Best
Hi Wolfgang,
On Thursday 16 April 2009, Wolfgang Denk wrote:
> Overwriting the function definition in "cpu/ppc4xx/speed.c" with a
> #define like here is pretty ugly.
>
> Looking closer at this, I think the whole implementation of
> get_bus_freq() needs to be cleaned up. Why does get_bus_freq() nee
Dear Guenter,
please STOP top posting / full quoting!!! Make sure to read
http://www.netmeister.org/news/learn2quote.html before posting again.
Thanks.
In message you
wrote:
>
> it's the same with standard u-boot, compiling MPC8315ERDB.
Hm... I don't see this problem here:
-> git-chec
Dear Stefan Roese,
In message <1239866038-32703-1-git-send-email...@denx.de> you wrote:
> The current define of get_bus_freq() in the CONFIG_NAND_SPL #ifdef is not
> used at all. This patch changes it's define to the currently used value of
> 1 and removes the unnecessary code.
>
> Signed
Dear Bhavna YADAV,
In message <03e301c9be5a$80a23d20$2b52c...@dlh.st.com> you wrote:
>
> But can you please let me know why this
...
I already explained this to you:
> Ancient code and recent tools don't mix. Either use a tool chain that is as
> old as the code you are using, or (better) use cu
Hello,
it's the same with standard u-boot, compiling MPC8315ERDB.
The problem is caused by the installed newer version of the dtc.
The libfdt.h differs in the declaration of fdt_offset_ptr.
$diff /usr/include/../include/libfdt.h u-boot-2009.03/include/libfdt.h
125c125
< c
The current define of get_bus_freq() in the CONFIG_NAND_SPL #ifdef is not
used at all. This patch changes it's define to the currently used value of
1 and removes the unnecessary code.
Signed-off-by: Stefan Roese
---
board/amcc/sequoia/sdram.c |6 +-
1 files changed, 1 insertions
59 matches
Mail list logo