Signed-off-by: Mike Frysinger
CC: Ben Warren
CC: Daniel Hellstrom
CC: Michal Simek
CC: Shinya Kuribayashi
CC: Scott McNutt
CC: Nobuhiro Iwamatsu
---
include/asm-arm/u-boot.h|5 -
include/asm-avr32/u-boot.h |1 -
include/asm-blackfin/u-boot.h |1 -
include/asm-
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
Also stop calling load_sernum_ethaddr() since all boards now implement
this as a stub.
Signed-off-by: Mike Frysinger
CC: Ben War
Signed-off-by: Mike Frysinger
CC: Ben Warren
---
board/kup/common/load_sernum_ethaddr.c |4
board/m501sk/m501sk.c |5 -
board/pcs440ep/pcs440ep.c |4
board/tqc/tqm8xx/load_sernum_ethaddr.c |4
include/common.h
Rename load_sernum_ethaddr() to kup_load_sernum_ethaddr() and have board
init code call it rather than the common ppc board code.
Signed-off-by: Mike Frysinger
CC: Ben Warren
---
board/kup/common/load_sernum_ethaddr.c |6 +-
board/kup/kup4k/kup4k.c|3 +++
board/kup/k
Rename load_sernum_ethaddr() to tqc_load_sernum_ethaddr() and have board
init code call it rather than the common ppc board code.
Signed-off-by: Mike Frysinger
CC: Ben Warren
---
board/tqc/tqm8xx/load_sernum_ethaddr.c |6 +-
board/tqc/tqm8xx/tqm8xx.c |3 +++
2 files cha
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
Move all the work of load_sernum_ethaddr() into a local load_ethaddr()
func and call that from misc_init_r(). We leave load_sernu
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
Also rename load_sernum_ethaddr() to misc_init_r() so we don't need to
handle this board specially in common ARM code.
Signed-off
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
The cpus that get converted here:
at91rm9200
mpc512x
mpc5xxx
mpc8260
mpc8xx
ppc4xx
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
Some warts are remaining and should be killed off (by moving the func to
the appropriate board init code):
- davinci_eth_s
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
For the nx823, the serial number is moved out of load_sernum_ethaddr() and
into misc_init_r() as is the env setup. This lets us k
Since everyone is using the environment for mac address storage, there is
no point in seeding the global data.
The arches that are converted here:
i386
m68k
microblaze
mips
nios
nios2
sh
sparc
Signed-off-by: Mike Frysinger
CC: Ben W
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
The resulting code can also be simplified even further.
Signed-off-by: Mike Frysinger
CC: Stefan Roese
CC: Ben Warren
---
cpu
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
Also, do not bother checking the EEPROM if the env is setup. This
simplifies the code greatly.
Signed-off-by: Mike Frysinger
CC
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
The sh_eth driver can also be simplified a bit by using enetaddr member of
the eth_device structure.
Signed-off-by: Mike Frysinge
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
The cs8900 driver also changes slightly in that the hardware is not
consulted if the mac address in the env is sane.
Signed-off-b
The environment is the canonical storage location of the mac address, so
we're killing off the global data location and moving everything to
querying the env directly.
Since the address is in the PLM_DEVICE_BLOCK structure already, there is
no need to pass the NodeAddress as a second parameter. S
The boards that get converted here to use the environment for the mac
address rather than global data:
debris
mgcoge
mgsuvd
muas3001
netstal
pn62
sixnet
vcma9
xilinx (the ones that use xilinx_enet)
Signed-off-by: Mike Frysinge
Always use the MAC address that is stored in the environment first before
falling back to the ROM. This also cuts out any comparison steps: if the
mac in the env is sane, the ROM is never consulted.
Signed-off-by: Mike Frysinger
CC: Thomas Frieden
CC: Ben Warren
---
board/MAI/AmigaOneG3SE/ene
Since the ethernet layer handles updating of device addresses itself from
the environment, there is no point in calling eth_set_enetaddr().
Signed-off-by: Mike Frysinger
CC: Ben Warren
---
common/cmd_nvedit.c | 24 +---
1 files changed, 1 insertions(+), 23 deletions(-)
di
Signed-off-by: Mike Frysinger
CC: Ben Warren
---
common/lynxkdi.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/common/lynxkdi.c b/common/lynxkdi.c
index 5f12b0d..17b0607 100644
--- a/common/lynxkdi.c
+++ b/common/lynxkdi.c
@@ -33,7 +33,7 @@ void lynxkdi_boot (image_h
Signed-off-by: Mike Frysinger
CC: Niklaus Giger
CC: Ben Warren
---
common/cmd_elf.c |6 --
1 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/common/cmd_elf.c b/common/cmd_elf.c
index 19e1249..4a3fff1 100644
--- a/common/cmd_elf.c
+++ b/common/cmd_elf.c
@@ -131,10 +131,12 @@
Add a new print_eth() function to automate the eth*addr env var acquisition
and display. Affects all arches.
Signed-off-by: Mike Frysinger
CC: Nobuhiro Iwamatsu
CC: Scott McNutt
CC: Shinya Kuribayashi
CC: Michal Simek
CC: Daniel Hellstrom
CC: Ben Warren
---
common/cmd_bdinfo.c | 136
Signed-off-by: Mike Frysinger
CC: Ben Warren
---
net/bootp.c | 13 ++---
net/net.c | 20
2 files changed, 10 insertions(+), 23 deletions(-)
diff --git a/net/bootp.c b/net/bootp.c
index 83465e4..c87049c 100644
--- a/net/bootp.c
+++ b/net/bootp.c
@@ -579,21 +579
Since the on-chip MAC does not have an eeprom or similar interface, force
all Blackfin boards that use this driver to setup the board data with a
proper MAC.
Signed-off-by: Mike Frysinger
CC: Ben Warren
---
drivers/net/bfin_mac.c | 16
drivers/net/bfin_mac.h |2 +-
lib_bl
Signed-off-by: Mike Frysinger
CC: Ben Warren
---
doc/README.enetaddr | 96 +++
1 files changed, 96 insertions(+), 0 deletions(-)
create mode 100644 doc/README.enetaddr
diff --git a/doc/README.enetaddr b/doc/README.enetaddr
new file mode 100644
this set of patches aims to standardize the mac address handling in all of
u-boot by doing the following:
- add helper funcs for working with mac addresses (binary & string)
- convert all duplicated code to use aforementioned helper funcs
- convert all places to get the mac
Declare new utility functions for converting between the environment
variables (eth*addr) and the binary MAC address representation. This way
we can unify all the random places that already do this kind of thing.
The functions in question:
eth_parse_enetaddr - "..." -> {...}
eth_g
is there any statements that i cannot find dictating the proper encoding of
files ? considering git itself whines when things are not proper utf8
encoded, i'd expect that this would carry over to the files in u-boot itself.
for example, the MAINTAINERS and the CREDITS files are both using iso-
Initial multiadapter/multibus I2C support.
Atmel AT91RM9200 based boards.
This goes on top of previous patches.
Signed-off-by: Sergey Kubushyn
---
diff -purN u-boot-i2c.ORIG/board/cmc_pu2/load_sernum_ethaddr.c
u-boot-i2c/board/cmc_pu2/load_sernum_ethaddr.c
--- u-boot-i2c.ORIG/board/cmc_pu2/loa
Add missing #endif in include/i2c.h
Signed-off-by: Sergey Kubushyn
---
diff -purN u-boot-i2c.ORIG/include/i2c.h u-boot-i2c/include/i2c.h
--- u-boot-i2c.ORIG/include/i2c.h 2009-02-13 16:34:36.0 -0800
+++ u-boot-i2c/include/i2c.h2009-02-13 16:25:52.0 -0800
@@ -226,6 +226,7
Initial multiadapter/multibus I2C support.
Signed-off-by: Sergey Kubushyn
---
diff -purN u-boot-i2c.orig/include/configs/MHPC.h
u-boot-i2c/include/configs/MHPC.h
--- u-boot-i2c.orig/include/configs/MHPC.h 2009-02-12 10:43:41.0
-0800
+++ u-boot-i2c/include/configs/MHPC.h 2009-02-1
Initial multiadapter/multibus I2C support.
Signed-off-by: Sergey Kubushyn
---
diff -purN u-boot-i2c.orig/drivers/i2c/sm502_i2c.c
u-boot-i2c/drivers/i2c/sm502_i2c.c
--- u-boot-i2c.orig/drivers/i2c/sm502_i2c.c 1969-12-31 16:00:00.0
-0800
+++ u-boot-i2c/drivers/i2c/sm502_i2c.c 2009-02
Initial multiadapter/multibus I2C support.
Signed-off-by: Sergey Kubushyn
---
diff -purN u-boot-i2c.orig/drivers/i2c/omap1510_i2c.c
u-boot-i2c/drivers/i2c/omap1510_i2c.c
--- u-boot-i2c.orig/drivers/i2c/omap1510_i2c.c 2009-02-12 10:43:41.0
-0800
+++ u-boot-i2c/drivers/i2c/omap1510_i2c.c
Initial multiadapter/multibus I2C support.
Signed-off-by: Sergey Kubushyn
---
diff -purN u-boot-i2c.orig/common/cmd_date.c u-boot-i2c/common/cmd_date.c
--- u-boot-i2c.orig/common/cmd_date.c 2009-02-12 10:43:41.0 -0800
+++ u-boot-i2c/common/cmd_date.c2009-02-12 10:46:00.0
Wolfgang Grandegger wrote:
> Scott Wood wrote:
>> On Wed, Feb 11, 2009 at 06:38:22PM +0100, Wolfgang Grandegger wrote:
>>> Index: u-boot/drivers/mtd/nand/fsl_upm.c
>>> ===
>>> --- u-boot.orig/drivers/mtd/nand/fsl_upm.c
>>> +++ u-boot/d
Wolfgang Grandegger wrote:
> Scott Wood wrote:
>> On Wed, Feb 11, 2009 at 06:38:22PM +0100, Wolfgang Grandegger wrote:
>>> Index: u-boot/drivers/mtd/nand/fsl_upm.c
>>> ===
>>> --- u-boot.orig/drivers/mtd/nand/fsl_upm.c
>>> +++ u-boot/d
On Fri, 13 Feb 2009, Heiko Schocher wrote:
> Hello ksi,
>
> k...@koi8.net wrote:
> > Signed-off-by: Sergey Kubushyn
> > ---
> > diff -purN u-boot-i2c.orig/drivers/i2c/soft_i2c.c
> > u-boot-i2c/drivers/i2c/soft_i2c.c
> > --- u-boot-i2c.orig/drivers/i2c/soft_i2c.c 2009-02-12 10:43:41.0
Scott Wood wrote:
> On Wed, Feb 11, 2009 at 06:38:22PM +0100, Wolfgang Grandegger wrote:
>> Index: u-boot/drivers/mtd/nand/fsl_upm.c
>> ===
>> --- u-boot.orig/drivers/mtd/nand/fsl_upm.c
>> +++ u-boot/drivers/mtd/nand/fsl_upm.c
>> @@ -9
On Wed, Feb 11, 2009 at 06:38:22PM +0100, Wolfgang Grandegger wrote:
> Index: u-boot/drivers/mtd/nand/fsl_upm.c
> ===
> --- u-boot.orig/drivers/mtd/nand/fsl_upm.c
> +++ u-boot/drivers/mtd/nand/fsl_upm.c
> @@ -90,8 +90,11 @@ static void
On Wed, Feb 11, 2009 at 06:38:19PM +0100, Wolfgang Grandegger wrote:
> The following patch series intends to support the Micron multi-chip
> NAND device MT29F8G08FAB on the TQM8548 modules from TQ-Components.
> To offer this multi-chip device as one single device to the user,
> multi-chip device ha
On Fri, Feb 13, 2009 at 10:39:34AM -0700, Derek Ou wrote:
> 1) The nand_util.c does not have WATCHDOG_RESET() in the
> nand_read_skip_bad() and nand_write_skip_bad() while the original
> nand_write_opts() and nand_read_opts() do. Is there a special reason
> this is removed? It's likely that wa
On Fri, 13 Feb 2009, Heiko Schocher wrote:
> Hello ksi,
>
> k...@koi8.net wrote:
> > Here is the second attempt for initial portion of multibus/multiadapter
> > I2C support.
> >
>
> Can you please send your patches with some better commit messages.
> You only send your Signed-off-by, without
On Fri, 2009-02-13 at 09:03 +0100, Heiko Schocher wrote:
> Hello ksi,
>
> k...@koi8.net wrote:
> > Signed-off-by: Sergey Kubushyn
> >
>
> Patch aplies with warnings:
>
> Applying: 1/12 Multiadapter/multibus I2C, common part 1
> /home/hs/i2c/u-boot-i2c/.git/rebase-apply/patch:630: trailing wh
On Fri, Feb 13, 2009 at 6:36 AM, hendrik wrote:
> Hi all
>
> When i included the struct as is the my board with the MPC8548 ver1 cpu
> worked correctly but the board with ver2 CPU does not work.
> A would appeciate any help
In what way does it "not work"? the cpu version shouldn't affect PHY
re
I have a few issues/questions regarding the NAND commands in the latest
git main tree.
1) The nand_util.c does not have WATCHDOG_RESET() in the
nand_read_skip_bad() and nand_write_skip_bad() while the original
nand_write_opts() and nand_read_opts() do. Is there a special reason
this is removed
Hello,
I am using u-boot 2009.01 and linux kernel 2.6.27 from kernel.org
compiled for MCF5271 tested using the M5271EVB eval board.
I am trying to pass kernel boot arguments and initrd from u-boot to the kernel.
There is a patch on the DENX-linux-2.6
http://git.denx.de/?p=linux-2.6-denx.git;a=co
Added code to setup the extra Flash and FRAM chip selects as used on the
MIMC200 board.
V2 moves the init code from the common "cpu.c" file into the board specific
setup file.
Signed-off-by: Mark Jackson
---
board/mimc/mimc200/mimc200.c | 14 ++
1 files changed, 14 insertions(
Hi
Why does most of the existing configurations use
such addresses as:
For passing boot_params
gd->bd->bi_boot_params = PHYS_SDRAM + 0x100;
Why + 0x100 and not just PHYS_SDRAM?
Similarly for Linux kernel load address
PHYS_SDRAM + 0x8000
Why + 0x8000?
I think by doing this the following
This is the InterControl custom device based on the MPC5200B chip.
Signed-off-by: Grzegorz Bernacki
---
Version 6:
- adjusted kernel console variable to use PSC4
(to reflect recent DTS changes)
Version 5:
- removed unnecessary braces
- changed out32/in32 to out_be32/in_be32
Version 4:
- re
Hi all
In porting from U-Boot 1.2 to U-boot 2009 i noticed that the phys on my
board was not detected and defulted to Generic/Unrecognised; while
looking through my code for U-boot 1.2 I found a phy_info struct for
the Vitesse phys my board has( in drivers/tsec.c). The Same struck does
not a
i am using mpc8360 emds board.
it is working fine with socdimm.
but with sordimm not working.
there is minor change i have done it for sordimm as follows for testing
only.
/* sdram_cfg[3] = RD_EN - registered DIMM enable */
// if (spd.mod_attr & 0x02) vivek
// {
printf("sdramcfg[3] registered DIM
Byte is too small unit for CONFIG_MG_DISK_RES and also needs
sector size alignment.
Signed-off-by: unsik Kim
---
doc/README.mflash | 10 +-
drivers/block/mg_disk.c | 10 +++---
2 files changed, 8 insertions(+), 12 deletions(-)
diff --git a/doc/README.mflash b/doc/README.mf
Mflash is fusion memory device mainly targeted consumer eletronic and
mobile phone.
Internally, it have nand flash and other hardware logics and supports
some different operation (ATA, IO, XIP) modes.
IO mode is custom mode for the host that doesn't have IDE interface.
(Many mobile targeted SoC do
When using CONFIG_MG_DISK_RES, total sectors should be
recalculated.
Signed-off-by: unsik Kim
---
drivers/block/mg_disk.c | 18 ++
1 files changed, 14 insertions(+), 4 deletions(-)
diff --git a/drivers/block/mg_disk.c b/drivers/block/mg_disk.c
index e1b1a68..193a441 100644
---
Hello?
The following patch series support mflash for u-boot.
[U-BOOT][PATCH 1/3] Initial mflash support
[U-BOOT][PATCH 2/3] Change CONFIG_MG_DISK_RES unit to KB
[U-BOOT][PATCH 3/3] Fix miscalculated total sectors
Previous patches I posted were wrong(line wrapped, not rebased and so on).
Please ig
Hello ksi,
k...@koi8.net wrote:
> Signed-off-by: Sergey Kubushyn
> ---
> diff -purN u-boot-i2c.orig/drivers/i2c/soft_i2c.c
> u-boot-i2c/drivers/i2c/soft_i2c.c
> --- u-boot-i2c.orig/drivers/i2c/soft_i2c.c2009-02-12 10:43:41.0
> -0800
> +++ u-boot-i2c/drivers/i2c/soft_i2c.c 2009-02-12
Some SPI devices have special requirements on chip-select handling.
With this patch we can use a GPIO as a chip-select and strictly follow
the SPI_XFER_BEGIN and SPI_XFER_END flags.
Signed-off-by: Guennadi Liakhovetski
---
Changes since v1: long lines split, mx31_gpio_* calls now also defined if
i.MX31 powers on with most clocks running, so, after a power on this explicit
clock start up is not required. However, as Linux boots it disables most clocks
to save power. This includes the I2C clock. If we then soft reboot from Linux
the I2C clock stays off. This breaks the phycore, which has its
Hello ksi,
k...@koi8.net wrote:
> Signed-off-by: Sergey Kubushyn
>
Patch apply with warnings
Applying: 9/12 Multiadapter/multibus I2C, configs part 2
/home/hs/i2c/u-boot-i2c/.git/rebase-apply/patch:181: space before tab in
indent.
{1, CONFIG_SYS_I2C_8
Hello ksi,
k...@koi8.net wrote:
> Signed-off-by: Sergey Kubushyn
>
Patch apply with warnings:
Applying: 6/12 Multiadapter/multibus I2C, drivers part 3
/home/hs/i2c/u-boot-i2c/.git/rebase-apply/patch:108: trailing whitespace.
/home/hs/i2c/u-boot-i2c/.git/rebase-apply/patch:125: trailing white
Hello ksi
k...@koi8.net wrote:
> Signed-off-by: Sergey Kubushyn
>
Patch apply with warnings:
Applying: 5/12 Multiadapter/multibus I2C, drivers part 2
/home/hs/i2c/u-boot-i2c/.git/rebase-apply/patch:698: trailing whitespace.
#ifdef CONFIG_SYS_OMAP24XX_I2C2_BASE
/home/hs/i2c/u-boot-i2c/.git/re
Hello ksi,
k...@koi8.net wrote:
> Signed-off-by: Sergey Kubushyn
>
Patch aplies with warnings:
Applying: 1/12 Multiadapter/multibus I2C, common part 1
/home/hs/i2c/u-boot-i2c/.git/rebase-apply/patch:630: trailing whitespace.
/home/hs/i2c/u-boot-i2c/.git/rebase-apply/patch:688: trailing whit
62 matches
Mail list logo