Hi,
It seems ur linker script is overlapping both the sections .start16 and
text and similarly the reset and text.
Try to change the boundary limits for the sections to prevent conflicts,
this is due to the new addition of the driver code.
Thanks & Regards,
Vignesh Kumar B
-Original Messa
Hi I add a ethernet driver to u-boot, when I compile the source tree, I got
the following link error, can anyone please suggest me how to fix the error?
i686-pc-linux-gnu-ld:
section .start16 [0500 -> 05ba] overlaps section .text [05fe ->
06011b85]
i686-pc-linux-gnu-ld:
section .res
The BAT fields are architected; there's no need for these to be in
cpu-specific files. Drop the duplication and move these to
include/asm-ppc/mmu.h. Also, remove the BL_xxx defines that were only
used by the alaska board, and switch to using the BATU_BL_xxx defines
used by all the other boards.
include/flash.h was commented to say that the address in
flash_info->start was a physical address. However, from u-boot's
point of view, and looking at most flash code, it makes more
sense for this to be a virtual address. So I corrected the
comment to indicate that this was a virtual address.
T
If CONFIG_ADDR_MAP is enabled, update the address map
whenever we write a bat.
Signed-off-by: Becky Bruce <[EMAIL PROTECTED]>
---
cpu/mpc86xx/cpu_init.c | 27 +++
include/asm-ppc/mmu.h | 16 +---
lib_ppc/bat_rw.c | 28
The code assumes that the pci bus address and the virtual
address used to access a region are the same, but they might
not be. Fix this assumption.
Signed-off-by: Becky Bruce <[EMAIL PROTECTED]>
---
drivers/block/ahci.c |7 ++-
1 files changed, 2 insertions(+), 5 deletions(-)
diff --git
Now that the rest of u-boot can support it, change the PCI bus
address of the PCI MEM regions from 0x8000 to 0xc000,
and use the same bus address for both PCI1 and PCI2. This will
maximize the amount of PCI address space left over to map RAM
on systems with large amounts of memory.
Signed
Some parts can support large physical mappings; so make the
size argument to addrmap_set_entry a phys_size_t. Also update
the 85xx tlb code to be sure the size quantity is unsigned.
Signed-off-by: Becky Bruce <[EMAIL PROTECTED]>
---
cpu/mpc85xx/tlb.c |4 ++--
include/addr_map.h |
Signed-off-by: Becky Bruce <[EMAIL PROTECTED]>
---
include/configs/MPC8641HPCN.h |2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/include/configs/MPC8641HPCN.h b/include/configs/MPC8641HPCN.h
index 1d287ec..7f69611 100644
--- a/include/configs/MPC8641HPCN.h
+++ b/include/c
Clean up PCI mapping concepts in the 8641 config - rename _BASE
to _BUS, as it's actually a PCI bus address, separate virtual
and physical addresses into _VIRT and _PHYS, and use each
appopriately.
Signed-off-by: Becky Bruce <[EMAIL PROTECTED]>
---
board/freescale/mpc8641hpcn/mpc8641hpcn.c | 10
It is no longer always true that the pci bus address can be
used as the virtual address for pci accesses. pci_map_bar()
is created to return the virtual address for a pci region.
Signed-off-by: Becky Bruce <[EMAIL PROTECTED]>
---
drivers/pci/pci.c | 19 +++
include/pci.h |
Because the inbound pci windows are mapped generously, set up
the more specific outbound windows first. This way, when we
search the pci regions for something, we will hit on the more
specific region. This can actually be a problem on systems
with large amounts of RAM.
Signed-off-by: Becky Bruce
Casting a pointer to a phys_addr_t when it's an unsigned long long
on a 32-bit system without first casting to a non-pointer type
generates a compiler warning. Fix this.
Signed-off-by: Becky Bruce <[EMAIL PROTECTED]>
---
include/asm-ppc/io.h |2 +-
1 files changed, 1 insertions(+), 1 deletion
This patch series cleans up much of for VA/PA/PCI bus address confusion
that is is currently causing a couple of problems on the 8641 36-bit
port, and was preventing us from having a PCI mem bus address that
differed from the virtual address of the region.
I have fixed a number of problems, from
Rename _BASE to _BUS, as it's actually a PCI bus address,
separate virtual and physical addresses into _VIRT and _PHYS,
and use each appopriately. This makes the code easier to read
and understand, and facilitates mapping changes going forward.
Signed-off-by: Becky Bruce <[EMAIL PROTECTED]>
---
Rename _BASE to _BUS, as it's actually a PCI bus address,
separate virtual and physical addresses into _VIRT and _PHYS,
and use each appopriately. This makes the code easier to read
and understand, and facilitates mapping changes going forward.
Signed-off-by: Becky Bruce <[EMAIL PROTECTED]>
---
Hi, Ben.
Ben Warren wrote:
> Hi Nobuhiro,
>
> Nobuhiro Iwamatsu wrote:
>> Add CONFIG_NET_MULTI in config file, because sh_eth changed new
>> newwork API.
>>
>> Signed-off-by: Nobuhiro Iwamatsu <[EMAIL PROTECTED]>
>> ---
>> include/configs/sh7763rdp.h |1 +
>> 2 files changed, 2 insertions(+
> start_addr = 0
> size = 0x1000
>
> start will be 0
> end will be 0x1000
>
> The loop will flush the cache line at 0x1000, because it uses
> <= rather than <. That is outside the area that was requested to be
flushed.
> Maybe it's not mapped. Or, maybe start + size = 0 and > nothing gets
flu
On newer CPUs, 8536, 8572, and 8610, the CLKDIV field of LCRR is five bits
instead of four.
In order to avoid an ifdef, LCRR_CLKDIV is set to 0x1f on all systems. It
should be safe as the fifth bit was defined as reserved and set to 0.
Code that was using a hard coded 0x0f is changed to use LCRR
Currently MPC85xx and MPC86xx boards just calculate the localbus frequency
and print it out, but don't save it.
This changes where its calculated and stored to be more consistent with the
CPU, CCB, TB, and DDR frequencies and the MPC83xx localbus clock.
The localbus frequency is added to sysinfo
Export the localbus frequency in the device tree, the same way the CPU, TB,
CCB, and various other frequencies are exported in their respective device
tree nodes.
Some localbus devices need this information to be programed correctly, so
it makes sense to export it along with the other frequencies.
The clock divider for the MPC8568 local bus should be doubled, like the
other newer MPC85xx chips.
Since there are now more chips with a 2x divider than a 1x, and any new
85xx chips will probably be 2x, invert the sense of the #if so that it
lists the 1x chips instead of the 2x ones.
Signed-off-b
The local bus clock divider should be doubled for both 8610 and 8641.
Signed-off-by: Trent Piepho <[EMAIL PROTECTED]>
Acked-by: Kumar Gala <[EMAIL PROTECTED]>
Acked-by: Jon Loeliger <[EMAIL PROTECTED]>
---
cpu/mpc86xx/cpu.c |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/
Dear Wolfgang,
> In message pink sez,
>> So still doing some hacking trying to build this and
>> wondering if either u-boot-1.3.4 is busted, or the
>> instructions are wrong.
>
> v1.3.4 is old. Why don't you use current code?
Far as I can tell v1.3.4 is from Sept this year. Is it older
than
Is there any documentation for this global variable? I'm trying to fix a bug in
NetStartAgain(), and I'm trying to understand the purpose of this variable.
--
Timur Tabi
Linux kernel developer at Freescale
___
U-Boot mailing list
U-Boot@lists.denx.de
h
has anyone used a PCIe based SATA card w/u-boot?
- k
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot
The following changes since commit 2077e348c2a84901022ad95311b47b70361e6daa:
Scott Wood (1):
NAND: Fix misplaced return statement in nand_{read,write}_skip_bad().
are available in the git repository at:
git://git.denx.de/u-boot-nand-flash.git master
Stefan Roese (1):
OneNAND: A
On Tue, Dec 02, 2008 at 11:06:47AM +0100, Stefan Roese wrote:
> - Add subpage write support
> - Add onenand_oob_64/32 ecclayout
>
> This has been missing and without it UBI has some incompatibilies issues
> with the current (>= 2.6.27) Linux kernel version. vid_hdr_offset is
> placed differently (
On Wed, Dec 03, 2008 at 04:05:14PM +0530, Vignesh Kumar B wrote:
> I have tried modifying the Start.s of uboot as mentioned below.
> When I try to link I get an error "`.bootpg' can't be allocated in
> segment 1".
> Can someone guide me on this. I am also attaching the start.o and the
> linker sc
Daniel Mack wrote:
> Hi Ben,
>
> On Tue, Dec 02, 2008 at 04:43:32PM -0800, Ben Warren wrote:
>
>> Sorry, I've been bogged down with other stuff. Some things are missing
>> from your patches, which can mainly be fixed by using 'git format-patch
>> -C':
>> 1. No signed-off-by
>> 2. No diffstat
All implementations of the functions i2c_reg_read() and i2c_reg_write() are
identical. We can save space and simplify the code by converting these
functions into inlines and putting them in i2c.h.
Signed-off-by: Timur Tabi <[EMAIL PROTECTED]>
---
v3: add 8xx-specific code, and include PRINTDs fr
Liu Dave wrote:
> The lib_ppc version basically is as below.
> void flush_cache (ulong start_addr, ulong size)
> {
> ulong addr, end_addr = start_addr + size;
> addr = start_addr & (CONFIG_SYS_CACHELINE_SIZE - 1);
> for (addr = start_addr; addr < end_addr; addr +=
> CONFIG_SYS_CA
As stated in the subject, we used multiple 460EXs tied together via
PCI and been able to boot the master from flash and all the slaves
are now able to boot via PCI and run linux. There were several config
changes in u-boot that I made to get this to work (one of which I have
a question about). BT
On Dec 3, 2008, at 9:08 AM, Haiying Wang wrote:
> Assuming the OSes exception vectors start from the base of kernel
> address, and
> the kernel physical starting address can be relocated to an non-zero
> address.
> This patch enables the second core to have a valid IVPR for debugger
> befor
Assuming the OSes exception vectors start from the base of kernel address, and
the kernel physical starting address can be relocated to an non-zero address.
This patch enables the second core to have a valid IVPR for debugger before
kernel setting IVPR in CAMP mode. Otherwise, IVPR is 0x0 and it
Hello,
On Wed, Dec 3, 2008 at 8:40 AM, Trent Piepho <[EMAIL PROTECTED]> wrote:
> On Wed, 3 Dec 2008, Sean MacLennan wrote:
>>> Yes, I would recommend to do it this way if possible. A small NOR for
>>> U-Boot and environment and everything else in NAND. This makes things
>>> much easier. But I unde
> That comment was on the version you posted in the NAND patch; the
> lib_ppc version actually looks worse -- it tried to round
> down to avoid
> the issue, but it was missing a ~. Thus, it flushed everything from
> address 0 to the end.
the lib_ppc version basically is as below.
void flush
2008/12/3 Wolfgang Denk <[EMAIL PROTECTED]>:
> Dear hank.peng <[EMAIL PROTECTED]>,
>
> repl: bad addresses:
>hank.peng <[EMAIL PROTECTED]> -- no at-sign after local-part (<)
>
> Please fix the mail address you provide in your headers as return
> address. Either get rid of the dot, or add qu
> "Wolfgang" == Wolfgang Denk <[EMAIL PROTECTED]> writes:
Hi,
Wolfgang> As mentioned before, this doesn't work because the length you are
Wolfgang> checking is not the image length, but the device size.
Yes, because you rejected the patch to fix this.
So, what do you suggest?
--
Bye, Pe
> "Wolfgang" == Wolfgang Denk <[EMAIL PROTECTED]> writes:
Hi,
>> Exactly, hence my other patch (tools/mkimage: ignore trailing
>> garbage) to only error out if the size is smaller than the size
>> defined in the header.
Wolfgang> This doesn't make sense to me. If we have a way to check
Dear Peter Korsgaard,
In message <[EMAIL PROTECTED]> you wrote:
> Use lseek rather than fstat for file size for list mode, so
> mkimage -l /dev/mtdblockN works (stat returns st_size == 0 for devices).
>
> Notice that you have to use /dev/mtdblockN and not /dev/mtdN, as the
> latter doesn't suppor
Dear Peter Korsgaard,
In message <[EMAIL PROTECTED]> you wrote:
> Ignore trailing data after the uimage data and only complain if the
> file is too small.
>
> (E.G. if the uImage was stored in flash and hence padded to the flash
> sector size).
I reject this patch. The length checking of the ima
Dear Peter Korsgaard,
In message <[EMAIL PROTECTED]> you wrote:
>
> Wolfgang> Later, you should get data checksum errors because of the
> Wolfgang> incorrect lenght, i. e. a ``ERROR: "" has
> Wolfgang> corrupted data!'' error message.
>
> Exactly, hence my other patch (tools/mkimage: ignore
Dear hank.peng <[EMAIL PROTECTED]>,
repl: bad addresses:
hank.peng <[EMAIL PROTECTED]> -- no at-sign after local-part (<)
Please fix the mail address you provide in your headers as return
address. Either get rid of the dot, or add quotes.
In message <[EMAIL PROTECTED]> you wrote:
>
> I a
Dear Diptopal Basu,
In message <[EMAIL PROTECTED]> you wrote:
>
> As suggested I migrated to Fedora 9 . However in the site all examples are
> with power PC as reference . I am downloading the arm iso image
> arm-2008-11-24.iso and intend to use it to compile U boot . There is no
> definition fo
Dear Pink Boy,
In message <[EMAIL PROTECTED]> you wrote:
>
> So still doing some hacking trying to build this and wondering if
> either u-boot-1.3.4 is busted, or the instructions are wrong.
v1.3.4 is old. Why don't you use current code?
> Note sure it it works or not. When I run it I get the
Use lseek rather than fstat for file size for list mode, so
mkimage -l /dev/mtdblockN works (stat returns st_size == 0 for devices).
Notice that you have to use /dev/mtdblockN and not /dev/mtdN, as the
latter doesn't support mmap.
Signed-off-by: Peter Korsgaard <[EMAIL PROTECTED]>
---
tools/mkim
Ignore trailing data after the uimage data and only complain if the
file is too small.
(E.G. if the uImage was stored in flash and hence padded to the flash
sector size).
Signed-off-by: Peter Korsgaard <[EMAIL PROTECTED]>
---
tools/mkimage.c |9 -
1 files changed, 8 insertions(+), 1
Hi,
I have tried modifying the Start.s of uboot as mentioned below.
When I try to link I get an error "`.bootpg' can't be allocated in
segment 1".
Can someone guide me on this. I am also attaching the start.o and the
linker script that I am using along with this mail.
When I see the dump of star
¶ÌÐÅȺ·¢ÎªÆóÒµ´øÀ´±ä¸ï
¡¾1¡¿
¹ã¸æÐû´«¡£Õë¶ÔÄ¿±ê¿Í»§Ò»¶ÔÒ»½øÐÐÐû´«£¬Èÿͻ§µÄÿһ·ÖÇ®¶¼»¨ÔÚÓÐÓõĵط½£¬´ó´ó½ÚÔ¼ÁËÐû´«³É±¾µÄÀË·Ñ¡£
a ²»¿É»Ø±ÜÐÔ - Ä¿±êÎÞÑ¡ÔñÐԵı»ÆȽÓÊÜÐÅÏ¢
b Õë¶ÔÐÔ - Ìض¨µÄÄ¿±êȺÌ壬ÌرðÊǸßÏû·ÑȺÌå
c ΨһÐÔ - Õë¶Ô¿Í»§µ¥Ò»½éÉܲúÆ·£¬»Ø±ÜÆäËûͬÐÐÒµ²úÆ·µÄ¸ÉÈÅ
d DZ·üÐÔ - Ä
50 matches
Mail list logo