> On 2 Jul 2015, at 00:07, Simon J. Gerraty wrote:
>
> Mark Murray wrote:
>> * src/sys/dev/random/random_adaptors.c src/sys/dev/random/random_adaptors.h
>> - Remove; plugability is no longer used. Compile-time algorithm
>>selection is the way to go.
>
> Errr we use that and need it.
> Pl
Author: araujo (ports committer)
Date: Tue Aug 4 07:04:36 2015
New Revision: 286279
URL: https://svnweb.freebsd.org/changeset/base/286279
Log:
Get it closes to style(9).
Staticization usage() and printit().
Fix the usage of err(3).
Reviewed by: bde
Modified:
head/usr.bin/ypcat/ypca
On Mon, Aug 03, 2015 at 08:54:51PM +0300, Andriy Gapon wrote:
> On 03/08/2015 19:27, Edward Tomasz Napierala wrote:
> > New Revision: 286234
> > URL: https://svnweb.freebsd.org/changeset/base/286234
> >
> > Log:
> > Fix a problem which made loader(8) load non-kld files twice.
>
> What was the p
Author: trasz
Date: Tue Aug 4 08:16:18 2015
New Revision: 286280
URL: https://svnweb.freebsd.org/changeset/base/286280
Log:
Revert r286236; vgonel() is a static function.
Sponsored by: The FreeBSD Foundation
Modified:
head/share/man/man9/Makefile
head/share/man/man9/vgone.9
Modified:
On 0803T1352, Benjamin Kaduk wrote:
> On Mon, Aug 3, 2015 at 12:30 PM, Edward Tomasz Napierala
> wrote:
>
> > Author: trasz
> > Date: Mon Aug 3 16:30:47 2015
> > New Revision: 286236
> > URL: https://svnweb.freebsd.org/changeset/base/286236
> >
> > Log:
> > Document vgonel(9).
> >
>
> Er, isn
On 03/08/2015 21:48, Warner Losh wrote:
On Aug 3, 2015, at 1:44 PM, Slawa Olhovchenkov wrote:
On Tue, Aug 04, 2015 at 03:35:50AM +0800, Julian Elischer wrote:
On 8/3/15 8:03 PM, Konstantin Belousov wrote:
On Mon, Aug 03, 2015 at 12:50:19PM +0100, Steven Hartland wrote:
For this change I d
Author: trasz
Date: Tue Aug 4 08:51:56 2015
New Revision: 286281
URL: https://svnweb.freebsd.org/changeset/base/286281
Log:
Mark vgonel() as static. It was already declared static earlier;
no idea why compilers don't warn about this.
MFC after:1 month
Sponsored by: The FreeBSD Fou
On 0804T0724, Konstantin Belousov wrote:
> On Tue, Aug 04, 2015 at 07:16:50AM +0300, Konstantin Belousov wrote:
> > On Mon, Aug 03, 2015 at 01:52:46PM -0400, Benjamin Kaduk wrote:
> > > On Mon, Aug 3, 2015 at 12:30 PM, Edward Tomasz Napierala
> > >
> > > wrote:
> > >
> > > > Author: trasz
> > >
2015-08-04 10:51 GMT+02:00 Edward Tomasz Napierala :
> Mark vgonel() as static. It was already declared static earlier;
> no idea why compilers don't warn about this.
That's because according to the standard, those keywords are meant to pile up:
static void foo(void);
_Noreturn void foo(void
On Tue, Aug 04, 2015 at 10:56:45AM +0200, Edward Tomasz Napierala wrote:
> Would be nice if clang warned about this case. No idea why it doesn't.
Because it is valid standard C. Qualifiers are required for declaration,
and are optional for definition.
_
Author: hselasky
Date: Tue Aug 4 09:45:10 2015
New Revision: 286282
URL: https://svnweb.freebsd.org/changeset/base/286282
Log:
Avoid calling into the random subsystem before it is initialized.
Sponsored by: Mellanox Technologies
Modified:
head/sys/ofed/drivers/net/mlx4/en_tx.c
Modified
Hi Bruce,
2015-08-02 7:35 GMT+02:00 Bruce Evans :
> This function shouldn't be deprecated. It is a kernel wrapper with a
> good name for hiding the implementation detail or not-yet standard
> interface _Static_assert().
_Static_assert has been part of the C standard for approximately 4 years now
On 7/2/15, Konstantin Belousov wrote:
> Author: kib
> Date: Thu Jul 2 14:37:21 2015
> New Revision: 285041
> URL: https://svnweb.freebsd.org/changeset/base/285041
>
> Log:
> Use single instance of the identical INKERNEL() and PMC_IN_KERNEL()
> macros on amd64 and i386. Move the definition to
On 7/2/15, Konstantin Belousov wrote:
> Author: kib
> Date: Thu Jul 2 15:22:13 2015
> New Revision: 285046
> URL: https://svnweb.freebsd.org/changeset/base/285046
>
> Log:
> Account for the main process stack being one page below the highest
> user address when ABI uses shared page.
>
> Not
Author: trasz
Date: Tue Aug 4 10:40:08 2015
New Revision: 286283
URL: https://svnweb.freebsd.org/changeset/base/286283
Log:
Fix panic triggered by code like this:
open("/dev/md0", O_EXEC);
Discussed with: kib@, mav@
MFC after:1 month
Sponsored by: The FreeBSD Foundation
On 08/04/15 12:03, Ed Schouten wrote:
Hi Bruce,
2015-08-02 7:35 GMT+02:00 Bruce Evans:
>This function shouldn't be deprecated. It is a kernel wrapper with a
>good name for hiding the implementation detail or not-yet standard
>interface _Static_assert().
_Static_assert has been part of the C s
2015-08-04 12:48 GMT+02:00 Hans Petter Selasky :
> Once C-compilers finally decide to compile time support queues, we should
> throw queue.3 aswell?
If the API provided by the C standard would be functionally identical
and easy to emulate with older compilers (which is the case for
_Static_assert
On Tue, 4 Aug 2015, Ed Schouten wrote:
2015-08-04 10:51 GMT+02:00 Edward Tomasz Napierala :
Mark vgonel() as static. It was already declared static earlier;
no idea why compilers don't warn about this.
That's because according to the standard, those keywords are meant to pile up:
static
another thing that seems broken now is that -q no longer stopps errors
when deleting non existant rules.
root@vps1:~ # ipfw -q delete 4000
ipfw: rule 4000 not found
root@vps1:~ # echo $?
69
root@vps1:
___
svn-src-head@freebsd.org mailing list
http://l
On Tue, 4 Aug 2015, Ed Schouten wrote:
Hi Bruce,
2015-08-02 7:35 GMT+02:00 Bruce Evans :
This function shouldn't be deprecated. It is a kernel wrapper with a
good name for hiding the implementation detail or not-yet standard
interface _Static_assert().
_Static_assert has been part of the C
Author: kib
Date: Tue Aug 4 12:33:51 2015
New Revision: 286284
URL: https://svnweb.freebsd.org/changeset/base/286284
Log:
Copy the fencing of the algorithm to do lock-less update and reading
of the timehands, from the kern_tc.c implementation to vdso. Add
comments giving hints where to loo
Author: gjb
Date: Tue Aug 4 13:40:26 2015
New Revision: 286285
URL: https://svnweb.freebsd.org/changeset/base/286285
Log:
Ensure the local MANIFEST is always used when verifying remote
distribution sets.
MFC after:immediately
Sponsored by: The FreeBSD Foundation
Modified:
head/u
Author: kib
Date: Tue Aug 4 13:50:52 2015
New Revision: 286288
URL: https://svnweb.freebsd.org/changeset/base/286288
Log:
Give large kernel stack to the initial thread . Otherwise, ZFS
overflows the stack during root mount in some configurations.
Tested by:Fabian Keil (previous ver
This effects other platforms arm and mips spring to mind from when I
last checked.
Would you like me to backout the checks I added to the ZFS module once
all the platforms are addressed?
Regards
Steve
On 04/08/2015 14:50, Konstantin Belousov wrote:
Author: kib
Date: Tue Aug 4 13:50
On 0803T2054, Andriy Gapon wrote:
> On 03/08/2015 19:27, Edward Tomasz Napierala wrote:
> > Author: trasz
> > Date: Mon Aug 3 16:27:36 2015
> > New Revision: 286234
> > URL: https://svnweb.freebsd.org/changeset/base/286234
> >
> > Log:
> > Fix a problem which made loader(8) load non-kld files t
Author: allanjude
Date: Tue Aug 4 14:27:25 2015
New Revision: 286289
URL: https://svnweb.freebsd.org/changeset/base/286289
Log:
xargs now takes -P0, creating as many concurrent processes as possible
PR: 199976
Submitted by: Nikolai Lifanov
Reviewed by: mjg, bjk
Approved b
Author: kevlo
Date: Tue Aug 4 15:04:28 2015
New Revision: 286290
URL: https://svnweb.freebsd.org/changeset/base/286290
Log:
Add support for Planex GW-NS300N.
Modified:
head/share/man/man4/ral.4
Modified: head/share/man/man4/ral.4
=
On Tue, Aug 04, 2015 at 03:00:59PM +0100, Steven Hartland wrote:
> This effects other platforms arm and mips spring to mind from when I
> last checked.
>
> Would you like me to backout the checks I added to the ZFS module once
> all the platforms are addressed?
I stated my opinion in a review f
On Tue, Aug 04, 2015 at 09:30:30AM +0100, Steven Hartland wrote:
>
>
> On 03/08/2015 21:48, Warner Losh wrote:
> >> On Aug 3, 2015, at 1:44 PM, Slawa Olhovchenkov wrote:
> >>
> >> On Tue, Aug 04, 2015 at 03:35:50AM +0800, Julian Elischer wrote:
> >>
> >>> On 8/3/15 8:03 PM, Konstantin Belousov
Hans Petter Selasky wrote this message on Tue, Aug 04, 2015 at 12:48 +0200:
> My gut feeling is it's good practice to have those wrapper macros
> because they isolate the compiler into a consistent and coherent API.
Except that we now have a consistent and coherent API w/
_Static_assert... We e
Author: jmg
Date: Tue Aug 4 17:47:11 2015
New Revision: 286292
URL: https://svnweb.freebsd.org/changeset/base/286292
Log:
Make IPsec work with AES-GCM and AES-ICM (aka CTR) in OCF... IPsec
defines the keys differently than NIST does, so we have to muck with
key lengths and nonce/IVs to be
On 08/04/15 01:12, Bruce Evans wrote:
On Tue, 4 Aug 2015, Pedro F. Giffuni wrote:
Log:
Revert r286144 leaving the original fix to the buffer overflow.
Some developers consider the new code unnecessarily obfuscated.
There was also a benign off-by-one.
Discussed with:bde, vangyzen, jm
2015-07-31 8:21 GMT+02:00 Bruce Evans :
> For gcc before 4.6,
> the ifdef reduces to using __COUNTER__ as the second variable if
> __COUNTER__ is supported, else nothing. So for the undocumented
> subset of compilers that support __COUNTER__ all cases work, and
> for the complementary subset no ca
> On Aug 4, 2015, at 12:19 PM, Ed Schouten wrote:
>
> 2015-07-31 8:21 GMT+02:00 Bruce Evans :
>> For gcc before 4.6,
>> the ifdef reduces to using __COUNTER__ as the second variable if
>> __COUNTER__ is supported, else nothing. So for the undocumented
>> subset of compilers that support __COUNT
2015-08-04 20:23 GMT+02:00 Warner Losh :
> There’s at least one compiler in common use that warns about
>
> extern int fred[1];
> extern int fred[1];
>
> being a repeated declaration (despite being legal C).
Would you happen to know which one that is?
--
Ed Schouten
Nuxi, 's-Hertogenbosch, the
Author: jkim
Date: Tue Aug 4 18:59:54 2015
New Revision: 286293
URL: https://svnweb.freebsd.org/changeset/base/286293
Log:
Fix style(9) bugs.
Modified:
head/sys/x86/include/_types.h
Modified: head/sys/x86/include/_types.h
=
Author: rpaulo
Date: Tue Aug 4 19:04:02 2015
New Revision: 286294
URL: https://svnweb.freebsd.org/changeset/base/286294
Log:
BEAGLEBONE: remove dtrace from MODULES_EXTRA.
This config is already building all modules, so we don't need the
MODULES_EXTRA definition. It was also causing prob
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256
On 08/04/2015 01:04, Bruce Evans wrote:
> On Tue, 4 Aug 2015, Konstantin Belousov wrote:
>
>> On Tue, Aug 04, 2015 at 12:11:40AM +, Jung-uk Kim wrote:
>>> Log: Always define __va_list for amd64 and restore pre-r232261
>>> behavior for i386. Note
> On Aug 4, 2015, at 1:04 PM, Rui Paulo wrote:
>
> Author: rpaulo
> Date: Tue Aug 4 19:04:02 2015
> New Revision: 286294
> URL: https://svnweb.freebsd.org/changeset/base/286294
>
> Log:
> BEAGLEBONE: remove dtrace from MODULES_EXTRA.
>
> This config is already building all modules, so we do
Author: jah
Date: Tue Aug 4 19:46:13 2015
New Revision: 286296
URL: https://svnweb.freebsd.org/changeset/base/286296
Log:
Add two new pmap functions:
vm_offset_t pmap_quick_enter_page(vm_page_t m)
void pmap_quick_remove_page(vm_offset_t kva)
These will create and destroy a temporary, C
On 04/08/2015 17:14, Slawa Olhovchenkov wrote:
On Tue, Aug 04, 2015 at 09:30:30AM +0100, Steven Hartland wrote:
On 03/08/2015 21:48, Warner Losh wrote:
On Aug 3, 2015, at 1:44 PM, Slawa Olhovchenkov wrote:
On Tue, Aug 04, 2015 at 03:35:50AM +0800, Julian Elischer wrote:
On 8/3/15 8:03 P
On Tue, Aug 04, 2015 at 09:06:55PM +0100, Steven Hartland wrote:
>
>
> On 04/08/2015 17:14, Slawa Olhovchenkov wrote:
> > On Tue, Aug 04, 2015 at 09:30:30AM +0100, Steven Hartland wrote:
> >
> >>
> >> On 03/08/2015 21:48, Warner Losh wrote:
> On Aug 3, 2015, at 1:44 PM, Slawa Olhovchenkov
> On 04 Aug 2015, at 17:47 , John-Mark Gurney wrote:
>
> Author: jmg
> Date: Tue Aug 4 17:47:11 2015
> New Revision: 286292
> URL: https://svnweb.freebsd.org/changeset/base/286292
>
> Log:
> .. . ..
>
> Reviewed by: gnn
>
This should have been 6-8 commits; dissecting what is what even if
> On 04 Aug 2015, at 19:46 , Jason A. Harmening wrote:
>
> Author: jah
> Date: Tue Aug 4 19:46:13 2015
> New Revision: 286296
> URL: https://svnweb.freebsd.org/changeset/base/286296
>
> Log:
> Add two new pmap functions:
> vm_offset_t pmap_quick_enter_page(vm_page_t m)
> void pmap_quick_rem
On 08/04/15 18:22, Bjoern A. Zeeb wrote:
>
>> On 04 Aug 2015, at 19:46 , Jason A. Harmening wrote:
>>
>> Author: jah
>> Date: Tue Aug 4 19:46:13 2015
>> New Revision: 286296
>> URL: https://svnweb.freebsd.org/changeset/base/286296
>>
>> Log:
>> Add two new pmap functions:
>> vm_offset_t pmap
Author: jhibbits
Date: Wed Aug 5 01:52:11 2015
New Revision: 286298
URL: https://svnweb.freebsd.org/changeset/base/286298
Log:
Remove some unnecessary includes.
Modified:
head/sys/dev/nand/nfc_rb.c
Modified: head/sys/dev/nand/nfc_rb.c
Author: jhibbits
Date: Wed Aug 5 01:52:52 2015
New Revision: 286299
URL: https://svnweb.freebsd.org/changeset/base/286299
Log:
Remove one more that crept in unnecessarily from previous commit.
Modified:
head/sys/dev/nand/nfc_rb.c
Modified: head/sys/dev/nand/nfc_rb.c
Author: ngie
Date: Wed Aug 5 03:03:57 2015
New Revision: 286303
URL: https://svnweb.freebsd.org/changeset/base/286303
Log:
Update the comment about handling old-style rc(5) scripts
The old-style (*.sh) scripts in /etc/rc.d are explicitly ignored, whereas
other scripts ending in .sh are p
Author: ngie
Date: Wed Aug 5 03:17:06 2015
New Revision: 286304
URL: https://svnweb.freebsd.org/changeset/base/286304
Log:
Set f_file to -1/F_UNUSED when after closing when possible
This will help ensure we don't trash file descriptors that get used later on
in the daemon
Found via
On Tue, 4 Aug 2015, Ed Schouten wrote:
2015-08-04 20:23 GMT+02:00 Warner Losh :
There???s at least one compiler in common use that warns about
extern int fred[1];
extern int fred[1];
being a repeated declaration (despite being legal C).
Would you happen to know which one that is?
All non-
On Tue, Aug 04, 2015 at 03:04:58PM -0400, Jung-uk Kim wrote:
> Done. I was not really interested in API compatibility. FYI, "Figure
> 3.34: va_list Type Declaration" defines the structure like this:
>
> typedef struct {
> unsigned int gp_offset;
> unsigned int f
On Tue, 4 Aug 2015, Jung-uk Kim wrote:
Log:
Fix style(9) bugs.
Thanks.
Modified:
head/sys/x86/include/_types.h
Modified: head/sys/x86/include/_types.h
==
--- head/sys/x86/include/_types.h Tue Aug 4 17:47:11
52 matches
Mail list logo