On 08/04/15 12:03, Ed Schouten wrote:
Hi Bruce,
2015-08-02 7:35 GMT+02:00 Bruce Evans<b...@optusnet.com.au>:
>This function shouldn't be deprecated. It is a kernel wrapper with a
>good name for hiding the implementation detail or not-yet standard
>interface _Static_assert().
_Static_assert has been part of the C standard for approximately 4 years now.
I personally couldn't care less about the naming, but in a couple of
years from now we'll have an entire generation of recently graduated
computer scientists who know what _Static_assert does, because they
used it in their C/C++ programming classes. None of them know what a
'CTASSERT' is.
Hi,
Is it correct to assume that everyone doing programming has done a
programming class of a certain kind?
My gut feeling is it's good practice to have those wrapper macros
because they isolate the compiler into a consistent and coherent API.
Wouldn't the argument be the same for queue.3 . Once C-compilers finally
decide to compile time support queues, we should throw queue.3 aswell?
I'd say it is better to stay independent of what the compiler guys will
come up with next, reminding me how hard it was to upgrade a machine
recently from 9- to 10- because of C++11 ....
--HPS
_______________________________________________
svn-src-head@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-src-head
To unsubscribe, send any mail to "svn-src-head-unsubscr...@freebsd.org"