Author: kmacy
Date: Sat Nov 22 08:05:05 2008
New Revision: 185165
URL: http://svn.freebsd.org/changeset/base/185165
Log:
- enable multiple transmit queues
- invert sense of hw.cxgb.singleq tunable to hw.cxgb.multiq
- don't wake up transmitting thread by default
- add per tx queue ifaltq to
Author: kmacy
Date: Sat Nov 22 08:46:16 2008
New Revision: 185166
URL: http://svn.freebsd.org/changeset/base/185166
Log:
Add flowid to mbuf to allow drivers to uniquely
identify connection flows to guarantee ordering
across queues
Modified:
head/sys/sys/mbuf.h
Modified: head/sys/sys/mbuf
On Sat, Nov 22, 2008 at 05:55:56AM +, Kip Macy wrote:
> Author: kmacy
> Date: Sat Nov 22 05:55:56 2008
> New Revision: 185162
> URL: http://svn.freebsd.org/changeset/base/185162
>
> Log:
> - bump __FreeBSD version to reflect added buf_ring, memory barriers,
> and ifnet functions
>
>
Author: jkoshy
Date: Sat Nov 22 12:34:49 2008
New Revision: 185168
URL: http://svn.freebsd.org/changeset/base/185168
Log:
Unbreak LINT.
Modified:
head/sys/dev/hwpmc/hwpmc_arm.c
head/sys/dev/hwpmc/hwpmc_ia64.c
head/sys/dev/hwpmc/hwpmc_powerpc.c
head/sys/dev/hwpmc/hwpmc_sparc64.c
Modifie
Author: kib
Date: Sat Nov 22 12:36:15 2008
New Revision: 185169
URL: http://svn.freebsd.org/changeset/base/185169
Log:
Add sv_flags field to struct sysentvec with intention to provide description
of the ABI of the currently executing image. Change some places to test
the flags instead of exp
Author: kib
Date: Sat Nov 22 13:11:11 2008
New Revision: 185170
URL: http://svn.freebsd.org/changeset/base/185170
Log:
Busy ufs filesystem around block of code that does ".." lookup. Since
mnt_lock is before lock of any vnode on the mp, it uses LK_NOWAIT. Since
MNTK_UNMOUNT may be transient,
Author: pjd
Date: Sat Nov 22 13:22:24 2008
New Revision: 185171
URL: http://svn.freebsd.org/changeset/base/185171
Log:
IFp4: Don't free pathname too soon, debugging code is still using it.
Modified:
head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/spa_config.c
Modified: head/sys/cddl/cont
Author: pjd
Date: Sat Nov 22 13:24:44 2008
New Revision: 185172
URL: http://svn.freebsd.org/changeset/base/185172
Log:
IFp4: Finish implemnetation of chflags(2) for ZFS. While doing this I found
that zfs_access() can only handle VREAD, VWRITE and VEXEC, for the rest we
need
to use vaccess(9
Author: pjd
Date: Sat Nov 22 13:27:15 2008
New Revision: 185173
URL: http://svn.freebsd.org/changeset/base/185173
Log:
IFp4: Regression tests for FreeBSD/ZFS chflags(2)/lchflags(2).
Modified:
head/tools/regression/fstest/tests/chflags/00.t
head/tools/regression/fstest/tests/chflags/01.t
h
Author: pjd
Date: Sat Nov 22 13:33:06 2008
New Revision: 185174
URL: http://svn.freebsd.org/changeset/base/185174
Log:
IFp4: Don't rely on disk IDs and always use vdev guids, which means always
look
up for components by reading metadata. This might be slower when there are big
number of dis
Author: dfr
Date: Sat Nov 22 14:24:55 2008
New Revision: 185175
URL: http://svn.freebsd.org/changeset/base/185175
Log:
Fix amd64 build and re-enable gptzfsboot.
Modified:
head/sys/boot/i386/Makefile
head/sys/boot/i386/gptzfsboot/Makefile
head/sys/boot/zfs/Makefile
Modified: head/sys/boot
> Joseph Koshy <[EMAIL PROTECTED]> writes:
> > Modified: head/sys/dev/hwpmc/hwpmc_mod.c
> > ==
> > --- head/sys/dev/hwpmc/hwpmc_mod.c Sat Nov 15 11:07:54 2008
> > (r184993)
> > +++ head/sys/dev/hwpmc/hwpmc_mod.c
Author: mav
Date: Sat Nov 22 14:48:40 2008
New Revision: 185176
URL: http://svn.freebsd.org/changeset/base/185176
Log:
Change check order to avoid array overrun.
Found with: Coverity Prevent(tm)
CID: 2497
Modified:
head/sys/dev/sound/pci/hda/hdac.c
Modified: head/sys/dev/so
Author: mav
Date: Sat Nov 22 15:35:21 2008
New Revision: 185177
URL: http://svn.freebsd.org/changeset/base/185177
Log:
Handle device_get_children() errors in more correct way.
We shouldn't detach until all children are surely destroyed.
Found with: Coverity Prevent(tm)
CID:
Author: mav
Date: Sat Nov 22 15:38:24 2008
New Revision: 185178
URL: http://svn.freebsd.org/changeset/base/185178
Log:
Whitespace cleanup for previous commit.
Modified:
head/sys/dev/sound/pci/hda/hdac.c
Modified: head/sys/dev/sound/pci/hda/hdac.c
=
Author: mav
Date: Sat Nov 22 16:03:18 2008
New Revision: 185179
URL: http://svn.freebsd.org/changeset/base/185179
Log:
Remove unneeded NULL check. At first msg can't be null here and and at second
NG_FREE_MSG() also checks it.
Found with: Coverity Prevent(tm)
Modified:
head/sys/netgr
Author: mav
Date: Sat Nov 22 16:40:12 2008
New Revision: 185182
URL: http://svn.freebsd.org/changeset/base/185182
Log:
Fix typo. Clear session stats instead of config and part of stats.
Found with: Coverity Prevent(tm)
CID: 2472
Modified:
head/sys/netgraph/ng_l2tp.c
Modifie
Author: mav
Date: Sat Nov 22 16:55:55 2008
New Revision: 185183
URL: http://svn.freebsd.org/changeset/base/185183
Log:
Remove unused variable.
Found with: Coverity Prevent(tm)
CID:3682
Modified:
head/sys/netgraph/ng_socket.c
Modified: head/sys/netgraph/ng_socket.c
Author: marcel
Date: Sat Nov 22 17:54:30 2008
New Revision: 185184
URL: http://svn.freebsd.org/changeset/base/185184
Log:
MFC 184734:
Fix a panic caused by a corrupted table when the header is
still valid.
PR: 119868
Approved by: re (kib)
Modified:
stable/7/sys/ (props
On Wed, Nov 19, 2008 at 12:58:52AM -0800, Alfred Perlstein wrote:
> Cool, thank you, sorry I've been slow to pick up these deltas.
>
> I think we may be at a point where we can take some more of
> those changes you have.
>
> Can you resend them? I think you had two deltas?
I have updated them n
Author: kib
Date: Sat Nov 22 21:08:25 2008
New Revision: 185185
URL: http://svn.freebsd.org/changeset/base/185185
Log:
MFC r184860 (by obrien):
Add the kerberos5 libs to the install32 target.
Approved by: re (kensmith)
Modified:
stable/7/Makefile.inc1 (contents, props changed)
Modi
Author: thompsa
Date: Sat Nov 22 21:12:47 2008
New Revision: 185186
URL: http://svn.freebsd.org/changeset/base/185186
Log:
Allow multiple makeoption lines to be used with the += operator, this permits
the following syntax in the kernel config.
makeoptions MODULES_OVERRIDE=foo
makeopti
Author: marcel
Date: Sat Nov 22 21:22:53 2008
New Revision: 185187
URL: http://svn.freebsd.org/changeset/base/185187
Log:
Cast to uintptr_t before casting to void*. This allows the
QUICC backend to be built on LP64 platforms. This makes it
possible to include the QUICC backend in the kernel
Author: marcel
Date: Sat Nov 22 21:24:07 2008
New Revision: 185188
URL: http://svn.freebsd.org/changeset/base/185188
Log:
Include the QUICC backend in the kernel module.
PR: 127120
Modified:
head/sys/modules/uart/Makefile
Modified: head/sys/modules/uart/Makefile
==
This was a concern of mine - note that many driver writers assume they exist.
Thoughts on efficiently handling it via checking cpuid at runtime?
Alternatively we could have it be conditional on CPU_i786.
On 11/22/08, Kostik Belousov <[EMAIL PROTECTED]> wrote:
> On Sat, Nov 22, 2008 at 05:55:56AM
A neat hack would be for the kernel linker to scan the text and do a
drop-in replacement of the opcode that is appropriate for the platform.
I can't see how a CPU_XXX definition would work because it's just a
compile time construct, one that can be included with any kernel
compile.
Scott
[EMAIL
On 11/22/08, Scott Long <[EMAIL PROTECTED]> wrote:
> A neat hack would be for the kernel linker to scan the text and do a
> drop-in replacement of the opcode that is appropriate for the platform.
Yup, Linux does that for a number of things wasn't sure we want to go
down that road.
> I can't see h
Author: marcel
Date: Sat Nov 22 22:15:34 2008
New Revision: 185189
URL: http://svn.freebsd.org/changeset/base/185189
Log:
Unbreak previous commit.
Modified:
head/sys/powerpc/include/atomic.h
Modified: head/sys/powerpc/include/atomic.h
=
On Sat, Nov 22, 2008 at 03:05:22PM -0700, Scott Long wrote:
> A neat hack would be for the kernel linker to scan the text and do a
> drop-in replacement of the opcode that is appropriate for the platform.
> I can't see how a CPU_XXX definition would work because it's just a
> compile time construct
Kostik Belousov wrote:
On Sat, Nov 22, 2008 at 03:05:22PM -0700, Scott Long wrote:
A neat hack would be for the kernel linker to scan the text and do a
drop-in replacement of the opcode that is appropriate for the platform.
I can't see how a CPU_XXX definition would work because it's just a
comp
Author: sam
Date: Sat Nov 22 23:48:33 2008
New Revision: 185190
URL: http://svn.freebsd.org/changeset/base/185190
Log:
change private mbuf flags to use M_PROTO* so they don't conflict with public
definitions; note this constitutes an ABI change so drivers that use M_TXCB
or M_FF must be reco
Author: kmacy
Date: Sun Nov 23 00:13:25 2008
New Revision: 185191
URL: http://svn.freebsd.org/changeset/base/185191
Log:
intr_machdep.h breaks build on some arches and is not needed
Modified:
head/sys/dev/cxgb/cxgb_main.c
Modified: head/sys/dev/cxgb/cxgb_main.c
==
Author: delphij
Date: Sun Nov 23 00:16:10 2008
New Revision: 185192
URL: http://svn.freebsd.org/changeset/base/185192
Log:
MFC r185038,185044,185046:
Automatically pad gptboot, style for include files,
use humanize_number() for consistency and reduce
code duplication.
Approved by:
Author: kmacy
Date: Sun Nov 23 00:20:51 2008
New Revision: 185193
URL: http://svn.freebsd.org/changeset/base/185193
Log:
buf_ring_peek should return NULL if the ring is empty rather than
whatever happened to be at cons_tail last time it was in use
Modified:
head/sys/sys/buf_ring.h
Modified
Author: kmacy
Date: Sun Nov 23 00:22:52 2008
New Revision: 185194
URL: http://svn.freebsd.org/changeset/base/185194
Log:
work around periodic leak on queue overrun by enabling coalescing of packets
in to
work requests by default
Modified:
head/sys/dev/cxgb/cxgb_multiq.c
Modified: head/sys
On Sat, Nov 22, 2008 at 11:08 PM, Scott Long <[EMAIL PROTECTED]> wrote:
> Kostik Belousov wrote:
>>
>> On Sat, Nov 22, 2008 at 03:05:22PM -0700, Scott Long wrote:
>>>
>>> A neat hack would be for the kernel linker to scan the text and do a
>>> drop-in replacement of the opcode that is appropriate f
Author: sam
Date: Sun Nov 23 01:51:14 2008
New Revision: 185197
URL: http://svn.freebsd.org/changeset/base/185197
Log:
correct sorting
Modified:
head/sys/net80211/ieee80211_var.h
Modified: head/sys/net80211/ieee80211_var.h
=
Author: kmacy
Date: Sun Nov 23 07:30:07 2008
New Revision: 185199
URL: http://svn.freebsd.org/changeset/base/185199
Log:
Add backward compatibility ifdefs for non-multiq kernels
Modified:
head/sys/dev/cxgb/cxgb_config.h
head/sys/dev/cxgb/cxgb_main.c
head/sys/dev/cxgb/cxgb_osdep.h
Modifie
38 matches
Mail list logo