On Tue, 2018-01-16 at 12:28 +, Frediano Ziglio wrote:
> Signed-off-by: Frediano Ziglio
> ---
> server/stream-device.c | 154
> ++---
> 1 file changed, 147 insertions(+), 7 deletions(-)
>
> diff --git a/server/stream-device.c b/server/stream-device.
Create an AgentRunner (TODO: needs a better name) class to encapsulate
the streaming and communication with the server. The basic setup (cmd
arg parsing, signal handling, ...) is moved to main.cpp. The rest of the
functions is moved to the AgentRunner class and modified as little as
possible:
- The
>
> On Thu, 2018-02-08 at 16:21 +, Frediano Ziglio wrote:
> > As discussed about style the usage or "using namespace" should be
> > avoided.
> >
> > Signed-off-by: Frediano Ziglio
> > ---
> > src/concrete-agent.cpp| 11 +--
> > src/mjpeg-fallback.cpp| 3 +--
> > src
On Thu, 2018-02-08 at 16:21 +, Frediano Ziglio wrote:
> As discussed about style the usage or "using namespace" should be
> avoided.
>
> Signed-off-by: Frediano Ziglio
> ---
> src/concrete-agent.cpp| 11 +--
> src/mjpeg-fallback.cpp| 3 +--
> src/spice-streaming-agen
As discussed about style the usage or "using namespace" should be
avoided.
Signed-off-by: Frediano Ziglio
---
src/concrete-agent.cpp| 11 +--
src/mjpeg-fallback.cpp| 3 +--
src/spice-streaming-agent.cpp | 5 ++---
3 files changed, 8 insertions(+), 11 deletions(-)
diff
Create an AgentRunner (TODO: needs a better name) class to encapsulate
the streaming and communication with the server. The basic setup (cmd
arg parsing, signal handling, ...) is moved to main.cpp. The rest of the
functions is moved to the AgentRunner class and modified as little as
possible:
- The
Hello,
as previously discussed, I've attempted to separate out the agent code
into a class (temporarily called AgentRunner, see the commit message for
details).
The patch is cleaned up and working, it could only use a better naming
for the class and then to rename the source files accordingly. Th
On Thu, 2018-02-08 at 15:33 +0100, Christophe de Dinechin wrote:
> > On 8 Feb 2018, at 14:53, Lukáš Hrázký wrote:
> >
> > On Wed, 2018-02-07 at 10:10 +0100, Christophe de Dinechin wrote:
> > > Frediano Ziglio writes:
> > >
> > > > These style are used by other SPICE projects like spice-streaming
>
> > On 8 Feb 2018, at 15:16, Lukáš Hrázký wrote:
> >
> > On Thu, 2018-02-08 at 14:03 +, Frediano Ziglio wrote:
> >> This style is used by other SPICE projects like spice-streaming-agent.
> >> See discussion "Coding style and naming conventions for C++" at
> >> https://lists.freedesktop.org
> On 8 Feb 2018, at 14:53, Lukáš Hrázký wrote:
>
> On Wed, 2018-02-07 at 10:10 +0100, Christophe de Dinechin wrote:
>> Frediano Ziglio writes:
>>
>>> These style are used by other SPICE projects like spice-streaming-agent.
>
> "This style is used ..."
>
>>> See discussion "Coding style and n
> On 8 Feb 2018, at 15:16, Lukáš Hrázký wrote:
>
> On Thu, 2018-02-08 at 14:03 +, Frediano Ziglio wrote:
>> This style is used by other SPICE projects like spice-streaming-agent.
>> See discussion "Coding style and naming conventions for C++" at
>> https://lists.freedesktop.org/archives/spi
On Thu, 2018-02-08 at 14:00 +, Frediano Ziglio wrote:
> Discussed recently on the mailing list.
> This patch changes the namespace name only.
> See discussion "Coding style and naming conventions for C++" at
> https://lists.freedesktop.org/archives/spice-devel/2018-January/041562.html.
>
> Sig
On Thu, 2018-02-08 at 14:03 +, Frediano Ziglio wrote:
> This style is used by other SPICE projects like spice-streaming-agent.
> See discussion "Coding style and naming conventions for C++" at
> https://lists.freedesktop.org/archives/spice-devel/2018-January/041562.html.
>
> Signed-off-by: Fre
This style is used by other SPICE projects like spice-streaming-agent.
See discussion "Coding style and naming conventions for C++" at
https://lists.freedesktop.org/archives/spice-devel/2018-January/041562.html.
Signed-off-by: Frediano Ziglio
---
docs/spice_style.txt | 52 +++
Discussed recently on the mailing list.
This patch changes the namespace name only.
See discussion "Coding style and naming conventions for C++" at
https://lists.freedesktop.org/archives/spice-devel/2018-January/041562.html.
Signed-off-by: Frediano Ziglio
---
include/spice-streaming-agent/frame-
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
.clang-format | 23 +++
1 file changed, 23 insertions(+)
create mode 100644 .clang-format
diff --git a/.clang-format b/.clang-format
new file mode 100644
index ..91203600
--- /dev/null
+++ b/.cl
On Wed, 2018-02-07 at 10:10 +0100, Christophe de Dinechin wrote:
> Frediano Ziglio writes:
>
> > These style are used by other SPICE projects like spice-streaming-agent.
"This style is used ..."
> > See discussion "Coding style and naming conventions for C++" at
> > https://lists.freedesktop.org
>
> From: Marc-André Lureau
>
> spice:// has a weird scheme encoding, where it can accept both plain
> and tls ports with URI query parameters. However, it's not very
> convenient nor very common to use (who really want to mix plain & tls
> channels?).
>
> Instead, let's introduce the more read
>
> From: Marc-André Lureau
>
> For some reason, the URIs test didn't include spice+unix:// checks,
> probably because they came about the same time.
>
> Signed-off-by: Marc-André Lureau
> ---
> tests/session.c | 28 +---
> 1 file changed, 25 insertions(+), 3 deletions
ping
more than 2 years old now
>
> These patches try to add interface to support flush interface.
> This interface could help improving bandwidth usage reducing bytes
> sent through network.
> The TCP_CORK is one possible usage of the library which actually
> decrease bandwidth (not using SSL) b
ping
almost 6 months old now
>
> These patches was already posted (second was also acked) however first
> one was not complete. Updated reusing some new fields more coherently.
>
> Frediano Ziglio (2):
> stream-device: handle cursor from device
> stream-device: Implement mouse movement
>
>
From: Marc-André Lureau
Hi,
Here are a few patches related to spice schemes URI handling. They
introduce a spice+tls:// form (see related man page update and patch
for details).
cheers
Marc-André Lureau (4):
tests: add spice+unix:// URI checks
uri: learn to parse spice+tls:// form
uri: g
From: Marc-André Lureau
They couldn't not be introduced before, because the test needs both
parsing and generation.
Signed-off-by: Marc-André Lureau
---
tests/session.c | 14 ++
1 file changed, 14 insertions(+)
diff --git a/tests/session.c b/tests/session.c
index fc874fc..ae2a22c
From: Marc-André Lureau
For some reason, the URIs test didn't include spice+unix:// checks,
probably because they came about the same time.
Signed-off-by: Marc-André Lureau
---
tests/session.c | 28 +---
1 file changed, 25 insertions(+), 3 deletions(-)
diff --git a/tes
From: Marc-André Lureau
spice:// has a weird scheme encoding, where it can accept both plain
and tls ports with URI query parameters. However, it's not very
convenient nor very common to use (who really want to mix plain & tls
channels?).
Instead, let's introduce the more readable form spice+tls
From: Marc-André Lureau
Signed-off-by: Marc-André Lureau
---
src/spice-session.c | 31 +++
tests/session.c | 20 ++--
2 files changed, 33 insertions(+), 18 deletions(-)
diff --git a/src/spice-session.c b/src/spice-session.c
index 7218449..b2517e6
> On 8 Feb 2018, at 09:48, Frediano Ziglio wrote:
>
>>
>> From: Christophe de Dinechin
>>
>> The indent of the rephrasing is that:
>>
>> - If you have a single constant, use const, e.g. (visible in debugger)
>>const unsigned max_stuff = 42;
>>
>> - If you have multiple constants, prefe
> On 8 Feb 2018, at 09:50, Frediano Ziglio wrote:
>
>>
>> From: Christophe de Dinechin
>>
>> Signed-off-by: Christophe de Dinechin
>> ---
>> docs/spice_style.txt | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/docs/spice_style.txt b/docs/spice_style.txt
>> index
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 20
1 file changed, 20 insertions(+)
diff --git a/docs/spice_style.txt b/docs/spice_style.txt
index f5d13642..10bfbc9a 100644
--- a/docs/spice_style.txt
+++ b/docs/spice_style.txt
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 19 +++
1 file changed, 19 insertions(+)
diff --git a/docs/spice_style.txt b/docs/spice_style.txt
index eb2ee252..ae91f987 100644
--- a/docs/spice_style.txt
+++ b/docs/spice_style.txt
From: Christophe de Dinechin
Changes in v3:
- Integrated clarification regarding headers
- Added external references as a starting point
- Changed [source,h] annotations (unsure if that's accepted)
- Changed brace placement from Allman to Linux in .clang-format
Changes in v2:
- This splits the
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 15 ---
1 file changed, 12 insertions(+), 3 deletions(-)
diff --git a/docs/spice_style.txt b/docs/spice_style.txt
index 13032df6..eef4880f 100644
--- a/docs/spice_style.txt
+++ b/docs/spic
From: Christophe de Dinechin
As written, the headers style guide looks quite wrong. In particular,
it places headers in an order that makes it hard to detect hidden
dependencies in SPICE headers.
These rules can be enforced by the .clang-format proposed in earlier patch,
locally if you use the E
From: Christophe de Dinechin
The sentence explaining that example makes no real sense, and
the coding style suggestion is horrendous (not to mention flies in the
face of all automatic indentation tools)
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 10 +-
1 file chan
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 11 ++-
1 file changed, 10 insertions(+), 1 deletion(-)
diff --git a/docs/spice_style.txt b/docs/spice_style.txt
index 10bfbc9a..13032df6 100644
--- a/docs/spice_style.txt
+++ b/docs/spice_sty
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 5 +
1 file changed, 5 insertions(+)
diff --git a/docs/spice_style.txt b/docs/spice_style.txt
index 68dbeeef..eb2ee252 100644
--- a/docs/spice_style.txt
+++ b/docs/spice_style.txt
@@ -128,6 +128,1
From: Christophe de Dinechin
The objective of these guidelines is that:
- We avoid introducing new warnings
- We know how to fix old ones
- We don't have to isolate whitespace changes when submitting patches,
i.e. someone who use tools that automatically strip whitespaces and
therefore "repai
From: Christophe de Dinechin
The indent of the rephrasing is that:
- If you have a single constant, use const, e.g. (visible in debugger)
const unsigned max_stuff = 42;
- If you have multiple constants, prefer enums over #define, as
already suggested later in the guide:
enum {
From: Christophe de Dinechin
Signed-off-by: Christophe de Dinechin
---
docs/spice_style.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/docs/spice_style.txt b/docs/spice_style.txt
index b92b5b00..486efbc9 100644
--- a/docs/spice_style.txt
+++ b/docs/spice_style.txt
@@ -1
> On 8 Feb 2018, at 10:04, Frediano Ziglio wrote:
>
>>
>> From: Christophe de Dinechin
>>
>> Signed-off-by: Christophe de Dinechin
>> ---
>> .clang-format | 23 +++
>> 1 file changed, 23 insertions(+)
>> create mode 100644 .clang-format
>>
>> diff --git a/.clang-format b
> On 8 Feb 2018, at 10:35, Frediano Ziglio wrote:
>
>>
>> From: Christophe de Dinechin
>>
>> Signed-off-by: Christophe de Dinechin
>> ---
>> docs/spice_style.txt | 6 +-
>> 1 file changed, 5 insertions(+), 1 deletion(-)
>>
>> diff --git a/docs/spice_style.txt b/docs/spice_style.txt
>> i
Hi,
On Thu, Feb 08, 2018 at 11:14:02AM +0100, Christophe de Dinechin wrote:
> > Because the code itself is inconsistent. It would be so much
> > better to have a few patches that make the code consistent and
> > then some git hook to check if given patch does not mess around
> > the coding style i
On Thu, 2018-02-08 at 11:09 +0100, Victor Toso wrote:
> Hi,
>
> On Thu, Feb 08, 2018 at 05:01:05AM -0500, Frediano Ziglio wrote:
> > > > Depends on many cases. You don't want spurious changes to make harder to
> > > > look at the history for instance (that is a point for Nack).
> > > > The patch i
> On 8 Feb 2018, at 11:09, Victor Toso wrote:
>
> Hi,
>
> On Thu, Feb 08, 2018 at 05:01:05AM -0500, Frediano Ziglio wrote:
Depends on many cases. You don't want spurious changes to make harder to
look at the history for instance (that is a point for Nack).
The patch is not fixin
> On 8 Feb 2018, at 11:01, Frediano Ziglio wrote:
>
>>>
>>> On 8 Feb 2018, at 10:52, Frediano Ziglio wrote:
>>>
On Thu, 2018-02-08 at 10:21 +0100, Victor Toso wrote:
> Hey,
>
> On Thu, Feb 08, 2018 at 10:13:21AM +0100, Lukáš Hrázký wrote:
>> On Thu, 2018-02-08 at
> On 8 Feb 2018, at 10:02, Frediano Ziglio wrote:
>
>>
>> From: Christophe de Dinechin
>>
>> The objective of these guidelines is that:
>> - We avoid introducing new warnings
>> - We know how to fix old ones
>> - We don't have to isolate whitespace changes when submitting patches,
>> i.e. s
Hi,
On Thu, Feb 08, 2018 at 05:01:05AM -0500, Frediano Ziglio wrote:
> > > Depends on many cases. You don't want spurious changes to make harder to
> > > look at the history for instance (that is a point for Nack).
> > > The patch is not fixing anything or adding new feature (another for Nack).
>
>
> > On 8 Feb 2018, at 10:52, Frediano Ziglio wrote:
> >
> >>
> >> On Thu, 2018-02-08 at 10:21 +0100, Victor Toso wrote:
> >>> Hey,
> >>>
> >>> On Thu, Feb 08, 2018 at 10:13:21AM +0100, Lukáš Hrázký wrote:
> On Thu, 2018-02-08 at 04:02 -0500, Frediano Ziglio wrote:
> >>
> >> Fro
> On 8 Feb 2018, at 10:52, Frediano Ziglio wrote:
>
>>
>> On Thu, 2018-02-08 at 10:21 +0100, Victor Toso wrote:
>>> Hey,
>>>
>>> On Thu, Feb 08, 2018 at 10:13:21AM +0100, Lukáš Hrázký wrote:
On Thu, 2018-02-08 at 04:02 -0500, Frediano Ziglio wrote:
>>
>> From: Christophe de Dine
>
> On Thu, 2018-02-08 at 10:21 +0100, Victor Toso wrote:
> > Hey,
> >
> > On Thu, Feb 08, 2018 at 10:13:21AM +0100, Lukáš Hrázký wrote:
> > > On Thu, 2018-02-08 at 04:02 -0500, Frediano Ziglio wrote:
> > > > >
> > > > > From: Christophe de Dinechin
> > > > >
> > > > > The objective of these g
>
> From: Christophe de Dinechin
>
> Signed-off-by: Christophe de Dinechin
> ---
> docs/spice_style.txt | 6 +-
> 1 file changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/docs/spice_style.txt b/docs/spice_style.txt
> index 72ed2ef7..61cb0701 100644
> --- a/docs/spice_style.txt
> ++
On Thu, 2018-02-08 at 10:21 +0100, Victor Toso wrote:
> Hey,
>
> On Thu, Feb 08, 2018 at 10:13:21AM +0100, Lukáš Hrázký wrote:
> > On Thu, 2018-02-08 at 04:02 -0500, Frediano Ziglio wrote:
> > > >
> > > > From: Christophe de Dinechin
> > > >
> > > > The objective of these guidelines is that:
>
Hey,
On Thu, Feb 08, 2018 at 10:13:21AM +0100, Lukáš Hrázký wrote:
> On Thu, 2018-02-08 at 04:02 -0500, Frediano Ziglio wrote:
> > >
> > > From: Christophe de Dinechin
> > >
> > > The objective of these guidelines is that:
> > > - We avoid introducing new warnings
> > > - We know how to fix old
On Wed, 2018-02-07 at 12:07 +0100, Christophe de Dinechin wrote:
> From: Christophe de Dinechin
>
> Signed-off-by: Christophe de Dinechin
> ---
> docs/spice_style.txt | 6 +-
> 1 file changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/docs/spice_style.txt b/docs/spice_style.txt
> ind
On Thu, 2018-02-08 at 04:02 -0500, Frediano Ziglio wrote:
> >
> > From: Christophe de Dinechin
> >
> > The objective of these guidelines is that:
> > - We avoid introducing new warnings
> > - We know how to fix old ones
> > - We don't have to isolate whitespace changes when submitting patches,
>
>
> From: Christophe de Dinechin
>
> Signed-off-by: Christophe de Dinechin
> ---
> .clang-format | 23 +++
> 1 file changed, 23 insertions(+)
> create mode 100644 .clang-format
>
> diff --git a/.clang-format b/.clang-format
> new file mode 100644
> index ..339ce84
>
> From: Christophe de Dinechin
>
> The objective of these guidelines is that:
> - We avoid introducing new warnings
> - We know how to fix old ones
> - We don't have to isolate whitespace changes when submitting patches,
> i.e. someone who use tools that automatically strip whitespaces and
>
>
> From: Christophe de Dinechin
>
> Signed-off-by: Christophe de Dinechin
> ---
> docs/spice_style.txt | 15 +++
> 1 file changed, 15 insertions(+)
>
> diff --git a/docs/spice_style.txt b/docs/spice_style.txt
> index 780f0615..e2465aa9 100644
> --- a/docs/spice_style.txt
> +++ b/
>
> From: Christophe de Dinechin
>
> The sentence explaining that example makes no real sense, and
> the coding style suggestion is horrendous (not to mention flies in the
> face of all automatic indentation tools)
>
> Signed-off-by: Christophe de Dinechin
> ---
> docs/spice_style.txt | 10 +-
>
> From: Christophe de Dinechin
>
> Signed-off-by: Christophe de Dinechin
> ---
> docs/spice_style.txt | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/docs/spice_style.txt b/docs/spice_style.txt
> index 3e463d2f..74f4e29d 100644
> --- a/docs/spice_style.txt
> +++ b/d
>
> From: Christophe de Dinechin
>
> The indent of the rephrasing is that:
>
> - If you have a single constant, use const, e.g. (visible in debugger)
> const unsigned max_stuff = 42;
>
> - If you have multiple constants, prefer enums over #define, as
> already suggested later in the gu
>
> From: Christophe de Dinechin
>
> Signed-off-by: Christophe de Dinechin
> ---
> docs/spice_style.txt | 11 ++-
> 1 file changed, 10 insertions(+), 1 deletion(-)
>
> diff --git a/docs/spice_style.txt b/docs/spice_style.txt
> index c127f026..72ed2ef7 100644
> --- a/docs/spice_style.t
>
> From: Christophe de Dinechin
>
> Signed-off-by: Christophe de Dinechin
> ---
> docs/spice_style.txt | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/docs/spice_style.txt b/docs/spice_style.txt
> index eb0e30ef..c127f026 100644
> --- a/docs/spice_style.txt
> +++ b/d
63 matches
Mail list logo