On 10/30/2015 07:24 AM, j...@eyeos.com wrote:
>> Wow! That is astonishing, and well done, congratulations.
>>
>>
>> I've played with it a bit; I had some issues with keyboard problems, and
>> it wasn't immediately obvious how to use passwords or ssl. Of course, I
>> suspect those are issues that
We do this by auto detecting the inbound http(s) 'GET' and probing
for a well formulated WebSocket binary connection, such as used
by the spice-html5 client. If detected, we implement a set of
cover functions that abstract the read/write/writev functions,
in a fashion similar to the SASL implement
>
> On Thu, Oct 29, 2015 at 03:57:46PM -0400, Frediano Ziglio wrote:
> >
> > >
> > > From: Marc-André Lureau
> > >
> > > ---
> > > server/Makefile.am | 1 +
> > > server/display-channel.c | 38 +++
> > > server/display-channel.h | 52
> > >
>
> On Fri, 2015-10-30 at 13:23 -0400, Frediano Ziglio wrote:
> > >
> > > On Thu, Oct 29, 2015 at 04:24:27PM -0400, Frediano Ziglio wrote:
> > > > >
> > > > > From: Marc-André Lureau
> > > > >
> > > > > There is no guarantee in the code that this can't be hit, so we
> > > > > should
> > > > >
>
> From: Marc-André Lureau
>
> Signed-off-by: Jonathon Jongsma
> ---
>
> Changes since v1:
> - added back removed red_channel_is_connected() checks
> - switch from (RedChannel*) cast to using &cursor->common.base
> - use local 'channel' variable throughout red_channel_reset()
>
>
> ser
On Fri, 2015-10-30 at 14:39 +0100, Christophe Fergeau wrote:
> Hey,
>
> On Thu, Oct 29, 2015 at 04:54:40PM -0500, Jonathon Jongsma wrote:
> > From: Marc-André Lureau
> >
> > The specific item type that was not being handled was
> > PIPE_ITEM_TYPE_INVAL_ONE (#102). This item type is used by the
>
On Fri, 2015-10-30 at 13:23 -0400, Frediano Ziglio wrote:
> >
> > On Thu, Oct 29, 2015 at 04:24:27PM -0400, Frediano Ziglio wrote:
> > > >
> > > > From: Marc-André Lureau
> > > >
> > > > There is no guarantee in the code that this can't be hit, so we
> > > > should
> > > > cope with it (the con
>
> On Thu, Oct 29, 2015 at 04:24:27PM -0400, Frediano Ziglio wrote:
> > >
> > > From: Marc-André Lureau
> > >
> > > There is no guarantee in the code that this can't be hit, so we should
> > > cope with it (the condition can be reached easily by running the server
> > > without waiting for bl
>
> From: Marc-André Lureau
>
> Rename and lightly refactor the function that creates new common
> channels for RedWorker (essentially Cursor and Display channels).
>
> Signed-off-by: Jonathon Jongsma
> ---
>
> Changes since v1:
> - rename variable from 'cursor' to 'cursor_channel'
>
>
>
From: Marc-André Lureau
Signed-off-by: Jonathon Jongsma
---
Changes since v1:
- added back removed red_channel_is_connected() checks
- switch from (RedChannel*) cast to using &cursor->common.base
- use local 'channel' variable throughout red_channel_reset()
server/cursor-channel.c | 35 ++
>
> From: Marc-André Lureau
>
> The first argument should be CursorChannel* rather than RedChannel*
> since it's essentially a CursorChannel method.
>
> Signed-off-by: Jonathon Jongsma
> ---
>
> Changes since v1:
> - use parameter name cursor_channel instead of cursor
>
>
> server/cursor
ACK
On Fri, 2015-10-30 at 16:55 +0100, Christophe Fergeau wrote:
> SPICE_CHECK_SMARTCARD documentation ends with a '---' comment,
> but
> the # to start the comment is missing, causing a warning message when
> running configure.
> ---
> m4/spice-deps.m4 | 2 +-
> 1 file changed, 1 insertion(+
On Fri, 2015-10-30 at 12:21 -0400, Marc-André Lureau wrote:
> Hi
>
> - Original Message -
> > > > @@ -446,10 +446,11 @@ void
> > > > cursor_channel_process_cmd(CursorChannel
> > > > *cursor,
> > > > RedCursorCmd *cursor_cmd,
> > > > return;
> > > > }
> > > >
> > > > -if
This one looks good to me.
Some
#define COMMON_CHANNEL_CLIENT(Client) ((CommonChannelClient*)(Client))
macro which we might want to change for now to
#define COMMON_CHANNEL_CLIENT(Client) ((Client)->base))
and ditto for
#define CURSOR_CHANNEL_CLIENT(Client) ((CursorChannelClient*)(Client))
Chr
On Thu, Oct 29, 2015 at 04:24:27PM -0400, Frediano Ziglio wrote:
> >
> > From: Marc-André Lureau
> >
> > There is no guarantee in the code that this can't be hit, so we should
> > cope with it (the condition can be reached easily by running the server
> > without waiting for blocked clients or p
Hi
- Original Message -
> > > @@ -446,10 +446,11 @@ void cursor_channel_process_cmd(CursorChannel
> > > *cursor,
> > > RedCursorCmd *cursor_cmd,
> > > return;
> > > }
> > >
> > > -if (red_channel_is_connected(&cursor->common.base) &&
> > > (cursor->mouse_mode == SPICE_M
On Fri, 2015-10-30 at 03:39 -0400, Frediano Ziglio wrote:
> >
> > From: Marc-André Lureau
> >
> > Signed-off-by: Jonathon Jongsma
> > ---
> > server/cursor-channel.c | 30 +-
> > server/red_worker.c | 7 ---
> > 2 files changed, 21 insertions(+), 16 deletio
From: Marc-André Lureau
Rename and lightly refactor the function that creates new common
channels for RedWorker (essentially Cursor and Display channels).
Signed-off-by: Jonathon Jongsma
---
Changes since v1:
- rename variable from 'cursor' to 'cursor_channel'
server/cursor-channel.c | 31
From: Marc-André Lureau
The first argument should be CursorChannel* rather than RedChannel*
since it's essentially a CursorChannel method.
Signed-off-by: Jonathon Jongsma
---
Changes since v1:
- use parameter name cursor_channel instead of cursor
server/cursor-channel.c | 4 +++-
server/cu
On Fri, 2015-10-30 at 03:24 -0400, Frediano Ziglio wrote:
> >
> > From: Marc-André Lureau
> >
> > Doing so allows us to remove the extra QXLInstance parameter from
> > cursor_item_unref() and makes the code a bit cleaner.
> >
> > Also add cursor_item_ref().
> >
> > Signed-off-by: Jonathon Jong
SPICE_CHECK_SMARTCARD documentation ends with a '---' comment, but
the # to start the comment is missing, causing a warning message when
running configure.
---
m4/spice-deps.m4 | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/m4/spice-deps.m4 b/m4/spice-deps.m4
index 59744d2
On Fri, Oct 30, 2015 at 11:45:44AM +0100, Francois Gouget wrote:
> Signed-off-by: Francois Gouget
> ---
> configure.ac | 15 ---
> 1 file changed, 4 insertions(+), 11 deletions(-)
>
> This brings it more in line with the spice-gtk notice.
>
> This is also a test of the email threadi
On Fri, Oct 30, 2015 at 04:45:20PM +0100, Christophe Fergeau wrote:
> Hey,
>
> This looks good, but I was wondering whether this is being copied/pasted
> from some other configure.ac/m4 file, or if this is the initial
> implementation?
> We'll need to readd the AS_VAR_APPEND fallback which was rem
This fixes a bug where Xspice had to listen on two ports, even in an
SSL only configuration.
Signed-off-by: Jeremy White
---
examples/spiceqxl.xorg.conf.example | 1 +
src/spiceqxl_spice_server.c | 1 -
2 files changed, 1 insertion(+), 1 deletion(-)
diff --git a/examples/spiceqxl.xorg.c
Hey,
This looks good, but I was wondering whether this is being copied/pasted
from some other configure.ac/m4 file, or if this is the initial
implementation?
We'll need to readd the AS_VAR_APPEND fallback which was removed in
f7ec855af3d , otherwise looks fine
Christophe
On Fri, Oct 30, 2015 at
ACK, this was made obsolete when dropping glib < 2.28 support.
On Fri, Oct 30, 2015 at 11:45:57AM +0100, Francois Gouget wrote:
> Signed-off-by: Francois Gouget
> ---
> configure.ac | 4
> 1 file changed, 4 deletions(-)
>
> diff --git a/configure.ac b/configure.ac
> index 5790a37..7033cbb
On Wed, Oct 21, 2015 at 03:27:02PM +0200, Francois Gouget wrote:
> On Wed, 21 Oct 2015, Christophe Fergeau wrote:
>
> > ACK.
> >
> > Since the changes up to now are useful cleanups regardless of the
> > addition of gstreamer, I suggest we land the patches up to this one
> > right now, hopefully t
Hi,
On Fri, Oct 23, 2015 at 03:37:47PM +0200, Hans de Goede wrote:
> Ack, I believe the usbredir patch is ready, feel free to push that
> with my suggested doc change, then do a follow up patch to bump
> the version in usbredirproto.h and configure.ac to 0.7.1 and
> update the Changelog file with
Hi,
On Fri, Oct 23, 2015 at 03:28:52PM +0200, Hans de Goede wrote:
> Hi,
> applications *pending writes* buffer size (in bytes).
>
> (so add the pending writes, drop the "that are ... isoc data", since the
> application
> is not aware which data is isoc data and which is not.
>
> Otherwise looks
On Mon, Oct 26, 2015 at 09:06:03PM +0100, Francois Gouget wrote:
> On Thu, 22 Oct 2015, Christophe Fergeau wrote:
>
> > On Wed, Oct 14, 2015 at 05:32:03PM +0200, Francois Gouget wrote:
> > > The Spice server administrator can specify the preferred encoder and
> > > codec preferences to optimize fo
On Thu, Oct 29, 2015 at 03:57:46PM -0400, Frediano Ziglio wrote:
>
> >
> > From: Marc-André Lureau
> >
> > ---
> > server/Makefile.am | 1 +
> > server/display-channel.c | 38 +++
> > server/display-channel.h | 52
> >
Hey,
On Thu, Oct 29, 2015 at 04:54:40PM -0500, Jonathon Jongsma wrote:
> From: Marc-André Lureau
>
> The specific item type that was not being handled was
> PIPE_ITEM_TYPE_INVAL_ONE (#102). This item type is used by the cursor
> channel, but the analogous item for the display channel is
> PIPE_I
On Fri, Oct 30, 2015 at 01:24:36PM +0100, j...@eyeos.com wrote:
>
> > I note the attribution clause in your license. As it stands now, I
> > don't think that would cause any trouble (because of the 'however' of 5
> > (d) of the agpl). But it would probably be useful to get a clear
> > expression
Hi
- Original Message -
> Wow! That is astonishing, and well done, congratulations.
I second this, big thanks :)
> More or less. We have developed a eyeos-agent (like spice-agent) that uses
> rabbitmq and through this we send coordinates and positions of remote
> windows. Depending on th
> Wow! That is astonishing, and well done, congratulations.
>
> I've played with it a bit; I had some issues with keyboard problems, and
> it wasn't immediately obvious how to use passwords or ssl. Of course, I
> suspect those are issues that are relatively easy to address.
Keyboard support i
Hello, Jeremy.
I've miss support for SPICE_MSG_DISPLAY_DRAW_ALPHA_BLEND in spice-html5. The
image type that is passed from the server that we've use is a incremental
updates (compressed full-size frame) on top of the surface. Do you have some
roadmap for implementation more SPIDE_MSG_DISPLAY_*
>
> On Fri, Oct 30, 2015 at 03:30:40AM -0400, Frediano Ziglio wrote:
> >
> > >
> > > From: Marc-André Lureau
> > >
> > > Instead of passing a CommonChannel* argument, use CursorChannel* since
> > > this function is only valid for CursorChannels.
> > >
> > > Signed-off-by: Jonathon Jongsma
>
On Fri, Oct 30, 2015 at 03:44:05AM -0400, Frediano Ziglio wrote:
> OT: I don't fully agree with the reasoning. Today compilers are really
> good inlining single used static functions. Putting even some lines in
> small functions can improve readability if function name is well choosed,
> future mai
>
> On Thu, 29 Oct 2015, Frediano Ziglio wrote:
> [...]
> > +/* FIXME: consider g_get_monotonic_time (), but in microseconds */
> > +static inline red_time_t red_get_monotonic_time(void)
> > +{
> > +struct timespec time;
> > +
> > +clock_gettime(CLOCK_MONOTONIC, &time);
> > +return (r
On Fri, Oct 30, 2015 at 03:30:40AM -0400, Frediano Ziglio wrote:
>
> >
> > From: Marc-André Lureau
> >
> > Instead of passing a CommonChannel* argument, use CursorChannel* since
> > this function is only valid for CursorChannels.
> >
> > Signed-off-by: Jonathon Jongsma
> > ---
> > server/cur
>
> On Wed, 21 Oct 2015, Christophe Fergeau wrote:
>
> > ACK.
> >
> > On Wed, Oct 14, 2015 at 05:30:35PM +0200, Francois Gouget wrote:
> > > Signed-off-by: Francois Gouget
> > > ---
> > > server/red_worker.c | 3 +--
> > > 1 file changed, 1 insertion(+), 2 deletions(-)
> > >
> > > diff --git
*data must always be set to NULL on error.
Signed-off-by: Francois Gouget
---
src/channel-display.c | 17 +
1 file changed, 9 insertions(+), 8 deletions(-)
diff --git a/src/channel-display.c b/src/channel-display.c
index 46e9829..9e42dd9 100644
--- a/src/channel-display.c
+++ b/
On Wed, 21 Oct 2015, Christophe Fergeau wrote:
> ACK.
>
> On Wed, Oct 14, 2015 at 05:30:35PM +0200, Francois Gouget wrote:
> > Signed-off-by: Francois Gouget
> > ---
> > server/red_worker.c | 3 +--
> > 1 file changed, 1 insertion(+), 2 deletions(-)
> >
> > diff --git a/server/red_worker.c b/s
>
> On Thu, Oct 29, 2015 at 04:54:39PM -0500, Jonathon Jongsma wrote:
> > From: Marc-André Lureau
> >
> > The first argument should be CursorChannel* rather than RedChannel*
> > since it's essentially a CursorChannel method.
> >
> > Signed-off-by: Jonathon Jongsma
> > ---
> > server/cursor-c
On Thu, 29 Oct 2015, Frediano Ziglio wrote:
[...]
> +/* FIXME: consider g_get_monotonic_time (), but in microseconds */
> +static inline red_time_t red_get_monotonic_time(void)
> +{
> +struct timespec time;
> +
> +clock_gettime(CLOCK_MONOTONIC, &time);
> +return (red_time_t) time.tv_sec
Hi,
[ context for spice folks: patch was added to qemu increasing usb-audio
default buffer size ]
> > What bothers me is that you have no qualms about making latency on
> > everyone's system worse.
>
> How do you know it makes sound on other people's systems worse? If you have
> actually do
Signed-off-by: Francois Gouget
---
configure.ac | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Of course this one depends on 'common 3/5' but not on 'spice 4/5'.
diff --git a/configure.ac b/configure.ac
index 7033cbb..db2891f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -671,6 +
Signed-off-by: Francois Gouget
---
configure.ac | 9 ++---
1 file changed, 2 insertions(+), 7 deletions(-)
diff --git a/configure.ac b/configure.ac
index ad76467..95e35a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,10 +64,9 @@ m4_ifndef([AS_VAR_APPEND],
# Check for the CPU we are us
A call to SPICE_WARNING() anywhere in the configure file results in the
warning being printed at the end of the configure run where it will be
be visible. This makes it possible to keep the SPICE_WARNING() calls
together with the related feature checks instead of having to put a
separate AC_MSG_WAR
Signed-off-by: Francois Gouget
---
configure.ac | 15 ---
1 file changed, 4 insertions(+), 11 deletions(-)
This brings it more in line with the spice-gtk notice.
This is also a test of the email threading.
diff --git a/configure.ac b/configure.ac
index dfb967b..ad76467 100644
---
Signed-off-by: Francois Gouget
---
configure.ac | 4
1 file changed, 4 deletions(-)
diff --git a/configure.ac b/configure.ac
index 5790a37..7033cbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -671,10 +671,6 @@ have_dbus=no
if test "x$enable_dbus" != "xno"; then
AC_DEFINE([USE_GDBUS]
On Thu, Oct 29, 2015 at 04:54:39PM -0500, Jonathon Jongsma wrote:
> From: Marc-André Lureau
>
> The first argument should be CursorChannel* rather than RedChannel*
> since it's essentially a CursorChannel method.
>
> Signed-off-by: Jonathon Jongsma
> ---
> server/cursor-channel.c | 4 +++-
> s
>
> From: Marc-André Lureau
>
> Various changes in RedWorker and CursorChannel related to error and
> warning messages.
>
> Signed-off-by: Jonathon Jongsma
> ---
> server/cursor-channel.c | 28
> server/red_worker.c | 22 ++
> server/red_wo
>
> From: Marc-André Lureau
>
> red_cursor_marshall_inval(), red_migrate_cursor() and
> on_new_cursor_channel() were short functions that were each only called
> from a single location, so there's no need for them to be separate
> functions.
>
> Signed-off-by: Jonathon Jongsma
Acked
OT: I d
>
> From: Marc-André Lureau
>
> Signed-off-by: Jonathon Jongsma
> ---
> server/cursor-channel.c | 30 +-
> server/red_worker.c | 7 ---
> 2 files changed, 21 insertions(+), 16 deletions(-)
>
> diff --git a/server/cursor-channel.c b/server/cursor-channel.c
>
> From: Marc-André Lureau
>
> Move the cursor-specific pipe item types to cursor-channel.h, and the
> display-specific types to red_worker.c. Only leave the common
> definitions in red_worker.h. This prepares for splitting the display
> channel into a separate file.
>
> Signed-off-by: Jonath
>
> From: Marc-André Lureau
>
> Instead of passing a CommonChannel* argument, use CursorChannel* since
> this function is only valid for CursorChannels.
>
> Signed-off-by: Jonathon Jongsma
> ---
> server/cursor-channel.c | 5 ++---
> server/cursor-channel.h | 2 +-
> server/red_worker.c
>
> From: Marc-André Lureau
>
> Rename and lightly refactor the function that creates new common
> channels for RedWorker (essentially Cursor and Display channels).
>
> Signed-off-by: Jonathon Jongsma
> ---
> server/cursor-channel.c | 25 ++---
> server/red_worker.c | 59
>
> From: Marc-André Lureau
>
> Instead of passing a verb enumeration value, pass the verb pipe item
>
> Signed-off-by: Jonathon Jongsma
> ---
> server/cursor-channel.c | 4 ++--
> server/red_worker.c | 4 ++--
> server/red_worker.h | 4 ++--
> 3 files changed, 6 insertions(+), 6 del
>
> From: Marc-André Lureau
>
> Rename and re-order the initial arguments to make this function look and
> act more like a method of the CommonChannel class.
>
> Signed-off-by: Jonathon Jongsma
> ---
> server/cursor-channel.c | 18 +-
> server/red_worker.c | 24 ++
>
> From: Marc-André Lureau
>
> cursor_channel_new() is only called from one location, and always passes
> FALSE as the value for the 'migrate' paramater. In addition, this
> parameter is not used within the function. Remove it.
>
> Signed-off-by: Jonathon Jongsma
> ---
> server/cursor-channe
>
> From: Marc-André Lureau
>
> The first argument should be CursorChannel* rather than RedChannel*
> since it's essentially a CursorChannel method.
>
> Signed-off-by: Jonathon Jongsma
> ---
> server/cursor-channel.c | 4 +++-
> server/cursor-channel.h | 2 +-
> server/red_worker.c | 2 +-
>
> From: Marc-André Lureau
>
> Doing so allows us to remove the extra QXLInstance parameter from
> cursor_item_unref() and makes the code a bit cleaner.
>
> Also add cursor_item_ref().
>
> Signed-off-by: Jonathon Jongsma
> ---
> server/cursor-channel.c | 70
> +++--
63 matches
Mail list logo