Module Name:src
Committed By: rillig
Date: Fri Mar 19 01:02:53 UTC 2021
Modified Files:
src/tests/usr.bin/xlint/lint1: d_c99_init.c d_c99_init.exp
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: replace assertion in initialization with proper error message
To
Module Name:src
Committed By: rillig
Date: Fri Mar 19 00:55:02 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: cgram.y externs1.h init.c
Log Message:
lint: rename push_member and pop_member
These two functions are supposed to model the designator that is used
for initia
Module Name:src
Committed By: simonb
Date: Fri Mar 19 00:44:09 UTC 2021
Modified Files:
src/tests/lib/libc/sys: t_ptrace_signal_wait.h
Log Message:
Sprinkle a few more \n's and the end of some debug printfs.
To generate a diff of this commit:
cvs rdiff -u -r1.4 -r1.5 src
Module Name:src
Committed By: rillig
Date: Fri Mar 19 00:39:17 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: extend documentation about initialization
No functional change.
To generate a diff of this commit:
cvs rdiff -u -r1.101 -r1.102 src
Module Name:src
Committed By: rillig
Date: Fri Mar 19 00:19:32 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: split initstack_pop_item into separate functions
No functional change.
To generate a diff of this commit:
cvs rdiff -u -r1.100 -r1.
Module Name:src
Committed By: rillig
Date: Fri Mar 19 00:08:13 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: improve debug logging in initstack_push
No functional change outside debug mode.
To generate a diff of this commit:
cvs rdiff -u -r
Module Name:src
Committed By: rillig
Date: Thu Mar 18 23:45:20 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: split initstack_push into smaller functions
No functional change.
To generate a diff of this commit:
cvs rdiff -u -r1.98 -r1.99 src
Module Name:src
Committed By: rillig
Date: Thu Mar 18 23:37:31 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: clean up control flow in initstack_push
No functional change.
To generate a diff of this commit:
cvs rdiff -u -r1.97 -r1.98 src/usr
Module Name:src
Committed By: rillig
Date: Thu Mar 18 23:23:40 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: extract extend_if_array_of_unknown_size from initstack_push
No functional change.
To generate a diff of this commit:
cvs rdiff -u -
Module Name:src
Committed By: simonb
Date: Thu Mar 18 23:18:36 UTC 2021
Modified Files:
src/sys/arch/mips/include: ptrace.h
Log Message:
Add PTRACE_ILLEGAL_ASM using the MIPS32r6/MIPS64r6 backwards and
forwards compatible "sigrie" instruction to generate a Reserved
Instruc
Module Name:src
Committed By: rillig
Date: Thu Mar 18 22:51:32 UTC 2021
Modified Files:
src/tests/usr.bin/xlint/lint1: d_c99_init.c
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: replace undefined behavior during initialization with assertion
This only affects
Module Name:src
Committed By: rillig
Date: Thu Mar 18 22:08:05 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: improve debug logging during initialization
No functional change outside debug mode.
To generate a diff of this commit:
cvs rdiff -
Module Name:src
Committed By: rillig
Date: Thu Mar 18 22:05:33 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: tree.c
Log Message:
lint: make the debug log for nodes more readable
The operator NAME has the name 'name', therefore no special case is
needed.
Having the wo
Module Name:src
Committed By: rillig
Date: Thu Mar 18 21:56:35 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: ops.def
Log Message:
lint: rename operator 'const' to 'constant'
The previous name could be too easily confused with the type qualifier
'const'. The operator
Module Name:src
Committed By: rillig
Date: Thu Mar 18 21:26:56 UTC 2021
Modified Files:
src/tests/usr.bin/xlint/lint1: d_c99_init.exp d_struct_init_nested.exp
msg_185.c msg_185.exp
src/usr.bin/xlint/lint1: err.c tree.c
Log Message:
lint: reword message
Module Name:src
Committed By: rillig
Date: Thu Mar 18 21:20:21 UTC 2021
Modified Files:
src/tests/usr.bin/xlint/lint1: msg_185.c msg_185.exp
Log Message:
tests/lint: add test for type mismatch in initialization
Copied and adapted from d_c99_init.c.
To generate a diff of
Module Name:src
Committed By: rillig
Date: Thu Mar 18 20:58:02 UTC 2021
Modified Files:
src/tests/usr.bin/xlint/lint1: d_struct_init_nested.c
Log Message:
tests/lint: warning 210 has type information by now
To generate a diff of this commit:
cvs rdiff -u -r1.4 -r1.5 src/
Module Name:src
Committed By: rillig
Date: Thu Mar 18 20:55:58 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: reduce debug logging for initialization, update documentation
No functional change outside debug mode.
To generate a diff of this c
Module Name:src
Committed By: rillig
Date: Thu Mar 18 20:22:50 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: init.c
Log Message:
lint: document how initialization works, improve debug logging
No functional change outside debug mode.
To generate a diff of this commit
Module Name:src
Committed By: rillig
Date: Thu Mar 18 20:20:55 UTC 2021
Modified Files:
src/tests/usr.bin/xlint/lint1: d_c99_init.c d_c99_init.exp
Log Message:
tests/lint: add more examples for initialization
To generate a diff of this commit:
cvs rdiff -u -r1.6 -r1.7 sr
Module Name:src
Committed By: cheusov
Date: Thu Mar 18 20:02:19 UTC 2021
Modified Files:
src/usr.sbin/mtree: compare.c crc.c extern.h verify.c
Log Message:
mtree: use POSIX type uint32_t instead of u_int32_t
To generate a diff of this commit:
cvs rdiff -u -r1.58 -r1.59 s
Module Name:src
Committed By: cheusov
Date: Thu Mar 18 19:47:41 UTC 2021
Modified Files:
src/usr.bin/join: join.c
Log Message:
join.c: print usage after warning "illegal option..." as it was originally
intended
To generate a diff of this commit:
cvs rdiff -u -r1.32 -r1.
Module Name:src
Committed By: cheusov
Date: Thu Mar 18 19:41:54 UTC 2021
Modified Files:
src/usr.bin/join: join.c
Log Message:
join.c: explicitly convert -1 to u_long in order to fix compiler warnings
To generate a diff of this commit:
cvs rdiff -u -r1.31 -r1.32 src/usr.
Module Name:src
Committed By: cheusov
Date: Thu Mar 18 19:34:05 UTC 2021
Modified Files:
src/usr.bin/ipcs: ipcs.c
Log Message:
ipcs.c: do not #include sys/inttypes.h header which is not necessary
To generate a diff of this commit:
cvs rdiff -u -r1.43 -r1.44 src/usr.bin/i
Module Name:src
Committed By: cheusov
Date: Thu Mar 18 18:24:14 UTC 2021
Modified Files:
src/usr.bin/find: function.c
Log Message:
find: use POSIX strtoll(3) instead of legacy strtoq(3)
To generate a diff of this commit:
cvs rdiff -u -r1.78 -r1.79 src/usr.bin/find/functi
Module Name:src
Committed By: cheusov
Date: Thu Mar 18 18:21:18 UTC 2021
Modified Files:
src/usr.bin/find: find.h function.c
Log Message:
find: use POSIX type uint32_t instead of u_int32_t
To generate a diff of this commit:
cvs rdiff -u -r1.26 -r1.27 src/usr.bin/find/fin
Module Name:src
Committed By: cheusov
Date: Thu Mar 18 18:12:35 UTC 2021
Modified Files:
src/usr.bin/cksum: cksum.c crc.c crc_extern.h extern.h print.c sum1.c
sum2.c
Log Message:
cksum: use POSIX type uint32_t instead of u_int32_t
To generate a diff of this c
Module Name:src
Committed By: rillig
Date: Thu Mar 18 14:58:44 UTC 2021
Modified Files:
src/usr.bin/xlint/lint1: init.c lint1.h
Log Message:
lint: document the initialization of an object in more detail
This will help fixing the bugs that are currently demonstrated in
msg
Module Name:src
Committed By: nia
Date: Thu Mar 18 14:05:38 UTC 2021
Modified Files:
src/sys/kern: subr_time.c
Log Message:
restore flags-as-bitmask, just in case another function is passing its
flags here.
To generate a diff of this commit:
cvs rdiff -u -r1.29 -r1.30 sr
Module Name:src
Committed By: nia
Date: Thu Mar 18 14:01:18 UTC 2021
Modified Files:
src/sys/kern: subr_time.c
Log Message:
ts2timo(9): refactor TIMER_ABSTIME handling
- only use *start for output of the original time.
for clarity purposes, use the temporary variable fo
Module Name:src
Committed By: nia
Date: Thu Mar 18 13:45:15 UTC 2021
Modified Files:
src/sys/kern: subr_time.c
Log Message:
revert previous
To generate a diff of this commit:
cvs rdiff -u -r1.27 -r1.28 src/sys/kern/subr_time.c
Please note that diffs are not public domai
Module Name:src
Committed By: nia
Date: Thu Mar 18 12:37:51 UTC 2021
Modified Files:
src/sys/kern: subr_time.c
Log Message:
ts2timo(9): further deobfuscation.
we want to check against NULL, so use it, rather than some random value on
the stack
To generate a diff of this
Module Name:src
Committed By: nia
Date: Thu Mar 18 11:53:16 UTC 2021
Modified Files:
src/sys/kern: subr_time.c
Log Message:
ts2timo(9): refactor for clarity
- 'flags' is not a boolean...
- actually, it is, but it should simply be named "absolute".
- conver
33 matches
Mail list logo