Module Name: src Committed By: nia Date: Thu Mar 18 11:53:16 UTC 2021
Modified Files: src/sys/kern: subr_time.c Log Message: ts2timo(9): refactor for clarity - 'flags' is not a boolean... - actually, it is, but it should simply be named "absolute". - convert tests for if (flags) to if (flags != TIMER_RELTIME) - hoist function calls out of if expressions (requested by uwe) still needs fixing: - need to check for overflow before timespecsub. To generate a diff of this commit: cvs rdiff -u -r1.25 -r1.26 src/sys/kern/subr_time.c Please note that diffs are not public domain; they are subject to the copyright notices on the relevant files.