On Tue, 31 Oct 2023 00:57:02 GMT, John R Rose wrote:
>> Using a reference here leads to unnecessary overhead when `E` is small and
>> trivially copyable, unless the predicate function is inlined. Pass by value
>> is
>> better in that case. Of course, as noted above, if `E` is "expensive" to copy
> 8315149: Add hsperf counters for CPU time of internal GC threads
Jonathan Joo has updated the pull request incrementally with one additional
commit since the last revision:
Replace NULL with nullptr
-
Changes:
- all: https://git.openjdk.org/jdk/pull/15082/files
- new: https
> 8315149: Add hsperf counters for CPU time of internal GC threads
Jonathan Joo has updated the pull request incrementally with one additional
commit since the last revision:
Implement hsperf counter for G1ServiceThread
-
Changes:
- all: https://git.openjdk.org/jdk/pull/15082/f
On Sun, 29 Oct 2023 07:51:48 GMT, Kim Barrett wrote:
>> @dholmes-ora Yes it helps avoid copying, especially if the copy constructor
>> is non-trivial. And I think it is more idiomatic in C++ to use references
>> here.
>
> Using a reference here leads to unnecessary overhead when `E` is small an
On Thu, 26 Oct 2023 21:01:53 GMT, Jonathan Joo wrote:
>> 8315149: Add hsperf counters for CPU time of internal GC threads
>
> Jonathan Joo has updated the pull request incrementally with one additional
> commit since the last revision:
>
> Remove StringDedup from GC thread list
> Okay, these
On Wed, 18 Oct 2023 07:34:19 GMT, Kimura Yukihiro wrote:
> I would like to fix this issue
> because the test dose not work as intended.
> Could someone please review it?
>
> Thanks,
> Kimura Yukihiro
This pull request has now been integrated.
Changeset: d051f222
Author:Kimura Yukihiro
Co
On Thu, 19 Oct 2023 07:54:47 GMT, Kimura Yukihiro wrote:
>> I would like to fix this issue
>> because the test dose not work as intended.
>> Could someone please review it?
>>
>> Thanks,
>> Kimura Yukihiro
>
> Kimura Yukihiro has updated the pull request incrementally with one
> additional com
On Fri, 27 Oct 2023 14:00:43 GMT, Albert Mingkun Yang wrote:
> Okay, these counters can be accessed frequently, but is it necessary for them
> to provide up-to-date information on every access? If not, what level of
> delay is acceptable? I assume this depends on how often AHS resizes the heap.
On Thu, 19 Oct 2023 07:54:47 GMT, Kimura Yukihiro wrote:
>> I would like to fix this issue
>> because the test dose not work as intended.
>> Could someone please review it?
>>
>> Thanks,
>> Kimura Yukihiro
>
> Kimura Yukihiro has updated the pull request incrementally with one
> additional com
On Mon, 30 Oct 2023 08:46:08 GMT, Taizo Kurashige wrote:
> Hi,
>
> I fixed the typos for JFR.start and JFR.dump.
> Acconding to issue's description, there is some typo in JFR.stop
> documentation, but I couldn't find that. I confirmed that there is no such
> typo in this repository. So I thoug
On Mon, 30 Oct 2023 13:43:33 GMT, Albert Mingkun Yang wrote:
>> Maybe rename `should_retain_evac_failed_region` to
>> `should_keep_retained_region[_in_old]` or something?
>
> Is it possible to drop 1 so that an obj is evac-fail iff it's pinned or OOM?
> (I feel "retain" is on region-level.)
Th
On Mon, 30 Oct 2023 13:46:21 GMT, Albert Mingkun Yang wrote:
>> Apart from having an early return in the `should_compact`-if, one option
>> would be making `has_pinned_objects()` more clever by stating something like:
>>
>>
>> bool has_pinned_objects() const {
>> return pinned_count() >
On Mon, 30 Oct 2023 13:41:02 GMT, Thomas Schatzl wrote:
>> src/hotspot/share/gc/g1/heapRegion.cpp line 734:
>>
>>> 732: // ranges passed in here corresponding to the space between live
>>> objects, it is
>>> 733: // possible that there is a pinned object that is not any more
>>> referenced
> The JEP covers the idea very well, so I'm only covering some implementation
> details here:
>
> * regions get a "pin count" (reference count). As long as it is non-zero, we
> conservatively never reclaim that region even if there is no reference in
> there. JNI code might have references to i
On Mon, 30 Oct 2023 08:46:08 GMT, Taizo Kurashige wrote:
> Hi,
>
> I fixed the typos for JFR.start and JFR.dump.
> Acconding to issue's description, there is some typo in JFR.stop
> documentation, but I couldn't find that. I confirmed that there is no such
> typo in this repository. So I thoug
On Mon, 30 Oct 2023 13:25:07 GMT, Thomas Schatzl wrote:
>> src/hotspot/share/gc/g1/g1EvacFailureRegions.hpp line 36:
>>
>>> 34: class HeapRegionClaimer;
>>> 35:
>>> 36: // This class records for every region on the heap whether it has to be
>>> retained
>>
>> I feel the term "retain" has two
On Sat, 28 Oct 2023 18:32:56 GMT, Albert Mingkun Yang wrote:
>> Thomas Schatzl has updated the pull request incrementally with one
>> additional commit since the last revision:
>>
>> ayang review1
>
> src/hotspot/share/gc/g1/heapRegion.cpp line 734:
>
>> 732: // ranges passed in here corre
> The JEP covers the idea very well, so I'm only covering some implementation
> details here:
>
> * regions get a "pin count" (reference count). As long as it is non-zero, we
> conservatively never reclaim that region even if there is no reference in
> there. JNI code might have references to i
On Fri, 27 Oct 2023 20:53:29 GMT, Albert Mingkun Yang wrote:
>> The JEP covers the idea very well, so I'm only covering some implementation
>> details here:
>>
>> * regions get a "pin count" (reference count). As long as it is non-zero, we
>> conservatively never reclaim that region even if th
On Fri, 27 Oct 2023 20:38:19 GMT, Albert Mingkun Yang wrote:
>> The JEP covers the idea very well, so I'm only covering some implementation
>> details here:
>>
>> * regions get a "pin count" (reference count). As long as it is non-zero, we
>> conservatively never reclaim that region even if th
On Fri, 27 Oct 2023 20:18:24 GMT, Albert Mingkun Yang wrote:
>> The JEP covers the idea very well, so I'm only covering some implementation
>> details here:
>>
>> * regions get a "pin count" (reference count). As long as it is non-zero, we
>> conservatively never reclaim that region even if th
On Mon, 30 Oct 2023 10:32:17 GMT, Thomas Stuefe wrote:
>This code would gain IMHO by being dumbed down
Agreed, seems like it's had a lot of "just one more feature" commits over time.
-
PR Review Comment: https://git.openjdk.org/jdk/pull/16335#discussion_r1376144551
On Thu, 19 Oct 2023 07:54:47 GMT, Kimura Yukihiro wrote:
>> I would like to fix this issue
>> because the test dose not work as intended.
>> Could someone please review it?
>>
>> Thanks,
>> Kimura Yukihiro
>
> Kimura Yukihiro has updated the pull request incrementally with one
> additional com
On Sat, 28 Oct 2023 13:04:05 GMT, Thomas Stuefe wrote:
>> Analysts and supporters often use /proc/xx/maps to make sense of the memory
>> footprint of a process.
>>
>> Interpreting the memory map correctly can help when used as a complement to
>> other tools (e.g. NMT). There even exist tools o
On Mon, 30 Oct 2023 10:13:02 GMT, Johan Sjölen wrote:
>> Thomas Stuefe has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix Windows build
>
> test/hotspot/jtreg/compiler/compilercontrol/commands/MemStatTest.java line 3:
>
>> 1: /*
>> 2:
On Mon, 30 Oct 2023 10:22:06 GMT, Johan Sjölen wrote:
> Ouch, I just realized that we can't differentiate between being provided with
> the literal number 2 and `MemStatAction::print` anymore since you moved the
> literal number parsing into this function. That means that we can't set
> `print
On Mon, 30 Oct 2023 09:55:35 GMT, Johan Sjölen wrote:
>> Thomas Stuefe has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fix Windows build
>
> src/hotspot/share/compiler/compilerOracle.cpp line 654:
>
>> 652: IF_ENUM_STRING("print", {
On Thu, 26 Oct 2023 16:17:14 GMT, Thomas Stuefe wrote:
>> When using 'MemStat' CompileCommand, we accidentally register the command if
>> an invalid suboption had been specified. Fixed, added regression test
>> (verified).
>
> Thomas Stuefe has updated the pull request incrementally with one ad
On Thu, 19 Oct 2023 07:54:47 GMT, Kimura Yukihiro wrote:
>> I would like to fix this issue
>> because the test dose not work as intended.
>> Could someone please review it?
>>
>> Thanks,
>> Kimura Yukihiro
>
> Kimura Yukihiro has updated the pull request incrementally with one
> additional com
On Mon, 30 Oct 2023 09:28:03 GMT, Kimura Yukihiro wrote:
> This project has not yet received a notification from the bot that I can type
> the integrate command. Should I adde a noreg-self label on JBS, or should I
> find one more reviewer?
>
> Thanks, Kimura Yukihiro
You can see this message
On Thu, 19 Oct 2023 07:54:47 GMT, Kimura Yukihiro wrote:
>> I would like to fix this issue
>> because the test dose not work as intended.
>> Could someone please review it?
>>
>> Thanks,
>> Kimura Yukihiro
>
> Kimura Yukihiro has updated the pull request incrementally with one
> additional com
On Tue, 24 Oct 2023 09:56:57 GMT, Thomas Schatzl wrote:
> The JEP covers the idea very well, so I'm only covering some implementation
> details here:
>
> * regions get a "pin count" (reference count). As long as it is non-zero, we
> conservatively never reclaim that region even if there is no
On Fri, 27 Oct 2023 16:22:10 GMT, Chris Plummer wrote:
>> Matthias Baesken has updated the pull request incrementally with one
>> additional commit since the last revision:
>>
>> More info about address lists
>
> src/jdk.jdwp.agent/share/native/libjdwp/debugInit.c line 839:
>
>> 837: "serve
> The allow option of agentlib:jdwp has been introduced a long time ago (see
> JDK-8061228) and is documented here :
> https://docs.oracle.com/en/java/javase/17/docs/specs/jpda/conninv.html#oracle-vm-invocation-options
> However it is still missing in the agentlib:jdwp help output and should be
>
Hi,
I fixed the typos for JFR.start and JFR.dump.
Acconding to issue's description, there is some typo in JFR.stop documentation,
but I couldn't find that. I confirmed that there is no such typo in this
repository. So I thought there was no need to fix JFR.stop documentation.
I confirmed that t
On Thu, 26 Oct 2023 08:55:49 GMT, Thomas Stuefe wrote:
>> Okay I'll butt out. The comment doesn't make sense to me.
>
> @dholmes-ora Sorry if I came across as flippant; that was not my intention.
> If you can stomach it, I rewrote the patch to be hopefully easier to read.
> Thanks.
No I didn't
36 matches
Mail list logo