on a 4-years old x86 laptop I have, I usually just cannot build Atlas
in Sage. It fails, as it's
unable to perform their (in)famous tuning precisely enough.
A replacement for Atlas would be nice, therefore...
On Dec 10, 9:21 am, Bill Hart wrote:
> So I don't know what is considered a fast time
On Dec 10, 10:09 am, William Stein wrote:
> A.H seems arbitrary? Why "H"?
I saw this regularly when reading up on the confusion. When A^H==A
the matrix is Hermitian, so I would *speculate* that this is the
origin of the choice.
Rob
--
To post to this group, send an email to sage-devel@go
Thanks again for the input and excellent background and suggestions.
I've made a small meta-ticket to track progress on this. I'll get
started soon on the first two parts and attach the actual ticket
numbers to the meta-ticket as they get created.
http://trac.sagemath.org/sage_trac/ticket/10465
On Fri, Dec 10, 2010 at 1:18 PM, Simon King wrote:
> Hi Robert,
>
> On 10 Dez., 19:51, Robert Bradshaw
> wrote:
>> As for the more general question, the current state of comparison of
>> elements in Sage is a huge mess, and not much should be read into the
>> current structure. It was written bef
See #10130. I have some more work on that ticket beyond what I posted, but
it's pretty widespread throughout the Sage library. I think the right
approach may be to set up a framework to do the shift gradually, as we
eventually did for coercion.
David
On Fri, Dec 10, 2010 at 16:13, Simon King wr
It shouldn't be slower; the problem is probably the preparser (I made
the same mistake).
http://groups.google.com/group/sage-devel/msg/3aa85064f81becae
On Dec 9, 4:15 pm, G Hahn wrote:
> Hi,
>
> I wrote a function using the sage notebook (not on sagenb.org but a
> local sage build). As the funct
On 12/10/10 4:21 PM, Joris Vankerschaver wrote:
On 10 dec, 13:25, Jason Grout wrote:
3. If you *really* want to use Q like you did above, you could do this:
sage: Q=var('x,y,z')
sage: f(*Q)=(x-z,y-z)
sage: f
(x, y, z) |--> (x - z, y - z)
This is exactly what I need, but thanks also for
On 10 dec, 13:25, Jason Grout wrote:
> 3. If you *really* want to use Q like you did above, you could do this:
>
> sage: Q=var('x,y,z')
> sage: f(*Q)=(x-z,y-z)
> sage: f
> (x, y, z) |--> (x - z, y - z)
>
This is exactly what I need, but thanks also for the explanation of
what goes on behind th
On 12/10/10 2:36 PM, Joris Vankerschaver wrote:
Dear all,
Is there a reason why Sage doesn't allow you to define vector
functions using the following short hand:
sage: Q = var('x, y, z')
sage: f(Q) = [x - z, y - z]
sage: f
Q |--> (x - z, y - z)
I would have expected/liked the last line to be
Hi Robert,
On 10 Dez., 19:51, Robert Bradshaw
wrote:
> As for the more general question, the current state of comparison of
> elements in Sage is a huge mess, and not much should be read into the
> current structure. It was written before cpdef existed and before the
> interaction between __cmp__
Hi Jason,
On 10 Dez., 19:34, Jason Grout wrote:
> I think you misunderstood the post. They *can* be inherited. The point
> is that "according to the Python/C API docs [3], either all of __hash__,
> __cmp__, and __richcmp__ are inherited, or none are. "
>
> In our case, since none of these three
Dear all,
Is there a reason why Sage doesn't allow you to define vector
functions using the following short hand:
sage: Q = var('x, y, z')
sage: f(Q) = [x - z, y - z]
sage: f
Q |--> (x - z, y - z)
I would have expected/liked the last line to be
sage: f
(x, y, z) |--> (x - z, y - z)
This would
On Fri, Dec 10, 2010 at 10:34 AM, Jason Grout
wrote:
> On 12/10/10 10:47 AM, Simon King wrote:
>>
>> Dear Jason,
>>
>> On 10 Dez., 14:55, Jason Grout wrote:
In sage/modules/vector_rational_dense.pyx there is a class definition
Vector_rational_dense. It has a cdef'd method _cmp_c_im
On Dec 10, 10:09 am, William Stein wrote:
> In addition to whatever gets done, it would be a good idea to add a
> method called "conjugate_transpose()".
+1
I was thinking of this as a seque until adjoint broke free, and based
on this discussion I think having adjoint be more general and high-
po
On 12/10/10 12:09 PM, William Stein wrote:
In numpy, the conjugate transpose is A.H, the transpose is A.T, and the
> inverse is A.I. I'd love if we adopted those shortcuts (as properties
A.H seems arbitrary? Why "H"?Consistency with numpy is a good
argument for supporting this though.
On 12/10/10 10:47 AM, Simon King wrote:
Dear Jason,
On 10 Dez., 14:55, Jason Grout wrote:
In sage/modules/vector_rational_dense.pyx there is a class definition
Vector_rational_dense. It has a cdef'd method _cmp_c_impl, which is
supposed to do the comparison.
...
Hence, the comparison method
On Fri, Dec 10, 2010 at 2:45 AM, daveloeffler wrote:
>
>
> On Dec 10, 9:03 am, John Cremona wrote:
>> On Fri, Dec 10, 2010 at 12:03 AM, Rob Beezer wrote:
>> > Thanks, everybody, for the illuminating discussion.
>>
>> > Is there any objection to deprecating the current .adjoint() function
>> > (w
Dear Jason,
On 10 Dez., 14:55, Jason Grout wrote:
> > In sage/modules/vector_rational_dense.pyx there is a class definition
> > Vector_rational_dense. It has a cdef'd method _cmp_c_impl, which is
> > supposed to do the comparison.
> ...
> > Hence, the comparison method is consulted *only* when ca
On 12/10/10 2:33 AM, Simon King wrote:
Hi!
I try to understand how comparison works in cdef'd classes, and
currently it confuses me a lot.
In sage/modules/vector_rational_dense.pyx there is a class definition
Vector_rational_dense. It has a cdef'd method _cmp_c_impl, which is
supposed to do the
I could be interested in attending, deppending on the location and
dates.
On 10 dic, 05:37, William Stein wrote:
> Hi Sage-devel,
>
> If you would be interested in organizing, being involved in,
> attending, getting your friends to attend, etc., a "Sage for Newbies"
> Sage Days, please send me an
On Dec 10, 9:03 am, John Cremona wrote:
> On Fri, Dec 10, 2010 at 12:03 AM, Rob Beezer wrote:
> > Thanks, everybody, for the illuminating discussion.
>
> > Is there any objection to deprecating the current .adjoint() function
> > (which returns a matrix of cofactors) and renaming it as the
> >
On Fri, Dec 10, 2010 at 12:03 AM, Rob Beezer wrote:
> Thanks, everybody, for the illuminating discussion.
>
> Is there any objection to deprecating the current .adjoint() function
> (which returns a matrix of cofactors) and renaming it as the
> "adjugate"? With all the usual procedures and warnin
Hi!
I try to understand how comparison works in cdef'd classes, and
currently it confuses me a lot.
In sage/modules/vector_rational_dense.pyx there is a class definition
Vector_rational_dense. It has a cdef'd method _cmp_c_impl, which is
supposed to do the comparison.
Now, I inserted the line
I'm working on a singular value decomposition demonstration (you may
have seen my dumb questions on sage-support) and I've run into some
problems with matrix_plot and graphics_array. They don't work very well
together:
https://sagenb.kaist.ac.kr:8066/home/pub/22/
Can someone who knows more about
24 matches
Mail list logo