On Thu, 26 Sep 2019 17:27:35 +
"Zhang, Chen" wrote:
> > -Original Message-
> > From: Lukas Straub
> > Sent: Monday, September 16, 2019 3:20 AM
> > To: qemu-devel
> > Cc: Zhang, Chen ; Jason Wang
> > ; Wen Congyang ;
> > Xie Changlong ; kw...@redhat.com;
> > mre...@redhat.com
> > Sub
On Thu, 26 Sep 2019 17:40:03 +
"Zhang, Chen" wrote:
> > -Original Message-
> > From: Lukas Straub
> > Sent: Monday, September 16, 2019 3:20 AM
> > To: qemu-devel
> > Cc: Zhang, Chen ; Jason Wang
> > ; Wen Congyang ;
> > Xie Changlong ; kw...@redhat.com;
> > mre...@redhat.com
> > Sub
On Thu, 26 Sep 2019 17:02:58 +
"Zhang, Chen" wrote:
> > diff --git a/qemu-options.hx b/qemu-options.hx index
> > 08749a3391..23fa5a344e 100644
> > --- a/qemu-options.hx
> > +++ b/qemu-options.hx
> > @@ -4368,7 +4368,7 @@ applications, they can do this through this
> > parameter. Its format is
"Aleksandar Markovic" writes:
> OK, my case belongs to "used to work before" group. I used GMail
> Android app to send this particular mail, and have been using that app
> for several months without problema. I am going to find an alternative
> way of sending mails to the list.
Appreciated!
[..
26.09.2019. 20.14, "Mark Cave-Ayland" је
написао/ла:
>
> As part of the investigation into the DFP number issue reported at
> https://bugs.launchpad.net/qemu/+bug/1841990 it appears that there may
also be a bug
> introduced by the new optimised vsl/vsr implementation:
>
> commit 4e6d0920e7547e6af4
Patchew URL:
https://patchew.org/QEMU/20190927062302.110144-1-ys...@users.sourceforge.jp/
Hi,
This series seems to have some coding style problems. See output below for
more information:
Type: series
Message-id: 20190927062302.110144-1-ys...@users.sourceforge.jp
Subject: [PATCH v25 00/22] Add
I compiled 4.1.0 on the Raspberry, everything seemed to compile.
I have verified with qemu-system-i386 --version displays 4.1.0
Using the below basic command line:
qemu-system-i386 -hda c.hda -cdrom FD12CD.iso -boot order=d
now when I try to execute the qemu I get only below as it just seems to
When we introduced the QAPISchema intermediate representation (commit
ac88219a6c7), we took a shortcut: we left check_exprs() & friends
alone instead of moving semantic checks into the
QAPISchemaFOO.check(). check_exprs() still checks and reports errors,
and the .check() assert check_exprs() did t
From: Michal Privoznik
If a command is disabled an error is reported. But due to usage of
error_setg() the class of the error is GenericError which does not
help callers in distinguishing this case from a case where a qmp
command fails regularly due to other reasons.
We used to use class Comman
check_type() checks the array's contents, then peels off the array and
falls through to the "not array" code without resetting allow_array
and allow_dict to False. Works because the peeled value is a string,
and allow_array and allow_dict aren't used then. Tidy up anyway:
recurse instead, default
Split check_name() into check_name_is_str() and check_name_str(), keep
check_name() as a wrapper.
Move add_name()'s call into its caller check_exprs(), and inline.
This permits delaying check_name_str() there, so its error message
gains an "in definition" line.
Signed-off-by: Markus Armbruster
We track source locations with a dict of the form
{'file': FNAME, 'line': LINENO, 'parent': PARENT}
where PARENT is None for the main file, and the include directive's
source location for included files.
This is serviceable enough, but the next commit will add information,
and that's going t
QAPISchemaMember.owner is the name of the defining entity. That's a
confusing name when an object type inherits members from a base type.
Rename it to .defined_in. Rename .set_owner() and ._pretty_owner() to
match.
Signed-off-by: Markus Armbruster
Reviewed-by: Eric Blake
Message-Id: <201909271
Split check_flags() off check_keys() and have check_exprs() call it
later, so its error messages gain an "in definition" line. Tweak the
error messages.
Checking values in a function named check_keys() is unclean anyway.
Signed-off-by: Markus Armbruster
Reviewed-by: Eric Blake
Message-Id: <201
The following changes since commit c6f5012ba5fa834cbd5274b1b8369e2c5d2f5933:
Merge remote-tracking branch
'remotes/stsquad/tags/pull-testing-next-260919-1' into staging (2019-09-27
15:43:41 +0100)
are available in the Git repository at:
git://repo.or.cz/qemu/armbru.git tags/pull-qapi-2019-
check_name() consists of check_name_is_str() and check_name_str().
check_union() relies on the latter to catch optional discriminators.
The next commit will replace that by a more straightforward check.
Inlining check_name() into check_union() now should make that easier
to review.
Signed-off-by:
Move check_if() from check_keys() to check_exprs() and call it later,
so its error messages gain an "in definition" line.
Checking values in a function named check_keys() is unclean anyway.
The original sin was commit 0545f6b887 "qapi: Better error messages
for bad expressions", which checks the v
The checks for reserved names are spread far and wide. Move one from
add_name() to new check_defn_name_str(). This is a first step towards
collecting them all in dedicated name checking functions next to
check_name().
While there, drop the quotes around the meta-type in
check_name_str()'s error
Replace check_name() by check_name_str() where the name is known to be
a string.
Signed-off-by: Markus Armbruster
Reviewed-by: Eric Blake
Message-Id: <20190927134639.4284-11-arm...@redhat.com>
---
scripts/qapi/common.py | 9 -
1 file changed, 4 insertions(+), 5 deletions(-)
diff --git
Have check_exprs() check this later, so the error message gains an "in
definition line". Tweak the error message.
Signed-off-by: Markus Armbruster
Reviewed-by: Eric Blake
Message-Id: <20190927134639.4284-25-arm...@redhat.com>
---
scripts/qapi/common.py| 18 --
tests
QAPISchemaMember.check_clash() checks for member names that map to the
same c_name(). Takes care of rejecting duplicate names.
It also checks a naming rule: no uppercase in member names. That's a
rather odd place to do it. Enforcing naming rules is
check_name_str()'s job.
qapi-code-gen.txt spe
Future commits will need info in the .check() methods of
QAPISchemaMember and its descendants. Get it there.
Signed-off-by: Markus Armbruster
Reviewed-by: Eric Blake
Message-Id: <20190927134639.4284-15-arm...@redhat.com>
---
scripts/qapi/common.py | 76 +++--
The special "does not allow optional name" error is well meant, but
confusing in practice. Drop it.
Signed-off-by: Markus Armbruster
Reviewed-by: Eric Blake
Message-Id: <20190927134639.4284-12-arm...@redhat.com>
---
scripts/qapi/common.py | 6 ++
tests/qap
QAPISchemaCommand.check() and QAPISchemaEvent().check() check 'data'
is present when 'boxed': true. That's context-free. Move to
check_command() and check_event().
Tweak the error message while there.
check_exprs() & friends now check exactly what qapi-code-gen.txt calls
the second layer of syn
Most check_FOO() take the thing being checked as first argument.
check_name(), check_type(), check_known_keys() don't. Clean that up.
While there, drop a "Todo" comment that should have been dropped in
commit 87adbbffd4 "qapi: add a dictionary form for TYPE".
Signed-off-by: Markus Armbruster
Re
check_if()'s errors don't point to the offending part of the
expression. For instance:
tests/qapi-schema/alternate-branch-if-invalid.json:2: 'if' condition ' '
makes no sense
Other check_FOO() do, with the help of a @source argument. Make
check_if() do that, too. The example above improve
qapi-gen.py crashes when it can't open the main schema file, and when
it can't read from any schema file. Lazy.
Change QAPISchema.__init__() to take a file name instead of a file
object. Move the open code from _include() to __init__(), so it's
used for the main schema file, too.
Move the read
Have check_exprs() call check_keys() later, so its error messages gain
an "in definition" line.
Both check_keys() and check_name_is_str() check the definition's name
is a string. Since check_keys() now runs after check_name_is_str()
rather than before, its check is dead. Bury it. Checking value
We report name clashes like this:
struct-base-clash.json: In struct 'Sub':
struct-base-clash.json:5: 'name' (member of Sub) collides with 'name'
(member of Base)
The "(member of Sub)" is redundant with "In struct 'Sub'". Comes from
QAPISchemaMember.describe(). Pass info to it, so it ca
Patchew URL:
https://patchew.org/QEMU/20190927062302.110144-1-ys...@users.sourceforge.jp/
Hi,
This series seems to have some coding style problems. See output below for
more information:
Type: series
Message-id: 20190927062302.110144-1-ys...@users.sourceforge.jp
Subject: [PATCH v25 00/22] Add
Point to the previous definition, unless it's a built-in.
Signed-off-by: Markus Armbruster
Reviewed-by: Eric Blake
Message-Id: <20190927134639.4284-26-arm...@redhat.com>
---
scripts/qapi/common.py | 5 +
tests/qapi-schema/redefined-command.err | 4 +++-
tests/qapi-schema/re
check_keys() has become a trivial wrapper for check_known_keys().
Eliminate it.
This makes its name available. Rename check_known_keys().
Signed-off-by: Markus Armbruster
Reviewed-by: Eric Blake
Message-Id: <20190927134639.4284-24-arm...@redhat.com>
---
scripts/qapi/common.py | 40 +++
On IBM Z, KVM in the kernel is only implemented for 64-bit mode, and
with regards to TCG, we also only support 64-bit host CPUs (see the
check at the beginning of tcg/s390/tcg-target.inc.c), so we should
remove s390 (without "x", i.e. the old 31-bit mode CPUs) from the
list of supported CPUs.
Sign
We take pains to include the offending expression in error messages,
e.g.
tests/qapi-schema/alternate-any.json:2: alternate 'Alt' member 'one' cannot
use type 'any'
But not always:
tests/qapi-schema/enum-if-invalid.json:2: 'if' condition must be a string
or a list of strings
Instead o
Many error messages refer to the offending definition even though
they're preceded by an "in definition" line. Rephrase them.
Signed-off-by: Markus Armbruster
Message-Id: <20190927134639.4284-22-arm...@redhat.com>
Reviewed-by: Eric Blake
---
scripts/qapi/common.py| 129
When we introduced the QAPISchema intermediate representation (commit
ac88219a6c7), we took a shortcut: we left check_exprs() & friends
alone instead of moving semantic checks into the
QAPISchemaFOO.check(). The .check() assert check_exprs() did its job.
Time to finish the conversion job. Move e
Starting error messages with a capital letter complicates things when
text can get interpolated both at the beginning and in the middle of
an error message. The next patch will do that. Switch to lower case
to keep it simpler.
For what it's worth, the GNU Coding Standards advise the message
"sho
On 9/26/19 12:18 PM, Paolo Bonzini wrote:
On 26/09/19 10:59, Maxim Levitsky wrote:
If you mean to ask if there is a way to let guest access use no
paging at all, that is access host physical addresses directly, then
indeed there is no way, since regular non 'unrestricted guest' mode
required bot
28.09.2019. 19.45, "Aleksandar Markovic" је
написао/ла:
>
>
> 26.09.2019. 20.14, "Mark Cave-Ayland" је
написао/ла:
> >
> > As part of the investigation into the DFP number issue reported at
> > https://bugs.launchpad.net/qemu/+bug/1841990 it appears that there may
also be a bug
> > introduced by
> -Original Message-
> From: Peter Xu
> Sent: Friday, September 27, 2019 5:32 PM
> To: Zhang, Qi1
> Cc: qemu-devel@nongnu.org; ehabk...@redhat.com; m...@redhat.com;
> pbonz...@redhat.com; r...@twiddle.net; Qi, Yadong
> Subject: Re: [PATCH V2] intel_iommu: TM field should not be in rese
On 9/28/2019 4:22 AM, Paolo Bonzini wrote:
On 18/09/19 09:23, Tao Xu wrote:
+} else if (function == 7 && index == 0 && reg == R_ECX) {
+if (enable_cpu_pm) {
+ret |= CPUID_7_0_ECX_WAITPKG;
+}
This should be the opposite; remove the bit if enable_cpu_pm is not set
UMONITOR, UMWAIT and TPAUSE are a set of user wait instructions.
This patch adds support for user wait instructions in KVM. Availability
of the user wait instructions is indicated by the presence of the CPUID
feature flag WAITPKG CPUID.0x07.0x0:ECX[5]. User wait instructions may
be executed at any
UMONITOR, UMWAIT and TPAUSE are a set of user wait instructions.
UMONITOR arms address monitoring hardware using an address. A store
to an address within the specified address range triggers the
monitoring hardware to wake up the processor waiting in umwait.
UMWAIT instructs the processor to ente
UMWAIT and TPAUSE instructions use 32bits IA32_UMWAIT_CONTROL at MSR
index E1H to determines the maximum time in TSC-quanta that the processor
can reside in either C0.1 or C0.2.
This patch is to Add support for save/load IA32_UMWAIT_CONTROL MSR in
guest.
Co-developed-by: Jingqi Liu
Signed-off-by
On Sun, Sep 29, 2019 at 01:11:12AM +, Zhang, Qi1 wrote:
>
>
> > -Original Message-
> > From: Peter Xu
> > Sent: Friday, September 27, 2019 5:32 PM
> > To: Zhang, Qi1
> > Cc: qemu-devel@nongnu.org; ehabk...@redhat.com; m...@redhat.com;
> > pbonz...@redhat.com; r...@twiddle.net; Qi, Y
On 2019/9/27 22:02, Peter Maydell wrote:
> On Fri, 6 Sep 2019 at 09:33, Xiang Zheng wrote:
>>
>> From: Dongjiu Geng
>>
>> Support RAS Virtualization feature since version 4.2, disable it by
>> default in the old versions. Also add a machine option which allows user
>> to enable it explicitly.
> -Original Message-
> From: Peter Xu
> Sent: Sunday, September 29, 2019 10:02 AM
> To: Zhang, Qi1
> Cc: qemu-devel@nongnu.org; ehabk...@redhat.com; m...@redhat.com;
> pbonz...@redhat.com; r...@twiddle.net; Qi, Yadong
> Subject: Re: [PATCH V2] intel_iommu: TM field should not be in res
On Sun, Sep 29, 2019 at 10:02:20AM +0800, Peter Xu wrote:
> On Sun, Sep 29, 2019 at 01:11:12AM +, Zhang, Qi1 wrote:
> >
> >
> > > -Original Message-
> > > From: Peter Xu
> > > Sent: Friday, September 27, 2019 5:32 PM
> > > To: Zhang, Qi1
> > > Cc: qemu-devel@nongnu.org; ehabk...@red
Hi All,
I have a custom ISA that's based on MIPS. The LW and SW instructions' opcodes
are changed into 0x17(OPC_BGTZL) and 0x1F(OPC_SPECIAL3).
I have made the following changes in target/mips/translate.c:
@@ -29331,7 +29331,11 @@ static void decode_opc(CPUMIPSState *env, DisasContext
*ctx)
El mié, 04-09-2019 a las 19:13 +0200, Philippe Mathieu-Daudé escribió:
> IEC binary prefixes ease code review: the unit is explicit.
>
> Signed-off-by: Philippe Mathieu-Daudé
> ---
> hw/arm/raspi.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/hw/arm/raspi.c b/hw/
50 matches
Mail list logo