Hi,
This series failed build test on s390x host. Please find the details below.
Type: series
Subject: [Qemu-devel] [PATCH v2] configure: adding ppc64le to supported host
CPUs
Message-id: 20171101191030.16136-1-danie...@linux.vnet.ibm.com
=== TEST SCRIPT BEGIN ===
#!/bin/bash
# Testing script wi
On 11/02/2017 01:12 PM, Jindřich Makovička wrote:
> This fixes the following case:
>
> 1) Ctrl-Alt-2 for console is pressed
> 2) console pops up and gets focus
> 3) console receives the Ctrl-Alt-2 keypress event
> 4) console closes
> 5) focus returns to the main window
> 6) main window gets the ke
Le 04/11/2017 à 22:20, Stafford Horne a écrit :
> Hello,
>
> On Fri, Nov 03, 2017 at 09:26:22PM +0100, Laurent Vivier wrote:
>> Signed-off-by: Laurent Vivier
>
> There is no commit body here, do we need one? I can see in your cover letter
> its mentioned this was revealed after enabling "USE_SO
Seen on both RHEL7 and Ubuntu:
$ gtester -k --verbose -m=quick tests/test-crypto-hash
TEST: tests/test-crypto-hash... (pid=96313)
/crypto/hash/iov:FAIL
GTester: last random seed: R02S1fb9dd7b21cb29ff371b0d53bccdf6e4
(pid=96315)
/crypto/hash/a
The following changes since commit b33afc415622e5eb26e0f14fd27eb86e32a5472e:
Merge remote-tracking branch
'remotes/stsquad/tags/pull-ci-updates-for-softfreeze-021117-2' into staging
(2017-11-03 10:08:34 +)
are available in the Git repository at:
git://github.com/bonzini/qemu.git tags/f
GCC 4.9 and newer stopped warning for missing braces around the
"universal" C zero initializer {0}. One such initializer sneaked
into scsi/qemu-pr-helper.c and is breaking the build with such
older GCC versions.
Detect the lack of support for the idiom, and disable the warning
in that case.
Sign
Legacy PCI device assignment has been removed from Linux in 4.12,
and had been deprecated 2 years ago there. We can remove it from
QEMU as well.
The ROM loading code was shared with Xen PCI passthrough, so move
it to hw/xen.
Reviewed-by: Philippe Mathieu-Daudé
Signed-off-by: Paolo Bonzini
---
Hi Max,
On Sat, Nov 4, 2017 at 12:45 AM, Max Filippov wrote:
> const16 is an opcode that shifts 16 lower bits of an address register
> to the 16 upper bits and puts its immediate operand into the lower 16
> bits. It is not controlled by an Xtensa option and doesn't have a fixed
> opcode.
>
> Sign
[Reviving a more than 1-year old thread. I randomly noticed this (refer
below) while browsing through AF_VSOCK changes in my 'qemu-devel'
maildir.]
On Tue, Oct 18, 2016 at 11:21:23AM +0100, Stefan Hajnoczi wrote:
> On Mon, Oct 17, 2016 at 09:25:46AM -0500, Eric Blake wrote:
> > On 10/16/2016 08:3
I have a similar setup to yours, running on Ubuntu 17.10 Artful.
Symptoms are the same. Did you find out what's wrong with 2.10? (Haven't
tested 2.9 here)
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs
Hi Eric,
On Fri, Nov 03, 2017 at 05:45:07PM -0500, Eric Blake wrote:
> As currently written, structured reply is documented as:
>
> > NBD_REPLY_TYPE_OFFSET_DATA (1)
> >
> > This chunk type is in the content chunk category. length MUST be at least
> > 9. It represents the contents of length - 8 b
Hi Philippe,
On Sun, Nov 5, 2017 at 7:23 AM, Philippe Mathieu-Daudé wrote:
>> +static void translate_const16(DisasContext *dc, const uint32_t arg[],
>> + const uint32_t par[])
>> +{
>> +if (gen_window_check1(dc, arg[0])) {
>> +TCGv_i32 v = tcg_temp_new_i32(
On Sun, Nov 5, 2017 at 3:43 PM, Max Filippov wrote:
>> however I think this can be simplified in 1 instr on target supporting
>> deposit32:
>>
>> tcg_gen_deposit_i32(cpu_R[arg[0]], cpu_R[arg[1]], cpu_R[arg[0]], 16, 16)
>
> arg[1] is an immediate argument, not a register index, so probably not.
On 04/11/17 02:33, Daniel P. Berrange wrote:
> This short series of patches improves the reliability of the submodule
> handling to cope with various dev env scenarios that have since emerged
>
> v2: https://lists.gnu.org/archive/html/qemu-devel/2017-10/msg06272.html
>
> Changed in v3:
>
> -
On 04/11/17 06:38, Laurent Vivier wrote:
> linux-user binaries don't need firmware and NMI,
> so don't add them in this case, move QDEV
> firmware functions to qdev-fw.c
When configured with --target-list=ppc64-linux-user , config-host.mak gets
TARGET_DIRS=ppc64-linux-user and I would expect CON
OpenBSD/i386 uses elf_i386_obsd for the emulation linker.
Signed-off-by: Brad Smith
diff --git a/configure b/configure
index dd73cce62f..02799d38ac 100755
--- a/configure
+++ b/configure
@@ -5159,9 +5159,9 @@ if test \( "$cpu" = "i386" -o "$cpu" = "x86_64" \) -a \
"$targetos" != "Darwi
Define TIME_MAX to LLONG_MAX for OpenBSD since OpenBSD uses 64-bit time_t.
Signed-off-by: Brad Smith
diff --git a/include/qemu/osdep.h b/include/qemu/osdep.h
index 6855b94bbf..824714049b 100644
--- a/include/qemu/osdep.h
+++ b/include/qemu/osdep.h
@@ -132,8 +132,12 @@ extern int daemon(int, int
The compiler will make reasonable default choies for inline
functions, so the inline keywords are redundant. Remove them to
retain consistant code style.
Signed-off-by: Jiang Biao
Suggested-by: Richard Henderson
---
tcg/mips/tcg-target.inc.c | 52 +++
On 11/03/2017 11:10 PM, Stefan Hajnoczi wrote:
On Thu, Oct 12, 2017 at 10:44:26AM +0800, Mao Zhongyi wrote:
On 09/12/2017 06:16 PM, Stefan Hajnoczi wrote:
On Sat, Sep 09, 2017 at 02:22:26PM +0800, Mao Zhongyi wrote:
ioh3420_interrupts_init() pass error message to local_err, then
propagate it
+QEMU dev list
On Fri, Nov 3, 2017 at 10:07 PM, Anton Gerasimov
wrote:
> Hi all,
>
> I'm trying to use u-boot (v2017.01) with qemu-system-x86_64 v2.10.0 and
> run into a "trying to execute code outside of RAM or ROM at x"
> issue. It happens both when I build and use u-boot as a bios and as E
KVM HV will soon support running a guest in hash mode on a POWER9 host
running in radix mode (see [1]), however the guest currently fails to
boot.
This is because the "htab_shift" value (the size of the MMU's hash
table) is added to the device tree before KVM has had a chance to
change it. If the
On 06/11/17 11:22, Alexey Kardashevskiy wrote:
> On 04/11/17 02:33, Daniel P. Berrange wrote:
>> This short series of patches improves the reliability of the submodule
>> handling to cope with various dev env scenarios that have since emerged
>>
>> v2: https://lists.gnu.org/archive/html/qemu-deve
I could re-produce using the following command,
# MALLOC_PERTURB_=${MALLOC_PERTURB_:-$(( ${RANDOM:-0} % 255 + 1))} gtester -k
--verbose -m=quick tests/test-aio-multithread
TEST: tests/test-aio-multithread... (pid=116074)
/aio/multi/lifecycle:OK
Gerd Hoffmann writes:
[...]
>> Libvirt doesn't use '-machine graphics=off' AFAIK, only '-
>> nographic'.
>
> I think that is pretty much the same. Setting "graphichs=off" is one
> of the effects of passing -nographic, and the other effects (like
> setting up default serial + monitor in a differ
On Thu, Nov 02, 2017 at 11:35:59AM +0100, Luc MICHEL wrote:
> When overwritting a valid TLB entry with a new one, the previous page
> were not flushed in QEMU TLB, leading to incoherent mapping. This commit
> fixes this.
I don't think this is right. As a rule, overwriting a TLB entry
doesn't nece
Peter Maydell writes:
> On 11 October 2017 at 05:33, Jiang Biao wrote:
>> There are some rare cases which need external declarations in .c
>> files. patchew.org and checkpatch.pl will complain errors on
>> patches for these declarations.
>>
>> Degrade ERROR to WARN to erase the error complaints
Test-crypto-hash calls qcrypto_hash_bytesv/digest/base64 with
errp=NULL, this will cause a NULL poniter deference if afalg_driver
doesn't support requested algos:
ret = qcrypto_hash_afalg_driver.hash_bytesv(alg, iov, niov,
result, resultlen,
On 2017-11-06 08:57, Jiang Biao wrote:
> The compiler will make reasonable default choies for inline
> functions, so the inline keywords are redundant. Remove them to
> retain consistant code style.
>
> Signed-off-by: Jiang Biao
> Suggested-by: Richard Henderson
> ---
> tcg/mips/tcg-target.inc.
This is the specification about the new virtio crypto device.
---
v21 -> v20
- rename 'queue_id' to 'reserved' [Halil]
- redescribe the format of the structures which using 'union'
in the previous version [Halil]
v20 -> v19
- fix some typos and grammar fixes [Halil]
- make queue_id reserve
The queue_id is needless bacause we can get the info from
VirtQueue->queue_index.
For existing frontend driver, this field is always zero,
so we can just mark this field as reserved and ingore its
value.
Signed-off-by: Longpeng(Mike)
---
hw/virtio/virtio-crypto.c | 8 +++---
The struct virtio_crypto_op_ctrl_req is not needed, we can
use 'header + payload' instead as suggested by Halil. This
can makes the code simpler to add MUX-mode support in the
next patch.
Signed-off-by: Longpeng(Mike)
---
hw/virtio/virtio-crypto.c | 48 --
Adds stateless mode cipher support.
Signed-off-by: Longpeng(Mike)
---
backends/cryptodev.c | 21 +
include/hw/virtio/virtio-crypto.h | 1 +
include/sysemu/cryptodev.h| 18 ++
3 files changed, 40 insertions(+)
diff --git a/backends/crypto
From: Gonglei
So that the new function can be used by both seesion creation
and the following stateless crypto operation.
Signed-off-by: Gonglei
Signed-off-by: Longpeng(Mike)
---
backends/cryptodev-builtin.c | 100 +--
1 file changed, 58 insertions(+),
From: Gonglei
We enable all feature bits acquiescently.
Signed-off-by: Gonglei
---
hw/virtio/virtio-crypto.c | 15 +++
include/hw/virtio/virtio-crypto.h | 1 +
2 files changed, 16 insertions(+)
diff --git a/hw/virtio/virtio-crypto.c b/hw/virtio/virtio-crypto.c
index e46c4
The struct virtio_crypto_op_data_req is not needed, we can
use 'header + payload' instead. This makes the code simpler
to add MUX-mode support in the next patch.
Signed-off-by: Longpeng(Mike)
---
hw/virtio/virtio-crypto.c | 34 ++
include/standard-hea
We can support stateless crypto request now.
The stateless cipher request componet is:
header + payload + key + iv + src_data + dst_data
and The algorithm chainning stateless request
component is:
header + payload + key + auth_key + iv + aad + src_data +
dst_data + hash_result
Signed-off-by: Go
This is the specification about the new virtio crypto device.
---
v21 -> v20
- rename 'queue_id' to 'reserved' [Halil]
- redescribe the format of the structures which using 'union'
in the previous version [Halil]
v20 -> v19
- fix some typos and grammar fixes [Halil]
- make queue_id reserve
From: Gonglei
The virtio crypto device is a virtual crypto device (ie. hardware
crypto accelerator card). Currently, the virtio crypto device provides
the following crypto services: CIPHER, MAC, HASH, and AEAD.
In this patch, CIPHER, MAC, HASH, AEAD services are introduced.
VIRTIO-153
Signed-o
Adds stateless cipher support for builtin-backend
Signed-off-by: Gonglei
[simplify the code & correct the return value]
Signed-off-by: Longpeng(Mike)
---
backends/cryptodev-builtin.c | 86
1 file changed, 86 insertions(+)
diff --git a/backends/crypt
From: Gonglei
Add the conformance targets and clauses for
virtio-crypto device.
Signed-off-by: Gonglei
Signed-off-by: Longpeng(Mike)
---
conformance.tex | 29 +
1 file changed, 29 insertions(+)
diff --git a/conformance.tex b/conformance.tex
index 7b7df32..266a22f
Hi Shanker,
On 03/11/2017 13:37, Shanker Donthineni wrote:
> The commit cddafd8f353d ("hw/intc/arm_gicv3_its: Implement state save
> /restore") breaks the backward compatibility with the older kernels
> where vITS save/restore support is not available. The vmstate function
> vm_change_state_handle
From: Gonglei
Add the conformance targets and clauses for
virtio-crypto device.
Signed-off-by: Gonglei
Signed-off-by: Longpeng(Mike)
---
conformance.tex | 29 +
1 file changed, 29 insertions(+)
diff --git a/conformance.tex b/conformance.tex
index 7b7df32..266a22f
FYI - this is from http://lists.nongnu.org/archive/html/qemu-
devel/2017-11/msg00417.html
Upstream response looks good, but not committed there yet.
@Julian - given the case will you need this as an SRU as well or is it
only tied to newer apt (or newer apt use cases)?
Test queues in Bionic are s
From: Gonglei
The virtio crypto device is a virtual crypto device (ie. hardware
crypto accelerator card). Currently, the virtio crypto device provides
the following crypto services: CIPHER, MAC, HASH, and AEAD.
In this patch, CIPHER, MAC, HASH, AEAD services are introduced.
VIRTIO-153
Signed-o
Hi Gerd,
Would you please take a look at this patch, testing shows it prevents
these crashes. I'm not an expert, just to give you more information.
I cannot public the fuzzer program, if you need to gather more
diagnostic information or try test patches, I'm happy to help.
diff --git a/hw/displ
*NOTE*
The code realization is based on the latest virtio crypto spec:
[PATCH v21 0/2] virtio-crypto: virtio crypto device specification
In session mode, the process of create/close a session
makes we have a least one full round-trip cost from guest to host to guest
to be able to send any data fo
Adds some macros about the features of multiplexing
mode and supports the session create for this mode.
Signed-off-by: Longpeng(Mike)
---
hw/virtio/virtio-crypto.c | 13 +++--
include/standard-headers/linux/virtio_crypto.h | 7 +++
2 files changed, 18 insertions
Adds dataq operation support for MUX mode.
Signed-off-by: Longpeng(Mike)
---
hw/virtio/virtio-crypto.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/hw/virtio/virtio-crypto.c b/hw/virtio/virtio-crypto.c
index 828d7ef..10a0c35 100644
--- a/hw/virtio/virtio-crypto.c
+++
> [..]
> >> Yes, the GUID will specifically identify this range as "Virtio Shared
> >> Memory" (or whatever name survives after a bikeshed debate). The
> >> libnvdimm core then needs to grow a new region type that mostly
> >> behaves the same as a "pmem" region, but drivers/nvdimm/pmem.c grows a
49 matches
Mail list logo