On 07/06/2012 09:06 PM, Jan Kiszka wrote:
> On 2012-07-06 19:16, Jan Kiszka wrote:
>> On 2012-06-24 16:08, Jan Kiszka wrote:
>>> On 2012-06-24 10:49, Avi Kivity wrote:
On 06/23/2012 02:45 PM, Jan Kiszka wrote:
>
> Hmm, we may need the iothread lock around cpu_set_apic_tpr for
> !kv
On 2012년 07월 07일 16:51, Blue Swirl wrote:
On Fri, Jul 6, 2012 at 11:43 AM, Yeongkyoon Lee
wrote:
On 2012년 07월 05일 23:06, Peter Maydell wrote:
On 5 July 2012 14:23, Yeongkyoon Lee wrote:
Add an option "--enable-ldst-optimization" to enable
CONFIG_QEMU_LDST_OPTIMIZATION macro for TCG qemu_ld/s
Well that's very interesting because one of the patches we have added in
Fedora is:
http://pkgs.fedoraproject.org/gitweb/?p=qemu.git;a=blob;f=0001-qemu-kvm-
Add-missing-default-machine-
options.patch;h=e785a708d0bf0861c2f0f1777b8cc477d12fe145;hb=HEAD
--
You received this bug notification because
Peter Maydell writes:
[...]
> +/**
> + * extract32:
> + * @value: the value to extract the bit field from
> + * @start: the lowest bit in the bit field (numbered from 0)
> + * @length: the length of the bit field
> + *
> + * Extract from the 32 bit input @value the bit field specified by the
> + *
On 8 July 2012 10:55, Lluís Vilanova wrote:
> Wouldn't it be better to use "unsigned int" instead on all the "start" and
> "length" arguments?
See the arguments about this on one of the previous patch series:
http://lists.gnu.org/archive/html/qemu-devel/2012-06/msg04304.html
-- PMM
Am 08.07.2012 12:01, schrieb Peter Maydell:
On 8 July 2012 10:55, Lluís Vilanova wrote:
Wouldn't it be better to use "unsigned int" instead on all the "start" and
"length" arguments?
See the arguments about this on one of the previous patch series:
http://lists.gnu.org/archive/html/qemu-devel/
On 8 July 2012 11:59, Stefan Weil wrote:
> Am 08.07.2012 12:01, schrieb Peter Maydell:
>> On 8 July 2012 10:55, Lluís Vilanova wrote:
>>> Wouldn't it be better to use "unsigned int" instead on all the "start"
>>> and "length" arguments?
>>
>> See the arguments about this on one of the previous pa
On 06/28/2012 08:58 AM, Markus Armbruster wrote:
>>>
>>> Better code is an argument only if the effect can be demonstrated.
>>
>> I don't know even for which compilers or CPUs this is true so it's
>> unlikely I could demonstrate it. However, googling finds a few
>> articles in defense of this.
>
>
On Sun, Jul 8, 2012 at 11:37 AM, Avi Kivity wrote:
> On 06/28/2012 08:58 AM, Markus Armbruster wrote:
Better code is an argument only if the effect can be demonstrated.
>>>
>>> I don't know even for which compilers or CPUs this is true so it's
>>> unlikely I could demonstrate it. However
From: Blue Swirl
I entertained myself by compiling QEMU with -std=c99 -pedantic and
fixing some issues found with that.
Blue Swirl (5):
Avoid GCC extension ?:
Avoid returning void
Use __asm__ instead of asm or __asm
Avoid unportable %m format
Avoid redefining inline
block.c
From: Blue Swirl
It's silly and non-conforming to standards to return void,
don't do it.
Signed-off-by: Blue Swirl
---
block.c|2 +-
dma.h |6 +++---
hw/bt-l2cap.c | 11 +++
hw/eepro100.c | 15 +++
hw/ide/cmd646
From: Blue Swirl
Replace asm and __asm with __asm__.
Signed-off-by: Blue Swirl
---
bswap.h | 40
cache-utils.h | 10 +-
exec-all.h|6 +++---
qemu-barrier.h| 14 +++---
qemu-timer.h
From: Blue Swirl
System headers (e.g. gutils.h) may define 'inline', #undefine it
before #defining.
Signed-off-by: Blue Swirl
---
osdep.h |2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/osdep.h b/osdep.h
index 3ea4af0..1e15a4b 100644
--- a/osdep.h
+++ b/osdep.h
@@ -70
From: Blue Swirl
Replace expr1 ?: expr2 with expr1 ? expr1 : expr2 as K&R intended.
If expr1 has side effects, introduce a temporary variable.
Signed-off-by: Blue Swirl
---
block.c |6 --
block/qcow2.c|6 --
bt-vhci.c|2 +-
hw/bt-hci.c
From: Blue Swirl
Replace %m format with explicit call to standard strerror().
Signed-off-by: Blue Swirl
---
kvm-all.c |3 ++-
main-loop.c |2 +-
net/tap-linux.c |8 +---
qemu-nbd.c |3 +--
4 files changed, 9 insertions(+), 7 deletions(-)
diff --git a/kvm-all
blauwir...@gmail.com writes:
> +pstrcpy(bs->backing_format, sizeof(bs->backing_format),
> +backing_fmt ? backing_file : "");
s/backing_file/backing_fmt/
Andreas.
--
Andreas Schwab, sch...@linux-m68k.org
GPG Key fingerprint = 58CA 54C7 6D53 942B 1756 01D3 44D5 214B 8276 4ED5
"A
From: Blue Swirl
Use 'unsigned int' for bit numbers. Return 'bool' for test functions. QEMU is
not the kernel, we don't need 'volatile'. Adjust asserts.
Signed-off-by: Blue Swirl
---
bitops.h | 47 ---
1 files changed, 24 insertions(+), 23 deletion
On Sun, Jul 8, 2012 at 12:09 PM, Andreas Schwab wrote:
> blauwir...@gmail.com writes:
>
>> +pstrcpy(bs->backing_format, sizeof(bs->backing_format),
>> +backing_fmt ? backing_file : "");
>
> s/backing_file/backing_fmt/
Thanks, will fix.
I accidentally sent the patches using wrong
From: Blue Swirl
I entertained myself by compiling QEMU with -std=c99 -pedantic and
fixing some issues found with that.
v1->v2:
Fix copypasta in 1/5 (Anders Schwab)
Resent with correct address
Blue Swirl (5):
Avoid GCC extension ?:
Avoid returning void
Use __asm__ instead of asm or __asm
From: Blue Swirl
System headers (e.g. gutils.h) may define 'inline', #undefine it
before #defining.
Signed-off-by: Blue Swirl
---
osdep.h |2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/osdep.h b/osdep.h
index 3ea4af0..1e15a4b 100644
--- a/osdep.h
+++ b/osdep.h
@@ -70
From: Blue Swirl
It's silly and non-conforming to standards to return void,
don't do it.
Signed-off-by: Blue Swirl
---
block.c|2 +-
dma.h |6 +++---
hw/bt-l2cap.c | 11 +++
hw/eepro100.c | 15 +++
hw/ide/cmd646
From: Blue Swirl
Replace asm and __asm with __asm__.
Signed-off-by: Blue Swirl
---
bswap.h | 40
cache-utils.h | 10 +-
exec-all.h|6 +++---
qemu-barrier.h| 14 +++---
qemu-timer.h
From: Blue Swirl
Replace expr1 ?: expr2 with expr1 ? expr1 : expr2 as K&R intended.
If expr1 has side effects, introduce a temporary variable.
Signed-off-by: Blue Swirl
---
block.c |6 --
block/qcow2.c|6 --
bt-vhci.c|2 +-
hw/bt-hci.c
From: Blue Swirl
Replace %m format with explicit call to standard strerror().
Signed-off-by: Blue Swirl
---
kvm-all.c |3 ++-
main-loop.c |2 +-
net/tap-linux.c |8 +---
qemu-nbd.c |3 +--
4 files changed, 9 insertions(+), 7 deletions(-)
diff --git a/kvm-all
On 8 July 2012 13:12, wrote:
> -static inline uint64_t deposit64(uint64_t value, int start, int length,
> - uint64_t fieldval)
> +static inline uint64_t deposit64(uint64_t value, unsigned int start,
> + unsigned int length, uint64_t
On Fri, Jul 6, 2012 at 9:43 PM, Alexander Graf wrote:
>
> On 02.07.2012, at 07:25, zhlci...@gmail.com wrote:
>
>> From: Li Zhang
>>
>> pSeries machine needs to enable USB to add a USB
>> keyboard or USB mouse. -usb option won't be used in
>> the future, and machine options are a better way to
>>
On 08.07.2012, at 16:21, Li Zhang wrote:
> On Fri, Jul 6, 2012 at 9:43 PM, Alexander Graf wrote:
>>
>> On 02.07.2012, at 07:25, zhlci...@gmail.com wrote:
>>
>>> From: Li Zhang
>>>
>>> pSeries machine needs to enable USB to add a USB
>>> keyboard or USB mouse. -usb option won't be used in
>
On Sat, Jul 7, 2012 at 12:03 AM, Alexander Graf wrote:
>
> On 06.07.2012, at 17:58, Andreas Färber wrote:
>
>> Am 06.07.2012 15:43, schrieb Alexander Graf:
>>>
>>> On 02.07.2012, at 07:25, zhlci...@gmail.com wrote:
>>>
From: Li Zhang
pSeries machine needs to enable USB to add a USB
On Sun, Jul 8, 2012 at 10:45 PM, Alexander Graf wrote:
>
>
> On 08.07.2012, at 16:21, Li Zhang wrote:
>
>> On Fri, Jul 6, 2012 at 9:43 PM, Alexander Graf wrote:
>>>
>>> On 02.07.2012, at 07:25, zhlci...@gmail.com wrote:
>>>
From: Li Zhang
pSeries machine needs to enable USB to ad
On 08.07.2012, at 16:46, Li Zhang wrote:
> On Sat, Jul 7, 2012 at 12:03 AM, Alexander Graf wrote:
>>
>> On 06.07.2012, at 17:58, Andreas Färber wrote:
>>
>>> Am 06.07.2012 15:43, schrieb Alexander Graf:
On 02.07.2012, at 07:25, zhlci...@gmail.com wrote:
> From: Li Zhang
On Fri, Jul 6, 2012 at 9:50 PM, Alexander Graf wrote:
>
> On 02.07.2012, at 07:25, zhlci...@gmail.com wrote:
>
>> From: Li Zhang
>>
>> Also instanciate the USB keyboard and mouse when that option is used
>> (you can still use -device to create individual devices without all
>> the defaults)
>>
>>
On Sun, Jul 8, 2012 at 11:02 PM, Alexander Graf wrote:
>
>
> On 08.07.2012, at 16:46, Li Zhang wrote:
>
>> On Sat, Jul 7, 2012 at 12:03 AM, Alexander Graf wrote:
>>>
>>> On 06.07.2012, at 17:58, Andreas Färber wrote:
>>>
Am 06.07.2012 15:43, schrieb Alexander Graf:
>
> On 02.07.2012
** Changed in: qemu
Status: Invalid => New
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1021649
Title:
qemu 1.1.0 waits for a keypress at boot
Status in QEMU:
New
Bug description:
qem
This is a bit more interesting. I've got a bugreport in debian about
the same thing, and verified it in debian qemu-kvm package - indeed,
with -nographics, upstream 1.1 qemu and qemu-kvm refuses to boot without
an extra keypress, but only when kernel_irqchip is enabled. Ie, the
following requires
** Changed in: qemu-kvm (Debian)
Status: Unknown => Incomplete
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1021649
Title:
qemu 1.1.0 waits for a keypress at boot
Status in QEMU:
New
Sta
when the guest is waiting for the keypress, it is sitting in KVM_RUN
ioctl and eating 100% CPU. When enabling Seabios debugging, the last
lines before the stall is this:
Returned 57344 bytes of ZoneHigh
e820 map has 7 items:
0: - 0009dc00 = 1 RAM
1: 0009dc00 -
** Changed in: qemu
Status: New => Confirmed
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1021649
Title:
qemu 1.1.0 waits for a keypress at boot
Status in QEMU:
Confirmed
Status in “qemu
On Sun, Jul 8, 2012 at 2:04 PM, Peter Maydell wrote:
> On 8 July 2012 13:12, wrote:
>> -static inline uint64_t deposit64(uint64_t value, int start, int length,
>> - uint64_t fieldval)
>> +static inline uint64_t deposit64(uint64_t value, unsigned int start,
>> +
On 8 July 2012 19:32, Blue Swirl wrote:
> On Sun, Jul 8, 2012 at 2:04 PM, Peter Maydell
> wrote:
>> On 8 July 2012 13:12, wrote:
>>> -static inline uint64_t deposit64(uint64_t value, int start, int length,
>>> - uint64_t fieldval)
>>> +static inline uint64_t dep
Public bug reported:
When user is in a directory with 1-character long filenames, parameter -cpu ?
causes shell to expand ? into filename, which can cause a very confused user.
One solution would be to replace/add alias to -cpu ?, for example
-cpulist
** Affects: qemu
Importance: Undecide
On Sun, Jul 8, 2012 at 6:54 PM, Peter Maydell wrote:
> On 8 July 2012 19:32, Blue Swirl wrote:
>> On Sun, Jul 8, 2012 at 2:04 PM, Peter Maydell
>> wrote:
>>> On 8 July 2012 13:12, wrote:
-static inline uint64_t deposit64(uint64_t value, int start, int length,
-
From: Blue Swirl
Improve bit operations.
v1->v2
Split from single patch.
Blue Swirl (3):
bitops: fix types
bitops: drop volatile qualifier
bitops: use bool
bitops.h | 42 ++
1 files changed, 22 insertions(+), 20 deletions(-)
--
1.7.2.5
From: Blue Swirl
Qualifier 'volatile' is not useful for applications, it's too strict
for single threaded code but does not give the real atomicity guarantees
needed for multithreaded code.
Drop them.
Signed-off-by: Blue Swirl
---
bitops.h | 18 +++---
1 files changed, 7 inserti
From: Blue Swirl
Use 'bool' type for return value of bit test functions.
Signed-off-by: Blue Swirl
---
bitops.h |8
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/bitops.h b/bitops.h
index bc99727..1cecf00 100644
--- a/bitops.h
+++ b/bitops.h
@@ -153,7 +153,7 @@ st
From: Blue Swirl
Use 'unsigned int' for bit numbers instead of 'unsigned long' or
'int'. Adjust asserts.
Signed-off-by: Blue Swirl
---
bitops.h | 46 ++
1 files changed, 26 insertions(+), 20 deletions(-)
diff --git a/bitops.h b/bitops.h
index b967
On 8 July 2012 20:12, Blue Swirl wrote:
> On Sun, Jul 8, 2012 at 6:54 PM, Peter Maydell
> wrote:
>> On 8 July 2012 19:32, Blue Swirl wrote:
>>> On Sun, Jul 8, 2012 at 2:04 PM, Peter Maydell
>>> wrote:
On 8 July 2012 13:12, wrote:
> -static inline uint64_t deposit64(uint64_t value,
Only buffers that map to unallocated blocks need to be zeroed.
Signed-off-by: Christoph Hellwig
---
block/sheepdog.c | 28 ++--
1 file changed, 18 insertions(+), 10 deletions(-)
Index: qemu/block/sheepdog.c
=
On Sun, Jul 8, 2012 at 7:32 PM, Peter Maydell wrote:
> On 8 July 2012 20:12, Blue Swirl wrote:
>> On Sun, Jul 8, 2012 at 6:54 PM, Peter Maydell
>> wrote:
>>> On 8 July 2012 19:32, Blue Swirl wrote:
On Sun, Jul 8, 2012 at 2:04 PM, Peter Maydell
wrote:
> On 8 July 2012 13:12, w
On 8 July 2012 20:39, Blue Swirl wrote:
> On Sun, Jul 8, 2012 at 7:32 PM, Peter Maydell
> wrote:
>> On 8 July 2012 20:12, Blue Swirl wrote:
>>> On Sun, Jul 8, 2012 at 6:54 PM, Peter Maydell
>>> wrote:
On 8 July 2012 19:32, Blue Swirl wrote:
> On Sun, Jul 8, 2012 at 2:04 PM, Peter Ma
Signed-off-by: Stefan Weil
---
bitops.h |8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/bitops.h b/bitops.h
index b967ef3..c456232 100644
--- a/bitops.h
+++ b/bitops.h
@@ -319,8 +319,8 @@ static inline uint64_t extract64(uint64_t value, int start,
int length)
* @
On 8 July 2012 21:31, Stefan Weil wrote:
> Signed-off-by: Stefan Weil
Doh.
Reviewed-by: Peter Maydell
-- PMM
On Sun, 2012-07-08 at 23:08 +0800, Li Zhang wrote:
> > Are you sure we want to set these in -nographic or -vga none mode as
> well?
>
> I am not sure about this.
>
> Ben, would you please give more information about this?
Doesn't matter much. They are only useful when there is a vga adapter,
the
Please take this to your shell. The queston mark is a metacharacter for
any *nix shell, you should just quote or backslash it. The same
question mark is not special on windows.
Thanks,
/mjt
** Changed in: qemu
Status: New => Invalid
--
You received this bug notification because you ar
On 8 July 2012 20:51, Peter Maydell wrote:
> On 8 July 2012 20:39, Blue Swirl wrote:
>> On Sun, Jul 8, 2012 at 7:32 PM, Peter Maydell
>> wrote:
>>> On 8 July 2012 20:12, Blue Swirl wrote:
Nice. Why is it written like that, I'd use
start + length <= 64?
>>>
>>> That would fail to hand
On 8 July 2012 20:44, Michael Tokarev <1022...@bugs.launchpad.net> wrote:
> Please take this to your shell. The queston mark is a metacharacter for
> any *nix shell, you should just quote or backslash it. The same
> question mark is not special on windows.
I think it's a legitimate complaint to
Ping?
On 02/07/12 05:48, Alexey Kardashevskiy wrote:
> QEMU uses IO handlers to run select() in the main loop. The handlers list is
> managed by qemu_set_fd_handler() helper which works fine when called from the
> main thread as it is called not when select() is waiting.
>
> However sometime we
Il 07/07/2012 07:01, Deep Debroy ha scritto:
> Signed-off-by: Deep Debroy
> ---
> cutils.c |7 +++
> qemu-common.h |1 +
> 2 files changed, 8 insertions(+)
>
> diff --git a/cutils.c b/cutils.c
> index af308cd..68a7d10 100644
> --- a/cutils.c
> +++ b/cutils.c
> @@ -27,6 +27,13 @@
Il 07/07/2012 07:03, Deep Debroy ha scritto:
> Options vendor_name and product_nameadded for SCSI
> disks.
I renamed the property names to vendor/product (and similarly changed
the field names), and applied to scsi-next with correct attribution to
Dmitry Fleitman based on
http://lists.gnu.org/ar
Il 07/07/2012 09:56, Blue Swirl ha scritto:
> These don't seem useful. I think DMA accessors should also be used.
This is a paravirtualized device model, so I think no (like virtio).
I agree that this patch can be dropped and the functions inlined
manually in pvscsi.c (patch 4).
Paolo
59 matches
Mail list logo