Hi,
Your series seems to have some coding style problems. See output below for
more information:
Subject: [Qemu-devel] [PATCH] {disas, slirp}: Replace min/max with MIN/MAX
macros
Type: series
Message-id: 1480108791-16178-1-git-send-email-yuval.sh...@oracle.com
=== TEST SCRIPT BEGIN ===
#!/bin
On Mon, Nov 28, 2016 at 08:39:21AM +0100, Markus Armbruster wrote:
> The "{disas, slirp}: " prefix is unusual. Better: "disas, slirp: ".
> But I'd instead split the patch into the slirp part, where you really
> replace stuff, and the disas part, where you merely drop an unused macro
> definition.
The "{disas, slirp}: " prefix is unusual. Better: "disas, slirp: ".
But I'd instead split the patch into the slirp part, where you really
replace stuff, and the disas part, where you merely drop an unused macro
definition.
On Fri, 11/25 23:19, Yuval Shaia wrote:
> diff --git a/slirp/tcpip.h b/slirp/tcpip.h
> index 7bdb971..71eb6a6 100644
> --- a/slirp/tcpip.h
> +++ b/slirp/tcpip.h
> @@ -30,6 +30,8 @@
> * tcpip.h,v 1.3 1994/08/21 05:27:40 paul Exp
> */
>
> +#include "qemu/osdep.h"
> +
It's a rule that sources i
Use generic declaration of min and max macros instead of private ones.
Signed-off-by: Yuval Shaia
---
disas/m68k.c | 4
slirp/dhcpv6.c | 2 +-
slirp/ip6_icmp.c | 2 +-
slirp/slirp.c | 2 +-
slirp/slirp.h | 5 -
slirp/tcp_input.c | 14 +++---
slirp/tcp