在 2016年03月03日 14:31, hitmoon 写道:
On 25 February 2016 at 10:30, xiaoqiang zhao wrote:
This patch series QOM'ify timer code under hw/timer directory.
Main idea is to split the initfn's work, some to TypeInfo.instance_init
and some is placed in DeviceClass::realize.
Drop
reate(NULL, TYPE_FOO) puts the created object on the
system bus, and then we may try to run functions like sysbus_dev_print()
on it, which fail when casting the object to SysBusDevice.
(This is the same mistake that we made with the NAND device
and fixed in commit 6749695eaaf346c1.)
Reported-by: hi
在 2016年03月14日 14:24, hitmoon 写道:
在 2016年03月11日 12:18, hitmoon 写道:
在 2016年03月11日 11:14, Peter Maydell 写道:
On 11 March 2016 at 10:08, hitmoon wrote:
Peter:
first launch following command:
arm-softmmu/qemu-system-arm -M versatilepb -kernel
~/Qemu-ARM/vmlinuz-3.2.0-4-versatile -initrd
在 2016年03月11日 12:18, hitmoon 写道:
在 2016年03月11日 11:14, Peter Maydell 写道:
On 11 March 2016 at 10:08, hitmoon wrote:
Peter:
first launch following command:
arm-softmmu/qemu-system-arm -M versatilepb -kernel
~/Qemu-ARM/vmlinuz-3.2.0-4-versatile -initrd
~/Qemu-ARM/initrd.img-3.2.0-4
在 2016年03月11日 11:14, Peter Maydell 写道:
On 11 March 2016 at 10:08, hitmoon wrote:
Peter:
first launch following command:
arm-softmmu/qemu-system-arm -M versatilepb -kernel
~/Qemu-ARM/vmlinuz-3.2.0-4-versatile -initrd
~/Qemu-ARM/initrd.img-3.2.0-4-versatile -hda
Peter:
first launch following command:
arm-softmmu/qemu-system-arm -M versatilepb -kernel
~/Qemu-ARM/vmlinuz-3.2.0-4-versatile -initrd
~/Qemu-ARM/initrd.img-3.2.0-4-versatile -hda
~/debian_wheezy_armel_standard.qcow2 -append 'root=/dev/sda1'
Then execute 'info qtree' in the monitor, qemu a
在 2016年03月08日 01:40, Peter Crosthwaite 写道:
On Sun, Mar 6, 2016 at 11:05 PM, xiaoqiang zhao wrote:
Drop the use of old SysBus init function and use instance_init
Signed-off-by: xiaoqiang zhao
Reviewed-by: Peter Crosthwaite
(just this one as I have done some highbank work recently - I cant
On 25 February 2016 at 10:30, xiaoqiang zhao wrote:
This patch series QOM'ify timer code under hw/timer directory.
Main idea is to split the initfn's work, some to TypeInfo.instance_init
and some is placed in DeviceClass::realize.
Drop the use of SysBusDeviceClass::init if possible.
Patch 3,4
在 2016年02月26日 18:25, Peter Maydell 写道:
On 26 February 2016 at 08:40, xiaoqiang zhao wrote:
In the regions overlap example, region B has a higher priority thus
should has a larger priority number than C.
Signed-off-by: xiaoqiang zhao
---
docs/memory.txt | 4 ++--
1 file changed, 2 inserti
在 2016年02月23日 18:26, Peter Maydell 写道:
On 23 February 2016 at 10:02, hitmoon wrote:
I still can NOT understand your intention properly. Can you explain more
clearly?
VMState structures should generally mirror the structs
they are saving/restoring. The M48txxISAState has an entry
that just
在 2016年02月23日 17:04, Peter Maydell 写道:
On 23 February 2016 at 05:11, hitmoon wrote:
在 2016年02月22日 19:03, Peter Maydell 写道:
You'd basically need to have extra VMState structures for the
devices themselves which just said "inside this M48txxISAState
is an M48t59State", a
在 2016年02月22日 19:03, Peter Maydell 写道:
On 22 February 2016 at 10:28, hitmoon wrote:
在 2016年02月22日 17:24, Peter Maydell 写道:
Just noticed this won't work as it is -- the vmstate
struct is for the M48t59State*, but the ISA and
Sysbus wrappers have their own structs which are
what the dc-
在 2016年02月22日 17:24, Peter Maydell 写道:
On 22 February 2016 at 09:11, xiaoqiang zhao wrote:
assign DeviceClass::vmsd instead of using vmstate_register function
Signed-off-by: xiaoqiang zhao
---
hw/timer/m48t59.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/hw/ti
在 2016年02月22日 17:18, Peter Maydell 写道:
On 22 February 2016 at 03:15, xiaoqiang zhao wrote:
Move majority of old SysBus init's work the into instance_init.
Note:
musb_init must be called in SysBus's init, otherwise it will
break "make check" with error message as follows:
qom/object.c:1576:ob
在 2016年02月18日 21:48, Peter Maydell 写道:
On 16 February 2016 at 11:10, xiaoqiang zhao wrote:
assign tusb6010_init to tusb6010_info.instance_init and drop
the SysBusDeviceClass::init
Reviewed-by: Peter Maydell
Signed-off-by: xiaoqiang zhao
(Again, I didn't review this patch.)
---
hw/time
在 2016年02月16日 17:41, Peter Maydell 写道:
On 16 February 2016 at 09:34, hitmoon wrote:
在 2016年02月16日 02:14, Peter Maydell 写道:
On 27 January 2016 at 02:54, xiaoqiang zhao wrote:
* split milkymist_sysctl_init into milkymist_sysctl_info.instance_init
and milkymist_sysctl_realize
I think the
在 2016年02月16日 02:14, Peter Maydell 写道:
On 27 January 2016 at 02:54, xiaoqiang zhao wrote:
>* split milkymist_sysctl_init into milkymist_sysctl_info.instance_init and
milkymist_sysctl_realize
I think the "info" in this function name is wrong ?
I can not understand , can you give me more de
17 matches
Mail list logo