Thomas Huth writes:
> On 07/27/2018 05:13 PM, Markus Armbruster wrote:
>> Signed-off-by: Markus Armbruster
>> ---
>> tests/libqtest.c | 12 ++--
>> tests/libqtest.h | 4 ++--
>> 2 files changed, 8 insertions(+), 8 deletions(-)
>>
>> diff --git a/tests/libqtest.c b/tests/libqtest.c
>>
Eric Blake writes:
> On 07/27/2018 10:13 AM, Markus Armbruster wrote:
>> qtest_init() creates a new QTestState, and leaves @global_qtest alone.
>> qtest_start() additionally assigns it to @global_qtest, but
>> qtest_startf() additionall sets assigns NULL to @global_qtest. This
>
> s/additionall
Eric Blake writes:
> On 07/27/2018 11:46 AM, Thomas Huth wrote:
>> On 07/27/2018 05:13 PM, Markus Armbruster wrote:
>>> qtest_qmp_discard_response(...) is shorthand for
>>> qobject_unref(qtest_qmp(...), except it's not actually shorter.
>>
>> But the latter is IMHO harder to read.
Doing things s
Eric Blake writes:
> On 07/27/2018 10:13 AM, Markus Armbruster wrote:
>> qtest_qmp_discard_response(...) is shorthand for
>> qobject_unref(qtest_qmp(...), except it's not actually shorter.
>> Moreover, the presence of these functions encourage sloppy testing.
>> Remove them.
>>
>> Signed-off-by:
Eric Blake writes:
> On 07/27/2018 10:13 AM, Markus Armbruster wrote:
>> Leaving interpolation into JSON to qmp() is more robust than building
>> QMP input manually, as explained in the recent commit "tests: Clean up
>> string interpolation into QMP input (simple cases)".
>>
>> migration-test.c i
Eric Blake writes:
> On 07/27/2018 10:13 AM, Markus Armbruster wrote:
>> Leaving interpolation into JSON to qmp() is more robust than building
>> QMP input manually, as explained in the recent commit "tests: Clean up
>> string interpolation into QMP input (simple cases)".
>>
>> migrate() interpol
Eric Blake writes:
> On 07/27/2018 10:13 AM, Markus Armbruster wrote:
>> Commit b21373d0713 copied wait_command() from tests/migration-test.c
>> to tests/tpm-util.c. Replace both copies by new libqtest helper
>> qtest_qmp_receive_success(). Also use it to simplify
>> qtest_qmp_device_del().
>>
Eric Blake writes:
> On 07/27/2018 10:13 AM, Markus Armbruster wrote:
>> Leaving interpolation into JSON to qmp() is more robust than building
>> QMP input manually, as explained in the commit before previous.
>>
>> qtest_qmp_device_add() and its wrappers interpolate into JSON as
>> follows:
>>
>
On Fri, Jul 27, 2018 at 09:54:52AM +0200, Greg Kurz wrote:
> On Fri, 27 Jul 2018 15:27:24 +1000
> David Gibson wrote:
>
> > On Wed, Jul 25, 2018 at 04:45:26PM +0200, Greg Kurz wrote:
> > > Commit b585395b655 fixed a regression introduced by some recent changes
> > > in the XICS code, that was cau
Eric Blake writes:
> On 07/27/2018 10:13 AM, Markus Armbruster wrote:
>> The functions to receive messages are called qtest_qmp_receive() and
>> qmp_receive(), qmp_fd_receive(). The ones to send messages are called
>> qtest_async_qmp(), qtest_async_qmpv(), qmp_async(), qmp_fd_send(),
>> qmp_fd_s
On Mon, Jul 30, 2018 at 06:39:04AM +0200, Sebastian Bauer wrote:
> The four interrupts of the PCI bus are connected to the same UIC pin on the
> real Sam460ex. Evidence for this can be found in the UBoot source for the
> Sam460ex in the Sam460ex.c file where PCI_INTERRUPT_LINE in written. This
> ch
The four interrupts of the PCI bus are connected to the same UIC pin on the
real Sam460ex. Evidence for this can be found in the UBoot source for the
Sam460ex in the Sam460ex.c file where PCI_INTERRUPT_LINE in written. This
change brings the connection in line with this.
This fixes the problem tha
[Expired for qemu (Ubuntu) because there has been no activity for 60
days.]
** Changed in: qemu (Ubuntu)
Status: Incomplete => Expired
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/685096
Tit
On Fri, Jul 27, 2018 at 09:04:17AM +0200, CĂ©dric Le Goater wrote:
> [ ... ]
>
> >> +static void spapr_irq_init_xics(sPAPRMachineState *spapr, Error **errp)
> >> +{
> >> +MachineState *machine = MACHINE(spapr);
> >> +sPAPRMachineClass *smc = SPAPR_MACHINE_GET_CLASS(spapr);
> >> +int nr
From: yuchenlin
The CONFIG_VDI_WRITE is here when the first time vdi is added.
But there is no reason to leave an always on and cannot configure option
in the code-side.
Signed-off-by: yuchenlin
---
block/vdi.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/block/vdi.c b/block/vdi.c
i
From: yuchenlin
This series refine some code in vdi.c, includes:
* Remvoe CONFIG_VDI_WRITE because there is no reason to leave an always on
and cannot configure option in the code-side.
* decouple if else if chain to get more readability.
Thanks,
yuchenlin
yuchenlin (2):
vdi: remove CONFIG
From: yuchenlin
When the condition of each if or else if is true,
the code flow will goto fail. Which means we can decouple
if else if chain to get some readability.
Signed-off-by: yuchenlin
---
block/vdi.c | 27 ++-
1 file changed, 18 insertions(+), 9 deletions(-)
dif
** Changed in: qemu
Status: New => In Progress
** Changed in: qemu (Ubuntu)
Status: New => In Progress
--
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1783362
Title:
qemu-user: mmap sh
From: Gonglei
The virtio crypto device is a virtual crypto device (ie. hardware
crypto accelerator card). Currently, the virtio crypto device provides
the following crypto services: CIPHER, MAC, HASH, and AEAD.
In this patch, CIPHER, MAC, HASH, AEAD services are introduced.
VIRTIO-153
Signed-o
This is the specification about the new virtio crypto device.
---
v24 -> v23
- Some enhancements based on Halil's suggestion. [Halil]
v23 -> v22
- rename MUX_MODE to REVISION_1 [Halil]
- fixed-length paramenters' instead of 'header' and
'variable-length parameters' instead of 'extra paramet
From: Gonglei
Add the conformance targets and clauses for
virtio-crypto device.
Signed-off-by: Gonglei
Signed-off-by: Zhoujian
Signed-off-by: Longpeng(Mike)
---
conformance.tex | 29 +
1 file changed, 29 insertions(+)
diff --git a/conformance.tex b/conformance.te
Signed-off-by: Leonid Bloch
---
docs/qcow2-cache.txt | 9 ++---
qapi/block-core.json | 6 +++---
qemu-options.hx | 15 +--
3 files changed, 18 insertions(+), 12 deletions(-)
diff --git a/docs/qcow2-cache.txt b/docs/qcow2-cache.txt
index 8a09a5cc5f..fd9a6911cc 100644
--- a/
This series makes the qcow2 L2 cache cover the entire image by default.
The importance of this change is in noticeable performance improvement,
especially with heavy random I/O. The memory overhead is very small:
only 1 MB of cache for every 8 GB of image size. On systems with very
limited RAM the
Sufficient L2 cache can noticeably improve the performance when using
large images with frequent I/O. The memory overhead is not significant,
as the cache size is only 1 MB for each 8 GB of virtual image size (with
the default cluster size of 64 KB). On systems with limited memory, one
can limit th
The caches are now recalculated upon image resizing. This is done
because the new default behavior of assigning a sufficient L2 cache to
cover the entire image implies that the cache will still be sufficient
after image resizing. To put a limit on the cache, the options
cache-size and l2-cache-size
Signed-off-by: Leonid Bloch
---
block/qcow2.c | 2 +-
tests/qemu-iotests/103.out | 4 ++--
tests/qemu-iotests/137.out | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/block/qcow2.c b/block/qcow2.c
index 6162ed8be2..ec9e6238a0 100644
--- a/block/qcow2.c
+++ b/blo
Adds /roms/vgabios to .gitignore - this directory appears after the
build, and was not ignored by Git so far.
Signed-off-by: Leonid Bloch
---
.gitignore | 1 +
1 file changed, 1 insertion(+)
diff --git a/.gitignore b/.gitignore
index 5668d02782..2b3b30ae9f 100644
--- a/.gitignore
+++ b/.gitigno
Signed-off-by: Leonid Bloch
---
block/qcow2.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/block/qcow2.c b/block/qcow2.c
index ec9e6238a0..223d351e40 100644
--- a/block/qcow2.c
+++ b/block/qcow2.c
@@ -3646,6 +3646,8 @@ static int coroutine_fn
qcow2_co_truncate(BlockDriverState *bs, int6
This is mandated by the ohci specification. It tells at 6.4.4 on page 104
that for transfer descriptors that are retired with an error the done
queue interrupt counter is cleared as if the interrupt delay field of the
descriptions were zero.
Before this change, error conditions were handled simila
On 2018-07-28 06:32, Jeff Cody wrote:
> On Wed, Jul 25, 2018 at 05:01:44PM +0100, Daniel P. Berrangé wrote:
>> On Wed, Jul 25, 2018 at 10:56:48AM -0500, Eric Blake wrote:
>>> On 07/25/2018 10:10 AM, Markus Armbruster wrote:
qemu_rbd_parse_filename() builds a keypairs QList, converts it to JSON
The following changes since commit 18a398f6a39df4b08ff86ac0d38384193ca5f4cc:
Update version for v3.0.0-rc2 release (2018-07-24 22:06:31 +0100)
are available in the Git repository at:
https://people.debian.org/~sthibault/qemu.git tags/samuel-thibault
for you to fetch changes up to 176e867283
Hello,
aoa...@google.com, le sam. 28 juil. 2018 21:54:26 -0400, a ecrit:
> From: Andrew Oates
>
> On Linux, SOCK_DGRAM+IPPROTO_ICMP sockets give only the ICMP packet when
> read from. On macOS, however, the socket acts like a SOCK_RAW socket
> and includes the IP header as well.
>
> This chang
From: Andrew Oates
On Linux, SOCK_DGRAM+IPPROTO_ICMP sockets give only the ICMP packet when
read from. On macOS, however, the socket acts like a SOCK_RAW socket
and includes the IP header as well.
This change strips the extra IP header from the received packet on macOS
before sending it to the
Thanks, Yan.
On Sun, Jul 29, 2018 at 7:44 AM Yan Vugenfirer wrote:
>
>
>
> > On 26 Jul 2018, at 05:53, Jintack Lim wrote:
> >
> > Hi Peter,
> >
> > On Tue, Jul 24, 2018 at 1:55 AM Peter Xu wrote:
> >>
> >> On Mon, Jul 23, 2018 at 04:13:18PM -0400, Jintack Lim wrote:
> >>> Hi,
> >>>
> >>> I'm ru
> On 26 Jul 2018, at 05:53, Jintack Lim wrote:
>
> Hi Peter,
>
> On Tue, Jul 24, 2018 at 1:55 AM Peter Xu wrote:
>>
>> On Mon, Jul 23, 2018 at 04:13:18PM -0400, Jintack Lim wrote:
>>> Hi,
>>>
>>> I'm running a Windows VM on top of KVM on x86, and one of virtio-net
Hi,
What Windows OS are
On 28 July 2018 at 17:36, Richard Henderson
wrote:
> On 07/27/2018 04:49 PM, Alistair Francis wrote:
>> Allow QEMU to be built to run on a RISC-V host.
>>
>> QEMU does not yet have a RISC-V TCG or user mode target port, but
>> running other architectures on RISC-V using TCI does work.
>>
>> Signed
36 matches
Mail list logo