Thomas Huth <th...@redhat.com> writes: > On 07/27/2018 05:13 PM, Markus Armbruster wrote: >> Signed-off-by: Markus Armbruster <arm...@redhat.com> >> --- >> tests/libqtest.c | 12 ++++++------ >> tests/libqtest.h | 4 ++-- >> 2 files changed, 8 insertions(+), 8 deletions(-) >> >> diff --git a/tests/libqtest.c b/tests/libqtest.c >> index a0d44793fa..3706f30aa2 100644 >> --- a/tests/libqtest.c >> +++ b/tests/libqtest.c >> @@ -538,7 +538,7 @@ QDict *qmp_fdv(int fd, const char *fmt, va_list ap) >> return qmp_fd_receive(fd); >> } >> >> -QDict *qtest_qmpv(QTestState *s, const char *fmt, va_list ap) >> +QDict *qtest_vqmp(QTestState *s, const char *fmt, va_list ap) > > Unless you also add something to our coding conventions which mandates > the naming to be always this way, I think this is just unnecessary code > churn.
Consistency isn't "necessary", but it helps. Tree-wide consistency would be nice, but my aim right now is local consistency in libqtest.h. Four out of its six functions taking va_list are sensibly named. This patch renames the remaining two. Well worth the diffstat, in my opinion.