[EMAIL PROTECTED] wrote:
> Hi Rüdiger,
>
> Thanks for your message. I liked your approach and I've been trying
> something along exactly these sorts of lines, but I have a few
> problems and queries.
>
> The first problem is that the id of the frame object can be re-used,
> so for example this
Hi Rüdiger,
Thanks for your message. I liked your approach and I've been trying
something along exactly these sorts of lines, but I have a few
problems and queries.
The first problem is that the id of the frame object can be re-used,
so for example this code (where I haven't defined InstanceTrac
Well as I understand your problem now,
you would not like all instances of an specific object that are still alive,
but all references to an object (created somewhere, sometimes) in an local
context (stack frame),
that are accessible from 'that' context ( but also from many others).
However in pyt
that this
approach forces you to use what are essentially global variables,
whereas the searching through the stack method allows you to use the
structure of the program to organise what objects each 'magic'
function sees. Is this a good idea or not? I'm not entirely sure. I
think th
Steven D'Aprano:
> As simple as the above is, it could be made simpler. Judging from the
> example given, the Bigobj constructor doesn't need a keyword argument,
> it could just as easily take an arbitrary number of arguments:
> bigobj = Bigobj(obj1, obj2, obj3, obj4...)
I agree; "Things should be
On Fri, 11 Jan 2008 08:29:18 -0800, dg.google.groups wrote:
> Hi all,
>
> I'm part of a small team writing a Python package for a scientific
> computing project. The idea is to make it easy to use for relatively
> inexperienced programmers. As part of that aim, we're using what we're
> calling 'm
t; But that leaves me in a position where I can't understand your
> complaint. There's no reason I can see for the sort of compromise you
> ask for.
What compromise do you think I'm asking for?
I'm suggesting that the scientists be given a brief, introductory
education
On Jan 11, 8:40 pm, Steven D'Aprano <[EMAIL PROTECTED]
cybersource.com.au> wrote:
> Read the OP's post again. His (her?) users aren't expected to create the
> toolkit, merely to use it. To create good toolkits you need both a master
> programmer and an expert in the field. It is an advantage if th
On Fri, 11 Jan 2008 17:36:10 -0800, Michael Tobis wrote:
> On Jan 11, 6:15 pm, Steven D'Aprano <[EMAIL PROTECTED]
> cybersource.com.au> wrote:
>> Your users are *scientists*, and you don't trust their intellectual
>> ability to learn a programming language as simple as Python?
>>
>> Instead of spe
On Jan 11, 6:15 pm, Steven D'Aprano <[EMAIL PROTECTED]
cybersource.com.au> wrote:
> Your users are *scientists*, and you don't trust their intellectual
> ability to learn a programming language as simple as Python?
>
> Instead of spending time and effort writing, debugging and maintaining
> such a
On Fri, 11 Jan 2008 08:29:18 -0800, dg.google.groups wrote:
> Hi all,
>
> I'm part of a small team writing a Python package for a scientific
> computing project. The idea is to make it easy to use for relatively
> inexperienced programmers.
...
> This is fine, but we decided that for clarity o
[EMAIL PROTECTED] writes:
> obj1 = Obj(params1)
> obj2 = Obj(params2)
> ...
> run()
>
> The idea is that the run() function inspects the stack, and looks for
> object which are instances of class Obj, creates a Bigobj with those
> objects and calls its run() method.
>
> So, any comments on that
[EMAIL PROTECTED] wrote:
> Hi all,
>
> I'm part of a small team writing a Python package for a scientific
> computing project. The idea is to make it easy to use for relatively
> inexperienced programmers. As part of that aim, we're using what we're
> calling 'magic functions', and I'm a little b
On Jan 11, 4:29 pm, [EMAIL PROTECTED] wrote:
> Hi all,
>
> I'm part of a small team writing a Python package for a scientific
> computing project. The idea is to make it easy to use for relatively
> inexperienced programmers. As part of that aim, we're using what we're
> calling 'magic functions',
On Fri, 11 Jan 2008 08:29:18 -0800 (PST) [EMAIL PROTECTED] wrote:
> Hi all,
>
> I'm part of a small team writing a Python package for a scientific
> computing project. The idea is to make it easy to use for relatively
> inexperienced programmers. As part of that aim, we're using what we're
> call
Hi all,
I'm part of a small team writing a Python package for a scientific
computing project. The idea is to make it easy to use for relatively
inexperienced programmers. As part of that aim, we're using what we're
calling 'magic functions', and I'm a little bit concerned that they
are dangerous c
16 matches
Mail list logo