Re: Avoid converting functions to methods in a class

2010-02-23 Thread Daniel Fetchinson
> I have a convention when writing unit tests to put the target of the test > into a class attribute, as follows: > > class MyTest(unittest.TestCase): > target = mymodule.someclass > > def test_spam(self): > """Test that someclass has a spam attribute.""" > self.failUnless(h

Re: Avoid converting functions to methods in a class

2010-02-23 Thread Jean-Michel Pichavant
Steven D'Aprano wrote: I have a convention when writing unit tests to put the target of the test into a class attribute, as follows: class MyTest(unittest.TestCase): target = mymodule.someclass def test_spam(self): """Test that someclass has a spam attribute.""" self.fa

Re: Avoid converting functions to methods in a class

2010-02-20 Thread Arnaud Delobelle
On 20 Feb, 03:33, Steven D'Aprano wrote: > I have a convention when writing unit tests to put the target of the test > into a class attribute, as follows: > > class MyTest(unittest.TestCase): >     target = mymodule.someclass > >     def test_spam(self): >         """Test that someclass has a spam

Re: Avoid converting functions to methods in a class

2010-02-19 Thread Ben Finney
Steven D'Aprano writes: > I have a convention when writing unit tests Incidentally, you may be interested in the specific forum for testing in Python http://lists.idyll.org/listinfo/testing-in-python> that is a good resource for asking questions like this. > to put the target of the test into a

Re: Avoid converting functions to methods in a class

2010-02-19 Thread Chris Colbert
this is somewhat hackish: In [1]: def test(): ...: print 'spam' ...: ...: In [20]: class Ham(): : target = {'target': test} : def test_eggs(self): : self.target['target']() : : In [21]: h = Ham() In [22]: h.test_eggs() spam On Fr

Avoid converting functions to methods in a class

2010-02-19 Thread Steven D'Aprano
I have a convention when writing unit tests to put the target of the test into a class attribute, as follows: class MyTest(unittest.TestCase): target = mymodule.someclass def test_spam(self): """Test that someclass has a spam attribute.""" self.failUnless(hasattr(self.tar