[pve-devel] [PATCH manager] gui: TFAEdit: use viemodel binding for hiding/showing qr code

2020-02-06 Thread Dominik Csapak
and verification textfield. this fixes the issue that on the 'user menu' we accidentally showed the qr code and verification field, even if the user already had a totp code now it shows 'Unchanged' like when opened via dc/UserView Signed-off-by: Dominik Csapak --- www/manager6/dc/TFAEdit.js |

Re: [pve-devel] [RFC guest-common 1/16] Implement update_volume_ids and add required helpers: foreach_volume and print_volume

2020-02-06 Thread Fabian Ebner
On 2/5/20 10:29 AM, Fabian Grünbichler wrote: On January 29, 2020 2:29 pm, Fabian Ebner wrote: This function is intened to be used after doing a migration where some of the volume IDs changed. Signed-off-by: Fabian Ebner --- PVE/AbstractConfig.pm | 61

Re: [pve-devel] [RFC guest-common 1/16] Implement update_volume_ids and add required helpers: foreach_volume and print_volume

2020-02-06 Thread Fabian Ebner
On 2/5/20 10:38 AM, Fabian Grünbichler wrote: On January 29, 2020 2:29 pm, Fabian Ebner wrote: This function is intened to be used after doing a migration where some of the volume IDs changed. forgot to ask this - this is in AbstractConfig because you intend to also re-use this for a similar f

Re: [pve-devel] [RFC storage 6/16] pvesm import: allow specifying storage+vmid instead of full volumeid

2020-02-06 Thread Fabian Ebner
On 2/5/20 11:50 AM, Fabian Grünbichler wrote: On January 29, 2020 2:30 pm, Fabian Ebner wrote: Extends the API so that 'volume' can also only be a storage identifier. In that case the VMID needs to be specified as well. In 'import_volume' a new name for the allocation is determined. This is usef

Re: [pve-devel] [RFC guest-common 1/16] Implement update_volume_ids and add required helpers: foreach_volume and print_volume

2020-02-06 Thread Fabian Grünbichler
On February 6, 2020 9:42 am, Fabian Ebner wrote: > On 2/5/20 10:29 AM, Fabian Grünbichler wrote: >> On January 29, 2020 2:29 pm, Fabian Ebner wrote: >>> This function is intened to be used after doing a migration where some >>> of the volume IDs changed. >>> >>> Signed-off-by: Fabian Ebner >>> ---

[pve-devel] [PATCH 0/5] Fix deprecated QMP commands and clean up

2020-02-06 Thread Stefan Reiter
We were using some long deprecated QMP commands in our qemu-server module, most of which can easily be replaced by their successors. All of the changes are compatible down to QEMU 2.4[*] according to docmentation, and since only QMP commands (no machine config) is affected, no guarding is necessar

[pve-devel] [PATCH qemu-server 2/5] qmp: use 'blockdev-change-medium' instead of generic 'change'

2020-02-06 Thread Stefan Reiter
...and cleanup surrounding code a bit. 'change' is deprecated, and according to the qapi definition in QEMU it is 'strongly recommended' to avoid using it. Signed-off-by: Stefan Reiter --- PVE/QemuServer.pm | 12 +--- 1 file changed, 9 insertions(+), 3 deletions(-) diff --git a/PVE/Qem

[pve-devel] [PATCH qemu-server 1/5] Remove unused $force parameter

2020-02-06 Thread Stefan Reiter
The fixme got it right :) Signed-off-by: Stefan Reiter --- PVE/QemuServer.pm | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/PVE/QemuServer.pm b/PVE/QemuServer.pm index 9296634..9e00c8a 100644 --- a/PVE/QemuServer.pm +++ b/PVE/QemuServer.pm @@ -4865,7 +4865,7 @@ sub vmc

[pve-devel] [PATCH qemu-server 3/5] qmp: use 'id' parameter instead of 'device'

2020-02-06 Thread Stefan Reiter
'device' is deprecated since 2.8 in favor of 'id' [0], but since we always consistently set the id on our drives anyway we can substitute it easily. [0] see files qapi/block.json and qapi/block-core.json in QEMU source code, the online documentation doesn't mention it AFAICT Signed-off-by: Stefan

[pve-devel] [PATCH qemu-server 5/5] qmp: use query-cpus-fast for hotplug

2020-02-06 Thread Stefan Reiter
query-cpus has been deprecated since 2.12.0 [0] in favor of query-cpus-fast, which no longer incurs a guest performance penalty on the guest. The returned information is the same as far as our use case is concerned. [0] https://qemu.weilnetz.de/doc/qemu-doc.html#Deprecated-features Signed-off-by:

[pve-devel] [PATCH qemu-server 4/5] qmp: use migrate-set-parameters in favor of deprecated options

2020-02-06 Thread Stefan Reiter
migrate_set_downtime, migrate_set_speed and migrate-set-cachesize have all been deprecated since 2.8 or 2.11 [0]. They still work, but no reason not to use the correct version. Note that the downtime-limit parameter switched from seconds to milliseconds, so convert to that. Slightly improve log ou

Re: [pve-devel] [PATCH v2 docs] rewrite and extend pct documentation

2020-02-06 Thread Oguz Bektas
hi, any update here? On Tue, Jan 14, 2020 at 05:47:01PM +0100, Oguz Bektas wrote: > * rephrase some parts. > * update old information > * add info about pending changes and other "new" features > > Co-Authored-by: Aaron Lauterer > Signed-off-by: Oguz Bektas > --- > > v1->v2: > changed some of

[pve-devel] [PATCH manager 1/4] Fix error message

2020-02-06 Thread Fabian Ebner
Signed-off-by: Fabian Ebner --- www/manager6/window/Snapshot.js | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/www/manager6/window/Snapshot.js b/www/manager6/window/Snapshot.js index 3b1070a2..32a66fda 100644 --- a/www/manager6/window/Snapshot.js +++ b/www/manager6/window/Sna

[pve-devel] [PATCH manager 2/4] Use 'isCreate' instead of 'snapname' to determine window layout

2020-02-06 Thread Fabian Ebner
Signed-off-by: Fabian Ebner --- www/manager6/window/Snapshot.js | 24 1 file changed, 12 insertions(+), 12 deletions(-) diff --git a/www/manager6/window/Snapshot.js b/www/manager6/window/Snapshot.js index 32a66fda..e4355106 100644 --- a/www/manager6/window/Snapshot.js ++

[pve-devel] [PATCH manager 3/4] Hide 'Include RAM' when VM isn't running

2020-02-06 Thread Fabian Ebner
Signed-off-by: Fabian Ebner --- www/manager6/tree/SnapshotTree.js | 3 +++ www/manager6/window/Snapshot.js | 4 ++-- 2 files changed, 5 insertions(+), 2 deletions(-) diff --git a/www/manager6/tree/SnapshotTree.js b/www/manager6/tree/SnapshotTree.js index 0636ef68..7b5ac3ed 100644 --- a/www/ma

[pve-devel] [PATCH manager 0/4] Small improvements to snapshot GUI

2020-02-06 Thread Fabian Ebner
There is no need to display 'Include RAM' when the VM is not running. I thought it would make sense to warn users when they take a snapshot where a file system freeze would be needed, but isn't possible. Thanks to Oguz and Stefan for some JavaScript consulting. Fabian Ebner (4): Fix error mess

[pve-devel] [PATCH manager 4/4] Warn about file system state when a freeze would be needed, but isn't possible

2020-02-06 Thread Fabian Ebner
If a snapshot of a running VM is taken and the RAM is not included, the backend checks whether the QEMU Guest Agent is running inside the VM. If it is, it freezes the file system, otherwise the snapshot is taken without freezing, which could lead to an inconsistent file system state in the snapsho

[pve-devel] applied-series: [PATCH 0/5] Fix deprecated QMP commands and clean up

2020-02-06 Thread Thomas Lamprecht
On 2/6/20 10:53 AM, Stefan Reiter wrote: > We were using some long deprecated QMP commands in our qemu-server module, > most > of which can easily be replaced by their successors. > > All of the changes are compatible down to QEMU 2.4[*] according to > docmentation, and since only QMP commands (n

[pve-devel] [PATCH pve-qemu] security patches for libslirp CVE-2020-8608

2020-02-06 Thread Oguz Bektas
original commits and email can be found here[0] A out-of-bounds heap buffer access issue was found in the SLiRP networking implementation of the QEMU emulator. It occurs in tcp_emu() routine while emulating IRC and other protocols due to unsafe usage of snprintf(3) function. A user/process could

Re: [pve-devel] [PATCH container] apply_pending: call cleanup_pending between change/delete loops

2020-02-06 Thread Dominik Csapak
lgtm, did not break anything obvious, and fixed my problem i reported yesterday[0] Tested-By: Dominik Csapak 0: https://pve.proxmox.com/pipermail/pve-devel/2020-February/041548.html On 2/5/20 3:03 PM, Oguz Bektas wrote: instead of calling it while iterating, inbetween the loops is a better p

[pve-devel] applied: [PATCH container] apply_pending: call cleanup_pending between change/delete loops

2020-02-06 Thread Thomas Lamprecht
On 2/6/20 3:48 PM, Dominik Csapak wrote: > lgtm, did not break anything obvious, and fixed my problem i reported > yesterday[0] > > Tested-By: Dominik Csapak > Thanks, with your T-b applied. Oguz, the commit message lacked the total "why it happens" and "why does it get solved" parts. Those ar

Re: [pve-devel] applied: [PATCH container] apply_pending: call cleanup_pending between change/delete loops

2020-02-06 Thread Oguz Bektas
On Thu, Feb 06, 2020 at 04:53:04PM +0100, Thomas Lamprecht wrote: > On 2/6/20 3:48 PM, Dominik Csapak wrote: > > lgtm, did not break anything obvious, and fixed my problem i reported > > yesterday[0] > > > > Tested-By: Dominik Csapak > > > > Thanks, with your T-b applied. Oguz, the commit mess

Re: [pve-devel] applied: [PATCH container] apply_pending: call cleanup_pending between change/delete loops

2020-02-06 Thread Thomas Lamprecht
On 2/6/20 5:13 PM, Oguz Bektas wrote: >> Further, while this resolves the issue of a broken config in general the >> underlying "when are config property values equal" is not solved. I can >> still trigger a fake pending change. For example, assume the following >> config property present and appli

Re: [pve-devel] applied: [PATCH container] apply_pending: call cleanup_pending between change/delete loops

2020-02-06 Thread Oguz Bektas
On Thu, Feb 06, 2020 at 05:15:18PM +0100, Thomas Lamprecht wrote: > On 2/6/20 5:13 PM, Oguz Bektas wrote: > >> Further, while this resolves the issue of a broken config in general the > >> underlying "when are config property values equal" is not solved. I can > >> still trigger a fake pending chan

[pve-devel] applied-series: [PATCH manager 0/4] Small improvements to snapshot GUI

2020-02-06 Thread Thomas Lamprecht
On 2/6/20 1:26 PM, Fabian Ebner wrote: > There is no need to display 'Include RAM' when the VM is not running. > > I thought it would make sense to warn users when they take a snapshot > where a file system freeze would be needed, but isn't possible. > > Thanks to Oguz and Stefan for some JavaScr