I feel if we're going to do anything, we should put a unified description
of privileges and aclitem-reading into section 5.6, and take that material
out of the various places where it lives now. Like the attached, in which
I failed to resist the temptation to wordsmith some stuff as well as m
Hello Amul,
I have a doubt. Please find below the details,
1. autovacuum_vacuum_threshold and autovacuum_analyse_threshold are set at
300
2. autovacuum_vacuum_scale_factor and autovacuum_analyse_scale_face are set
at 300
3. there is table which has only 6 records
4. and the number of updates happ
On Sat, Dec 01, 2018 at 10:51:10AM +, Simon Riggs wrote:
> On Fri, 30 Nov 2018 at 23:08, Michael Paquier wrote:
>> It is not complicated to
>> handle duplicates for xacts and subxacts however holding ProcArrayLock
>> for a longer time stresses me as it is already a bottleneck.
>
> I hadn't re
> Hi,
>
> Could we improve the error message that's output when the subscription
> target relation is a partitioned table? Currently, we get:
>
> ERROR: logical replication target relation "public.foo" is not a table
>
> I think it'd be more helpful to get:
>
> ERROR: "public.foo" is a partit
Hi,
Could we improve the error message that's output when the subscription
target relation is a partitioned table? Currently, we get:
ERROR: logical replication target relation "public.foo" is not a table
I think it'd be more helpful to get:
ERROR: "public.foo" is a partitioned table
DETAIL:
On Mon, Dec 3, 2018 at 11:15 AM John Naylor wrote:
>
> On 12/3/18, Amit Kapila wrote:
> > On Mon, Dec 3, 2018 at 9:46 AM Amit Kapila wrote:
> >>
> >> On Thu, Nov 29, 2018 at 3:07 PM John Naylor wrote:
> >> >
> >>
> > v8 code:
> > +fsm_local_set(Relation rel, BlockNumber new_nblocks)
> > +{
> >
Hi, Evgeniy!
Thanks for working on the feature.
> 28 нояб. 2018 г., в 21:41, Evgeniy Efimkin
> написал(а):
>
> Hello!
> I wrote some tests(it's just 01_rep_changes.pl but for non superuser) and fix
> `DROP TABLE` from subscription. Now old and new tests pass.
>
> 22.11.2018, 16:23, "Evgeniy E
On Thu, Nov 29, 2018 at 8:46 PM Dmitry Dolgov <9erthali...@gmail.com> wrote:
> > On Wed, Oct 10, 2018 at 7:10 PM Chris Travers
> wrote:
> >
> >> More generally, I'd like this material to be code comments. It's the
> >> kind of stuff that gets outdated before long if it's kept separate.
> >
> > T
On 12/3/18, Amit Kapila wrote:
> On Mon, Dec 3, 2018 at 9:46 AM Amit Kapila wrote:
>>
>> On Thu, Nov 29, 2018 at 3:07 PM John Naylor wrote:
>> >
>>
> v8 code:
> +fsm_local_set(Relation rel, BlockNumber new_nblocks)
> +{
> + BlockNumber blkno,
> + cached_target_block;
> +
> + /*
> + * Mark blocks
On Sat, Dec 1, 2018 at 5:12 AM Dmitry Dolgov <9erthali...@gmail.com> wrote:
> > On Thu, Nov 8, 2018 at 4:03 AM Thomas Munro
> > wrote:
> > On Tue, Nov 6, 2018 at 12:42 AM Kuntal Ghosh
> > wrote:
> > > On Thu, Nov 1, 2018 at 8:53 AM Thomas Munro
> > > wrote:
> > > > It passes make check on Unix
> So I do not think a more precise wording harms. Maybe: "prepared: use
> extended query protocol with REUSED named prepared statements" would
> be even less slightly ambiguous.
I like this. But maybe we can remove "named"?
>>>
>>> I also think it makes sense to adjust wording
On 12/3/18, Amit Kapila wrote:
>> During pg_upgrade, skip transfer of FSMs if they wouldn't have been
>> created on the new cluster.
>
> I think in some cases, it won't be consistent with HEAD's behavior.
> After truncate, we leave the FSM as it is, so the case where before
> upgrade the relation
On Fri, Nov 30, 2018 at 05:18:09PM +0900, Michael Paquier wrote:
> No problem with that either. Thanks Noah for the lookup.
And done, without the change for worker_spi.
--
Michael
signature.asc
Description: PGP signature
On Mon, Dec 3, 2018 at 9:46 AM Amit Kapila wrote:
>
> On Thu, Nov 29, 2018 at 3:07 PM John Naylor wrote:
> >
>
v8 code:
+fsm_local_set(Relation rel, BlockNumber new_nblocks)
+{
+ BlockNumber blkno,
+ cached_target_block;
+
+ /*
+ * Mark blocks available starting after the last block number we hav
On Thu, Nov 29, 2018 at 3:07 PM John Naylor wrote:
>
- * Copy/link any fsm and vm files, if they exist
+ *
Copy/link any fsm and vm files, if they exist and if they would
+ * be created in the
new cluster.
*/
- transfer_relfile(&maps[mapnum], "_fsm",
vm_must_add_frozenbit);
+ if (maps[mapnum].r
On 12/1/18, Amit Kapila wrote:
> Can you check whether the number of pages after test are the same with
> and without a patch in this setup?
I did verify that the number of pages was as intended.
-John Naylor
>Alternative HINT message would be something like:
>
>HINT: In a moment you should be able to reconnect to the
> database and restart your transaction.
>
>This could make the meaning of the error (transaction aborted)
>cleaner and might give a better suggestion to t
> "Tom" == Tom Lane writes:
>> except there IS such a reason: if you need (as I do in pl/lua) to
>> wrap the call in a catch block, inside a function which takes the
>> name and so on as a parameter, then you have no option but to do so
>> (since using the macro errors out on the non-cons
> "Tom" == Tom Lane writes:
Tom> I don't buy that argument. We use psql's normal display in all the
Tom> regular regression tests, and it's not a big maintenance problem.
The regular regression tests have the advantage that they don't need to
work across pg versions.
It is more of a probl
>From: Tatsuo Ishii [mailto:is...@sraoss.co.jp]
>
>Hi Ideriha-san,
>
> Hi, it makes sense to me. One can submit transaction again same as
> other cases you mentioned.
>
> I didn't attach the patch but according to my simple experiment in
> psql the output would become the follow
On Sat, Dec 01, 2018 at 12:47:13PM +0100, Dmitry Dolgov wrote:
> Just for the information, looks like part of this patch (or at least some
> similar code), related to the tests in 002_actions.pl, was committed recently
> in 5c99513975, so there are minor conflicts with the master.
What what I can
On Sat, Dec 01, 2018 at 06:24:47PM +0100, Dmitry Dolgov wrote:
> I've turned off my spam machine and wanted to share some results:
Thanks for doing the work of this commit fest, Dmitry! This is a
difficult task.
> * I also noticed, that a lot of people add themselves as reviewers without
> act
On Thu, Nov 29, 2018 at 10:51:40PM -0800, Noah Misch wrote:
> On Thu, Nov 29, 2018 at 01:10:57PM +0100, Dmitry Dolgov wrote:
> > As a side note, with this patch recovery tests are failing now on 016_shm.pl
> >
> > # Failed test 'detected live backend via shared memory'
> > # at t/016_shm.pl li
On Thu, Nov 29, 2018 at 11:00:11AM +0900, Michael Paquier wrote:
> I am attaching the patch I would like to commit to close this thread,
> which has as single change TAP_TESTS commented out in contrib/bloom/ to
> not explode the buildfarm. Any objections to that?
And I gave this stuff another sho
>> I thought we prefer "on/off" rather than "true/false" for boolean
>> parameter values in postgresql.conf. Should we change them to "on/off"?
>
> +1 for on/off
I found a few more
places where true/false is used other than
ssl_passphrase_command_supports_reload in config.sgml.
Attached is a patc
On Sat, Dec 1, 2018 at 9:46 AM Justin Pryzby wrote:
> elog(FATAL,
> "dsa_allocate could not find %zu free
> pages", npages);
> + abort()
If anyone can reproduce this problem with a debugger, it'd be
interesting to see
Hello.
It is really nice feature. I am working on the project which heavily reads
from replicas (6 of them).
In our case we have implemented some kind of "replication barrier"
functionality based on table with counters (one counter per application
backend in simple case).
Each application backend
On 12/2/2018 2:22 AM, legrand legrand wrote:
I'm also very interested by collecting "search_path" information for
statements,
but this information may not be unique for pg_stat_statements key
(dbid,userid,queryid) ...
How would this 1-N relation be handled ?
1/ just catch initial session_info fo
On Sun, Dec 02, 2018 at 12:09:57PM -0500, Tom Lane wrote:
> Arkhena writes:
> > As a consultant with so many customers that simply install Postgres "out of
> > the box", I think that changing log_destination to 'csvlog' and
> > logging_collector to 'on' needs changing at least log_truncate_on_rota
Currently with 10 head
ERROR: could not determine polymorphic type because input has type unknown
With 9 head
ERROR: could not determine polymorphic type because input has type "unknown"
Another option could be: set display error to none and let user's
script do some regular expression on pdsl v
Arkhena writes:
> As a consultant with so many customers that simply install Postgres "out of
> the box", I think that changing log_destination to 'csvlog' and
> logging_collector to 'on' needs changing at least log_truncate_on_rotation
> (but certainly also log_filename and log_rotation_age) if w
Andrew Gierth writes:
> "Tom" == Tom Lane writes:
> With this change, there is no reason for anybody to call
> AllocSetContextCreateExtended directly, so in HEAD I renamed it to
> except there IS such a reason: if you need (as I do in pl/lua) to wrap
> the call in a catch block, inside a
ne 2. 12. 2018 v 16:56 odesílatel Tom Lane napsal:
> didier writes:
> > Currently on error psql is printing Postgres' PQerrorMessage text, but
> > there's no guarantee these messages are constant between Postgres
> > versions and it's a pain when using psql for writing regression tests,
>
> I do
didier writes:
> Currently on error psql is printing Postgres' PQerrorMessage text, but
> there's no guarantee these messages are constant between Postgres
> versions and it's a pain when using psql for writing regression tests,
I don't buy that argument. We use psql's normal display in all the
ne 2. 12. 2018 v 15:34 odesílatel didier napsal:
> Hi,
>
> Currently on error psql is printing Postgres' PQerrorMessage text, but
> there's no guarantee these messages are constant between Postgres
> versions and it's a pain when using psql for writing regression tests,
>
> Prior
> Disallow set
On Fri, Nov 2, 2018 at 11:55 PM Paul Ramsey wrote:
>
> As threatened, I have also added a patch to left() to also use sliced access.
Hi Paul,
The idea looks good and believing your performance evaluation it seems
like a practical one too.
I had a look at this patch and here are my initial comme
Hi, Dmitry, Daniel!
> 2 дек. 2018 г., в 17:22, Dmitry Dolgov <9erthali...@gmail.com> написал(а):
>
>> There were reviews: Andrey Borodin raised issues with the patch in
>> [2], I spent some time trying it and asked questions about the design
>> in [3], but no one followed up on them within the ne
Hi,
Currently on error psql is printing Postgres' PQerrorMessage text, but
there's no guarantee these messages are constant between Postgres
versions and it's a pain when using psql for writing regression tests,
Prior
Disallow setting client_min_messages higher than ERROR.
a bad workaround was
If I sum it up, we're at 2 against trying to write such a patch and one
for (with some modifications about which markdown format to implement).
Anyone else wants to join the vote?
Cheers,
Lætitia
Le dim. 2 déc. 2018 à 05:11, Pavel Stehule a
écrit :
>
>
> so 1. 12. 2018 v 22:11 odesílatel Dan
> On Sat, Dec 1, 2018 at 9:08 PM Daniel Verite wrote:
>
> Dmitry Dolgov wrote:
>
> > As a side note, I'm a bit confused, who is the original author of
> > the proposed patch? If it's Marina, why she isn't involved in the
> > discussion or even mentioned in the patch itself?
>
> The origina
On Sun, Dec 2, 2018 at 1:25 AM Tatsuo Ishii wrote:
>
> In the documentation of ssl_passphrase_command_supports_reload:
>
> configuration reload if a key file needs a passphrase. If this
> parameter is false (the default), then
> :
> :
> running. Setting this parameter to
Hi all,
> Also, in addition to the objections you noted, there's the problem that
> this change requires changing logging_collector to default to "on".
> That's an *enormous* compatibility break, because of the effects on
> where the log output goes.
>
As a consultant with so many customers that
I'm also very interested by collecting "search_path" information for
statements,
but this information may not be unique for pg_stat_statements key
(dbid,userid,queryid) ...
How would this 1-N relation be handled ?
1/ just catch initial session_info for each (dbid,userid,queryid),
2/ adding a sessi
43 matches
Mail list logo