Damian Conway <[EMAIL PROTECTED]> writes:
>
> From a Perl 6 perspective, it seems likely that C<%_> will be the name
>commonly used for the "slurpy hash" of a subroutine. Just as C<@_> will often
>be the name used for the "slurpy array". See Exegesis 6 for more details.
>
>Indeed, when it comes t
We have been discussing how to pass data to Tk callbacks.
In particular Entry widget validation routines.
There are a number of items that they _might_ be interested in
but a typical routine would only use a few.
Currently it passes them all as positional parameters.
One idea that occured to me/
a pain to support,
and most of the perl5.6 fails were due to XS-ness tweaks (PERL_POLLUTE).
--
Nick Ing-Simmons
http://www.ni-s.u-net.com/
< < is what it takes «here». But I don't see why AltGr < should
not work (SuSE Linux's keymap is so un-mnemonic compared to Sun's compose
key scheme).
--
Nick Ing-Simmons
who is looking for a new job see http://www.ni-s.u-net.com/
adjective, not a noun.
>>
>> make more sense than
>>
>> $thing is property
>
>"$foo has true" doesn't flow as well as "$foo is true". Dunno quite
>what the other expected uses are.
--
Nick Ing-Simmons
who is looking for a new job see http://www.ni-s.u-net.com/
Larry Wall <[EMAIL PROTECTED]> writes:
>Then Perl language variants could go the other way and be:
>
>Pern Nano Perl
Network perl - then we can say "here be dragons - but friendly ones..."
--
Nick Ing-Simmons
g without good reason, but this /is/ good reason. CAN SOMBODY
>PLEASE TELL ME A _GOOD_ REASON TO SWITCH TO . FOR METHOD CALLS?
One reason I have heard is that COM (Common Object Model) documents
incantations to call up external objects in VBish thing.whatnot.attrib
style. Not having to s/\./-&g
TH=/some/long:/bunch/of:/stuff
>>PATH="${PATH}:/more/stuff"
>>
>>would really be a shame.
>
>A backslash at the end of a line?
>
>Kidding!
Obviously you meant a '+' in column 6 of the continuation line ;-)
--
Nick Ing-Simmons
who is looking for a new job see http://www.ni-s.u-net.com/
t; presumably fail and return undef.
>>
>> Oops sorry that is perl5 ;-)
>
>Which part? "Presumably", "fail", "undef" ? ;-)
Well no one has written PerlIO::URL yet so all you get is:
nick@dromedary 507$ cd /home/perl5/perlio
nick@dromedary 508$ ./
.
Why not have URL.pm look for the appropriate module PerlIO::URL::fax
say - as I recall that is what LWP does in the mundane perl5.003 world.
>
>Z.
--
Nick Ing-Simmons
he semantics of /^mailto:/.
If it does it can do DNS lookup for MX record for north.pole and
presumably fail and return undef.
Oops sorry that is perl5 ;-)
--
Nick Ing-Simmons
uncall compare (cdr x) (cdr y)))
>)
> )
> )
So can you write that in perl5 rather than LISP?
If not what does perl6 need so we can write it in perl6.
sub Schwartzian
{
...
}
>
>Do you see any ESP there? Do you see any parsing of arbitrary pieces of
>code? No, me neither.
--
Nick Ing-Simmons <[EMAIL PROTECTED]>
Via, but not speaking for: Texas Instruments Ltd.
o we would want to do both if we did either,
>but time() really has no relation to them.
>
>Or, should we just implement usleep() and (for lack of a better name)
snooze() is a better name ;-)
--
Nick Ing-Simmons
I goofed. (EWRONGLIST)
I realise now that I should have said that RFC 328 (and 327) should have
been on this list, not perl-language-data
I had what I thought was a good look at previous RFCs but managed to miss
RFC226 (Selective interpolation in single quotish context.)
What I wanted comments a
)
This is the snag with this - it may noy be 1 : 10
but as in profile example I sent at weekend 1 : 5,833,600
Thus although 'use' occurs a lot as (by definition!) it is only executed once
it is less important than it looks.
--
Nick Ing-Simmons <[EMAIL PROTECTED]>
Via, but not speaking for: Texas Instruments Ltd.
ew'
>>expectation would be to have it become
>> # $foo=1 $baz=2 @bar=(4)
>
>Wouldn't that be $baz = 3, since the middle list would be taken in scalar
>context?
Which has sanely become the length of the list rather than last element.
--
Nick Ing-Simmons
David L . Nicol <[EMAIL PROTECTED]> writes:
>These things sound like perfectly reasonable CPAN modules.
>What's the block prevenenting their implementation w/in the
>perl5 framework?
No one has done it?
--
Nick Ing-Simmons
John Porter <[EMAIL PROTECTED]> writes:
>Nick Ing-Simmons wrote:
>> Ed Mills <[EMAIL PROTECTED]> writes:
>> >
>> >There are many logical reasons for and against the RFC's here, but saying
>> >"it looks like c so it doesn't make it
don't think using years as the
"unit" is right thing to do.
Seconds is my favourite...
--
Nick Ing-Simmons
7;t think anyone made that argument - they have all been
"I hate that in ..." type comments.
I did not work for X, so probably won't for for us - _is_ a valid argument.
We borrow what works not what doesn't!
>
--
Nick Ing-Simmons
t;meaningful (such as filehandle)? So that seems to be nothing unique to
>>=>. You
>>could just as well say
>>
>> bareword, $whatever
>>
>>and get the same effect in perl5!
>
>Have you used strict lately? :-)
It also matters in this case:
sub bareword { }
foo(bareword,4);
vs
foo(bareword => 4);
--
Nick Ing-Simmons
say the DST rules because
>they are legislation and fickle, not logic/astronomy and stable.
One of the most amusing of which is that at the UNIX epoch (Jan 1, 1970)
Greenwich (i.e. London) of GMT was not on GMT but BST which that year (or so)
stood for "British Standard Time" not "British Summer Time".
--
Nick Ing-Simmons
hinking of adding "objects" in the implementation of perl.
i.e. perl's primitive "things" (scalars, arrays, hashes) will have 'vtables'
(table of functions that do the work). So in that sense an array as in @foo
can be an "object" at some level of meaning while not being an "object"
at the perl level.
--
Nick Ing-Simmons
that's both inexact and incorrect.
But computer time is always inexact and incorrect - thats why we need NTP.
--
Nick Ing-Simmons
of
>computer programmers?")
You cannot as far as I aware define new operators in C++ - just redefine the
ones you have. I cannot decide that '>|<' is now an operator.
>
>>I guess it's getting too incestuous with the lexer.
That is the root of the problem.
--
Nick Ing-Simmons
Dan Sugalski <[EMAIL PROTECTED]> writes:
>At 06:16 PM 8/9/00 +0000, Nick Ing-Simmons wrote:
>>Dan Sugalski <[EMAIL PROTECTED]> writes:
>> >>
>> >>As an engineer I would really like to know when you are going to
>> >>run out of preci
Peter Scott <[EMAIL PROTECTED]> writes:
>At 06:23 PM 8/9/00 +0000, Nick Ing-Simmons wrote:
>>Damian Conway <[EMAIL PROTECTED]> writes:
>> >Operator overloading is scheduled to be revamped.
>>
>>While I remember - it would be good if overload mechansim
>
al.
>
> Dan
>
>--"it's like this"---
>Dan Sugalski even samurai
>[EMAIL PROTECTED] have teddy bears and even
> teddy bears get drunk
--
Nick Ing-Simmons
Damian Conway <[EMAIL PROTECTED]> writes:
>Operator overloading is scheduled to be revamped.
While I remember - it would be good if overload mechansim
could be extended to cover && and || as well as & and |
with the class deciding if short-circuit happens.
--
Nick Ing-Simmons
Dan Sugalski <[EMAIL PROTECTED]> writes:
>At 11:40 AM 8/5/00 +0000, Nick Ing-Simmons wrote:
>>Damian Conway <[EMAIL PROTECTED]> writes:
>> > > It definitely is, since formats do things that can't be done in
>> modules.
>> >
>> >
t precision, it's resolution. What do you do if your timers return
>values in 1/10ths of a second?
What is the problem with that?
--
Nick Ing-Simmons
ppens if you make everything
innermost lexical by default.
You get liberal sprinkling of
upvar 2 foo
global fred harry
etc.
The problem is you quite often whant variables to cross {} boundaries,
if any mention of thing on left declares it in current scope you
end up with "upvar" and "global" to say "no I don't mean that".
--
Nick Ing-Simmons
>at least in perl5...
Well Larry has been using
my Dog $spot;
for a while.
But I just realized if $ is one of something, @ sereral etc.
then do we need a magic char to designate 'type' (class or whatever).
I suppose:
my ¢Dog $spot; # That is "cent" i.e. c with line.
might do ;-)
--
Nick Ing-Simmons
Michael Mathews <[EMAIL PROTECTED]> writes:
>Jonathan Scott Duff said
>> Status: tabled # shelved, put away for now
Please avoid 'tabled' - it means near the opposite in the UK.
To table something is to put it "on the table" i.e. open for discussion.
--
Nick Ing-Simmons
omething bits of mantissa.
That is more precision than you have in the real world.
--
Nick Ing-Simmons
English had the same problem for 100s of years - all the serious
stuff was done in latin (or even french).
--
Nick Ing-Simmons
ill still return "true"
>(a handle) or "false" (undef).
You loose one little thing - you have a new scalar (the handle)
with
open $fh,$filename
one can re-use an existing thing to which someone else may have a reference.
(Not that that is useful very often.)
--
Nick Ing-Simmons
>returning an array as an entity is to return a reference to it - \@a.
>
>Have I got that straight?
At the perl level yes. The core C can push an AV * on the stack
but perl does not know what it means. (Tk did this for a while
internally before I decided to comply with the perl semantics.)
--
Nick Ing-Simmons
in "time"
>It is not, that's lexical values. It is scoped in time. I think
>it's name should refelect that. "temporary"?
>
> temporary $/ = "\n";
>
>It's a mouthful. But it's going where I'd want it to go.
--
Nick Ing-Simmons
Damian Conway <[EMAIL PROTECTED]> writes:
> > It definitely is, since formats do things that can't be done in modules.
>
>Such as???
Quite.
Even in perl5 an XS module can do _anything at all_.
--
Nick Ing-Simmons
the Tk-ish pipe.
It is the "return path" that bothers me - and of course the thread behind
the co routine still has locking issues if it updates "global" state.
--
Nick Ing-Simmons
We could do a deep
>DS> clone ala 5.6.0's ITHREADS, or a partial clone, or start new threads with
>DS> empty package stashes. Or any (or all) combinations of the above.
>
>
>Please explain what the utility of having unshared variables?
Thread local storage - is often what you want most of.
>I might
>as well just fork().
That assumes you can fork() ...
>
>
--
Nick Ing-Simmons
Buddha Buck <[EMAIL PROTECTED]> writes:
>
>The one concern I would raise about this is that a common use of multi-line
>comments is to dyke out code.
What is wrong with
if (0) {
}
(and of course teaching op builder not to build them in this case).
--
Nick Ing-Simmons
line disciplines, we need a built-in stdio replacement.
>Full ground-up rewrite, like sfio but Perlish.
I think that is almost a given - we have been on verge of doing it for
perl5 for years.
--
Nick Ing-Simmons
t;nice when generating classes from a template. I hope typeglobs go in the
>washing machine instead of the bathtub. But, I don't mind it they are hard
>to recognize when they come back.
What _should_ symbol table access look like to the perl programmer?
--
Nick Ing-Simmons <[E
ethod" -
which for normal case would be pointer to blue-white-hot "NoOp" function
which is near always in-cache, for a typed var it could be a slow
as you wanted...
--
Nick Ing-Simmons
rl.exe
they will of course be provided in perl6.tar.gz
We need a quick glossary:
perl core:
perl.exe + perl.dll or .../bin/perl + libperl.so
perl distribution
anything from perl6.tar.gz
Optional module
things in CPAN
--
Nick Ing-Simmons
...
>
> $foo = $unnamed_foo;
>}
>
>Is there something in the behavior of local I'm missing?
There certainly is - that functions _called_ in the scope of the
local see the $unnamed_foo as the value of $foo too.
While hard to get ones brain round at first is is amazingly useful
on occasion.
--
Nick Ing-Simmons
48 matches
Mail list logo