yary not.com-at-gmail.com |Perl 6| wrote:
That was a big part of it... I'm glad Mark posted the APL snippet
because it got me to finally read up on the language that's been at
the back of my mind. Plus it's useful for p6 language discussion. APL
(and a successor, J) may still have a few tricks to
=head1 Runtime Importation
Importing via C also installs names into the current lexical scope by
@@ -188,16 +234,13 @@
You may also import symbols from the various pseudo-packages listed in S02.
They behave as if all their symbols are in the C<:ALL> export list:
-use CONTEXT <$IN $O
Author: lwall
Date: 2009-05-31 08:09:18 +0200 (Sun, 31 May 2009)
New Revision: 26976
Modified:
docs/Perl6/Spec/S11-modules.pod
Log:
[S11] introduce declarators "need" and "defines", components of "use"
Modified: docs/Perl6/Spec/S11-modules.pod
=
On Thu, May 28, 2009 at 5:58 PM, John M. Dlugosz
<2nb81l...@sneakemail.com> wrote:
> I came upon a copy of "A Programming Language" in a similar way. My Dad
> passed it on from a co-worker. I don't recall how young I was, but it was a
> very interesting read. Perhaps this attracts youngsters bec
Larry Wall larry-at-wall.org |Perl 6| wrote:
Indeed, getting "close enough" is one of the underlying design themes
of Perl 6. As to whether we're close to do the operator aliasing in
a mostly digraphic fashion, I'm not sure. Currently a macro for an
infix would be given the AST of the left argu
On Sat, May 30, 2009 at 04:50:02PM -0500, John M. Dlugosz wrote:
> Note that ≥ and ≤ are "bidi mirroring" characters in the Unicode
> Properties. So if someone were crazy enough to use them as brackets,
> then the digraph equivalent should work as well, right?
No, they'd only function as digr
On Sun, May 31, 2009 at 12:22:31AM +0200, Daniel Carrera wrote:
> Mark Overmeer wrote:
>> A pity you didn't want to read the paper.
>
> I have better things to do with my life than read your 30-page paper.
> I'd rather participate in a consensus process where I feel I can make a
> difference.
Daniel Ruoso wrote:
The leap you make from the source package to the different binary
formats is overlooking a lot of details. It would be interesting if you
could take a look in the previous discussions on the matter.
I'll be happy to. I was just trying to make a small iterative step on
Synop
Em Sáb, 2009-05-30 às 22:54 +0200, Daniel Carrera escreveu:
> In the hopes of helping the CPAN discussion move forward, in the
> direction of tangible work, I have made a wiki page with a proposal:
> Please read the "Basics" section, which is quite short. The main point
> of this section is to di
Mark Overmeer wrote:
A pity you didn't want to read the paper.
I have better things to do with my life than read your 30-page paper.
I'd rather participate in a consensus process where I feel I can make a
difference.
Please clarify ... how would you specify that? And how
would you denot
David Green david.green-at-telus.net |Perl 6| wrote:
On 2009-May-29, at 7:53 pm, Darren Duncan wrote:
Thirdly, there are I'm sure a number of other aliases that could be
added to other ops, such as ≤ and ≥ for <= and >=, and ≠ for one of
the inequality operators, although that last one would pr
* Daniel Carrera (daniel.carr...@theingots.org) [090530 20:54]:
> 3) A high-level install tool, analogous to yum or apt, that uses the
> CPAN network and resolves dependencies.
> Mark O. is most interested in (3).
These are all things which I do *not* play in the layers I want to
build. Although
Hello,
In the hopes of helping the CPAN discussion move forward, in the
direction of tangible work, I have made a wiki page with a proposal:
http://wiki.github.com/perl6/misc/cpan-and-package-format
Please read the "Basics" section, which is quite short. The main point
of this section is to
On Sat, May 30, 2009 at 01:09:01PM -0600, David Green wrote:
> I think that one's ambiguous as to whether $bar exists as a key or a
> value.
>
> $bar ∈ @foo; $bar ∈ %foo.keys; $bar ∈ %foo.values; ∃ %foo{bar}
Generally when hashes have been used as sets we've taken the keys
to be the set, not th
It occurs to me that, while I don't want to pull in all the
possible Unicode operators by default, we should make it easy
to do so. Perhaps something like
use *;
should pull in all the Unicode operators. Which if course means that
any golfing would start with
*;
to pull in all the pos
Author: masak
Date: 2009-05-30 21:52:04 +0200 (Sat, 30 May 2009)
New Revision: 26974
Modified:
docs/Perl6/Spec/S29-functions.pod
Log:
[S29-functions] chasing spec changes to C
Modified: docs/Perl6/Spec/S29-functions.pod
===
--- do
On 2009-May-29, at 7:53 pm, Darren Duncan wrote:
Thirdly, there are I'm sure a number of other aliases that could be
added to other ops, such as ≤ and ≥ for <= and >=, and ≠ for
one of the inequality operators, although that last one would
probably make more sense if = was the equality test
Author: lwall
Date: 2009-05-30 21:00:14 +0200 (Sat, 30 May 2009)
New Revision: 26973
Modified:
docs/Perl6/Spec/S12-objects.pod
docs/Perl6/Spec/S31-pragmatic-modules.pod
docs/Perl6/Spec/S32-setting-library/Containers.pod
Log:
s/MONKEY_PATCHING/MONKEY_TYPING/ because it's funnier, and goes
Author: masak
Date: 2009-05-30 20:56:14 +0200 (Sat, 30 May 2009)
New Revision: 26972
Modified:
docs/Perl6/Spec/S05-regex.pod
Log:
[S05-regex.pod] moved ending paren for clarity
Modified: docs/Perl6/Spec/S05-regex.pod
===
--- docs/
On 2009-May-30, at 12:06 pm, David Green wrote:
...what "Perl6" is today, let alone what it will be tomorrow.
Actually, we do kind of know what Perl will look like a decade from
now, because P6 is deliberately extensible enough that we may never
need a Perl 7. But that simply means that ho
On 2009-May-30, at 6:56 am, Andrew Whitworth wrote:
I'm not saying we *can't* create a general repository for all sorts of
nonsense, I'm saying that we *shouldn't*.
"Holiday photos" is just a whimsical example. The problem is that
it's hard enough keeping up with what "Perl6" is today, let a
John M. Dlugosz said [off-list]:
> Darren Duncan darren-at-darrenduncan.net |Perl 6| wrote:
>> I also know that
>> given its current design, === and !=== just happen to have the same
>> semantics as logical xnor and xor when given 2 Bool inputs, and so
>> they serve the purpose. Having distinct xn
Em Sex, 2009-05-29 às 23:37 +0200, Daniel Carrera escreveu:
> Your idea of using CPAN to share holiday pictures is one of the things
> that really turned me off from your CPAN6 proposal.
If you replace "holiday pictures" by 'YAPC pictures', 'Talk slides',
'Code Snippets', 'Perl related scientific
On Sat, May 30, 2009 at 7:56 AM, Mark Overmeer wrote:
> * Andrew Whitworth (wknight8...@gmail.com) [090530 00:24]:
>> I agree. Doing one thing well is so much better for everybody then
>> doing a million things poorly. An assorted "blob of data" repository
>> is far less valuable to the Perl5, Per
On Sat, 30 May 2009, Mark Overmeer wrote:
* Timothy S. Nelson (wayl...@wayland.id.au) [090530 03:11]:
On Fri, 29 May 2009, Alex Elsayed wrote:
Instead, it would go to the distributions, who are already well-prepared to
handle packaging. We'd just be providing the tools and material they need
Assuming you have the right key set in the Registry, you can enter hex
Unicode in Windows. Hold down alt, press the + key on the numpad and
then type the hex code (using the main keyboard and/or the numpad),
then release alt.
On Sat, May 30, 2009 at 2:11 AM, John M. Dlugosz wrote:
> The same tr
* Timothy S. Nelson (wayl...@wayland.id.au) [090530 03:11]:
> On Fri, 29 May 2009, Alex Elsayed wrote:
>> Instead, it would go to the distributions, who are already well-prepared to
>> handle packaging. We'd just be providing the tools and material they need to
>> do so.
>
> Let me reiterate that,
* Andrew Whitworth (wknight8...@gmail.com) [090530 00:24]:
> I agree. Doing one thing well is so much better for everybody then
> doing a million things poorly. An assorted "blob of data" repository
> is far less valuable to the Perl5, Perl6, and Parrot communities then
> a dedicated library reposi
* Timothy S. Nelson (wayl...@wayland.id.au) [090530 02:15]:
>>> * PAUSE6; this is an actual network based on the CPAN6 software (see
>>> above). It also is not documented here.
>> Pause6 is one implementation of archive maintenance software. In the
>> first version written in Perl5, it implemen
> I support the notion of distributing binaries because nobody's gonna
> want to chew up their phone's battery doing unnecessary compiles. The
> ecology of computing devices is different from ten years ago.
And, in fact, binary distribution is something that's been done on CPAN
for quite a whil
jesse wrote:
1) Instead of calling the format "JIB", how about "PAR"? It can stand
for Perl ARchive or the recursive PAR ARchive. This is more memorable.
It might make sense to adopt the same naming as .jar and .epub, two very
different zipfile-as-container formats. Both use a top-level directo
On Fri, 29 May 2009, Daniel Carrera wrote:
Mark Overmeer wrote:
And the next consideration: when we have a piece of software which
administers Perl5 or Perl6 or Nokia.bin or Elf. Why stop there?
What is the overlap? It is basically all just some blob of data with
some associated meta-data to
The same tradition has variations in Windows. I recall the leading zero
means ANSI code page. I thought I recall a way to give more digits and
specify Unicode, but I can't find it on Google.
--John
Timothy S. Nelson wayland-at-wayland.id.au |Perl 6| wrote:
On Fri, 29 May 2009, John M. Dlugo
On Fri, May 29, 2009 at 11:04:38PM +0200, Daniel Carrera wrote:
> Hello,
>
> I finished reading S22 (CPAN [DRAFT]). This synopsis is about the
> package format, not about the network. I have some comments:
>
> 1) Instead of calling the format "JIB", how about "PAR"? It can stand
> for Perl A
On Fri, May 29, 2009 at 08:45:06PM -0700, Darren Duncan wrote:
> So does anyone else have thoughts on that?
Actually, I think ~x is kinda ugly. And I like the mnemonic value of
x returning one thing and xx returning multiple things. And in the
bitwise ops ~ doesn't indicate postprocessing. And
On Fri, May 29, 2009 at 11:06:46PM -0700, Darren Duncan wrote:
> Larry, did you choose = for assignment and == etc for comparison because
> you thought that looked prettier, or because that was the C/etc
> convention that you decided to copy?
Neither beauty nor convention, really. I chose it fo
John M. Dlugosz wrote:
Your nomenclature makes me think you are coming from an APL background.
Actually, I've never used APL.
The main influences for the terminology I use, besides Perl which is my favorite
general purpose language, is the field of relational databases, both the SQL
language
Thoughts:
Your nomenclature makes me think you are coming from an APL background.
!=== is already generated from ===, and compares the identity of any two
objects. It works on binary values since they are value types, but
that's not the "proper" usage, and Perl separates out the concerns.
S
38 matches
Mail list logo