On Sat, 9 Jul 2005, Robin Redeker wrote:
I wasn't thinking 'cool', I was thinking 'visually distinctive and
mnemonic'. I actually think o. is cooler.
Yes, i would like o. more too. At least it doesn't introduce
a completly meaningless '/' preceded by a '.'.
Hmmm... I am one of those who lik
In the old calling scheme the exception object arrived as P5 in the
handler. This doesn't really fit into the new scheme.
I can see two ways to go:
Store the exception (or an array of unhandled exceptions) in the
interpreter and make exceptions available as:
a) e = interpinfo .INTERPINFO_EXC
Hi,
class Foo {}
class Bar is Foo {}
Bar.new.isa(Object);# true
Bar.new.isa(Class); # false
Bar.new.isa(Foo); # true
Bar.new.isa(Bar); # true
# These are clear, I think.
Bar.isa(Object);# true
Bar.isa(Class); # true
Bar.isa(Foo);
Hi,
my $x = 42;
my $y = $x;
$y++;
say $x; # Still 42, of course
class Foo {
has $.data;
method incr () { $.data++ }
# Please fill in appropriate magic here
}
my Foo $x .= new(:data(42));
my Foo $y = $x;
$y.incr();
say $x.data;# Should still be 42
Hi!
On Sun, Jul 10, 2005 at 09:47:43AM -0700, chromatic wrote:
> I have an unreleased module that runs the kwalitee tests and reports the
> results. It works somewhat like Test::Pod and Test::Pod::Coverage.
>
> I haven't tested it with the latest release of M::C::G; domm said there
> might be s
On 7/9/05, Darren Duncan <[EMAIL PROTECTED]> wrote:
>
> At 1:03 AM -0700 7/9/05, Jonathan Leffler wrote:
> >Can you explain which parts of the SQL:2003 mandate this notation?
> >I've had a moderately good poke around my copy of ISO/IEC
> >9075-2:2003 (SQL/Foundation) and cannot find this. I'd like
> driver://user:[EMAIL PROTECTED]:port/instance
>
I haven't been following this too closely, so my apologies
if already mentioned.
This connect string is very much like the new Easy Connect
Naming method in Oracle 10g.
eg. sqlplus scott/[EMAIL PROTECTED]:port/service
Note that it is not 'ins
No - you don't seem to understand. The challenge-response protocol can ask
someone for the RSA key fob number this time, their mother's maiden name the
next time, their employee number the time after that, and nothing on the
fourth occasion. You cannot predict what the extra information requeste
Nik Clayton wrote:
Having been a little more prolific on the module front recently I'm
interesting in making sure that my own modules pass the kwalitee tests.
Preferably before I put them on CPAN.
But poking through qa.perl.org I can't find anywhere that these tests
are actually rigorously d
Ingo,
On Jul 11, 2005, at 9:16 AM, Ingo Blechschmidt wrote:
Hi,
class Foo {}
class Bar is Foo {}
Bar.new.isa(Object);# true
Bar.new.isa(Class); # false
Bar.new.isa(Foo); # true
Bar.new.isa(Bar); # true
# These are clear, I think.
Yes, these all make sense to
Note: The last kwalitee test, the one related to Devel::Cover, is
considered dangerous by a non-trivial percentage of the community,
and there's been a lot of debate on whether it should be removed.
Sorry, I should have said Pod::Test::Coverage.
Regardless, it executes code. I wonder how it de
On Mon, Jul 11, 2005 at 01:39:08PM +0200, Leopold Toetsch wrote:
> I can see two ways to go:
>
> a) e = interpinfo .INTERPINFO_EXCEPTION
>
> b) via the get_params opcode
>
> The latter would reflect the exception call being an internal
> continuation invocation:
>
>push_eh handler
>
Adam Kennedy wrote:
> My god! What is this wonderful module of which you speak?
Text::TypingEffort is available on CPAN.
> Finally a chance to help in the argument that ideas that try to force
> less characters in a huffman-inspired nightmare might make life worse
> from a "actually typing it in
Hi,
Stevan Little wrote:
> On Jul 11, 2005, at 9:16 AM, Ingo Blechschmidt wrote:
>> Bar.isa(Object);# true
>> Bar.isa(Class); # true
>> Bar.isa(Foo); # ? (my guess: false)
>> Bar.isa(Bar); # ? (my guess: false)
>
> I am not sure about this. I think that
In HTML::Widgets::NavMenu I have the following code:
<<<
sub get_coords_while_skipping_skips
{
my $self = shift;
my $callback = shift;
my $coords = shift || $self->get_current_coords(); # line 571
>>>
Now when I run the tests with Devel::Cover it reports the following for line
571 i
On Mon, Jul 11, 2005 at 19:27:52 +0300, Shlomi Fish wrote:
> <<<
> my $coords = shift;
>
> if (!$coords)
> {
> $coords = $self->get_current_coords();
> }
> >>>
A work around:
$coords = scalar(@_) ? shift : $self->get_current_coords();
> I should also note that I have many
>
> my
2005/7/11, Yuval Kogman <[EMAIL PROTECTED]>:
> Coverage reporting is not done for the pretty colors - a human reads
> it, and says "OK, this is logical, get_current_coords always returns
> a true value". It's not a race for greens and percentages.
otherwise it should be called "golf"... :)
--
Jé
On 7/11/05, Ingo Blechschmidt <[EMAIL PROTECTED]> wrote:
> Hi,
>
> my $x = 42;
> my $y = $x;
> $y++;
> say $x; # Still 42, of course
>
>
> class Foo {
> has $.data;
> method incr () { $.data++ }
>
> # Please fill in appropriate magic here
> }
I think it's just `
On 7/11/05, Ingo Blechschmidt <[EMAIL PROTECTED]> wrote:
> class Foo {
> has $.data;
> method incr () { $.data++ }
>
> # Please fill in appropriate magic here
> }
>
> my Foo $x .= new(:data(42));
> my Foo $y = $x;
> $y.incr();
> say $x.data;# Should still be 42
> sa
Ingo,
On Jul 11, 2005, at 12:30 PM, Ingo Blechschmidt wrote:
I am not sure about this. I think that .isa as a class method should
behave much as it does for an instance method. If we start supporting
things like Bar.isa(Class) then we start exposing the soft underbelly
of the meta-model to the o
On Mon, Jul 11, 2005 at 09:46:30AM -0400, Stevan Little wrote:
: Ingo,
:
: On Jul 11, 2005, at 9:16 AM, Ingo Blechschmidt wrote:
: >Hi,
: >
: > class Foo {}
: > class Bar is Foo {}
: >
: > Bar.new.isa(Object);# true
: > Bar.new.isa(Class); # false
: > Bar.new.isa(Foo); # true
:
Hi,
Stevan Little wrote:
> Actually I was thinking that MyClass.isa(...) would work much as it
> did in Perl 5 (like an instance). But that access to the underlying
> MyClass class instance would not be as simple. Something like
> ::MyClass would provide access to the Class instance.
>
>class
Hi,
Larry Wall wrote:
> On Mon, Jul 11, 2005 at 09:46:30AM -0400, Stevan Little wrote:
> : On Jul 11, 2005, at 9:16 AM, Ingo Blechschmidt wrote:
> : > Bar.isa(Object);# true
> : > Bar.isa(Class); # true
> : > Bar.isa(Foo); # ? (my guess: false)
> : > Bar.isa(Bar);
On Mon, Jul 11, 2005 at 11:48:09AM -0600, Luke Palmer wrote:
: Then you don't need any special magic. But if you want to have
: mutator methods that aren't in .= form (which I recommend against for
: value types), maybe the `is value` trait makes the class do the
: `value` role, which gives you a
On Mon, Jul 11, 2005 at 07:38:57PM +0300, Yuval Kogman wrote:
> > So what should I do to eliminate it?
>
> Maybe Just Nothing
>
> The issue is that you can't special case get_current_coords to be
> truish, as far as Devel::Cover is concerned - it might not be.
>
> Any fix that could be thought u
* Adam Kennedy <[EMAIL PROTECTED]> [2005-07-11T10:10:31]
> >Note: The last kwalitee test, the one related to Devel::Cover, is
> >considered dangerous by a non-trivial percentage of the community,
> >and there's been a lot of debate on whether it should be removed.
>
> Sorry, I should have said Po
On Mon, Jul 11, 2005 at 13:17:48 -0700, Michael G Schwern wrote:
> On Mon, Jul 11, 2005 at 07:38:57PM +0300, Yuval Kogman wrote:
>
> I'll make the same argument "no broken windows" argument here that I do
> about warnings and tests: elminate all warnings, even if they are dubious.
> Ensure all
Adrian Howard wrote:
On 8 Jul 2005, at 20:08, Adam Kennedy wrote: [snip]
There's no way to get a listing of the annotations for a given
author id, or even for a given dist. So I'm reduced to manually
looking through a thousand odd web pages to find potential changes
or improvements to the cod
On Mon, Jul 11, 2005 at 11:14:18AM +0200, Michele Dondi wrote:
: Hmmm... I am one of those who likes ./ more, instead. I mean, I _really_
: like it! Thus, how about making '/' less meaningless, i.e. more
: meaningful, in more general situations?!?
Um, do you have a specific proposal? Like maybe
On Mon, 2005-07-11 at 15:16 +0200, Ingo Blechschmidt wrote:
> Bar.new.isa(Object);# true
> Bar.new.isa(Class); # false
> Bar.new.isa(Foo); # true
> Bar.new.isa(Bar); # true
I'd like to go on a tangent to suggest that anyone who uses .isa() in
actual real code ought to
Though, arguably, if one is a true Platonist, one should view roles
as Aristotelian, and base classes as Platonic and therefore more
"real"...but I'm more of an Aristotelian myself, so I tend to think
of the Platonic ideals as less real than reality.
Whatever. Both Plato and Aristotle would proba
Larry~
On 7/11/05, Larry Wall <[EMAIL PROTECTED]> wrote:
> On Mon, Jul 11, 2005 at 11:14:18AM +0200, Michele Dondi wrote:
> : Hmmm... I am one of those who likes ./ more, instead. I mean, I _really_
> : like it! Thus, how about making '/' less meaningless, i.e. more
> : meaningful, in more general
On Mon, Jul 11, 2005 at 01:17:48PM -0700, Michael G Schwern wrote:
> On Mon, Jul 11, 2005 at 07:38:57PM +0300, Yuval Kogman wrote:
> > > So what should I do to eliminate it?
> >
> > Maybe Just Nothing
> >
> > The issue is that you can't special case get_current_coords to be
> > truish, as far as
Michael G Schwern wrote:
What's missing is a way to let Devel::Cover know that a bit of coverage is
not necessary. The first way to do this which pops into my mind is a comment.
my $foo = $bar || default(); # DC ignore X|0
I posted an item about this usage of the "||" operator th
Larry ,
At the risk of essentially signing my own committal papers for the
local looney bin, I have to say that this make sense to me. But I have
a few questions and requests for clarification :)
On Jul 11, 2005, at 3:07 PM, Larry Wall wrote:
On Mon, Jul 11, 2005 at 09:46:30AM -0400, Steva
Ingo,
On Jul 11, 2005, at 3:14 PM, Ingo Blechschmidt wrote:
Hi,
Stevan Little wrote:
Actually I was thinking that MyClass.isa(...) would work much as it
did in Perl 5 (like an instance). But that access to the underlying
MyClass class instance would not be as simple. Something like
::MyClass w
On Jul 11, 2005, at 3:07 PM, Larry Wall wrote:
Bar.meta.does(CLASS)# true
To me this is just code-reuse on the meta-level. Much like in smalltalk:
MetaClass isa
ClassDescription isa
Behavior isa
Object
and:
Class isa
Class
chromatic,
On Jul 11, 2005, at 4:26 PM, chromatic wrote:
On Mon, 2005-07-11 at 15:16 +0200, Ingo Blechschmidt wrote:
Bar.new.isa(Object);# true
Bar.new.isa(Class); # false
Bar.new.isa(Foo); # true
Bar.new.isa(Bar); # true
I'd like to go on a tangent to suggest tha
On Mon, Jul 11, 2005 at 11:22:51PM +0200, Paul Johnson wrote:
> > my $foo = $bar || default(); # DC ignore X|0
> >
> > "Hey, Devel::Cover! Ignore the case where the right side of this logic is
> > false."
>
> I wasn't particularly happy with the idea of needing to change the
> source code j
On Mon, Jul 11, 2005 at 17:33:26 -0400, David Golden wrote:
> Want.pm seems to imply that this might be possible, but I don't
> know the guts of Perl well enough.
Want looks into the opcode tree and looks for context thingies
inside it, so it should be possible as far as I understand from
readi
On Mon, Jul 11, 2005 at 05:33:26PM -0400, David Golden wrote:
> http://rt.cpan.org/NoAuth/Bug.html?id=11304
>
> My suggestion turns on the question of whether it's possible to
> differentiate the context between a true boolean context ( "foo() if $p
> || $q" ) and a "pseudo-boolean" context that
On Mon, Jul 11, 2005 at 02:54:19PM -0700, Michael G Schwern wrote:
> On Mon, Jul 11, 2005 at 11:22:51PM +0200, Paul Johnson wrote:
> > > my $foo = $bar || default(); # DC ignore X|0
> > >
> > > "Hey, Devel::Cover! Ignore the case where the right side of this logic is
> > > false."
> >
> > I
On Mon, 2005-07-11 at 17:47 -0400, Stevan Little wrote:
> I actually agree with you on that. But I would like to clarify it to
> say that:
>
>Foo.isa(Bar) # Foo.meta.isa(Bar) || Foo.meta.does(Bar)
>
> ... meaning that the .isa() which is supposed to be aliased into the
> class from .meta i
Michael G Schwern wrote:
"my $foo = $p || $q" is not boolean. I'm not even sure you can call it
"pseudo-boolean" without understanding the surrounding code. How do you
know that $q can never be false?
The other examples in the ticket play out the same way:
bless {}, ref $class || $class;
$cla
On Mon, Jul 11, 2005 at 07:43:24PM -0400, David Golden wrote:
> I think this is a coverage vs correctness distinction. The idea that I
> was trying to convey is that while these expressions use a boolean
> operator for a shortcut, they aren't really about truth vs. falsity of
> the overall expr
Ricardo SIGNES wrote:
* Adam Kennedy <[EMAIL PROTECTED]> [2005-07-11T10:10:31]
Note: The last kwalitee test, the one related to Devel::Cover, is
considered dangerous by a non-trivial percentage of the community,
and there's been a lot of debate on whether it should be removed.
Sorry, I shoul
On Mon, Jul 11, 2005 at 05:35:41PM -0400, Stevan Little wrote:
: So going away from philosophy 101 here, and back to CS, it could be
: said that a "Class" has-a "MetaClass" (although not in the strict
: user-level-OO sense of the word).
Yes, though I think of it more as delegation. Of course, d
On Sat, 2005-07-09 at 12:42 +0200, Jochen Wiedmann wrote:
> Jonathan Leffler wrote:
>
> > I dunno which DBMS support prepare without a database connection, but I
> > would expect all the mainstream databases to require a database connection.
>
> +1
>
> > I'm also far from convinced that there'
On Mon, Jul 11, 2005 at 04:50:56PM -0400, Matt Fowles wrote:
: Yay! I guess I will take this moment to resuggest @^ as a list of
: invocants and $^ =:= @^[0]. I like how the ^ kinda points you the
: right way, also visually distinctive and doesn't get in the way of
: $_...
I don't see much use f
[EMAIL PROTECTED] wrote:
Michael G Schwern wrote:
you're right that the case of $class being false may be of interest,
but that's not what this common idiom actually does. The code will
blithely pass a false value to bless (with potentially unexpected
results depending on whether $class
(Cross-posting the new ruling from p6l to p6c to discuss implementation
strategy)
On Mon, Jul 11, 2005 at 06:29:28PM -0700, Larry Wall wrote:
> {
> let $Larry.decisive = 1;
>
> Okay, this is what we're gonna do. We're gonna go back pretty close to
> where we were originally, but wit
Paul Johnson wrote:
On Mon, Jul 11, 2005 at 02:54:19PM -0700, Michael G Schwern wrote:
On Mon, Jul 11, 2005 at 11:22:51PM +0200, Paul Johnson wrote:
my $foo = $bar || default(); # DC ignore X|0
"Hey, Devel::Cover! Ignore the case where the right side of this logic is
false.
On Tue, 2005-07-12 at 10:46 +1000, [EMAIL PROTECTED] wrote:
> I'd say this idiom is one of the ones I am most often affected by in the
> work I do for the Kwalitee project - the my$class = ref$proto||$proto;
> idiom in constructors. I usually do the following
>
> 1. Add code to handle the 'both
[EMAIL PROTECTED] wrote:
On Tue, 2005-07-12 at 10:46 +1000, [EMAIL PROTECTED] wrote:
1. Add code to handle the 'both false' case, similiar to
my $class = ref $proto || $proto;
warn 'wrong calling convention for Class::Constructor::new - try
Class::Constructor->new' and return unles
At 6:30 PM -0700 7/11/05, Dean Arnold wrote:
RE: SQL Parse Trees (or other non-SQL query input)
Since none of (ODBC, JDBC, ADO.NET) seems compelled to
impose this concept on driver writers, I don't see why
DBI should be the vanguard.
I should emphasize that I never expected to be able to send a
On Mon, Jul 11, 2005 at 08:28:01PM -0600, Jim Cromie wrote:
> 1. emit a text version of the coverage failures which
> a. has same info as html details - ie line# conditionals, code
> b. starts with a comment.
>
> 2. use that 'exact' format as your ignore directive
> a. except that # means its enti
On 7/8/05, James E Keenan <[EMAIL PROTECTED]> wrote:
> One other curiosum: As a result of my Phalanx work, I've gotten in the
> habit of using File::Temp to create 'anonymous' directories and files in
> which to conduct testing.
This is one of the many features of Test::Cmd, which I a was about
On Mon, Jul 11, 2005 at 10:56:36PM -0400, Ian Langworth wrote:
> This is one of the many features of Test::Cmd, which I a was about to
> recommend. However, I remember being discouraged from using it, but
> I'm not sure from where or whom.
>
> Does anyone use Test::Cmd? Are there features in it th
Yuval asked me off-list if I would comment on the various dispatch algorithms
that have been proposed.
I guess I have used MMD more than most people in this discussion. Indeed,
having both written Class::Multimethods and supervised a PhD that involved
adding MMD to C++, one might have assumed that
On Tue, Jul 12, 2005 at 10:17:01AM +0800, Autrijus Tang wrote:
: On Mon, Jul 11, 2005 at 06:29:28PM -0700, Larry Wall wrote:
: The obvious thought is to have yet another magical, $^H like flag, to
: denote the current dialect. If it is set, then the parser can emit
: .method as $_.method, instead
Darren Duncan wrote:
I should emphasize that I never expected to be able to send any type of
ASTs over the pipe to the database. They would still be interpreted by
the database driver for Perl and/or a wrapper thereon, into the database
native format. Its just that, to an application, it woul
I'd like to add Punie to the Parrot repository. It's a first step
toward a compiler for Perl 1 running on Parrot. Currently it's *very*
simple: it only parses and compiles a single statement printing a
single digit -- but it uses PGE grammars and the stub in ast/ to do it.
Punie is a test case
On Mon, Jul 11, 2005 at 09:35:11PM -0700, Allison Randal wrote:
> I'd like to add Punie to the Parrot repository. It's a first step
> toward a compiler for Perl 1 running on Parrot. Currently it's *very*
> simple: it only parses and compiles a single statement printing a
> single digit -- but it
On Mon, Jul 11, 2005 at 09:04:54PM -0700, Larry Wall wrote:
> On Tue, Jul 12, 2005 at 10:17:01AM +0800, Autrijus Tang wrote:
> : On Mon, Jul 11, 2005 at 06:29:28PM -0700, Larry Wall wrote:
> : The obvious thought is to have yet another magical, $^H like flag, to
> : denote the current dialect. If
On Tue, Jul 12, 2005 at 12:41:00PM +0800, Autrijus Tang wrote:
> Is it Punie's goal to support all of those semantic constructs? If not,
> maybe call it something else than Perl 1, to avoid confusion? :)
(more bikesheding)
If the goal is to demonstrate the capability of the upcoming expression
p
On Jul 11, 2005, at 21:41, Autrijus Tang wrote:
Cool! However, I wonder if Punie is indeed targetting Perl 1.
As Schwern will attest, Perl 1 is a quite complicated language, with
nullary, unary, binary and ternary functions, arrays, hashes, pattern
matches, transliteration, format, loop contro
66 matches
Mail list logo