[again, apologies if this is a duplicate]
* Michael G Schwern <[EMAIL PROTECTED]> [05/04/2001 15:51]:
>
> Oddly enough, varying the number of traffic lights can effect
> efficiency. By over-regulating you can choke off traffic. Constant
> fiddling with the setups and timings, trying to control
On Fri, May 04, 2001 at 03:00:59PM +0100, Michael G Schwern wrote:
> On Fri, May 04, 2001 at 09:51:53AM -0400, John Porter wrote:
> > And btw . . . Wouldn't
> >
> > $thing has property
> >
> > make more sense than
> >
> > $thing is property
>
> "$foo has true" doesn't flow as well as
I know I'm jumping ahead, but here goes...
Built-in classes in Perl 5 and 6 are uppercase: UNIVERSAL, ARRAY, HASH, etc.
By convention, "user" classes are Title::Cased. Simple guideline: don't use
UPPERCASE class names or risk being squished by a later revision of Perl.
Method names *sort of* fo
Stephen P. Potter schrieb am 2001-05-03, 8:46:
> Lightning flashed, thunder crashed and "Matt Youell" <[EMAIL PROTECTED]> wh
> ispered:
> | > What about leaving the flora aund fauna and using a name
> | > like they call ships?
> | > They always got names of females or towns...
> | >
> | > I sugg
On Sat, May 05, 2001 at 01:10:52PM -0400, John Siracusa wrote:
> This problem already exists to some degree in Perl 5. Stuff like isa() and
> can() is already squatting in the lowercase "user method" namespace. But I
> have a feeling that properties will multiply a lot faster than UNIVERSAL
> me
On Saturday 05 May 2001 19:28, Uri Guttman wrote:
> the proposed qh only fails with a key or value of => which is highly
> unlikely and can be worked around as a value by inserting another =>
>
> %foo = qh( foo bar => => baz )
>
> is:
>
> %foo = ( foo => 1, bar => '=>', baz => 1 )
Or
On Sat, May 05, 2001 at 08:49:15PM -0400, Bryan C. Warnock wrote:
> %foo = ( foo => 1, bar => 1, '=>' => 'baz' )
> But I like the concept of a quote hash.
Of course, that could be spelt
%foo = <+foo +bar =>("baz")>;
(Just doing my bit for "use strict :<+refs>")
--
The debate rages on: Is Per
On Sat 05 May, John Siracusa wrote:
> On 5/5/01 3:28 PM, Larry Wall wrote:
> > Well, that's enough brainwracking for the moment. Gloria is making me
> > go eat something...
>
> Bread and water until Apocalypse 33 is done? ;)
At one Apocalypse a month, that is a very long time... Would Larry su
Nathan Wiger writes:
: You know, I was just thinking about this, and I agree with Dan. Actually,
: there's some big problems in trying to get rid of <> and make Perl do the
: "right thing" in boolean context (like the while loop example). Consider:
:
:$FH = open " a shortcut to the
: proposed
On 5/5/01 3:28 PM, Larry Wall wrote:
> I expect the real choice is between <$FOO and <$FOO>. I can convince
> myself pretty easily that a unary < is just another name for "next", or
> "more", or something.
Yeah, but it looks like "previous"! ;)
> maybe I should hold out for «» meaning qw() even
Rocco Caputo wrote:
> $thing's veracity is true.
What about just
$thing is;
--
John Porter
All men are subjects.
On Sat, May 05, 2001 at 04:10:47PM -0400, John Porter wrote:
> Rocco Caputo wrote:
> > $thing's veracity is true.
>
> What about just
> $thing is;
Existence is not the same as essence.
--
Triage your efforts, y'know?
- Thorfinn
Ok, this is long, so here goes...
> I expect the real choice is between <$FOO and <$FOO>. I can convince
> myself pretty easily that a unary < is just another name for "next", or
> "more", or something. On the other hand <$FOO> has history. And if
> one special-cases <$...>, we could also have
> "NW" == Nathan Wiger <[EMAIL PROTECTED]> writes:
NW> As for <> as a qw() replacement, I think there are really two
NW> issues here. First, you're not really talking about a
NW> "replacement", since you're mentioning different semantics. So
NW> qw() will still be widely used. I sugg
At 01:51 AM 5/6/01 +0100, Simon Cozens wrote:
>The debate rages on: Is Perl Bactrian or Dromedary?
It's a Dromedary, it says so in the Colophon.
But maybe the symbol of Perl 6 should be a Bactrian, with the extra hump
symbolizing the increased power.
You knew this was coming...
--
Peter Scott
15 matches
Mail list logo