On Wed, Jan 31, 2001 at 05:51:27PM -0500, John Porter wrote:
> > you *don't* need to remember
> > you are programming in perl5 or perl6, and get the same functionality.
>
> But you need to remember it anyway, so remembering it for time() is
> no added burden.
Uhm. NO! Remembering that $x+1 thing
On Wed, Jan 31, 2001 at 04:43:38PM -0500, Dan Sugalski wrote:
> The core's going to look big, but be small
What, like am inside-out TARDIS?
--
David Cantrell | [EMAIL PROTECTED] | http://www.cantrell.org.uk/david/
Any technology distinguishable from magic is insufficiently advanced
** I r
On Wed, Jan 31, 2001 at 05:35:03PM -0500, Michael G Schwern wrote:
> On Wed, Jan 31, 2001 at 05:23:43PM -0500, Dan Sugalski wrote:
> > Pulling out or mangling time strikes me as intensely pointless, and I don't
> > see it happening. The socket stuff is really the only core functionality
> > that
> "N" == <[EMAIL PROTECTED]> writes:
N> snooze() is a better name ;-)
TK::button->new( -name => 'snooze', -action => 'press' ) ;
uri
--
Uri Guttman - [EMAIL PROTECTED] -- http://www.sysarch.com
SYStems ARCHitecture, Software Engineering, Perl, Internet, UNI
On Wed, Jan 31, 2001 at 11:57:43PM +0100, [EMAIL PROTECTED] wrote:
> > Perhaps some of the more grossly UNIX specific things like getpwnam's
> > extended family and the SysV IPC stuff?
>
> But why? What is it going to buy you?
The fact is, they don't need to be there.
And there isn't really a go
Dave Storrs <[EMAIL PROTECTED]> writes:
> On Wed, 31 Jan 2001, Tim Bunce wrote:
>
> > Since this thread is in the mood for quotes, here's one I'm fond of...
> > It goes something along the lines of:
> >
> > Any fool can create a complicated system.
> > The real skill is in making a simp
ok,
"I've done it in one row, why you want it to fit in 80 columns ?!" (or
something like that can't remember well)
-- Larry Wall
:")
=
iVAN
[EMAIL PROTECTED]
=
> Ok, if we're all contributing quotes, here's mine:
>
> "I'm sorry for writing you such a long letter; I didn't have time
> t
On Wednesday 31 January 2001 16:03, Dave Storrs wrote:
> "I'm sorry for writing you such a long letter; I didn't have time
> to write a shorter one."
> -- Abraham Lincoln
I thought that was a quote by Pascal?
--
Matthew Cline| Suppose you were an idiot. And
On Wed, Jan 31, 2001 at 09:52:36PM -0600, [EMAIL PROTECTED] wrote:
> Once one starts reading more quotations one will find that quotations
> get misquoted, shortened, misattributed, rewritten, more than you
> really wanted to believe. Some persons seem to be 'quotation
> sponges', everything witt
On Wed, Jan 31, 2001 at 04:44:00PM -0600, Jarkko Hietaniemi wrote:
> Or explore various garbage collection alternatives.
No good, the mob wouldn't be happy.
--
Michael G. Schwern <[EMAIL PROTECTED]>http://www.pobox.com/~schwern/
Hey Schwern! honk, honk, honk, honk, honk, honk, honk, ho
On Wed, 31 Jan 2001 12:05:46 -0600, Jarkko Hietaniemi <[EMAIL PROTECTED]> wrote:
> On Wed, Jan 31, 2001 at 05:55:13PM +, Simon Cozens wrote:
> >Never over-design. Never think "Hmm, maybe somebody would find this
> >useful". Start from what you know people _have_ to have, and try to
> >
Thus it was written in the epistle of Dave Rolsky,
> On Thu, 1 Feb 2001, Nathan Wiger wrote:
>
> > There's the big problem of overlapping function names. If I say:
> >
> >$name = param('name');
> >
> > I probably mean "use CGI". But maybe there's some other module that has
> > param() also? W
Lightning flashed, thunder crashed and "raptor" <[EMAIL PROTECTED]> whispered:
| ok,
|
| "I've done it in one row, why you want it to fit in 80 columns ?!" (or
| something like that can't remember well)
"You want it in one line? Does it have to fit in 80 columns? :-)"
-lwall
-spp
Simon Cozens wrote:
> John Porter wrote:
> > But you need to remember it anyway, so remembering it for time() is
> > no added burden.
>
> Uhm. NO! Remembering that $x+1 things have changed is an "added burden"
> over remembering that $x things have changed.
Not as x approaches infinity.
I'm res
On Wed, 31 Jan 2001, Simon Cozens wrote:
> God gave man two ears and one tongue so that we listen twice as much as
> we speak.
> -- Arab proverb
...but alas on the net we have 10 fingers to type but only 2 eyes to read.
--
Andy Dougherty [EMAIL PROTECTED]
D
On Thu, Feb 01, 2001 at 09:00:47AM -0500, John Porter wrote:
> > Uhm. NO! Remembering that $x+1 things have changed is an "added burden"
> > over remembering that $x things have changed.
>
> Not as x approaches infinity.
We are not changing an infinite number of things.
> Please knock it off wi
Lightning flashed, thunder crashed and [EMAIL PROTECTED] whispered:
| To make a simple loop, Perl offers you: for, foreach, while, until,
| {redo}, map, grep, //g, goto and recursion. Which 9 of them do you
| propose to drop from the language so Perl causes less confusion?
|
| There Is More Than
John Porter <[EMAIL PROTECTED]> wrote:
> Simon Cozens wrote:
> > John Porter wrote:
> > > But you need to remember it anyway, so remembering it for time() is
> > > no added burden.
> >
> > Uhm. NO! Remembering that $x+1 things have changed is an "added
burden"
> > over remembering that $x
Since everyone's spinning aimlessly around, I'll throw out something for
everyone to think about, and perhaps we can get a PDD out of it.
One of the features of perl 6 is going to be the ability to automatically
use a module if one or more preregistered functions are used in your
source. So, f
At 09:49 PM 2/1/2001 +0100, Johan Vromans wrote:
>Dan Sugalski <[EMAIL PROTECTED]> writes:
>
> > The module loaded can define the routines as either regular perl
> > subs or opcode functions (the difference is in calling convention
> > mainly) [...]
>
>Difference in calling convention at the user
[EMAIL PROTECTED] wrote:
> It might makes sense to have some other functions giving units
> since some point in the past next to time() though.
How about time($)
it could take an offset. Not
time(3)
being the same as
(time() + 3)
That would be silly; but what if
On Thu, Feb 01, 2001 at 02:04:41PM -0500, Ken Fox wrote:
> Dan Sugalski wrote:
> > Looks pretty close to what's needed. Care to flesh it out (and streamline
> > it where needed) to a PDD?
>
> Isn't the trick to detect the necessary modules at compile time?
Yeah, but at least with AnyLoader as a
Dan Sugalski <[EMAIL PROTECTED]> writes:
> The module loaded can define the routines as either regular perl
> subs or opcode functions (the difference is in calling convention
> mainly) [...]
Difference in calling convention at the user level or just internal?
-- Johan
On Thu, Feb 01, 2001 at 09:32:30AM +, David Grove wrote:
> John Porter <[EMAIL PROTECTED]> wrote:
> > Simon Cozens wrote:
> > > > "Perl should remain Perl" (once known as RFC 0) is bogus
> > > If you want things that *aren't* Perl, you know exactly where to find
> > them.
> > RFC 0 contin
At 02:04 PM 2/1/2001 -0500, Ken Fox wrote:
>Dan Sugalski wrote:
> > At 12:33 PM 2/1/2001 -0500, Michael G Schwern wrote:
> > > Have a look at AnyLoader in CPAN.
> >
> > Looks pretty close to what's needed. Care to flesh it out (and streamline
> > it where needed) to a PDD?
>
>Isn't the trick to de
Dan Sugalski wrote:
> At 02:04 PM 2/1/2001 -0500, Ken Fox wrote:
> >Isn't the trick to detect the necessary modules at compile time?
>
> Nope, no trick at all. The parser will have a list of functions--if it sees
> function X, it loads in module Y. (Possibly version Z) Nothing fancy needs
> to be
On Thu, Feb 01, 2001 at 11:45:16AM -0500, John Porter wrote:
>
> I don't think anyone is suggesting that we make changes just
> because we can. OBVIOUSLY we would only implement changes
> that add something desirable. And the weight of known
> desirables is large, or we wouldn't be making perl6
Dan Sugalski wrote:
> At 12:33 PM 2/1/2001 -0500, Michael G Schwern wrote:
> > Have a look at AnyLoader in CPAN.
>
> Looks pretty close to what's needed. Care to flesh it out (and streamline
> it where needed) to a PDD?
Isn't the trick to detect the necessary modules at compile time? Run-time
ca
At 07:34 PM 2/1/2001 -0500, Michael G Schwern wrote:
>On Thu, Feb 01, 2001 at 02:04:41PM -0500, Ken Fox wrote:
> > Dan Sugalski wrote:
> > > Looks pretty close to what's needed. Care to flesh it out (and streamline
> > > it where needed) to a PDD?
> >
> > Isn't the trick to detect the necessary mo
On Thu, Feb 01, 2001 at 10:14:20AM -0500, Dan Sugalski wrote:
> The module loaded can define the routines as either regular
> perl subs or opcode functions (the difference is in calling convention
> mainly) and could be the standard mix of perl or compiled code.
>
> Would someone care to take a
On Thu, Feb 01, 2001 at 10:14:20AM -0500, Dan Sugalski wrote:
> One of the features of perl 6 is going to be the ability to automatically
> use a module if one or more preregistered functions are used in your
> source.
>
> Would someone care to take a shot at formalizing the system? We need a w
On Thu, Feb 01, 2001 at 04:02:31PM +, Tim Bunce wrote:
> of the Foo interface (one SX and one pure-perl, for example).
s/SX/XS/ of course.
Tim.
On Thu, Feb 01, 2001 at 11:45:16AM -0500, John Porter wrote:
> For example, take a look at RFC 28 (whose title
> happens to be "Perl should stay Perl"): nothing but ill-
> informed, petulant, absurd whinging about certain classes
> of proposed features that the author, in his humble little
> opin
At 12:33 PM 2/1/2001 -0500, Michael G Schwern wrote:
>On Thu, Feb 01, 2001 at 10:14:20AM -0500, Dan Sugalski wrote:
> > One of the features of perl 6 is going to be the ability to automatically
> > use a module if one or more preregistered functions are used in your
> > source.
> >
> > Would someo
On Thu, Feb 01, 2001 at 04:54:53PM +, Simon Cozens wrote:
> On Thu, Feb 01, 2001 at 11:52:37AM -0500, Dan Sugalski wrote:
> > > just a method for doing what we currently do with, say, glob or
> > >the heavy unicode things?
> >
> > None of the above. What I'm looking for is the pieces that tu
Looking over some C code of the form
int fname(char *param){
int rval;
...
return(rval);
}
I recalled hearing about a language (was it java?) where
you set the return value of a function (was it VB?) by
assigning to the name of the function within the function b
At 07:12 PM 2/1/01 -0600, David L. Nicol wrote:
>I recalled hearing about a language (was it java?) where
>you set the return value of a function (was it VB?) by
>assigning to the name of the function within the function body,
>so the last line would be
>
> fname=rval;
>
>or fname could be
On Thu, Feb 01, 2001 at 07:36:59PM -0600, David L. Nicol wrote:
> So a way
> to have the feature (direct assignment to external lvalue) and maintain
> portability might be to forget about magic names and just make the new
> LNV (which I am calling $__ in this thread) mean "An alias for the
> L-val
Ted Ashton wrote:
>
> It appears to me that there's a focus problem here. After all,
> if I want to use CGI or CGI::Minimal, I can already do that.
> The auto-autoloading, unless I am sorely mistaken (which is
> quite possible :-), is for the purpose of moving things out
> of the core and yet a
"David L. Nicol" wrote:
> We could even define a new line noise variable which could hold the
> results of the last name-of-function subroutine that was not invoked
> as an rvalue (I nominate $__ ); make such an invokation a warning-level
> offense; and make $__ visibility/localization compatible
At 04:54 PM 2/1/2001 +, Simon Cozens wrote:
>On Thu, Feb 01, 2001 at 11:52:37AM -0500, Dan Sugalski wrote:
> > > just a method for doing what we currently do with, say, glob or
> > >the heavy unicode things?
> >
> > None of the above. What I'm looking for is the pieces that turn the use of
> >
On Thu, Feb 01, 2001 at 11:52:37AM -0500, Dan Sugalski wrote:
> > just a method for doing what we currently do with, say, glob or
> >the heavy unicode things?
>
> None of the above. What I'm looking for is the pieces that turn the use of
> a function into an automagic use of the module containi
At 03:44 PM 2/1/2001 +, Simon Cozens wrote:
>On Thu, Feb 01, 2001 at 10:14:20AM -0500, Dan Sugalski wrote:
> > The module loaded can define the routines as either regular
> > perl subs or opcode functions (the difference is in calling convention
> > mainly) and could be the standard mix of per
On Thu, Feb 01, 2001 at 10:14:20AM -0500, Dan Sugalski wrote:
> Since everyone's spinning aimlessly around, I'll throw out something for
> everyone to think about, and perhaps we can get a PDD out of it.
>
> One of the features of perl 6 is going to be the ability to automatically
> use a modul
David Grove wrote:
>
> > RFC 0 continues to be bogus, despite its repetition.
> > Perl6 will be Perl, even though it won't be Perl5.
> > It will be a different language, yet it will still be Perl.
>
> Correct. However, the lack of that argument doesn't mean that we should
> arbitrarily slaugh
Dan Sugalski wrote:
>
> At 12:33 PM 2/1/2001 -0500, Michael G Schwern wrote:
> >
> >Have a look at AnyLoader in CPAN.
>
> Looks pretty close to what's needed. Care to flesh it out (and streamline
> it where needed) to a PDD?
There's also autouse, a pragma that ships with Perl. Again, not exactl
Dan Sugalski wrote:
> At 11:57 PM 1/31/2001 +0100, [EMAIL PROTECTED] wrote:
> > On Wed, Jan 31, 2001 at 05:35:03PM -0500, Michael G Schwern wrote:
> > > grossly UNIX specific things like getpwnam's [can be pulled]
> >
> > But why? What is it going to buy you?
>
> Not that much. More than anything
On Thu, 1 Feb 2001, Nathan Wiger wrote:
> There's the big problem of overlapping function names. If I say:
>
>$name = param('name');
>
> I probably mean "use CGI". But maybe there's some other module that has
> param() also? What if I really mean "use CGI::Minimal"?
Here's a gross thought (f
On Thu, Feb 01, 2001 at 05:10:55PM +, Tim Bunce wrote:
> On Thu, Feb 01, 2001 at 04:02:31PM +, Tim Bunce wrote:
> > of the Foo interface (one SX and one pure-perl, for example).
> s/SX/XS/ of course.
Dammit. And there was I thinking you'd already designed the extension
system for Perl 6!
At 11:57 PM 1/31/2001 +0100, [EMAIL PROTECTED] wrote:
>On Wed, Jan 31, 2001 at 05:35:03PM -0500, Michael G Schwern wrote:
> > On Wed, Jan 31, 2001 at 05:23:43PM -0500, Dan Sugalski wrote:
> > > Pulling out or mangling time strikes me as intensely pointless, and I
> don't
> > > see it happening. T
On Thu, Feb 01, 2001 at 03:38:46PM +, Simon Cozens wrote:
> On Thu, Feb 01, 2001 at 09:00:47AM -0500, John Porter wrote:
> > > Uhm. NO! Remembering that $x+1 things have changed is an "added burden"
> > > over remembering that $x things have changed.
> >
> > Not as x approaches infinity.
>
>
51 matches
Mail list logo