[OpenWrt-Devel] [PATCH] fuse: remove

2020-05-16 Thread Rosen Penev
This package was last updated in 2016. All of the dependent packages are in the packages feeds, where this will be moved. Signed-off-by: Rosen Penev --- package/utils/fuse/Makefile | 103 -- .../fuse/patches/100-missing_includes.patch | 10 -- .../fuse/patche

[OpenWrt-Devel] [PATCH ucert 13/13] Do not print line number in debug messages

2020-05-16 Thread Matthias Schiffer
The line number does not add any significant information, and it makes the unit tests which check for these debug messages very fragile. Signed-off-by: Matthias Schiffer --- tests/cram/test_ucert.t | 4 ++-- ucert.c | 8 2 files changed, 6 insertions(+), 6 deletions(-)

[OpenWrt-Devel] [PATCH ucert 10/13] usign-exec: return code fixes

2020-05-16 Thread Matthias Schiffer
- WEXITSTATUS() should only be called when WIFEXITED() returns true - Fix double WEXITSTATUS() in usign_f() Signed-off-by: Matthias Schiffer --- usign-exec.c | 9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/usign-exec.c b/usign-exec.c index 0dde81ed647b..241d63077365

[OpenWrt-Devel] [PATCH ucert 11/13] usign-exec: improve usign -F output handling

2020-05-16 Thread Matthias Schiffer
While not likely to happen in pratice, nothing guarantees that read() will retrieve more than 1 byte at a time. The easiest way to make this code compliant is to wrap the file descriptor using fdopen(). While we're at it, also - remove useless memset() - check fingerprint for validity The check i

[OpenWrt-Devel] [PATCH ucert 12/13] Fix length checks in cert_load()

2020-05-16 Thread Matthias Schiffer
cert_load() iterates over multiple blobs, so the length argument to blob_parse_untrusted() needs to be updated to prevent out-of-bounds accesses. Some other checks have become redundant and are removed, as blob_parse_untrusted() already ensures that all attrs are contained in the passed buffer. N

[OpenWrt-Devel] [PATCH ucert 06/13] usign-exec: do not close stdin and stderr before exec

2020-05-16 Thread Matthias Schiffer
FDs 0, 1 and 2 should always be available. This also allows the exec error message in the forked process to be displayed. Signed-off-by: Matthias Schiffer --- usign-exec.c | 8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/usign-exec.c b/usign-exec.c index 22fdc14e7ebb..

[OpenWrt-Devel] [PATCH ucert 00/13] ucert fixes and cleanup

2020-05-16 Thread Matthias Schiffer
While looking for a build issue (see [1]), I noticed various issues in the ucert code (and this should not be applied before [1] is applied to usign). There might well be more problems lurking - I did not read all the code. In particular patch 12/12 is critical: It must be applied before the attac

[OpenWrt-Devel] [PATCH ucert 09/13] usign-exec: close writing end of pipe early in parent process

2020-05-16 Thread Matthias Schiffer
When the child process exited without producing output (for example because usign was not found), the parent process would hang forever in read(). By closing the writing end early in the parent process, read will return as soon as no writing FDs are left - that is, when the child process has exited

[OpenWrt-Devel] [PATCH ucert 02/13] Fix return code of write_file()

2020-05-16 Thread Matthias Schiffer
write_file() returns 1/true on success; it should return 0/false when opening the file fails. To make it more obvious that is function returns true and not 0 on success, also change its return type to bool. Signed-off-by: Matthias Schiffer --- ucert.c | 4 ++-- 1 file changed, 2 insertions(+),

[OpenWrt-Devel] [PATCH ucert 08/13] usign-exec: remove redundant return statements

2020-05-16 Thread Matthias Schiffer
All switch() cases were already returning value or exiting. Instead, move the default case out of the switch to reduce indentation (only relevant for usign_f()). Signed-off-by: Matthias Schiffer --- usign-exec.c | 43 +-- 1 file changed, 17 insertions(+),

[OpenWrt-Devel] [PATCH ucert 07/13] usign-exec: change usign_f_* fingerprint argument to char[17]

2020-05-16 Thread Matthias Schiffer
This makes it more obvious that a buffer with space for 17 characters is expected to be passed. The code still works the same (a char[17] is equivalent to char* as an argument). Signed-off-by: Matthias Schiffer --- usign-exec.c | 8 usign.h | 6 +++--- 2 files changed, 7 insertions

[OpenWrt-Devel] [PATCH ucert 04/13] usign-exec: simplify usign execv calls

2020-05-16 Thread Matthias Schiffer
When the executable to exec is passed as an absolute path, execv() and execvp() are equivalent, so there it no need to make the code hard to read with #ifdefs. Signed-off-by: Matthias Schiffer --- usign-exec.c | 24 +++- 1 file changed, 3 insertions(+), 21 deletions(-) diff

[OpenWrt-Devel] [PATCH ucert 05/13] usign-exec: fix exec error handling

2020-05-16 Thread Matthias Schiffer
When execvp fails in the forked process, we must exit. Also add an error message. Signed-off-by: Matthias Schiffer --- ucert.c | 4 ++-- usign-exec.c | 40 usign.h | 8 +--- 3 files changed, 27 insertions(+), 25 deletions(-) diff --git a/

[OpenWrt-Devel] [PATCH ucert 03/13] Introduce read_file() helper, improve error reporting

2020-05-16 Thread Matthias Schiffer
This helper simplifies handling, ensures that there are no resource leaks, and checks for EOF more robustly. Also introduce error reporting at all call sites to give the user some feedback when something went wrong. Signed-off-by: Matthias Schiffer --- ucert.c | 97 +

[OpenWrt-Devel] [PATCH ucert 01/13] stdout/stderr improvements

2020-05-16 Thread Matthias Schiffer
- Print error messages to stderr - fprintf(stdout, ...) is just printf(...) Signed-off-by: Matthias Schiffer --- ucert.c | 6 +++--- usign-exec.c | 4 ++-- 2 files changed, 5 insertions(+), 5 deletions(-) diff --git a/ucert.c b/ucert.c index d822199eb7f8..2ea939947d72 100644 --- a/ucert.c

[OpenWrt-Devel] [PATCH libubox] blob: make blob_parse_untrusted more permissive

2020-05-16 Thread Matthias Schiffer
Some tools like ucert use concatenations of multiple blobs. Account for this case by allowing the underlying buffer length to be greater than the blog length. Signed-off-by: Matthias Schiffer --- blob.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/blob.c b/blob.c index 528

Re: [OpenWrt-Devel] hostap commit 6c9543fcb breaks MESH-SAE with wolfssl

2020-05-16 Thread Jouni Malinen
On Wed, May 13, 2020 at 05:34:31PM +0100, Daniel Golle wrote: > I've just built OpenWrt for MIPS malta (BE) with mac80211-hwsim and > hereby confirm the problem shows up there in exactly the same way. > Also on MIPS malta with mac80211-hwsim, mesh with SAE works with > WolfSSL up to and including h

[OpenWrt-Devel] [PATCH v2] generic: platform/mikrotik: fix LZOR support

2020-05-16 Thread Thibaut VARÈNE
31e99fe3da which introduced this code was unfortunately untested. This commit fixes a number of issues and works around the fact that in this particular scheme, the LZO payload may be padded at the end which will trigger a harmless lzo decompression error. This commit also disambiguates the debug p

[OpenWrt-Devel] [PATCH] generic: platform/mikrotik: fix LZOR support

2020-05-16 Thread Thibaut VARÈNE
31e99fe3da which introduced this code was unfortunately untested. This commit fixes a number of issues and works around the fact that in this particular scheme, the LZO payload may be padded at the end which will trigger a harmless lzo decompression error. This commit also disambiguates the debug p

[OpenWrt-Devel] [PATCH usign] Always pad fingerprints to 16 characters

2020-05-16 Thread Matthias Schiffer
Fingerprints were not padded with zeros. This led to an ucert failure when the first byte of the fingerprint is 00, as it expects the fingerprint to have a constant length (and this expectation seems reasonable to me). Signed-off-by: Matthias Schiffer --- This issue was noticed as a spurious bui

Re: [OpenWrt-Devel] [PATCH] netifd: Improve handling of device rename

2020-05-16 Thread Kristian Evensen
Hi, On Wed, Mar 11, 2020 at 2:13 PM Kristian Evensen wrote: > > After an interface has been renamed on a "fast" device (for example > x86_64), the interface is sometimes not handled correctly by netifd. > Looking in the logs, I see the following messages when renaming fails: > > Wed Mar 11 08:52:

[OpenWrt-Devel] Is 18.06 packages buildbot intentionally offline?

2020-05-16 Thread Hannu Nyman
Apparently the openwrt-18.06 packages buildbot has been offline three weeks, since 22 April 2020: http://buildbot.openwrt.org/openwrt-18.06/packages/one_line_per_build Is that intentional? There has been some talk about 18.06.3  (http://lists.infradead.org/pipermail/openwrt-devel/2020-May/023

Re: [OpenWrt-Devel] [PATCH 2/2] build: compress kernel debuginfo using zstd

2020-05-16 Thread Matthias Schiffer
On 5/16/20 3:38 AM, Paul Spooren wrote: > Could we use that for the SDK/ImageBuilder as well? > > Best, > Paul Sure, have some benchmark results with the current ath79 snapshot IB: * openwrt-imagebuilder-ath79-generic.Linux-x86_64.tar: 515M * xz -7e (current implementation): 96M, ~100s * zstd -3

Re: [OpenWrt-Devel] Quectel RM500Q failing to get ip address assignment with netifd and modemmanager

2020-05-16 Thread Aleksander Morgado
Hey! > > > > root@localhost:~# mmcli -b 2 > > > > > > > > General| dbus path: > > > > /org/freedesktop/ModemManager1/Bearer/2 > > > > | type: default > > > > > > > > Status