On Fri, 9 Aug 2024 15:37:56 GMT, Andy Goryachev wrote:
>> `reconstruct` is a misnomer, as reconstruction is a two-step operation
>> (`convertBack` followed by `convert`). To be fair, I don't like any of these
>> better than `convertBack`, mostly because I want to stress that those two
>> opera
On Fri, 9 Aug 2024 19:42:56 GMT, John Hendrikx wrote:
>> But the converter is not reconstructable (in comparison to Interpolatable,
>> which is something the marked types actually are).
>
> Sorry to keep harping on this, but so far, I think all the options are quite
> poor from the perspective
> This PR completes the CSS Transitions story (see #870) by adding
> interpolation support for backgrounds and borders, making them targetable by
> transitions.
>
> `Background` and `Border` objects are deeply immutable, but not
> interpolatable. Consider the following `Background`, which descr
On Tue, 30 Jul 2024 18:26:21 GMT, Andy Goryachev wrote:
> Enable backpropagation of `isConsumed` flag to the ancestor(s) of events
> cloned via `Event.copyFor()`.
>
> This change has a minimal API impact and allows for a fine-grained control of
> when to propagate and when not to propagate.
>
On Fri, 9 Aug 2024 13:36:34 GMT, Michael Strauß wrote:
>> Clear, thanks MIchael. I would suggest `Reconstructable` as the name, which
>> seems more inline with interface naming (especially `Interpolatable`). Reads
>> nice also:
>>
>> if (converter instanceof Reconstructable r) { ... }
>
>
I noticed the copy/paste I did wasn't great, you don't need the `future`
variable or code that manipulates it (I had a different version before,
but this works quite well for now)
--John
On 08/08/2024 12:47, Thiago Milczarek Sayão wrote:
Nice! I will steal it if you don't mind.
Em qua., 7 de
Feel free, it is also somewhere on my github. I'm not entirely
confident it works for all cases, but it can be tweaked. Here's the
missing piece you may need:
/**
* Tracks time spent (in milliseconds) between calls of {@link
#enterNested()}and {@link #exitNested()}
* excluding time spent i
On Fri, 9 Aug 2024 03:30:09 GMT, Loay Ghreeb wrote:
>> Fix an issue in `SortedList` where the sorting became incorrect when adding
>> new items that are equal to existing items according to the comparator. The
>> `SortedList` should consider the insertion index of these items to maintain
>> th
> This PR completes the CSS Transitions story (see #870) by adding
> interpolation support for backgrounds and borders, making them targetable by
> transitions.
>
> `Background` and `Border` objects are deeply immutable, but not
> interpolatable. Consider the following `Background`, which descr
> This PR completes the CSS Transitions story (see #870) by adding
> interpolation support for backgrounds and borders, making them targetable by
> transitions.
>
> `Background` and `Border` objects are deeply immutable, but not
> interpolatable. Consider the following `Background`, which descr
On Tue, 30 Jul 2024 18:26:21 GMT, Andy Goryachev wrote:
> Enable backpropagation of `isConsumed` flag to the ancestor(s) of events
> cloned via `Event.copyFor()`.
>
> This change has a minimal API impact and allows for a fine-grained control of
> when to propagate and when not to propagate.
>
On Tue, 6 Aug 2024 08:08:09 GMT, Hima Bindu Meda wrote:
>> Updated libxslt to v1.1.42. Verified build on all platforms. No issue seen
>
> Hima Bindu Meda has updated the pull request incrementally with one
> additional commit since the last revision:
>
> Remove deprecated file
@arapte please
sorry to everyone. wrong list :(
Il 09/08/2024 17:56, Davide Perini ha scritto:
Hi there,
thanks for the opportunity that you give us to write on this mailing-list.
I'm am playing with the Vector API bundled in Java 22 and wow, they
are amazing.
I have some serious benefits using them even for
Hi there,
thanks for the opportunity that you give us to write on this mailing-list.
I'm am playing with the Vector API bundled in Java 22 and wow, they are
amazing.
I have some serious benefits using them even for simple tasks on my AMD
Ryzen 9 7950X3D CPU that uses Zen4 architecture.
Can't
On Fri, 9 Aug 2024 02:23:11 GMT, Michael Strauß wrote:
>> modules/javafx.graphics/src/main/java/javafx/css/StyleConverter.java line
>> 113:
>>
>>> 111: * @return a {@code Map} of the constituent values
>>> 112: */
>>> 113: Map, Object> convertBack(T
>>> value);
>>
>>
Michael:
Yes, by design. I think the JEPs still have value even after the actual
changes were made. Also, nothing prevents us from creating an index.html file
that lists the JEPs in chronological order and mentions the state of the
implemented features and whether and how the actual implement
On Wed, 7 Aug 2024 02:13:12 GMT, John Hendrikx wrote:
>> Moves `SimpleSelector` and `CompoundSelector` to internal packages.
>>
>> This can be done with only a minor API break, as `SimpleSelector` and
>> `CompoundSelector` were public before. However, these classes could not be
>> constructed
On Fri, 9 Aug 2024 14:37:38 GMT, Andy Goryachev wrote:
> > Maybe we should do that as a separate ticket. Changing the documentation of
> > properties that have nothing to do with backgrounds and borders is probably
> > a bit out of scope for this PR.
>
> I am afraid I'd disagree here: I would
On Tue, 30 Jul 2024 18:26:21 GMT, Andy Goryachev wrote:
> Enable backpropagation of `isConsumed` flag to the ancestor(s) of events
> cloned via `Event.copyFor()`.
>
> This change has a minimal API impact and allows for a fine-grained control of
> when to propagate and when not to propagate.
>
On Thu, 8 Aug 2024 04:00:16 GMT, Michael Strauß wrote:
>> This PR completes the CSS Transitions story (see #870) by adding
>> interpolation support for backgrounds and borders, making them targetable by
>> transitions.
>>
>> `Background` and `Border` objects are deeply immutable, but not
>> i
Hi Andy,
wouldn't these documents risk getting outdated when the codebase is
evolved? JEPs seem to be most relevant at the time when a feature is
proposed. I think I'd rather have documentation colocated with the
code itself, this makes it easier to keep the documentation in sync
with the actual i
On Fri, 9 Aug 2024 11:20:55 GMT, John Hendrikx wrote:
>> +1 for `StyleConverter.WithReconstructionSupport`
>>
>> maybe use a shorter name, like
>>
>> `StyleConverter.WithReconstruction`
>
> Clear, thanks MIchael. I would suggest `Reconstructable` as the name, which
> seems more inline with in
On Thu, 8 Aug 2024 15:45:37 GMT, Andy Goryachev wrote:
>> Returning `null` seems fine from the perspective of `StyleConverter`, but it
>> makes the calling code very awkward. Remember, we ended up here because we
>> needed a way to detect whether an object would support component-wise
>> trans
On Thu, 8 Aug 2024 12:35:59 GMT, Lukasz Kostyra wrote:
> When fixing [JDK-8233955](https://bugs.openjdk.org/browse/JDK-8233955) offset
> calculation was left out, which made Dragboard offset API not work on macOS.
>
> This change fixes this mistake. Now drag image should be properly offset.
I
> When fixing [JDK-8233955](https://bugs.openjdk.org/browse/JDK-8233955) offset
> calculation was left out, which made Dragboard offset API not work on macOS.
>
> This change fixes this mistake. Now drag image should be properly offset.
Lukasz Kostyra has updated the pull request incrementally w
25 matches
Mail list logo