> On Nov 3, 2015, at 1:22 AM, Jian Liu wrote:
>
> Hi,
>
> I test linux-dummy linux-yocto-dev linux-yocto-rt linux-yocto-tiny and the
> result is as follows,
>
> linux-dummy: this package just meets some dependency and there is no source
> code for it.
> The patch does no
On 11/3/15 6:06 PM, Peter Kjellerstedt wrote:
> Read and merge the passwd/group files before parsing the user and
> group definitions. This means they will only be read once per
> recipe. This solves a problem where if a user was definied in multiple
> files, it could generate group definitions for
Ruslan,
On 11/03/2015 04:53 PM, Ruslan Babayev wrote:
> Hi Armin,
>
> It is the latest stable. And it looks like this patch has made it into
> 2.2.4
Thanks for double checking.
- armin
> http://ftp.openbsd.org/pub/OpenBSD/patches/5.8/common/007_obj2txt.patch.sig
>
> akuster808 writes:
>
>> R
On 11/3/15 5:28 PM, Khem Raj wrote:
> On Tue, Nov 3, 2015 at 2:21 PM, Mark Hatle wrote:
>> Use the value 0x0080 for INSN_XLP, as the value 0x0040 has already
>> been assigned to INSN_OCTEON3 by the binutils project.
>>
>> Without this change, invalid instructions can be generated for both
I looked over this series (I have not tried it, but) everything looks ok to me.
I did make one comment on a minor hunk -- but otherwise I don't see any issues.
The python style police might have some further comments.
Acked-by: Mark Hatle
On 11/3/15 6:06 PM, Peter Kjellerstedt wrote:
> This s
This series of patches aims to improve useradd-staticids.bbclass.
We are currently using useradd-staticids.bbclass to make sure all
users and groups have well defined IDs. So far we have had the
definitions of the users both in the recipes and in the passwd file
used by useradd-staticids.bbclass.
The useradd options --create-home/--no-create-home and
--user-group/--no-user-group are mutually exclusive and should be
treated as such.
Signed-off-by: Peter Kjellerstedt
---
meta/classes/useradd-staticids.bbclass | 27 ++-
1 file changed, 14 insertions(+), 13 deletions(
Read and merge the passwd/group files before parsing the user and
group definitions. This means they will only be read once per
recipe. This solves a problem where if a user was definied in multiple
files, it could generate group definitions for groups that should not
be created. E.g., if the first
The original code was near impossible to follow, and missed a couple
of cases. For example, if one added the following line to the passwd
file specified in USERADD_UID_TABLES:
foobar:x:12345:nogroup::/:/bin/sh
and then specified the user as:
USERADD_PARAM_${PN} = "--system foobar"
one would the
The [, ][not ] construct may solve the
problem of implementing a conditional operator, but it is not very
readable. At least I find this:
uaargs.groupid = field[3] or uaargs.gid or uaargs.groupname
a lot more readable than this:
uaargs.groupid = [uaargs.gid, uaargs.groupname][not uaargs.
If --no-user-group is specified in USERADD_PARAM_${PN} for a user and
no --gid is specified, then we should not assume that the group name
for the user is the user name.
Signed-off-by: Peter Kjellerstedt
---
meta/classes/useradd-staticids.bbclass | 2 +-
1 file changed, 1 insertion(+), 1 deletio
On 3 November 2015 at 16:34,
wrote:
> From: Leonardo Sandoval
>
> Old tmux version (< 1.9) does not support nested formats on the -F parameter,
> so
> if nested format does not give any answer, do the query in two steps.
>
> Tested on tmux 1.6.
Yeah, I noticed this shortly after I submitted the
Hi Armin,
It is the latest stable. And it looks like this patch has made it into
2.2.4
http://ftp.openbsd.org/pub/OpenBSD/patches/5.8/common/007_obj2txt.patch.sig
akuster808 writes:
> Ruslan,
>
> any reason version 2.3.1 was not picked?
>
> I believe 2.2.4 is missing (CVE-2015-5333 and CVE-201
On Tue, Nov 3, 2015 at 2:21 PM, Mark Hatle wrote:
> Use the value 0x0080 for INSN_XLP, as the value 0x0040 has already
> been assigned to INSN_OCTEON3 by the binutils project.
>
> Without this change, invalid instructions can be generated for both INSN_XLP
> and INSN_OCTEON3.
>
this is ok
Ruslan,
any reason version 2.3.1 was not picked?
I believe 2.2.4 is missing (CVE-2015-5333 and CVE-2015-5334)
- armin
On 11/03/2015 03:34 PM, Ruslan Babayev wrote:
> Please find attached the patch to add support for LibreSSL.
>
> OpenSSL is still preferred, so you'd have add these to your loc
Burton, Ross writes:
>
> I think I'd prefer oe-core to have just the one provider of the openssl
> APIs, so if oe-core sticks with openssl then libressl should go into
> another layer, meta-networking maybe?
>
Thanks for feedback Ross. Moved it to meta-networking.
>From 5b41fed5cea2123bffd13c0d
From: Leonardo Sandoval
On the 3.19 to 4.1 migration, the target x86_64 was not taken into account
(no reason, just missing the correspoding update on the kernel-list.noinstall
file), so moving it to 4.1 to be align with the rest.
Signed-off-by: Leonardo Sandoval
---
.../target/arch/x86_64/rec
From: Daniel McGregor
According to the os-release specification, variable assignments
must be enclosed in double or single quotation marks if they include
spaces, semicolons, or other special characters.
Update the os-release recipe to use always use double quotation marks.
Signed-off-by: Danie
From: Dan McGregor
systemd names two manual pages for .so files ${foo}.so.2.8,
the library being named ${foo}.so.2. This hits the libdir
sanity checker:
WARNING: QA Issue: systemd-doc: found library in wrong location:
/usr/share/man/man8/libnss_mymachines.so.2.8 [libdir]
Disable the libdir sanit
From: Dan McGregor
These four patches include three bug fixes, and one new feature.
os-release is improved to handle variables with spaces
don't stomp on machine-id on systemd upgrade
don't complain about manpages with .so in their names
coredumpctl is added as a new systemd PACKAGECONFIG value
From: Dan McGregor
If / is mounted read-write machine-id will be overwritten on first boot.
This change ensures that the machine-id file persists across package
upgrades to systemd.
Signed-off-by: Dan McGregor
---
meta/recipes-core/systemd/systemd_225.bb | 3 ++-
1 file changed, 2 insertions(+
From: Daniel McGregor
Signed-off-by: Daniel McGregor
---
meta/recipes-core/systemd/systemd_225.bb | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/meta/recipes-core/systemd/systemd_225.bb
b/meta/recipes-core/systemd/systemd_225.bb
index 5f6be82..e2d6b16 100644
--- a/meta/
Sorry I meant this:
PREFERRED_PROVIDER_openssl ?= "libressl"
PREFERRED_PROVIDER_openssl-native ?= "libressl-native"
PREFERRED_PROVIDER_nativesdk-openssl ?= "nativesdk-libressl"
Ruslan Babayev writes:
> Please find attached the patch to add support for LibreSSL.
>
> OpenSSL is still preferred, so
On 3 November 2015 at 23:34, Ruslan Babayev wrote:
> Please find attached the patch to add support for LibreSSL.
>
I think I'd prefer oe-core to have just the one provider of the openssl
APIs, so if oe-core sticks with openssl then libressl should go into
another layer, meta-networking maybe?
R
Please find attached the patch to add support for LibreSSL.
OpenSSL is still preferred, so you'd have add these to your local.conf
PREFERRED_PROVIDER_openssl ?= "openssl"
PREFERRED_PROVIDER_openssl-native ?= "openssl-native"
PREFERRED_PROVIDER_nativesdk-openssl ?= "nativesdk-openssl"
>From db63d
From: Leonardo Sandoval
Old tmux version (< 1.9) does not support nested formats on the -F parameter, so
if nested format does not give any answer, do the query in two steps.
Tested on tmux 1.6.
Signed-off-by: Leonardo Sandoval
---
meta/lib/oe/terminal.py | 15 ++-
1 file change
There is a clash in the machine value, as Octeon3 was assigned one value
by binutils, but the XLP patch decided to use the same value. Since the
XLP value was not officially assigned, change it to avoid the clash.
This fixes an issue where certain instructions, such as DMUL, may be
assembled inc
Use the value 0x0080 for INSN_XLP, as the value 0x0040 has already
been assigned to INSN_OCTEON3 by the binutils project.
Without this change, invalid instructions can be generated for both INSN_XLP
and INSN_OCTEON3.
Signed-off-by: Mark Hatle
---
.../binutils/binutils/0012-Add-XLP-instr
From: Leonardo Sandoval
By mistake, the file was introduced with wrong extension, so changing to the
correct one.
Signed-off-by: Leonardo Sandoval
---
.../linux/{linux-yocto_4.1.bbapend => linux-yocto_4.1.bbappend} | 0
1 file changed, 0 insertions(+), 0 deletions(-)
rename
scripts
From: Leonardo Sandoval
In linux-yocto-dev or linux-yocto_X.YY bbappend files, the SRC_URI includes
{{=machine}}-standard.scc, which in turn includes {{=machine}}-user-parches.scc,
thus there is no need to include it again on the corresponding bbappend file.
[YOCTO #8486]
Signed-off-by: Leonard
Build of qemu-native on Ubuntu 15.10 fails on configure step.
The reason for this is that system dbus version is higher than
oe dbus version and system pulseaudio libraries require newer dbus.
It causes configure to break with a lot of errors similar to this:
libpulsecommon-6.0.so: undefined ref
Hi,
I test linux-dummy linux-yocto-dev linux-yocto-rt linux-yocto-tiny and
the result is as follows,
linux-dummy: this package just meets some dependency and there is no
source code for it.
The patch does not impact it
linux-yocto, linux-yocto-dev, linux-yocto-rt, linux
32 matches
Mail list logo