On Fri, 8 Aug 2014, Saul Wold wrote:
> On 08/08/2014 12:31 PM, Robert P. J. Day wrote:
> >
> > Given that there are no machine-specific files for the tslib recipe
> > anymore, might as well remove this line.
> >
>
> Robert,
>
> Can you please review the commit guidelines
>
> http://www.openembedde
> On Aug 6, 2014, at 7:42 AM, Paul Eggleton
> wrote:
>
>> On Wednesday 06 August 2014 16:37:34 Martin Jansa wrote:
>>> On Wed, Aug 06, 2014 at 01:41:58PM +0100, Paul Eggleton wrote:
On Wednesday 06 August 2014 13:41:56 Martin Jansa wrote:
* building with libav-9 fails with:
| ch
This represents a complete rework, and if we assume the previous
version should have been 1.0 (instead of a silly .1x version), then
this should be 2.0.
Signed-off-by: Tom Zanussi
---
scripts/lib/wic/__version__.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/scripts/lib/w
The wic code inherited a basic image-creation flow based on mounting
loop devices, but wic doesn't actually mount or unmount anything, so
get rid of unmount() and consolidate whatever it did do with
cleanup().
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/imager/baseimager.py | 28 ++---
It doesn't do anything we need, so remove it and fix up callers/base
classes.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/utils/fs_related.py| 16
scripts/lib/mic/utils/partitionedfs.py | 4 +---
2 files changed, 1 insertion(+), 19 deletions(-)
diff --git a/scripts/lib/
As well as any other stray instances of mic in the codebase that can
be removed.
We don't really need to carry around legacy naming, and the history is
in git.
Signed-off-by: Tom Zanussi
---
scripts/lib/image/engine.py | 12 ++--
scripts/lib/image/help.py
wic doesn't use anything but partition and bootloader, so remove the
rest.
Signed-off-by: Tom Zanussi
---
.../mic/3rdparty/pykickstart/commands/__init__.py |8 +-
.../3rdparty/pykickstart/commands/authconfig.py| 40 -
.../mic/3rdparty/pykickstart/commands/autopart.py | 119 ---
.../
The wic code inherited a basic image-creation flow based on installing
packages, but wic doesn't actually install anything, so rename parts
of the code dealing with installing to something more appropriate.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/imager/direct.py| 50 +
Remove what wic doesn't use from DirectImageCreator.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/imager/direct.py| 8 +---
scripts/lib/mic/plugins/imager/direct_plugin.py | 5 +
2 files changed, 2 insertions(+), 11 deletions(-)
diff --git a/scripts/lib/mic/imager/dire
wic doesn't mount anything, so can't have a mount error; rename it to
something more appropriate.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/imager/direct.py | 4 ++--
scripts/lib/mic/plugins/source/bootimg-efi.py| 2 +-
scripts/lib/mic/plugins/source/bootimg-pcbios.py |
It's actually a container for disks and partitions, and wic doesn't
mount anything, so rename it to match what it really is.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/imager/direct.py | 15 +++
scripts/lib/mic/plugins/imager/direct_plugin.py | 1 -
scripts/lib/
Also fix up users such as imager functions.
Signed-off-by: Tom Zanussi
---
scripts/lib/image/config/wic.conf | 1 -
scripts/lib/mic/conf.py | 39
scripts/lib/mic/imager/baseimager.py| 13 ++-
scripts/lib/mic/imager/direc
The wic code inherited a basic image-creation flow based on
image-configuration, but wic doesn't actually configure anything, so
rename parts of the code dealing with configuration to something more
appropriate.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/imager/direct.py| 7 +
wic doesn't use proxy support, so remove it.
Also remove anything related to proxies in misc and conf, and while
we're at it, remove all the obviously unneeded code from those files -
it's easier to just remove it than to figure out the callchain to the
proxy code usages.
Basically the extra stuf
wic doesn't use it, so remove it.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/utils/fs_related.py | 930
1 file changed, 930 deletions(-)
diff --git a/scripts/lib/mic/utils/fs_related.py
b/scripts/lib/mic/utils/fs_related.py
index 182171f..e6e362d 100644
More package-related stuff we don't need.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/rt_util.py | 223 -
1 file changed, 223 deletions(-)
delete mode 100644 scripts/lib/mic/rt_util.py
diff --git a/scripts/lib/mic/rt_util.py b/scripts/lib/mic/rt_u
Remove obsolete comment.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/utils/fs_related.py | 7 ++-
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/scripts/lib/mic/utils/fs_related.py
b/scripts/lib/mic/utils/fs_related.py
index 07a5ff9..cf2a759 100644
--- a/scripts/lib/mic/ut
wic doesn't use it, so remove it.
Signed-off-by: Tom Zanussi
---
.../3rdparty/pykickstart/urlgrabber/__init__.py| 53 -
.../3rdparty/pykickstart/urlgrabber/byterange.py | 463 --
.../mic/3rdparty/pykickstart/urlgrabber/grabber.py | 1477
.../3rdparty/pykickstart
wic doesn't use a lot of Creator, so remove it.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/creator.py | 176 ++---
1 file changed, 6 insertions(+), 170 deletions(-)
diff --git a/scripts/lib/mic/creator.py b/scripts/lib/mic/creator.py
index 267928f..7c
The wic code inherited a basic image-creation flow based on mounting
loop devices, but wic doesn't actually mount anything, so rename parts
of the code dealing with mounting to something more appropriate, and
remove related unused code.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/imager/basei
wic doesn't use a lot of BaseImageCreator, so remove it.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/imager/baseimager.py | 1030 +-
scripts/lib/mic/imager/direct.py |4 +-
2 files changed, 9 insertions(+), 1025 deletions(-)
diff --git a/scripts/lib/mi
The default is F16 and there's no reason to change that, so remove
everything else.
Signed-off-by: Tom Zanussi
---
.../3rdparty/pykickstart/commands/bootloader.py| 49 --
.../mic/3rdparty/pykickstart/commands/partition.py | 39 -
.../mic/3rdparty/pykickstart/handlers/control.py |
wic doesn't use a lot of ParitionedMount, so remove it.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/utils/partitionedfs.py | 355 +
1 file changed, 2 insertions(+), 353 deletions(-)
diff --git a/scripts/lib/mic/utils/partitionedfs.py
b/scripts/lib/mic/utils/p
Remove help text regarding the source and future intentions of the wic
codebase, since the code prompting those comments has now been mostly
removed.
Signed-off-by: Tom Zanussi
---
scripts/lib/image/help.py | 14 +-
1 file changed, 1 insertion(+), 13 deletions(-)
diff --git a/script
packaging bootstrap, not needed
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/bootstrap.py | 279 ---
1 file changed, 279 deletions(-)
delete mode 100644 scripts/lib/mic/bootstrap.py
diff --git a/scripts/lib/mic/bootstrap.py b/scripts/lib/mic/bootstrap.
wic doesn't use it, so remove it.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/utils/Fiemap.py | 252
1 file changed, 252 deletions(-)
delete mode 100644 scripts/lib/mic/utils/Fiemap.py
diff --git a/scripts/lib/mic/utils/Fiemap.py b/scripts/lib/mic/ut
Remove commands related to repos, packaging, configuration
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/kickstart/__init__.py | 763 --
1 file changed, 763 deletions(-)
diff --git a/scripts/lib/mic/kickstart/__init__.py
b/scripts/lib/mic/kickstart/__init__.py
installer, repo, desktop-related stuff
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/kickstart/__init__.py | 6 +-
.../lib/mic/kickstart/custom_commands/__init__.py | 7 --
.../lib/mic/kickstart/custom_commands/desktop.py | 95 ---
.../mic/kickstart/custom_comma
wic doesn't use it, so remove it.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/utils/BmapCreate.py | 298
1 file changed, 298 deletions(-)
delete mode 100644 scripts/lib/mic/utils/BmapCreate.py
diff --git a/scripts/lib/mic/utils/BmapCreate.py
b/scripts/l
wic doesn't use it, so remove it.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/utils/misc.py | 180 +-
1 file changed, 1 insertion(+), 179 deletions(-)
diff --git a/scripts/lib/mic/utils/misc.py b/scripts/lib/mic/utils/misc.py
index 8c1f016..010b16c 100
wic doesn't currently use it, so remove.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/plugins/source/bootimg-efi.py| 4 +-
scripts/lib/mic/plugins/source/bootimg-pcbios.py | 8 +-
scripts/lib/mic/utils/gpt_parser.py | 331 ---
scripts/lib/mic/utils/part
This patchset refactors wic to have the code better reflect what it
actually does, rather than look like something shoehorned into the
existing mic codebase, which is essentially what it was.
It also removes most of code inherited from mic but sitting
essentially unused; there's no reason to be ca
mic chroot allows users to chroot into an existing mic image and isn't
used by wic, so remove it.
Removing chroot.py leads in turn to various plugin-loading failures
for a number of plugins that wic doesn't use either, so remove those
as well.
The existing source plugins refer to chroot but don't
wic doesn't use it, so remove it.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/plugin.py | 2 +-
scripts/lib/mic/pluginbase.py | 45 ++
scripts/lib/mic/plugins/hook/.py | 0
scripts/lib/mic/plugins/hook/empty_hook.py | 3 --
The reason exec_cmd() warns but doesn't error out (broken parted)
doesn't really make sense, since the parted invocations don't even use
exec_cmd(). It really should just fail since by not doing so it's
actually enabling invalid images in some cases.
Also, since the return code is now always zero
wic doesn't use it, so remove it.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/utils/rpmmisc.py | 600 ---
1 file changed, 600 deletions(-)
delete mode 100644 scripts/lib/mic/utils/rpmmisc.py
diff --git a/scripts/lib/mic/utils/rpmmisc.py b/scripts/lib/mic/
wic doesn't use the yum or zypp package managers, remove them.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/plugins/backend/yumpkgmgr.py | 490 -
scripts/lib/mic/plugins/backend/zypppkgmgr.py | 973 --
2 files changed, 1463 deletions(-)
delete mode 100644
wic doesn't need to grab any urls, so remove it.
Signed-off-by: Tom Zanussi
---
scripts/lib/mic/utils/grabber.py | 97
1 file changed, 97 deletions(-)
delete mode 100644 scripts/lib/mic/utils/grabber.py
diff --git a/scripts/lib/mic/utils/grabber.py b/sc
On 08/08/2014 12:31 PM, Robert P. J. Day wrote:
Given that there are no machine-specific files for the tslib recipe
anymore, might as well remove this line.
Robert,
Can you please review the commit guidelines
http://www.openembedded.org/wiki/Commit_Patch_Message_Guidelines
The summary line
Given that there are no machine-specific files for the tslib recipe
anymore, might as well remove this line.
Signed-off-by: Robert P. J. Day
---
still not totally sure i know what i'm doing here, but git history
shows that any machine-specific tslib files vanished long ago, so
there's little
On 08/08/2014 02:37 AM, Sujith H wrote:
From: Sujith H
This is needed to deal with the situation where we're using ipk packaging, so
opkg-utils must be built regardless of what update-alternatives provider we
prefer. The downside to the current implementation is the need to adjust
PACKAGECONFIG
On 08/08/2014 02:09 AM, Sujith H wrote:
From: Sujith H
If the DISTRO_FEATURES has systemd, then its better
to have corresponding service files associated with
the psplash. This change will help to do the same.
Can you propose a patch to the psplash upstream which is part of the
Yocto Project
Hi Paul,
> Personally with how fragile package management can end up being, I'm
> convinced
> that full-image updates are the way to go for a lot of cases, but ideally
> with
> some intelligence so that you only ship the changes (at a filesystem level
> rather than a package or file level). Th
From: Yasir-Khan
Current trace-cmd version 1.2 throws "recorder error in
splice input" error while recording a trace on kernel
version 3.10. Update the trace-cmd version to latest 2.3.2
to resolve this error and drop the redundant patches.
* patches dropped - not needed anymore
- trace-cmd-Add-
On Fri, 8 Aug 2014, Christopher Larson wrote:
>
> On Fri, Aug 8, 2014 at 3:35 AM, Robert P. J. Day
> wrote:
>
> looking at SRC_URI_OVERRIDES_PACKAGE_ARCH variable, and i notice
> first that there is only one usage of it in all of oe-core (tslib),
> but i'm confused as to what value it has.
>
>
On Fri, Aug 08, 2014 at 03:08:06PM +0100, Paul Eggleton wrote:
> On Friday 08 August 2014 16:06:27 Martin Jansa wrote:
> > Signed-off-by: Martin Jansa
> > ---
> > .../gstreamer/gst-ffmpeg_0.10.13.bb| 3 +--
> > meta/recipes-multimedia/libav/libav.inc| 8
> >
While testing libmodule-build-tiny-perl, it was discovered that
perl-module-cpan is missing some RDEPENDS.
* Run "perl -mCPAN::Meta" on a target, the following is missing:
-- perl-module-parse-cpan-meta (Parse::CPAN::Meta)
* Run "perl -mCPAN" on a target, the following (and others) are
missin
On Fri, Aug 8, 2014 at 3:35 AM, Robert P. J. Day
wrote:
>
> looking at SRC_URI_OVERRIDES_PACKAGE_ARCH variable, and i notice
> first that there is only one usage of it in all of oe-core (tslib),
> but i'm confused as to what value it has.
>
> the ref manual reads:
>
> "By default, the OpenEmb
On Friday 08 August 2014 16:06:27 Martin Jansa wrote:
> Signed-off-by: Martin Jansa
> ---
> .../gstreamer/gst-ffmpeg_0.10.13.bb| 3 +--
> meta/recipes-multimedia/libav/libav.inc| 8
> .../0001-configure-enable-pic-for-AArch64.patch| 23
>
On Fri, Aug 08, 2014 at 04:06:27PM +0200, Martin Jansa wrote:
> Signed-off-by: Martin Jansa
> ---
> .../gstreamer/gst-ffmpeg_0.10.13.bb| 3 +--
> meta/recipes-multimedia/libav/libav.inc| 8
> .../0001-configure-enable-pic-for-AArch64.patch| 23
> ---
Signed-off-by: Martin Jansa
---
.../gstreamer/gst-ffmpeg_0.10.13.bb| 3 +--
meta/recipes-multimedia/libav/libav.inc| 8
.../0001-configure-enable-pic-for-AArch64.patch| 23 --
meta/recipes-multimedia/libav/libav_0.8.11.bb | 20 --
On 08/07/2014 11:10 AM, Paul Eggleton wrote:
...
* Provide tools to allow modifying software for which a recipe already exists.
If the user has an external source tree we use that, otherwise we can fetch
the source, apply any patches and place the result in an external source tree,
possibly mana
On Friday, August 08, 2014 at 07:22:04 AM, Koen Kooi wrote:
> Since 'yocto' is a project like freedesktop.org your commit message doesn't
> make sense, it should be something like:
>
> meta-toolchain-qt: Install full set of python modules
Got it, Saul also told me so. I will wait a bit for some
On Fri, Aug 08, 2014 at 02:13:46PM +0200, Martin Jansa wrote:
> On Fri, Aug 08, 2014 at 11:37:09AM +, Paul Barker wrote:
> > The 'opkg-key' utility requires gpg to manage the list of trusted keys. The
> > ability to verify package signatures is not much use without the ability to
> > add
> > k
On Fri, Aug 08, 2014 at 11:37:09AM +, Paul Barker wrote:
> The 'opkg-key' utility requires gpg to manage the list of trusted keys. The
> ability to verify package signatures is not much use without the ability to
> add
> keys to the trusted list...
>
> Signed-off-by: Paul Barker
> ---
> met
The 'opkg-key' utility requires gpg to manage the list of trusted keys. The
ability to verify package signatures is not much use without the ability to add
keys to the trusted list...
Signed-off-by: Paul Barker
---
meta/recipes-devtools/opkg/opkg.inc | 2 +-
1 file changed, 1 insertion(+), 1 del
A basic gpgme.pc file is installed with gpgme which should allow the library to
be found and used using pkg-config rather than gpgme-config.
Signed-off-by: Paul Barker
---
meta/recipes-support/gpgme/gpgme-1.4.3/gpgme.pc | 10 ++
meta/recipes-support/gpgme/gpgme_1.4.3.bb | 8 ++
After recent changes to disable binconfig programs, 'gpgme-config' is no longer
installed with gpgme. This prevents opkg from finding gpgme which is needed when
'gpg' is added to PACKAGECONFIG. This is fixed in two stages:
- A 'gpgme.pc' file was created and added to openembedded-core to be inst
On Wed, Jul 23, 2014 at 04:49:52PM +0200, Martin Jansa wrote:
> On Wed, Jul 23, 2014 at 01:51:23PM +, Paul Barker wrote:
> > Hi all,
> >
> > I'm trying to build opkg with 'gpg' added to PACKAGECONFIG on the master
> > branch
> > of OE. The gpg support for opkg is provided by gpgme, which uses
looking at SRC_URI_OVERRIDES_PACKAGE_ARCH variable, and i notice
first that there is only one usage of it in all of oe-core (tslib),
but i'm confused as to what value it has.
the ref manual reads:
"By default, the OpenEmbedded build system automatically detects
whether SRC_URI contains files
On Wed, Aug 06, 2014 at 03:42:38PM +0100, Paul Eggleton wrote:
> On Wednesday 06 August 2014 16:37:34 Martin Jansa wrote:
> > On Wed, Aug 06, 2014 at 01:41:58PM +0100, Paul Eggleton wrote:
> > > On Wednesday 06 August 2014 13:41:56 Martin Jansa wrote:
> > > > * building with libav-9 fails with:
> >
From: Sujith H
This is needed to deal with the situation where we're using ipk packaging, so
opkg-utils must be built regardless of what update-alternatives provider we
prefer. The downside to the current implementation is the need to adjust
PACKAGECONFIG as well as PREFERRED_PROVIDER, but it is
From: Sujith H
If the DISTRO_FEATURES has systemd, then its better
to have corresponding service files associated with
the psplash. This change will help to do the same.
Signed-off-by: Muzaffar Mahmood
Signed-off-by: Sujith H
---
meta/recipes-core/psplash/files/psplash-quit.service | 11
On Thu, Aug 7, 2014 at 11:10 AM, Paul Eggleton
wrote:
> Example workflow
>
>
> I won't give a workflow for every possible usage, but just to give a basic
> example - let's assume you want to build a "new" piece of software for which
> you have your own source tree on your machine.
On Thu, Aug 7, 2014 at 3:05 PM, Paul Eggleton
wrote:
> Personally with how fragile package management can end up being, I'm convinced
> that full-image updates are the way to go for a lot of cases, but ideally with
> some intelligence so that you only ship the changes (at a filesystem level
> rath
65 matches
Mail list logo