Academic writing is, of course, often highly specialised. We have
editors with PhDs in all the major academic disciplines; many of them
are still working in Oxford Proofreading Company and are up to date
with the latest research in their field. So we're confident that,
whatever your spec
This error path needs to disable the pci device before returning.
Fixes: ede58ef28e10 ("atm: remove deprecated use of pci api")
Signed-off-by: Dan Carpenter
---
drivers/atm/idt77252.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/atm/idt77252.c b/drivers/atm/idt7725
On Fri, Dec 18, 2020 at 08:08:56PM -0800, Florian Fainelli wrote:
> On 12/18/2020 2:38 PM, Vladimir Oltean wrote:
> > The SYSTEMPORT driver maps each port of the embedded Broadcom DSA switch
> > port to a certain queue of the master Ethernet controller. For that it
> > currently uses a dedicated no
PPPIOCGL2TPSTATS already uses 54. This shouldn't be a problem in
practice, but let's keep the logical decreasing assignment scheme.
Fixes: 4cf476ced45d ("ppp: add PPPIOCBRIDGECHAN and PPPIOCUNBRIDGECHAN ioctls")
Signed-off-by: Guillaume Nault
---
Original patch was committed to net-next just 9 d
Srinivasan Raju writes:
> This introduces the pureLiFi LiFi driver for LiFi-X, LiFi-XC
> and LiFi-XL USB devices.
>
> This driver implementation has been based on the zd1211rw driver.
>
> Driver is based on 802.11 softMAC Architecture and uses
> native 802.11 for configuration and management.
>
>
Srinivasan Raju writes:
> This introduces the pureLiFi LiFi driver for LiFi-X, LiFi-XC
> and LiFi-XL USB devices.
>
> This driver implementation has been based on the zd1211rw driver.
>
> Driver is based on 802.11 softMAC Architecture and uses
> native 802.11 for configuration and management.
>
>
Srinivasan Raju writes:
> This introduces the pureLiFi LiFi driver for LiFi-X, LiFi-XC
> and LiFi-XL USB devices.
>
> This driver implementation has been based on the zd1211rw driver.
>
> Driver is based on 802.11 softMAC Architecture and uses
> native 802.11 for configuration and management.
>
>
Srinivasan Raju writes:
>> What will be the directory structure in linux-firmware? It should be
>> unique so that it's not possible to mix with other drivers.
>
> I have created the following directory structure, Please let me know if this
> is OK.
>
> LICENCE.purelifi_firmware | 29 ++
The dwmac glue registers on Amlogic Meson8b and newer SoCs has two clock
inputs:
- Meson8b and Meson8m2: MPLL2 and MPLL2 (the same parent is wired to
both inputs)
- GXBB, GXL, GXM, AXG, G12A, G12B, SM1: FCLK_DIV2 and MPLL2
All known vendor kernels and u-boots are using the first input only. We
l
Lorenzo Bianconi writes:
On Mon, 2020-12-07 at 17:32 +0100, Lorenzo Bianconi wrote:
> Introduce xdp_shared_info data structure to contain info
> about
> "non-linear" xdp frame. xdp_shared_info will alias
> skb_shared_info
> allowing to keep most of the frags in the same cache-line.
[...]
Hi Jakub, Alexander,
Quoting Alexander Duyck (2020-12-19 02:41:08)
> On Fri, Dec 18, 2020 at 4:30 PM Jakub Kicinski wrote:
> >
> > Two things: (a) is the datapath not exposed to a similar problem?
> > __get_xps_queue_idx() uses dev->tc_num in a very similar fashion.
>
> I think we are shielded f
On Fri, 2020-12-18 at 12:16 -0800, Jakub Kicinski wrote:
> On Thu, 17 Dec 2020 12:40:26 -0800 Ben Greear wrote:
> > On 12/17/20 10:20 AM, Eric Dumazet wrote:
> > > On Thu, Dec 17, 2020 at 7:13 PM Ben Greear
> > > wrote:
> > > > It is the iwlwifi/mvm logic that supports ax200.
> > >
> > > Let
On 2020-12-19 9:53 a.m., Shay Agroskin wrote:
Lorenzo Bianconi writes:
for the moment I do not know if this area is used for other purposes.
Do you think there are other use-cases for it?
Sorry to interject:
Does it make sense to use it to store arbitrary metadata or a scratchpad
in this
Lorenzo Bianconi writes:
Introduce the capability to map non-linear xdp buffer running
mvneta_xdp_submit_frame() for XDP_TX and XDP_REDIRECT
Signed-off-by: Lorenzo Bianconi
---
drivers/net/ethernet/marvell/mvneta.c | 94
---
1 file changed, 56 insertions(+), 38 d
MT7621 is a SoC, so using "mediatek,mt7621" as its compatible is ambiguous.
Rename it to "mediatek,mt7621-gsw".
Signed-off-by: DENG Qingfang
---
Documentation/devicetree/bindings/net/dsa/mt7530.txt | 8
drivers/net/dsa/mt7530.c | 2 +-
2 files changed, 5 inse
> --- a/drivers/net/dsa/mt7530.c
> +++ b/drivers/net/dsa/mt7530.c
> @@ -2688,7 +2688,7 @@ static const struct mt753x_info mt753x_table[] = {
> };
>
> static const struct of_device_id mt7530_of_match[] = {
> - { .compatible = "mediatek,mt7621", .data = &mt753x_table[ID_MT7621], },
> + {
clang supports arbitrary length ints using the _ExtInt extension. This
can be useful to hold very large values, e.g. 256 bit or 512 bit types.
Larger types (e.g. 1024 bits) are possible but I am unaware of a use
case for these.
This requires the _ExtInt extension enabled in clang, which is under
On 12/19/20 7:18 AM, Johannes Berg wrote:
On Fri, 2020-12-18 at 12:16 -0800, Jakub Kicinski wrote:
On Thu, 17 Dec 2020 12:40:26 -0800 Ben Greear wrote:
On 12/17/20 10:20 AM, Eric Dumazet wrote:
On Thu, Dec 17, 2020 at 7:13 PM Ben Greear wrote:
It is the iwlwifi/mvm logic that supports ax200.
On 12/19/2020 8:26 AM, Andrew Lunn wrote:
>> --- a/drivers/net/dsa/mt7530.c
>> +++ b/drivers/net/dsa/mt7530.c
>> @@ -2688,7 +2688,7 @@ static const struct mt753x_info mt753x_table[] = {
>> };
>>
>> static const struct of_device_id mt7530_of_match[] = {
>> -{ .compatible = "mediatek,mt762
On Sat, 19 Dec 2020 04:53:45 + Parav Pandit wrote:
> > Why can't the SF ID match aux dev ID?
> Auxiliary bus holds the SFs of multiple PFs.
I see it now. Very unfortunate :(
> SF ID can be same for SFs from multiple PFs. Encoding PCI address in SF
> auxiliary device name doesn't do good.
Lorenzo Bianconi writes:
Introduce __xdp_build_skb_from_frame and
xdp_build_skb_from_frame
utility routines to build the skb from xdp_frame.
Add xdp multi-buff support to cpumap
Signed-off-by: Lorenzo Bianconi
---
include/net/xdp.h | 5
kernel/bpf/cpumap.c | 45 +--
On Thu 2020-12-17 16:34:29, Rob Herring wrote:
> The correct syntax for JSON pointers begins with a '/' after the '#'.
> Without a '/', the string should be interpretted as a subschema
> identifier. The jsonschema module currently doesn't handle subschema
> identifiers and incorrectly allows JSON p
On Thu, Dec 17, 2020 at 08:51:27AM +0100, Steen Hegelund wrote:
> Document the Sparx5 switch device driver bindings
>
> Signed-off-by: Steen Hegelund
> Signed-off-by: Lars Povlsen
Reviewed-by: Andrew Lunn
Andrew
Introduce xdp_prepare_buff utility routine to initialize per-descriptor
xdp_buff fields (e.g. xdp_buff pointers). Rely on xdp_prepare_buff() in
all XDP capable drivers.
Signed-off-by: Lorenzo Bianconi
---
drivers/net/ethernet/amazon/ena/ena_netdev.c | 7 +++
drivers/net/ethernet/broadco
Introduce xdp_init_buff and xdp_prepare_buff utility routines to initialize
xdp_buff data structure and remove duplicated code in all XDP capable
drivers.
Changes since v3:
- use __always_inline instead of inline for xdp_init_buff/xdp_prepare_buff
- add 'const bool meta_valid' to xdp_prepare_buff
Introduce xdp_init_buff utility routine to initialize xdp_buff fields
const over NAPI iterations (e.g. frame_sz or rxq pointer). Rely on
xdp_init_buff in all XDP capable drivers.
Signed-off-by: Lorenzo Bianconi
---
drivers/net/ethernet/amazon/ena/ena_netdev.c| 3 +--
drivers/net/ethernet
On Thu, 17 Dec 2020 14:37:28 +0200 stef...@marvell.com wrote:
> From: Stefan Chulski
>
> During GoP port 2 Networking Complex Control mode of operation configurations,
> also GoP port 3 mode of operation was wrongly set.
> Patch removes these configurations.
> GENCONF_CTRL0_PORTX naming also fixe
On Thu, 17 Dec 2020 18:07:58 +0200 stef...@marvell.com wrote:
> From: Stefan Chulski
>
> Patch didn't fix any issue, just improve parse flow
> and align ipv4 parse flow with ipv6 parse flow.
>
> Currently ipv4 kenguru parser first check IP protocol(TCP/UDP)
> and then destination IP address.
> P
On Fri, 18 Dec 2020 04:36:18 +0100 Marcin Wojtas wrote:
> czw., 17 gru 2020 o 15:54 napisaĆ(a):
> >
> > From: Stefan Chulski
> >
> > Force link UP can be enabled by bootloader during tftpboot
> > and breaks NFS support.
> > Force link UP disabled during port init procedure.
> >
> > Fixes: f84bf38
On Thu, 17 Dec 2020 20:30:17 +0200 stef...@marvell.com wrote:
> From: Stefan Chulski
>
> Issue:
> Flow control frame used to pause GoP(MAC) was delivered to the CPU
> and created a load on the CPU. Since XOFF/XON frames are used only
> by MAC, these frames should be dropped inside MAC.
>
> Fix:
On Fri, 18 Dec 2020 12:20:19 +0800 weichenchen wrote:
> pneigh_enqueue() tries to obtain a random delay by mod
> NEIGH_VAR(p, PROXY_DELAY). However, NEIGH_VAR(p, PROXY_DELAY)
> migth be zero at that point because someone could write zero
> to /proc/sys/net/ipv4/neigh/[device]/proxy_delay after the
Hello:
This patch was applied to netdev/net.git (refs/heads/master):
On Thu, 17 Dec 2020 20:37:46 +0200 you wrote:
> From: Stefan Chulski
>
> Current PPPoE+IPv6 entry is jumping to 'next-hdr'
> field and not to 'DIP' field as done for IPv4.
>
> Fixes: 3f518509dedc ("ethernet: Add new driver fo
On Fri, Dec 18, 2020 at 3:20 PM Jonathan Lemon wrote:
>
> From: Jonathan Lemon
>
> In preparation for further work, the zcopy* routines will
> become basic building blocks, while the zerocopy* ones will
> be specific for the existing zerocopy implementation.
Plural. There already are multiple di
When searching for inactive maintainers it's useful to filter
out mailing list addresses. Such "maintainers" will obviously
never feature in a "From:" line of an email or a review tag.
Since "L:" entries only provide the address of a mailing list
without a fancy name extend this pattern to "M:" en
On Fri, Dec 18, 2020 at 4:27 PM Jonathan Lemon wrote:
>
> On Fri, Dec 18, 2020 at 03:49:44PM -0500, Willem de Bruijn wrote:
> > On Fri, Dec 18, 2020 at 3:23 PM Jonathan Lemon
> > wrote:
> > >
> > > From: Jonathan Lemon
> > >
> > > This is set of cleanup patches for zerocopy which are intended
>
On Thu, Dec 17, 2020 at 08:51:28AM +0100, Steen Hegelund wrote:
> +static struct sparx5_io_resource sparx5_iomap[] = {
This could be made const i think,.
> + { TARGET_DEV2G5, 0, 0 }, /* 0x610004000: dev2g5_0 */
> + { TARGET_DEV5G, 0x4000,0 }, /* 0x610008000:
Hi Andrew, Florian,
On Sat, Dec 19, 2020 at 09:07:13AM -0800, Florian Fainelli wrote:
> On 12/19/2020 8:26 AM, Andrew Lunn wrote:
> >> --- a/drivers/net/dsa/mt7530.c
> >> +++ b/drivers/net/dsa/mt7530.c
> >> @@ -2688,7 +2688,7 @@ static const struct mt753x_info mt753x_table[] = {
> >> };
> >>
>
> + /* Create a phylink for PHY management. Also handles SFPs */
> + spx5_port->phylink_config.dev = &spx5_port->ndev->dev;
> + spx5_port->phylink_config.type = PHYLINK_NETDEV;
> + spx5_port->phylink_config.pcs_poll = true;
> +
> + /* phylink needs a valid interface mode to par
Allow DSA drivers to export stats64
Signed-off-by: Oleksij Rempel
Reviewed-by: Vladimir Oltean
---
include/net/dsa.h | 4 +++-
net/dsa/slave.c | 14 +-
2 files changed, 16 insertions(+), 2 deletions(-)
diff --git a/include/net/dsa.h b/include/net/dsa.h
index 4e60d2610f20..c50abb
changes v6:
- move stats64 callback to ethtool section
- ar9331: diff. fixes
- ar9331: move stats calculation to the worker
- ar9331: extend rx/tx error counters
- use spin lock instead of u64_stats*
changes v5:
- read all stats in one regmap_bulk_read() request
- protect stats with u64_stats* hel
Add stats support for the ar9331 switch.
Signed-off-by: Oleksij Rempel
---
drivers/net/dsa/qca/ar9331.c | 163 ++-
1 file changed, 162 insertions(+), 1 deletion(-)
diff --git a/drivers/net/dsa/qca/ar9331.c b/drivers/net/dsa/qca/ar9331.c
index 4d49c5f2b790..896fb2
On 2020-12-19 10:55, Jakub Kicinski wrote:
When searching for inactive maintainers it's useful to filter
out mailing list addresses. Such "maintainers" will obviously
never feature in a "From:" line of an email or a review tag.
Since "L:" entries only provide the address of a mailing list
withou
> + port13: port@13 {
> + reg = <13>;
> + /* Example: CU SFP, 1G speed */
> + max-speed = <1>;
One too many 0's for 1G.
> + /* 25G SFPs */
> + port56: port@56 {
> + reg = <56>;
Commit 34f0f4e3f488 ("ibmvnic: Fix login buffer memory leaks") frees
login_rsp_buffer in release_resources() and send_login()
because handle_login_rsp() does not free it.
Commit f3ae59c0c015 ("ibmvnic: store RX and TX subCRQ handle array in
ibmvnic_adapter struct") frees login_rsp_buffer in handle_
Commit f9c6cea0b385 ("ibmvnic: Skip fatal error reset after passive init")
says "If the passive
CRQ initialization occurs before the FATAL reset task is processed,
the FATAL error reset task would try to access a CRQ message queue
that was freed, causing an oops. The problem may be most likely to
o
(Apologies, trying one more time with a better mailer)
Sorry it took so long, but I finally got a chance to test the patches. They
seem to work well, but they only get rid of the downlink / uplink speed spam -
I still get the following filling my kernel log with a patched kernel:
[ 29.830383
> +void sparx5_get_stats64(struct net_device *ndev,
> + struct rtnl_link_stats64 *stats)
> +{
> + struct sparx5_port *port = netdev_priv(ndev);
> + struct sparx5 *sparx5 = port->sparx5;
> + u64 *portstats;
> +
> + if (!sparx5->stats)
> + return;
Hello,
syzbot found the following issue on:
HEAD commit:d635a69d Merge tag 'net-next-5.11' of git://git.kernel.org..
git tree: upstream
console output: https://syzkaller.appspot.com/x/log.txt?x=14502c1350
kernel config: https://syzkaller.appspot.com/x/.config?x=c3556e4856b17a95
das
From: Sara Sharon
[ Upstream commit f495acd8851d7b345e5f0e521b2645b1e1f928a0 ]
In case we have old supplicant, the akm field is uninitialized.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
Link:
https://lore.kernel.org/r/iwlwifi.20201129172929.930f0ab7ebee.Ic546e384efab3f4a89f318eafd
From: Arnd Bergmann
[ Upstream commit 0b32e91fdfd87314af9943e69eb85a88adb4233c ]
A number of ethernet drivers require crc32 functionality to be
avaialable in the kernel, causing a link error otherwise:
arm-linux-gnueabi-ld: drivers/net/ethernet/agere/et131x.o: in function
`et1310_setup_device_
From: Jean-Philippe Brucker
[ Upstream commit 3615bdf6d9b19db12b1589861609b4f1c6a8d303 ]
The verifier trace changed following a bugfix. After checking the 64-bit
sign, only the upper bit mask is known, not bit 31. Update the test
accordingly.
Signed-off-by: Jean-Philippe Brucker
Acked-by: John
From: Dongdong Wang
[ Upstream commit d9054a1ff585ba01029584ab730efc794603d68f ]
The per-cpu bpf_redirect_info is shared among all skb_do_redirect()
and BPF redirect helpers. Callers on RX path are all in BH context,
disabling preemption is not sufficient to prevent BH interruption.
In producti
From: Sara Sharon
[ Upstream commit f495acd8851d7b345e5f0e521b2645b1e1f928a0 ]
In case we have old supplicant, the akm field is uninitialized.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
Link:
https://lore.kernel.org/r/iwlwifi.20201129172929.930f0ab7ebee.Ic546e384efab3f4a89f318eafd
From: Sara Sharon
[ Upstream commit f495acd8851d7b345e5f0e521b2645b1e1f928a0 ]
In case we have old supplicant, the akm field is uninitialized.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
Link:
https://lore.kernel.org/r/iwlwifi.20201129172929.930f0ab7ebee.Ic546e384efab3f4a89f318eafd
From: Dongdong Wang
[ Upstream commit d9054a1ff585ba01029584ab730efc794603d68f ]
The per-cpu bpf_redirect_info is shared among all skb_do_redirect()
and BPF redirect helpers. Callers on RX path are all in BH context,
disabling preemption is not sufficient to prevent BH interruption.
In producti
From: Sara Sharon
[ Upstream commit f495acd8851d7b345e5f0e521b2645b1e1f928a0 ]
In case we have old supplicant, the akm field is uninitialized.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
Link:
https://lore.kernel.org/r/iwlwifi.20201129172929.930f0ab7ebee.Ic546e384efab3f4a89f318eafd
From: Jean-Philippe Brucker
[ Upstream commit 77ce220c0549dcc3db8226c61c60e83fc59dfafc ]
The test fails because of a recent fix to the verifier, even though this
program is valid. In details what happens is:
7: (61) r1 = *(u32 *)(r0 +0)
Load a 32-bit value, with signed bounds [S32_MIN, S32
From: Sara Sharon
[ Upstream commit f495acd8851d7b345e5f0e521b2645b1e1f928a0 ]
In case we have old supplicant, the akm field is uninitialized.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
Link:
https://lore.kernel.org/r/iwlwifi.20201129172929.930f0ab7ebee.Ic546e384efab3f4a89f318eafd
From: Jean-Philippe Brucker
[ Upstream commit 77ce220c0549dcc3db8226c61c60e83fc59dfafc ]
The test fails because of a recent fix to the verifier, even though this
program is valid. In details what happens is:
7: (61) r1 = *(u32 *)(r0 +0)
Load a 32-bit value, with signed bounds [S32_MIN, S32
From: Fugang Duan
[ Upstream commit 9d14edfdeabf37d8d8f045e63e5873712aadcd6b ]
Current timeout value is not enough for gmac5 dma reset
on imx8mp platform, increase the timeout range.
Signed-off-by: Fugang Duan
Signed-off-by: Joakim Zhang
Signed-off-by: David S. Miller
Signed-off-by: Sasha Le
From: Dongdong Wang
[ Upstream commit d9054a1ff585ba01029584ab730efc794603d68f ]
The per-cpu bpf_redirect_info is shared among all skb_do_redirect()
and BPF redirect helpers. Callers on RX path are all in BH context,
disabling preemption is not sufficient to prevent BH interruption.
In producti
From: Sara Sharon
[ Upstream commit f495acd8851d7b345e5f0e521b2645b1e1f928a0 ]
In case we have old supplicant, the akm field is uninitialized.
Signed-off-by: Sara Sharon
Signed-off-by: Luca Coelho
Link:
https://lore.kernel.org/r/iwlwifi.20201129172929.930f0ab7ebee.Ic546e384efab3f4a89f318eafd
Hello,
syzbot found the following issue on:
HEAD commit:3db1a3fa Merge tag 'staging-5.11-rc1' of git://git.kernel...
git tree: net
console output: https://syzkaller.appspot.com/x/log.txt?x=15c2f30f50
kernel config: https://syzkaller.appspot.com/x/.config?x=2764fc28a92339f9
dashboar
Hi Vladimir,
On Sun, Dec 20, 2020 at 3:48 AM Vladimir Oltean wrote:
>
> Hi Andrew, Florian,
>
> On Sat, Dec 19, 2020 at 09:07:13AM -0800, Florian Fainelli wrote:
> > On 12/19/2020 8:26 AM, Andrew Lunn wrote:
> > >> --- a/drivers/net/dsa/mt7530.c
> > >> +++ b/drivers/net/dsa/mt7530.c
> > >> @@ -26
Hello,
syzbot found the following issue on:
HEAD commit:d635a69d Merge tag 'net-next-5.11' of git://git.kernel.org..
git tree: upstream
console output: https://syzkaller.appspot.com/x/log.txt?x=1315f12350
kernel config: https://syzkaller.appspot.com/x/.config?x=c3556e4856b17a95
das
On Sun, Dec 20, 2020 at 12:48:08PM +0800, DENG Qingfang wrote:
> Hi Vladimir,
>
> On Sun, Dec 20, 2020 at 3:48 AM Vladimir Oltean wrote:
> >
> > Hi Andrew, Florian,
> >
> > On Sat, Dec 19, 2020 at 09:07:13AM -0800, Florian Fainelli wrote:
> > > On 12/19/2020 8:26 AM, Andrew Lunn wrote:
> > > >> -
Hi Jakub,
On Thu, Dec 17 2020, Jakub Kicinski wrote:
> On Tue, 15 Dec 2020 18:51:17 +0200 Baruch Siach wrote:
>> Before commit 889b8f964f2f ("packet: Kill CONFIG_PACKET_MMAP.") there
>> used to be a CONFIG_PACKET_MMAP config symbol that depended on
>> CONFIG_PACKET. The text still refers to PACKET
67 matches
Mail list logo