Herbert Xu wrote:
On Mon, Nov 21, 2005 at 01:52:49PM +0100, Richard Knutsson wrote:
This patch requirer the
"net-fix-compiler-error-on-dgrsc-when-config_pci.patch" (added to the
-mm tree after 2.6.15-rc1-mm2):
---
devel/drivers/net/dgrs.c~net-fix-compiler-error-on-dgrsc-when-config_pci
On Tue, Nov 22, 2005 at 12:20:30AM +0100, Richard Knutsson wrote:
>
> Am thinking of removing the #ifdef CONFIG_PCI's in other files, to
> "clean up" the code, but that would introduce this problem again, don't
> you think it is more readable to make an empty struct when !CONFIG_PCI,
> then mak
Herbert Xu wrote:
Richard Knutsson <[EMAIL PROTECTED]> wrote:
We need it even if pci_register_driver() and pci_register_driver() is
empty shells. And instead of removing #endif CONFIG_PCI for
I don't think so. Please see my previous patch where pci_register_driver
is not called at a
Richard Knutsson <[EMAIL PROTECTED]> wrote:
>
> We need it even if pci_register_driver() and pci_register_driver() is
> empty shells. And instead of removing #endif CONFIG_PCI for
I don't think so. Please see my previous patch where pci_register_driver
is not called at all if CONFIG_PCI is not
Herbert Xu wrote:
On Mon, Nov 21, 2005 at 01:52:49PM +0100, Richard Knutsson wrote:
This patch requirer the
"net-fix-compiler-error-on-dgrsc-when-config_pci.patch" (added to the
-mm tree after 2.6.15-rc1-mm2):
---
devel/drivers/net/dgrs.c~net-fix-compiler-error-on-dgrsc-when-config_pci
On Mon, Nov 21, 2005 at 01:52:49PM +0100, Richard Knutsson wrote:
>
> What do you think about this patch? Will you sign it? It is no longer an
> error-warning-fix but a bug-fix (and some cleanup).
> I "took" you implementation of dgrs_(un)register_eisa(), especially
> since eisa needed to be unre
Herbert Xu wrote:
On Sun, Nov 20, 2005 at 04:35:46PM +0100, Richard Knutsson wrote:
-#ifdef CONFIG_EISA
- cardcount = eisa_driver_register(&dgrs_eisa_driver);
+ cardcount = dgrs_register_eisa();
if (cardcount < 0)
return cardcount;
-#endif
- cardcoun
On Sun, Nov 20, 2005 at 04:35:46PM +0100, Richard Knutsson wrote:
>
> >-#ifdef CONFIG_EISA
> >-cardcount = eisa_driver_register(&dgrs_eisa_driver);
> >+cardcount = dgrs_register_eisa();
> > if (cardcount < 0)
> > return cardcount;
> >-#endif
> >-cardcount = pci_register_
Herbert Xu wrote:
Richard Knutsson <[EMAIL PROTECTED]> wrote:
diff -Narup a/drivers/net/dgrs.c b/drivers/net/dgrs.c
--- a/drivers/net/dgrs.c2005-11-19 20:17:51.0 +0100
+++ b/drivers/net/dgrs.c2005-11-19 20:29:52.0 +0100
@@ -1458,6 +1458,8 @@ static struct pci_
Richard Knutsson <[EMAIL PROTECTED]> wrote:
>
> diff -Narup a/drivers/net/dgrs.c b/drivers/net/dgrs.c
> --- a/drivers/net/dgrs.c2005-11-19 20:17:51.0 +0100
> +++ b/drivers/net/dgrs.c2005-11-19 20:29:52.0 +0100
> @@ -1458,6 +1458,8 @@ static struct pci_driver dgrs_pc
10 matches
Mail list logo